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COMPUTER APPLICATIONS

 Salient Features
  Answers for all Textual Questions.

  Exhaustive Additional MCQs, VSA, SA & LA questions with answers are given 
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2 Sura’s  XI Std - Computer Applications ➠ Unit I ➠ Chapter 1  

Evaluation
9. Which one of the following is the main memory?

(a) ROM   (b) RAM [QY. '19]
(c) Flash drive  (d) Hard disk 

 [Ans. (b) RAM]

10. Which generation of computer used IC’s? 
 [Sep. '21; CRT '22]

(a) First (b) Second (c) Third d) Fourth 
 [Ans. (c) Third]

Part - II
Very Short Answer. 
1. What is a computer? [Mar. '19; QY. & HY. '19]

Ans. (i) A computer is an electronic device that 
manipulates information, or data. It has the 
ability to store, retrieve, and process data.

(ii)  Computer works faster than human being and 
given the values more accuracy and reliable

2. Distinguish between data and information.

Ans. Data Information
Data is defined as an 
unprocessed collection 
of raw facts, suitable 
for communication, 
interpretation or processing.

Information is 
a collection of 
facts from which 
conclusions may 
be drawn.

(Eg)  134, 16, 'Kavitha', 'C' (Eg)  Kavitha is 16 
years old.

3. What are the components of a CPU? [Aug '22]
Ans. The CPU has three components which are Control 

unit, Arithmetic and Logic Unit (ALU) and Memory 
unit.

4. What is the function of an ALU? [CRT & May '22]

Ans. (i)  The ALU performs arithmetic operations. 
(ii)  The result of an operation is stored in internal 

memory of CPU.
(iii)  The logical operations of ALU promote the 

decision making ability of a computer.
5. Write the functions of control unit.
Ans. The control unit controls the flow of data between 

the CPU, memory and I/O devices. It also controls 
the entire operation of a computer.

Part - I
Choose the Correct Answer. 

1. First generation computers used  [HY. '19; Aug '22]
(a) Vacuum tubes  (b) Transistors
(c)  Integrated circuits (d) Microprocessors 

 [Ans. (a) Vacuum tubes]

2. Name the volatile memory  [CRT & May '22]
(a) ROM (b) PROM (c) RAM (d) EPROM 

 [Ans. (c) RAM]

3. Identify the output device 
(a)  Keyboard  (b) Memory
(c)  Monitor   (d)  Mouse  

 [Ans. (c) Monitor]

4. Identify the input device  [June '19]
(a) Printer   (b) Mouse
(c)  Plotter      (d)  Projector 

 [Ans. (b) Mouse]

5. …………… Output device is used for printing 
building plan.
(a) Thermal printer (b) Plotter
(c) Dot matrix  (d) Inkjet printer 

 [Ans. (b) Plotter]

6. Which one of the following is used to in ATM 
Machines   [Sep - 2020]
(a) Touch Screen (b) Speaker
(c) Monitor   (d) Printer 

 [Ans. (a) Touch Screen]

7. When a system restarts  which type of booting is 
used. [Mar. '19; QY. '19]
(a) Warm booting (b) Cold booting
(c) Touch boot  (d) Real boot. 

 [Ans. (a) Warm booting]

8. Expand POST  [Govt.MQP-'18]
(a) Post on self Test
(b) Power on Software Test
(c) Power on Self Test
(d) Power on Self Text 

 [Ans. (c) Power on Self Test]
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Sura’s  XI Std - Computer Applications ➠ Introduction to Computers 3

6. What is the function of memory?
Ans. The primary memory is used to temporarily store the 

programs and data when the instructions are ready to 
execute. The secondary memory is used to store the 
data permanently.

7. Differentiate Input and Output unit. [QY. '19]

Ans. Input Unit Output Unit
Input unit is used 
to feed any form of 
data  to the computer, 
which can be stored in 
the memory unit for 
further processing. 

An output unit is any 
hardware component 
that conveys 
information to users in 
an understandable form.

Example : 
Keyboard, mouse etc.

Example : 
Monitor, Printer etc.

8. Distinguish Primary and Secondary memory.

Ans. Primary Memory Secondary memory
It is used to 
temporarily store the 
programs and data 
when the instructions 
are ready to execute.

It is used to store the 
data permanently.

It is volatile, the 
content is lost when 
the power supply is 
switched off. 
Eg. RAM.

It is non-volatile, the 
content is available even 
after the power supply is 
switched off. Eg. ROM, 
CD-ROM, DVD ROM.

Part - III
Short Answers.
1. What are the characteristics of a computer? 
Ans. (i) Computer is the powerful machine.

(ii) It can perform large number of tasks.
(iii)  The main capacities of computer are work 

length, speed accuracy, diligence, versatility 
memory and automation and lots of more tasks.

2. Write the applications of computer.
Ans. The various applications of computers are,

(i) Business  (ii)  Education
(iii) Marketing  (iv)  Banking
(v) Insurance  (vi) Communication
(vii) Health care
(viii) Engineering - Robotics, Nano technology, Bio 

Engineering

3. What is an input device? Give two examples. 
 [HY. '19]

Ans. Input device is used to feed any form of data to the 
computer, which can be stored in the memory unit 
for further processing. 

  Example: Keyboard, mouse, Scanner, Fingerprint 
scanner, Track Ball, Retinal Scanner, Light pen etc.

4. Name any three output devices. [QY. '19; Sep. '21]
Ans. (i) Monitor (ii)     Printer

(iii)  Plotter (iv)    Speaker
(v)  Multimedia projectors are the output devices.

5. Differentiate optical and Laser mouse.

Ans. Optical Mouse Laser Mouse
Measures the motion 
and acceleration of 
pointer.

Measures the motion and 
acceleration of pointer.

It uses light source 
instead of ball to judge 
the motion of the 
pointer.

Laser Mouse uses Laser 
Light.

Optical mouse is less 
sensitive towards 
surface.

Laser Mouse is highly 
sensitive and able to work 
on any hard surface.

6. Write short note on impact printer. [CRT '22]
Ans. Impact printers :

(i)  These printers print with striking of hammers 
or pins on ribbon. These printers can print 
on multi-part (using carbon papers) by using 
mechanical pressure. For example, Dot Matrix 
printers and Line matrix printers are impact 
printers.

(ii)  A Dot matrix printer that prints using a fixed 
number of pins or wires.

(iii)  Line matrix printers use a fixed print head for 
printing.

7. Write the characteristics of sixth generation. 
 [Govt.MQP-'18]

(i)  Parallel and Distributed computing 

(ii)  Computers have become smarter, faster and 
smaller 

(iii)  Development of robotics 

(iv)  Natural Language Processing

(v)  Development of Voice Recognition Softwassre
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4 Sura’s  XI Std - Computer Applications ➠ Unit I ➠ Chapter 1  

8. Write the significant features of monitor. 
 [Sep. '21]

Ans. Monitor: 
(i)  Monitor is the most commonly used output 

device to display the information. It looks like a TV. 
(ii)  Pictures on a monitor are formed with picture 

elements called PIXELS. 
(iii) Monitors may either be Monochrome which 

display text or images in Black and White or can 
be color, which display results in multiple colors. 

(iv)  There are many types of monitors available 
such as CRT (Cathode Ray Tube), LCD (Liquid 
Crystal Display) and LED (Light Emitting 
Diodes).

(v)  The video graphics card helps the keyboard to 
communicate with the screen.

(vi)  It acts as an interface between the computer and 
display monitor.

Part - IV
Explain in detail.
1. Explain the basic components of a computer with a 

neat diagram. [Mar. '19, Sep. 2020; CRT & Aug '22] 
Ans. Components of a Computer :
  The computer is the combination of hardware and 

software. Hardware is the physical component of 
a computer like motherboard, memory devices, 
monitor, keyboard etc., while software is the set 
of programs or instructions. Both hardware and 
software together make the computer system to 
function. Every task given to a computer follows an 
Input-process - output cycle (IPO cycle).

 (i)  Input unit : Input unit is used to feed any form 
of data to the computer, which can be stored 
in the memory unit for further processing.  
Example : keyboard, mouse etc.

(ii)  Central Processing Unit : CPU is the major 
component which interprets and executes 
software instructions. It also control the 
operation of all other components such as 
memory, input and output units.

(iii)  Arithmetic and Logic Unit : The ALU is a part 
of the CPU where various computing functions 
are performed on data. The ALU performs 
arithmetic operations such as addition, 
subtraction, multiplication, division and logical 
operations.

 

Control Unit

Output UnitInput Unit

Internal 
Memory

Main Memory

Secondary Storage

ALU

Data Path
Control Path

Components of a Computer

(iv)  Control Unit : The control unit controls the 
flow of data between the CPU memory and  
I/o devices. It also controls the entire operation 
of a computer.

(v)  Output Unit : An output unit is any hardware 
component that convey information to users 
in an understandable form. Example : Monitor, 
Printer etc.

(vi) Memory Unit : The Memory Unit is of 
two types which are primary memory and 
secondary memory. The primary memory is 
used to temporarily store the programs and 
data when the instructions are ready to execute. 
The secondary memory is used to store the data 
permanently. The Primary Memory is volatile, 
that is, the content is lost when the power supply 
is switched off. The Random Access Memory 
(RAM) is an example of a main memory.   
The Secondary memory is non volatile, that is, 
the content is available even after the power 
supply is switched off. Hard disk, CD-ROM and 
DVD ROM are examples of secondary memory.
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6 Sura’s  XI Std - Computer Applications ➠ Unit I ➠ Chapter 1  

3. Explain the following :  
a.  Inkjet Printer    b.   Multimedia projector
c.  Bar code / QR code Reader

Ans. (a) Inkjet Printers:
(i)  Inkjet Printers use colour cartridges which 

combined Magenta, Yellow and Cyan inks to 
create color tones. A black cartridge is also used 
for monochrome output. Inkjet printers work 
by spraying jonised ink at a sheet of paper.  

(ii)  They use the technology of firing ink by heating 
it so that it explodes towards the paper in 
bubbles or by using piezoelectricity in which 
tiny electric currents controlled by electronic 
circuits are used inside the printer to spread ink 
in jet speed. 

(iii)  An Inkjet printer can spread millions of dots of 
ink at the paper every single second.

(b) Multimedia Projectors:
(i) Multimedia projectors are used to produce 

computer output on a big screen. 
(ii)  These are used to display presentations in 

meeting halls or in classrooms.
(c) Bar Code / QR Code Reader: 
(i) A Bar code is a pattern printed in lines of 

different thickness. The Bar code reader scans 
the information on the bar codes transmits to 
the Computer for further processing. 

(ii)  The system gives fast and error free entry of 
information into the computer.

QR (Quick response) Code: 
The QR code is the two dimension bar code which 
can be read by a camera and processed to interpret 
the image.

Government Exam Questions and Answers
5 Marks

1. Explain in detail the different types of Mouse.
 [Govt.MQP-'18]
Ans. (i)  Mechanical Mouse : A small ball is kept inside 

and touches the pad through a hole at the bottom 
of the mouse. When the mouse is moved, the 
ball rolls. This movement of the ball is converted 
into signals and sent to the computer.

(ii)  Optical Mouse: Measures the motion and 
acceleration of pointer. It uses light source 
instead of ball to judge the motion of the pointer. 
Optical mouse has three buttons. Optical mouse 
is less sensitive towards surface. 

(iii)  Laser Mouse:  
 Measures the motion and acceleration of 

pointer. Laser Mouse uses Laser Light Laser. 
Mouse is highly sensitive and able to work on 
any hard surface.

additional questions and Answers
Choose the Correct Answers. 
 1 MARK 

I.  Choose the Correct options for 
the below Questions.

1. Which of the following led us today to extremely 
high speed calculating device?
(a) Laptop   (b) Tabulating Machine
(c) Abacus   (d) ENIAC 

 [Ans. (c) Abacus]
2. The first calculating device is

(a) ENIAC   (b) Analytical Engine
(c) EDVAC   (d) Abacus 

 [Ans. (d) Abacus]

3. In which year the concept of the analytical engine 
was invented?
(a) 1837 (b) 1910 (c) 1991 (d) 1836 

 [Ans. (a) 1837]
4. Which of the following period the first generation 

computers belongs?
(a) 1956-1963  (b) 1940-1956
(c) 1964-1971  (d) 1980-1990

 [Ans. (b) 1940-1956]
5. Which of the following is not a first generation 

computers?
(a) ENIAC   (b) EDVAC
(c) UNIVAC 1  (d) IBM1401 

 [Ans. (d) IBM1401]
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6. Name the types of computer introduced in Fourth 
generation computers.

Ans. (i) Microcomputer
(ii) Portal Computers.

7. Write the developments of Sixth generation 
computers.

Ans. (i) Parallel Computing
(ii) Artificial Neural Networks 
(iii) Robotics 
(iv) Natural Language Processing 

8. What is NLP?
Ans. Natural Language Processing is the ability of a 

computer program to understand human language. 
It is a component of artificial intelligence.

9. What is the use of Microphone?
Ans. Microphone serves as a voice Input device. It captures 

the voice data and send it to the Computer.
10. Write a note on Digital Camera.
Ans. It captures images / videos directly in the digital form. 

It uses a CCD (Charge Coupled Device) electronic 
chip. When light falls on the chip through the lens, it 
converts light rays into digital format.

11. What is use of VGA?
Ans. The screen monitor works with the VGA (Video 

Graphics Array). The video graphics card helps the 
keyboard to communicate with the screen. It acts as an 
interface between the computer and display monitor. 
Usually the recent motherboard incorporates built in 
video card.

12. Write the two main categories of Printer.
Ans. Printers are divided into two main categories:

(i) Impact Printers
(ii) Non Impact printers

13. What is booting a computer?
Ans. Booting a computer is to load an operating system 

into the computer's main memory or random access 
memory (RAM).

14. What makes Charles Babbage the father of 
computing?

Ans. Charles Babbage radical ideas and concept of the 
Analytical Engine (It contained an ALU, basic flow 
control and integrated memory) makes him the 
father of computing.

15. What is the goal of neural network approach?
Ans. The original goal of the neural network approach was 

to solve problems in the same way that a human brain 
would. Over time, attention focused on matching 
specific mental abilities, leading to deviations from 
biology.

16. Write the tools in which nano technology was born.
Ans. The right tools, such as the scanning tunneling 

microscope (STM) and the atomic force microscope 
(AFM), the age of nano-technology was born.

17. Define IPO Cycle.
Ans. The functional components of a computer performs. 

Every task given to a computer follows an Input- 
Process- Output Cycle (IPO cycle).

18. Name the different keys available in the keyboard.
Ans. There are different set of keys available in the keyboard 

such as character keys, modifier keys, system and 
GUI keys, enter and editing keys, function keys, 
navigation keys, numeric keypad and lock keys.

19. Which device is used to draw a lines?
Ans. Light Pen is an input device which is used to draw 

lines or figures on a computer screen. It is touched 
to the CRT screen where it can detect faster on the 
screen as it passes.

20. Define Pixels.
Ans. Pictures on a monitor are formed with picture 

elements called PIXELS.
21. Name the types of Monitors available.
Ans. The types of monitors available such as CRT (Cathode 

Ray Tube), LCD (Liquid Crystal Display) and LED 
(Light Emitting Diodes).

22. How the date travel through control bus?
Ans. The date travel in both unidirectional and 

bidirectional due to the internal connection with in 
the computer architecture.

23. Name the type of registers are essential for 
instruction execution.

Ans. (i) Program counter
(ii) Instruction Register
(iii) Memory Address Registers
(iv) Memory Buffer Register
(v) Accumulator

24. Expand (a) MAR   (b) MBR
Ans. (a) MAR - Memory Address Register

(b) MBR - Memory Buffer Register
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25. Why POST is essential?
Ans. If the hardware is not detected, a particular pattern 

of beeps will inform about the error. An error 
found in the POST is usually fatal (that is, it causes 
current program to stop running) and will halt the 
boot process, since the hardware check is absolutely 
essential for the computer's functions.

26. What does reboot  mean?
Ans. It means to reload the operating system.

27. Write the limitations of impact printer.
Ans. (1) It is slow as compared to non-impact printers

(2) It is not best suited for graphics
(3) It is not possible to obtain colour output.

Short Answers. 3 MARKS
1. Write a note Vaccum tube.
Ans. (i) Vacuum tubes contain electrodes for controlling 

electron flow and were used in early computers 
as a switch or an amplifier.

(ii)  Vaccum  tubes are big in size and consumed 
more power.

2. Define Transistor.
Ans. (i)  The transistor ("transfer resistance") is made up 

of semi-conductors. 
(ii)  It is a component used to control the amount 

of current or voltage used for amplification/
modulation or switching of an electronic signal.

3. Define Punched cards.
Ans. Punch cards also known as Hollerith cards  are paper 

cards containing several punched or perforated holes 
that were punched by hand or machine to represent 
data.

4. What is Machine language?
Ans. (i)  Machine language is a collection of binary digits 

or bits that the computer reads and interprets. 
(ii)  In first generation, machined language was 

used.

5. What is Integrated circuits?
Ans. (i)  IC is short for Integrated Circuit or Integrated 

Chip. 
(ii)  The IC is a package containing many circuits, 

pathways, transistors, and other electronic 
components all working together to perform a 
particular function or a series of functions. 

6. What is Robotics?
Ans. (i)  Robot is a term coined by Karel Capek in the 

1921 play RUR (Rossum's Universal Robots). 
(ii)  It is used to describe a computerized machine 

designed to respond to input received manually 
or from its surroundings.

7. What is Nano-technology?
Ans. Nano-technology, is an engineering, science, and 

technology that develops machines or works with 
one atom or one molecule that is 100 nanometers or 
smaller.

8. Define POST.
Ans. (i)  POST (Power-On Self-Test) is the diagnostic 

testing sequence that a computer's basic input/
output system runs to determine if the computer 
keyboard, random access memory, disk drives 
and other hardware are working correctly. 

(ii)  If the necessary hardware is detected and found 
to be operating properly, the computer begins to 
boot.

9. Write the short note on finger print scanner.
Ans. Finger print Scanner: Fingerprint Scanners is a 

fingerprint recognition device used for computer 
security, equipped with the fingerprint recognition 
feature that uses biometric technology. Fingerprint 
Reader / Scanner is very safe and convenient device 
for security instead of password, that is vulnerable to 
fraud and is hard to remember.

10. Write a note on Touch Screen.
Ans. (i)  A touch screen is a display device that allows the 

user to interact with a computer by using the 
finger. 

(ii)  It can be quite useful as an alternative to a 
mouse or keyboard for navigating a Graphical 
User Interface (GUI). 

(iii)  Touch screens are used on a wide variety of 
devices such as computers, laptops, monitors, 
smart phones, tablets, cash registers, and 
information kiosks. 

(iv)  Some touch screens use a grid of infrared beams 
to sense the presence of a finger instead of 
utilizing touch-sensitive input.

11. Write the sequence of steps in boot process? (or) 
Explain the types of booting in computer. 

Ans. Booting process is of two types.
(i)  Cold Booting     (ii) Warm Booting
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(i)  Cold Booting: When the system starts from 
initial state i.e. it is switched on, we call it cold 
booting or Hard Booting. When the user presses 
the Power button, the instructions are read from 
the ROM to initiate the booting process.

(ii)  Warm Booting: When the system restarts or 
when Reset button is pressed, we call it Warm 
Booting or Soft Booting. The system does not 
start from initial state and so all diagnostic 
tests need not be carried out in this case. There 
are chances of data loss and system damage as 
the data might not have been stored properly.
Differentiate optical mouse and laser mouse.

12. Differentiate Impact Printers and Non-Impact 
Printers.

Ans. Impact Printers Non-Impact Printers
It uses ribbons / 
carbon papers to leave 
the impressions on the 
paper.

It use ink cartridges and 
the impressions appear 
on the paper with the 
flow of ink.

The quality of printing 
is a draft quality.

The quality of printing is 
a high quality.

Striking Mechanism 
used to produce 
output.

No striking mechanism 
used to produce output.

faster speeds around 
250 words per second.

slower speeds around 1 
page per seconds.

Example : Dot Matrix 
printers and line 
matrix printers

Example : Laser printers 
and Inkjet printers.

13. Differentiate Dot Matrix Printer and Laser Printer.

Ans. Dot Matrix Printer Laser Printer
Printing speed is slow. Printing speed is high.
Suitable for black and 
white printing.

Suitable of colour 
printing.

It makes noise while 
printing.

It is silent while 
printing.

Long Answers. 5 MARKS

1. Explain Impact Printers with an Example.
Ans. Impact Printers :  

(i) These printers print with striking of hammers 
or pins on ribbon. These printers can print 
on multi-part (using carbon papers) by using 
mechanical pressure. 

(ii)  For example, Dot Matrix printers and Line 
matrix printers are impact printers.

(iii) A Dot matrix printer that prints using a fixed 
number of pins or wires. Each dot is produced 
by a tiny metal rod, also called a “wire” or 
“pin”, which works by the power of a tiny 
electromagnet or solenoid, either directly or 
through a set of small levers. 

(iv)  It generally prints one line of text at a time. The 
printing speed of these printers varies from 30 
to 1550 CPS (Character Per Second).

2. Explain Non-Impact printers with an examples.
Ans. Non-Impact Printers :   

(i) These printers do not use striking mechanism 
for printing. They use electrostatic or laser 
technology. 

(ii)  Quality and speed of these printers are better 
than  Impact printers. For example, Laser 
printers and Inkjet printers are non-impact 
printers.

Laser Printers :
(i) Laser printers mostly work with similar 

technology used by photocopiers. 
(ii)  It makes a laser beam scan back and forth across 

a drum inside the printer, building up a pattern. 
It can produce very good quality of graphic 
images. 

Inkjet Printers :
(i) Inkjet Printers use colour cartridges which 

combined Magenta, Yellow and Cyan inks to 
create color tones. 

(ii)  A black cartridge is also used for monochrome 
output. Inkjet printers work by spraying ionised 
ink at a sheet of paper. 

(iii) They use the technology of firing ink by heating 
it so that it explodes towards the paper in 
bubbles or by using piezoelectricity in which 
tiny electric currents controlled by electronic 
circuits are used inside the printer to spread ink 
in jet speed. 

(iv)  An Inkjet printer can spread millions of dots of 
ink at the paper every single second.
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Evaluation
9. What is the shortcut key for finding and replacing 

text in a document? [CRT '22]
(a) Ctrl + F1  (b) Ctrl + F4
(c) Ctrl + F5  (d) Ctrl + F7
 [Ans. (*) Ctrl + F]

10. What is the shortcut key for Undo? [QY. '19]
(a) Ctrl + E   (b) Ctrl + U
(c) Ctrl + Z   (d) Ctrl + n
 [Ans. (c) Ctrl + Z]

Part - II
Very Short Answers.
1. How do you insert pictures in to your document?

  [QY. '19: Sep. '21; CRT '22]
Ans. Openoffice writer has the ability to insert and edit 

images in a more simply way. 
(i) Place the insertion pointer where you want the 

image to appear
(ii) Select Insert → Picture → From file
(iii) The insert picture dialog box appears where the 

picture gallery opens from which the desired 
picture can be selected.

(iv) If the picture is not in the gallery, then browse 
the pictures from the folder, choose the desired 
picture. 

(v) Click on the Open button.
(vi) The selected picture is inserted into the 

document.

2. What are the different packages in Openoffice 
Writer? [Sep. 2020]

Ans. Openoffice is a productive office suite with a 
collection of different software packages such as 
(i) Openoffice writer –  Word processor to 

create text documents
(ii) Openoffice calc –  Spreadsheet to create 

worksheets
(iii) Openoffice Base – Database
(iv) Openoffice Impress – Presentation Software
(v) Openoffice Draw – Drawing software
(vi) Openoffice Forumula –  Create formula and 

equations.

Part - I

Choose the Correct Answer. 
1. Which is the opening screen of OpenOffice?

(a) Star desktop  (b) Star center
(c) Star screen  (d) Star window 

 [Ans. (b) Star center]
2. Which option allows you to assign text, tables, 

graphics and other items to a key or key 
combination?
(a) Autoformat  (b) Automatic
(c) Auto text  (d) Autographics 
 [Ans. (c) Auto text]

3. Which menu contains the Numbering option?
(a) File   (b) Edit
(c) Tools   (d) Format 

 [Ans. (d) Format]

4. Which is displayed at the top part of the window?
 [Mar. '19; Sep. '21; May '22]

(a) Menu bar  (b) Tool bar 
(c) Title bar   (d) Format bar
 [Ans. (c) Title bar]

5. What is changing the default appearance of the text 
called? [QY. '19]
(a) Text formating (b) Page formating
(c) Special formating (d) Paragraph formating
 [Ans. (a) Text formating]

6. Find & Replace option is available in which menu?
 [May '22]
(a) File   (b) Edit
(c) Format   (d) Tools [Ans. (b) Edit]

7. Which button selects all instances of the search text 
in the document? [Aug '22]
(a) Find   (b) Find All
(c) Replace   (d) Replace All
 [Ans. (b) Find All]

8. What is the shortcut key to go to the start of the 
document?
(a) Ctrl + Home  (b) Ctrl + End
(c) Home   (d) End
 [Ans. (a) Ctrl + Home]
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3. What is auto text in Writer? [Sep. '21]
Ans. AutoText allows you to assign text, tables, graphics 

and other items to a key or key combination. For 
example, rather than typing "TamilNadu" every time 
you use that phrase, you might just type "tn" and 
press F3. 

4. How do you  merge cells in a table?
Ans. To merge a group of cells:

(i) Select the cells to merge.
(ii) Right click and choose Cell → Merge or 
 Choose Table → Merge Cells from the menu 

bar.

5. State the differences between proprietary software 
and open source software.

Ans. Proprietary software Open source software

Package Developer Package Developer
Microsoft 
Word

Microsoft 
Corporation

Open 
Office 
Writer

Apache

WPS 
Word

Kingsoft Libre 
Office 
Writer

The 
document 
foundation

WordPro Lotus 
Corportation

Abiword Abisource

Part - III
Short Answers.
1. What is the difference between moving and copying 

text?  [Sep. '21; CRT '22]

Ans. Moving text Copying text
To move a text from 
one location to another

To copy a text from one 
location to another

Select the text to be 
moved 

Select the text to be 
copied

Click Ctrl + X or Cut 
Icon  or Edit → Cut

Click Ctrl + C or Copy 
Icon  or Edit → Copy

The text is removed 
from the source 
location and placed in 
the clipboard

A duplicate copy of the 
text is made and send to 
the clipboard

Take the insertion 
pointer to the new 
location to be moved

Take the insertion 
pointer to the new 
location to be copied

2. What are the different types of orientation? 
 [Mar.  '19; QY. '19]

Ans. There are two different orientation :
(i) Landscape : The width of the document is more 

than the height. This is best suited for displaying 
professional photos, invitations, albums, tables 
etc.

(ii) Portrait : This is the most common and default 
orientation. Here, the height of the document 
is more than the width. Normally books, 
newspapers will be displayed in this format.

3. How  do you insert rows and columns?
Ans. To insert rows or columns inside a table:

(i) Place the insertion pointer in the row or in the 
column where you would like to add new rows 
or columns and right-click.

(ii) Choose Row → Insert – to insert a new row or 
Column → Insert  – to insert a new column. 
A dialog box will appear, from which you can 
select the number of rows or columns to insert. 
You can also set the position of the new rows or 
columns to Before or After.

4. What are the different ways to save a document?
 [Sep. '21]

Ans. (i) You can save by clicking File → Save on top 
left corner and then click File → Save As or 
Ctrl+Shift+S. After that browse the location 
where exactly you want to save in your computer.

(ii) You can also save by just pressing Ctrl + S and 
then browse the location where you want to 
save.

(iii) All documents in OpenOffice writer will be 
stored with .odt extension. You can store your 
OpenOffice document as Microsoft Word 
document or pdf.

5. Write the steps to change the line spacing of text.
Ans. (i) Rightclick → line spacing, select the type single, 

1.5 or double.
(ii) Select the entire document by Edit → Select All
(iii) Format → paragraph
(iv) The paragraph dialog box appears, click Indents 

& Spacing tab
(v) In the line spacing option, select the type and 

click OK button.
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Sura’s  XI Std - Computer Applications ➠ Introduction to Word Processor 85

Part - IV
Explain in detail.
1. What are the different methods to change margin 

in writer? [June '19]
Ans. Page margins are the white space around the top, 

bottom, left and right of your document.

Changing or setting page margins in openoffice 
writer can be done in two ways: 
(i) Using the Rulers - quick and easy, but does not 

have precise values. 
(ii) Using the Page Style dialog box - can specify 

precise values for the margins.  

Changing Page Margins using Ruler:
(i) The shaded sections of the rulers are the 

margins. 
(ii) Hold the mouse pointer over the line between 

the gray and white sections.
(iii) The mouse pointer turns into a double-headed 

arrow.
(iv) Hold down the left mouse button and drag the 

mouse to move the margin and release it at the 
required point.

(v) The new margin is set. 
Using the Page Style Dialog Box:
To change margins using the Page Style dialog box  
(i) Right-click anywhere on the page and select 

Page from the popup menu or select page tab of 
page style dialog box.

(ii) In the Margins boxes, specify the values for left, 
right, top and bottom margins.

(iii) Click on OK button. 

2. What is Header and Footer? How do you insert 
page numbers in footer area? [CRT & Aug '22]

Ans. The header is a section of the document that appears 
in the top margin, which displays the title or
chapter name , author name of a document.
(i)  Select from the main menu Insert → Header → 

Default.
(ii)  The header text area is separated from the 

normal text area.
(iii)  In the header area, Enter the text that is to be 

repeated in all pages or Select Insert → Fields 
→ Title.

  The footer is a section of the document that appears 
in the bottom margin of the page which displays the 
page number, date, time etc. which gets displayed on 
all the pages automatically.
(i) Select from the main menu Insert → Footer → 

Default
(ii)  Place the insertion pointer in the footer part of 

the page.
(iii)  Select Insert → Fields → Date to insert date in 

all the pages.
Inserting and Formatting page numbers

  The page numbers can be inserted by performing the 
following steps:
(i) Place the insertion pointer where you want to 

insert the page number
(ii)  choose Insert → Fields → Page Number
(iii)  The page number appears with a gray 

background.
  Normally, the page numbers appear as 1,2,3….., To 

change the numbering style, the following sequence 
of steps can be performed:
(i) Position the insertion pointer where the page 

number has to appear.
(ii)  Select Format → page, which will display the 

Page Style dialog box.
(iii)  Select page Tab
(iv) In the Layout settings, select the format drop 

down combo box
(v) Select the desired style and click OK button.

3. Write the steps to Find and Replace a word with 
another word in OpenOffice writer. 

 [QY. & HY. '19; Sep. '21; CRT '22]
Ans. OpenOffice Writer has a Find and Replace feature 

that helps to locate for a text inside a document and 
replace it with another word.
® Click Edit → Find & Replace (or) Ctrl + F
® The find & Replace dialog box appears as shown.
Steps to find & replace a text :
(i) Type the text you want to find in the Search for box
 For Example : To search a word "Bombay" in a 

document and replace with "Mumbai", enter the 
word "Bombay" in the Search for box.

(ii) To replace the text with different text, type the 
new text in the Replace with box Enter the 
word " Mumbai" in the Replace with box and 
Click Find button, to start the search , the found 
word is highlighted and the first occurrence of 
"Bombay" is highlighted.

(iii) To replace text, click Replace button.
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Chapter8
CHAPTER SNAPSHOT

 8.1  Presentation Software - Meaning 
 8.2.  Impress
 8.3.  Opening a new presentation
 8.4.  Creating a new presentation
  8.4.1.  Using Empty presentation
  8.4.2.  Using Template
  8.4.3.  Using Open existing presentation
 8.5.  Parts of the main Impress window
  8.5.1.  Slides pane
  8.5.2.  Tasks pane
 8.6.  Window elements of Impress
  8.6.1.  View Buttons
  8.6.2.  Status Bar
  8.6.3.  Navigator
 8.7.  Workspace
  8.7.1.  Normal view
  8.7.2.  Outline view

  8.7.3.  Notes view
  8.7.4.  Slide Sorter view
  8.7.5.  Handout view
 8.8.  Formatting a presentation
  8.8.1.   Inserting, deleting and 

rearranging slides
  8.8.2.  Creating the first slide
  8.8.3.  Inserting additional slides
  8.8.4.  Deleting a Slide
  8.8.5.  Rearranging slides
 8.9.  Running the slide show
 8.10.  Saving a Presentation
 8.11.  Master slide
 8. 12.  Creating Graphic Objects
  8.12.1. The Drawing toolbar
 8.13. Inserting images
 8.14.  Inserting audio and video

presentatIon basIcs
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Evaluation
Part - II

Very Short Answers.
1. What is the difference between a slide and a slide 

show? [QY. '19]
Ans. Slide Slide Show

Slide means a 
single slide that 
contains different 
elements like text, 
tables, charts, 
clip-art etc.

A slide show is a presentation of 
a series of slides on a projection 
screen typically in a prearranged 
sequence. The changes between 
slide may be automatic or 
manually controlled by a 
presenter or the viewer.

2. How many in-built slide layouts does impress 
consist of? 

Ans. In built the openoffice impress consists of 12 different 
layout of slides.

3. What do you understand by a presentation?   
 [May '22]

Ans. A presentation is a sequential collection of slides in 
which each slide displays some information in the 
form of text or graphics.

4. Define a template in Impress. 
Ans. Templates are built-in design files which contain 

different predefined styles, such as fond face and 
size, bullet size, place holder's size and position, 
background, colors heme and slide master.

5. What do you understand by the slide layout? 
Ans. Slide layouts are pre-packaged layouts which contain 

formatting, positioning, and placeholders for all 
of the content that appears on a slide. Placeholders 
are the containers in layouts that hold such content 
as text, tables, charts, SmartArt graphics, movies, 
sounds, pictures, and clip art.

Part - III
Short Answers.
1. How many types of views are provided by Impress 

to its users? [Mar. '19, Sep. 2020]
Ans. There are 5 types of views are provided by Impress. 

They are
(i)  Normal view  : Normal view is the main view 

for creating individual slides.
(ii)  Outline view : Outline view shows topic titles, 

bulleted lists and numbered lists for each slide 
in outline format.

Part - I
Choose the Correct Answer.
1. Which is used to move quickly from one slide to 

another?
(a) Compass  (b) Navigator
(c) Fill color   (d) Page border 

 [Ans. (b) Navigator]
2. Which is the shortcut key to view the slide show?

 [QY. '19; Sep. '21]
(a) F6   (b) F9 
(c) F5   (d) F10 [Ans. (c) F5]

3. In Impress, which views shows thumbnail versions 
of all your slides arranged in horizontal rows.
(a) Notes   (b) Outline
(c) Handout   (d) Slide Sorter 
 [Ans. (d) Slide Sorter]

4. Identify the default view in Impress.
(a) Normal   (b) Slide Sorter
(c) Handout   (d) Notes 
 [Ans. (a) Normal]

5. Which menu contains the Slide Transition option?
(a) Slide Show  (b) View
(c) Tools   (d) Format 
 [Ans. (a) Slide Show]

6. Identify the extension of the Impress presentation. 
 [QY. '19; CRT '22]
(a) ,odp   (b) .ppt 
(c) .odb   (d) ,ood [Ans. * .odp]

7. In presentation tools, the entry effect as one slide 
replaces another slide in a slide show. Identify the 
option that suits after reading the statement.
(a) Animation  (b) Slide Transition
(c) Custom animation (d) Rehearse Timing
 [Ans. (b) Slide Transition]

8. Vanya has made a presentation on “Global 
Warming”. She wants to progress her slide show 
automatically while speaks on the topic in the class. 
Which features of Impress would she use?
(a) Custom Animation  
(b) Rehearse Timing
(c) Slide Transition 
(d) Either (a) or (b). [Ans. (b) Rehearse Timing]
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b. Handout view is used for setting up the layout of 
your slides for a printed handout.

c. ■  Select the slide to insert the picture.
 ■   Choose Insert → Picture → From File 

option, and choose the required picture that 
has to be inserted into the slide.

d. Use Slide Show view to deliver your presentation 
to your audience. Slide Show view occupies 
the full computer screen, exactly the way your 
presentation will look on a big screen when your 
audience sees it.

e. To make her presentation attractive, she needs to 
add animation and transition effects to the slides.

2. Explain how a presentation can help a salesperson 
to promote his/her products. [QY. '19]

Ans. Presentation is helpful for a sales person to promote 
his/her products effectively.
(i) Presentation will give visual video, pictures to 

understand a goodness of the product.
(ii) By using presentation, sales person can make 

audience to understand easier and he can get 
more response from the people.

(iii) Presentation help sales person to present 
prospect challenges easier.

(iv) Sales person can explain with physical 
demonstration by shocking animations. It helps 
to increase the sales.

3. Sivabalan created a presentation to be shown at his 
school’s Annual Function. Just 5 minutes before 
the presentation, he noticed that he has misspelt 
the name of the school, which is appearing in 
all the 30 slides of the presentation. How can he 
rectify this mistake in all the slides in one-shot?.

Ans.  The slide master will be helpful in this situation. 
Select the Master slide,
(i) Choose Edit → Find & Replace option from 

the menu bar. The Find & Replace Dialog box 
appears on the screen.

 
(ii) In the search for box type the misspelt word.
(iii)  Type the correct word in the Replace with box.
(iv)  Click the Find option to find the misspelt word.
(v)  Click the Replace All option to replace the 

correct word in all the slides. You can see the 
replacement in all the slides.

4. List some advantages of using templates.
Ans.  (i)      Professional Graphic Design : Even the user 

don't have graphic design experience, they know 
how to make adjustments to existing graphics.

(ii) Branding :  Templates can easily be modified by 
changing colors, fonts, graphics etc.

(iii) Speed : With a good starting point in each slide, 
the presentation is made in a snap.

(iv) Quick customization : It's much easier to edit 
the template in its original form, not as a copy of 
a copy.

(v) Consistency : A consistent design scheme will 
avoid Jarring transitions and sneaking suspicion 
that the presentation was pasted together as a 
ransom note.

Government Exam Questions and Answers

1 Mark
1. The no.of tabs in the workspace of Impress is  

_________. [Govt.MQP-'18]

(a) 2 (b) 5 (c) 4 (d) 6  
 [Ans. (b) 5]

2. In Impress, Shortcut key used to make changes in 
the text style is ______. [Govt.MQP-'18]
(a) F5 (b) F7 (c) F11 (d) F12
 [Ans. (c) F11]

3. Which is the shortcut key to view the slide show?

(a) F6   (b) F8 [HY. '19]

(c) F5   (d) F10 [Ans. (c) F5]

4. You can display the Navigator by pressing:  
 [CRT '22]

(a) Shift+F5 (b) Ctrl+Shift+F5

(c) Ctrl+F5 (d) Shift+Ctrl+F5

 [Ans. (c) F11]

This is Only for Sample, Full Book Order Online or 
Available at All Leading Bookstores

orders@surabooks.com Ph:8124201000/8124301000

www.su
ra

bo
ok

s.c
om

www.Padasalai.Net                                                         www.TrbTnpsc.com

Kindly Share Your Study Materials to Our Email Id - padasalai.net@gmail..com

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

Padasalai

https://www.padasalai.net/


www.Padasalai.Netwww.Padasalai.Net

122 Sura’s  XI Std - Computer Applications ➠ Unit II ➠ Chapter 8  

2 Marks
1. What is use of slide sorter view in Impress? 

 [Govt.MQP-'18]
Ans. Slide Sorter view: Shows a thumbnail of each slide 

in order. Use this view to rearrange the order of 
slides, produce a timed slide show, or add transitions 
between selected slides.

2. Define slide transition. [March 2020]
Ans. Various transitions are available, in Impress. You can 

select the transition speed (slow / medium / fast). 
You can also choose between automatic or manual 
transition, and how long you want the selected slide 
to be shown.

3. What is presentation software? [Sep. 2020; CRT '22]
Ans. A presentation software is a computer software package 

used to show information, in the form of a slide show.

3 Marks
1. What are the three methods of inserting slide in 

Impress presentation?  [Govt.MQP-'18]
Ans. Step 1 : Insert a new slide. This can be done in a 

variety of ways.
  (i) Insert → Slide.
  (ii)  Right-click on the present slide, and 

select Slide → New Slide from the  
pop-up menu. 

  (iii)  Click the empty space after the last 
slide also to create a new slide by right 
clicking New Slide. 

  (iv) Click the Slide icon in the Presentation 
toolbar.

 Step 2 :  Select the layout slide that best fits your 
needs. 

 Step 3 :  Modify the elements of the slide like 
removing unneeded elements, adding 
needed elements (such as pictures), and 
inserting text.

2. How will you start open office impress? [HY. '19]

Ans. (i)    In order to open Impress using Start button, 
click Start button and select All Programs → 
Open Office → OpenOffice Impress. 

 (ii)  If it is already pinned in the Start menu, just 
click and open it. 

5 Marks
1. What is Master Slide? How can you create it using 

Open Office Impress? [QY. '19]

Ans. Master Slide: A Master Slide is a slide that is used 
as the starting point for other slides. It is similar to a 
page style in Writer. It controls the basic formatting 
of all slides. A slide show can have more than one 
Master Slide.

  The pre-packed presentation styles can be modified, 
but new presentation styles cannot be created.

  Click View → Master → Master Slide It is possible to 
view the Master slides in two styles :

  1. Slide Master
  2. Notes Master
 (i)  A New Master slide can be created either by using 

the Master View dialog box or by right clicking 
slides in the Slides pane.

 (ii)  The renaming of the Master Slide is also done by 
the same procedure.

 (iii)  Master Slide will be closed by using the Close 
Master View in the Master View dialog box.

additional questions and Answers
Choose the Correct Answers. 
 1 MARK 
I.  Choose the Correct options for 

the below Questions.
1. Which of the following software used to show 

information in the form of slide show?
(a) Word processor (b) Spread sheet
(c) Presentation (d) draw 

 [Ans. (c) Presentation]

2. How many major functions included in 
presentation software?
(a) 2 (b) 3 (c) 4 (d) many 

 [Ans. (b) 3]
3. Which of the following is used to create 

multimedia?
(a) Presentation (b) Word Processor
(c) draw   (d) Spreadsheet
 [Ans. (a) Presentation]
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3. Devi has created a presentation based on "Trends 
of Wireless Communication", she wants to add 
header, footer, slide numbers in presentation. 
Which menu option she click on?

Ans. She must click of view menu to add Header, Footer 
and slide numbers in presentation.

4. In which menu option is the picture sub menu 
option present?

Ans. The picture sub menu option present under Insert 
menu.

5. What does presentation software includes?
Ans. It includes three major functions:

(i)  an editor that allows the text to be inserted and 
formatted,

(ii)  a method for inserting and manipulating 
graphic images and

(iii)  a slide-show system to display the content.

6. Name few presentation software.
Ans. OpenOffice.org Impress, Microsoft PowerPoint and 

Apple's Keynote.

7. How will you create a presentation using templates?
Ans. (i)     Choose the option From template, it uses a 

template design already created as the basis for 
a new presentation. The wizard changes to show 
a list of available templates. Choose the template 
that you want. 

(ii)  Introducing a New Product and 
Recommendation of a Strategy are pre-packaged 
presentation templates. They can be used to 
create a presentation by choosing from template 
in the first step.

8. What are the three parts of the main impress 
window?

Ans. The main Impress window has three  parts : the Slies 
pane, the Workspace, and the Tasks pane.  

Short Answers. 3 MARKS
1. What do you understand by animation and how 

does it help in enhancing a presentation?
Ans.  Animation refers to the visual effects that are added 

to the text  as well as other objects in the slides in 
presentation. In other words, animation effects are 
used to apply movement in the images and objects 
in slides. The use of animation enhances presentation 
and makes it more attractive. 

2. Explain the usage of Rephrase Time in  options are  
available in presentation software.

Ans. While rehearing, use the slide Timing feature to 
record the time that needed to present each slide, 
and then use the recorded time to advance the slides 
automatically when the presentation shows to actual 
audience. The slide timing feature is ideal for creating 
a self-running presentation. If also make sure that the 
presentation fits within a certain time frame. 

3. Write the steps to change the font and effects of the 
current design theme of a presentation?

Ans. Changing font :
(i) Choose format → styles and formatting or press 

F11.
(ii) Select the style category by clicking on either 

the presentation styles icon or the Graphic 
Style icon at the top of the style and formatting 
window.

(iii) Right - Click on style to be modified and select 
modify from the pop menu.

4. Write a short note on impress.
Ans. Impress is OpenOffice.org’s presentations (slide 

show) module. You can create slides using Impress. 
It contains different elements like text, bulleted 
and numbered lists, tables, charts, clip art and a 
range of graphic objects. Impress has access to the 
spelling checker and thesaurus. Also, it comes with  
pre-packaged text styles, background styles with 
online help.

5. How will you create a presentation?
Ans. create a presentation by any one of the following 

methods.
(i) By selecting an Empty presentation.
(ii) By selecting From template.
(iii) By selecting from Open existing presentation.

Long Answers. 5 MARKS
1. Explain the steps to create a presentation  by 

selecting on empty presentation.
Ans. Using Empty presentation

(i) Select Empty presentation under Type. It creates 
a presentation from scratch.

(ii)  Click Next. The Presentation Wizard step 2 
appears. Figure 8.4 shows the Wizard.

(iii)  Choose a design under Select a slide design. The 
slide design section gives you two main choices: 
Presentation Backgrounds and Presentations.
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(iv)  Each one has a list of choices for slide designs. 
If you want to use one of these other than the 
<Original>, click it to select it. The preview of 
the same will be shown in the preview pane.

(v)  <Original> is an empty background. You can also 
select among three predefined Presentations: 
<Original>, Introducing a New Product, and 
Recommendation of a Strategy.

(vi)  Click an item to see a preview of the slide design 
in the Preview window.

(vii) Select how the presentation will be used 
under Select an output medium. Generally, 
presentations are created for computer screen 
display, so select Screen option. 

(viii) Click Next. The Presentation Wizard step 3 
appears. In this step, you can choose the desired 
slide transition from the Effect drop-down 
menu. Select the desired speed for the transition 
between the different slides in the presentation 
from the Speed drop-down menu. Medium is a 
good choice. Click Create. A new presentation is 
created.

2. Explain view buttons in Impress.
Ans. (i)        Normal, Outline, Notes, Handout and Slide 

Sorter, These five tabs are called View Buttons. 
There are many toolbars that can be used during 
the slide creation; they are revealed by selecting 
them with View → Toolbars.

(ii)  The actual Workspace section is below the 
View Buttons. This is where you assemble the 
various parts of your selected slide. Each view is 
designed to ease the completion of certain tasks.

(iii)  Normal view is the main view for creating 
individual slides. Use this view to format and 
design slides and to add text, graphics and 
animation effects.

(iv)  Outline view shows topic titles, bulleted lists and 
numbered lists for each slide in outline format. 
Use this view to rearrange the order of slides, 
edit titles and headings, rearrange the order of 
items in a list and add new slides.

(v)  Notes view lets you add notes to each slide that 
are not seen when the presentation is shown.

(vi)  Slide Sorter view shows a thumbnail of each 
slide in order. Use this view to rearrange the 
order of slides, produce a timed slide show, or 
add transitions between selected slides.

(vii) Handout view lets you print your slides for a 
handout. You can choose one, two, three, four, 
or six slides per page from Tasks pane → Layouts. 
Thumbnails can be re-arranged in this view by 
dragging and dropping them.

3. Explain the purposes served by outline view in 
Impress.

Ans. Outline view serves for two purposes.
Making changes in the text of a slide:
(i) Add or delete text in a slide just as in the Normal 

view.
(ii)  Move the paragraphs of text in the selected slide 

up or down by using the up and down arrow 
buttons (Move Up or Move Down) on the Text 
Formatting toolbar.

(iii)  Change the outline level for any of the paragraphs 
in a slide using the left and right arrow buttons 
(Promote or Demote).

(iv)  Both move a paragraph and change its outline 
level using a combination of these four arrow 
buttons.

(v)  Comparing the slides with  outline that another 
slide is needed, create it directly in the Outline 
view then return to review all the slides against 
your outline in the Outline view.
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Evaluation
9. In HTML, colours are represented as

(a)  Binary values (b) Octal values 
(c) Decimal values (d) Hexadecimal values
 [Ans. (d) Hexadecimal values]

10. Which of the following symbol is used to prefix with 
hexadecimal value representing colour in HTML? 
(a) % (b) # (c) @ (d)  & 

 [Ans. (b) #]
11. Which of the following attribute is used to change 

text colour within body tag?
(a)  bgcolor   (b) background
(c) text   (d) color [Ans. (c) text]

12. Within body section, which of the following 
attribute is used to set top margin?
(a)  margin   (b) top
(c) topmargin  (d) leftmargin 

 [Ans. (c) topmargin]
13. How many levels of heading tags available in HTML?

 [Aug '22]
(a) 6 (b) 4 (c) 8 (d) 3 

 [Ans. (a) 6]
14. The tag used to insert a line break: [June '19]

(a)  <hl> (b) <br> (c) <html> (d) <p>
 [Ans. (b) <br>]

15. The tag used to define a paragraph in HTML:
(a)  <para> (b)   <p> (c) <q> (d)   <br
 [Ans. (b) <p>]

Part - II
Very Short Answers. 
1. Sandhiya is creating a webpage. She is entering 

HTML code on her computer. In between, she 
keeps pressing “Refresh” / “Reload” button on her 
browser. What is the purpose?

Ans. Reload / Refresh button is used to get the changes 
from the source file:
(i) After modify and save the source file, minimize 

your source file.
(ii) Go to the browser.
(iii) Click Refresh (Internet Explorer)/Reload 

Current Page (Firefox)/Reload this page 
(Chrome) icons on the address bar.

(iv) Press Ctrl + R or F5 will be used to refresh / 
reload the modifications.

Part - I
Choose the Correct Answer. 
1. HTML is acronym for [Sep. '21]

(a) Hyper Transfer Markup Language  
(b) Hyper Text Markup Language
(c)  Hyper Transfer Makeup Language  
(d) Hyper Text Makeup Language
 [Ans. (b) Hyper Text Markup Language]

2. The coded HTML keywords that indicates how web 
browser should format and display the content is 
called _________. [HY. '19]
(a) Tags   (b) Attributes 
(c)  Headings  (d) Body [Ans. (a) Tags]

3. Which of the following is a special word used inside 
tag to specify additional information to the tag?
(a) Tags   (b) Attributes 
(c)  Headings  (d) Body
 [Ans. (b) Attributes]

4. HTML tags should be specified within: [Mar. '19]
(a) [ ]   (b) { }
(c)  ( )   (d)  < > [Ans. (d) < >]

5. An HTML document is bounded within a pair of 
.................. tags. [March 2020]
(a)  <body>.......</body> (b) <title>........</title>
(c) <html> ......</html> (d) <head>......</head> 
 [Ans. (c) <html>..........</html>]

6. Which of the following symbol is used to define a 
closing tag? [May '22]
(a) < >   (b) % 
(c) /   (d) \ [Ans. (c) / ]

7. Which section of the browser window displays the 
main contents? [Sep. 2020]
(a) Head   (b) Body 
(c) Title   (d) Heading
 [Ans. (b) Body]

8. Which of the following tag is a structural tag?
(a) <html>   (b) <hl> 
(c) <br>   (d) <p> 

 [Ans. (a) <html>]
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2. Explain with the help of an example the difference 
between container and empty elements of HTML.

Ans. Container Elements: [March '19 & 2020; HY. '19]
(i) The tags which are required opening and closing 

is known as container elements or tags. 
(ii)  Example : <html>, <body>, <title>, <p> etc.,
Empty Elements:
(i) The tags which are required only opening tag is 

known as empty elements or tags. 
(ii)  Example : <br>, <hr>, etc...

3. What is the wrong in the following coding?
<html>
<my web page>
<title> Welcome to my web page 
</head>
</title>

Ans. 1. </html> tag is missing
 2. There is no opening tag<head>
 3. </title>tag not closed properly.

 Corrected Code :
<html>
<head>
<title> Welcome to my web page </title>
</head>
</html> 

4. How do you define comments in HTML?
 [June '19, Sep. 2020]
Ans. The tag <!> is used to create comments. In HTML, 

the text what you type within this tag is considered 
as comments and it is ignored by the browser. 
Comments never show up onscreen. Comments can 
be placed anywhere in HTML document.
The general form of comments: <! comments >

5. How do you include an image as your web page 
background?

Ans. An image or picture can be applied as background to 
a webpage. When you insert an image as background, 
the text will be displayed on top of the image. 
Background images can be a texture or bitmap or 
even a photo.

 The attributes to apply an image as background:
 <body background = “image_name_with_ extenstion”>

Part - III
Short Answers. 
1. Explain the attributes available with <body> tag.

 [March '19; HY. '19]
Ans. The <body> tag defines the documents body. The 

contents of an HTML page reside within the <body> 
tag. <body> tag contains several attributes.
(i) Background Colour: bgcolor = color :
 By default all the browsers display the text on 

white background. However, the background 
color of the browser can be changed by using 
bgcolor tag.

 The tag to change background colour:
 <body bgcolor = color_name/color_code>
 <body bgcolor = yellow>
(ii) Body text Colour: text = color: The default text 

colour of body section is “black”, it is often called 
as automatic color, text attribute within body tag 
is used to change the text colour.

 The tag to change body text colour:
 <body text = color_name/color_code>
 <body text = #FFFF00>
(iii) Background image: background = image:  An 

image or picture can be applied as background 
to a webpage. When you insert an image as 
background, the text will be displayed on top of 
the image. Background images can be a texture 
or bitmap or even a photo.

 The tag to apply an image as background:
 <body background = “image_name_with_

 extenstion”>
 <body background = “E:\Images\ flower01.

 gif ">
(iv) Setting Margins: margin = value : The margin 

refers the blank area from left or top edge of the 
browser window. Generally there is no default 
margin setting in any browser. If you want 
to leave some space as margin to left or top; 
leftmargin or topmargin attributes will be used 
respectively. 

 The tag to specify the left and top margin:
 <body leftmargin = value topmargin = value>
 <body leftmargin = 50 topmargin = 50>
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2. What are the attributes available in <html> tags? 
 
 [March 2020]Ans. Attributes of <html> tag : 
(i) The <html> tag is used to specify the beginning 

and closing of an HTML document. This tag 
does not have any effect on appearance of 
document. This is only used to make browsers 
and other programs, known that this is an 
HTML document.

(ii) <html> tag has two attributes viz. dir and lang 
to specify the text direction and language setting 
respectively.

attribute
Value to 
be set to 
attribute

Description

dir

ltr (align left-
to-right)
rtl (align 
right-to-left)

dir attribute specifies the 
direction of the text to be 
aligned within the entire 
document.  It is global attribute.
1. ltr is the default value
2.  rtl is used for Arabian 

languages. 

attribute
Value to 
be set to 
attribute

Description

lang

Predefined 
language
code
English – en
Tamil – ta
Telugu – te

lang attribute specify the 
language used within
the document. Predefined 
language code will be
used for this purpose.
Malayalam – ml; Kannada – 
kn; Hindi – hi;
French – fr; German – de;

3. How do you view the source file? [Aug-'22]
Ans. Viewing Source file : Source file is an HTML 

document, what you actually type in text editor 
(Notepad or getit). You can view your original source 
file in the browser. The following steps are to be 
followed to view a source file.
(i) Right click on the browser.
(ii) Select View Page Source (Firefox and Chrome)/

View Source (Internet Explorer) or Press  
Ctrl + U (all browser).

(iii) Source file will be displayed.
(iv) In Internet Explorer, View → Source is also used 

to open source file. 

4. How do you save a file as HTML file?
Ans. (i)  Click File →  Save (or) Press Ctrl + S (ii) Save as dialog box appears. 

(iii)  In “File Name” text box, type a file name with .htm or .html extension.
(iv)  Select “All Files” from “Save as type” list box. (v) Click “Save” button.

Part - IV
Explain in Detail. 
1. Write a HTML program to display your school name and address using various grading level tags.
Ans. 

Kannaki,

Kannaki,
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2. Write the basic structure of a HTML program.
Ans.  

Opening 
Tag

Closing 
Tag

Description

<html> </html> The <html> tag identified 
the document as an HTML 
document.
All HTML documents 
should begins with <html> 
and end with </html>.

<head> </head> The <head> tag contains 
information about the 
document, including its title, 
scripts used, style definition 
and document descriptions.

Opening 
Tag

Closing 
Tag

Description

<title> </title> The <title> tag contains the 
title of the document. The title 
specified between opening and 
closing tags appears in the title 
bar / page tab of the browser.
<title> tag should be placed 
within <head> tag.

<body> </body> The <body> tag encloses 
all the tags, attributes and  
information to be displayed 
in the web page. <body> tag 
should be entered below the 
</head> tag.

Government Exam Questions and Answers
2 Marks

1. What is the error in the following code? [HY. '19]
<html> 
<my web page>
<title> Welcome my friends
</head>
</title>

Ans. 1. </html> tag is missing
 2. There is no opening tag<head>
 3. </title>tag not closed properly.
 Corrected Code :
 <html>
 <head>
 <title> Welcome to my web page </title>
 </head>
 </html> 

5 Marks
1. Write an attribute of heading tag with example. 

 [March 2020; Sep. '21; May '22]
Ans. Headings are used to include titles to sections of a 

web page. HTML has six levels of headings viz. <h1> 
to <h6>. The number with h indicates the level of 
heading. Headings tags are displayed in the body text 
as bold and larger in size according to its level.
Example : 
<html>
 <head>
  <title> Heading </title>
</head>
<body>
 <h1> Welcome to Computer Application</h1>
 <h2> Welcome to Computer Application</h2>
 <h3> Welcome to Computer Application</h3>
 <h4> Welcome to Computer Application</h4>
 <h5> Welcome to Computer Application</h5>
 <h6> Welcome to Computer Application</h6>
</body>
</html>
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Additional Questions and Answers
Choose the Correct Answers. 
 1 MARK 

I.  Choose the Correct options for 
the below Questions.

1. HTML was originally derived from
(a) XML   (b) XHTML
(c) SGML   (d) HTML 
 [Ans. (c) SGML]

2. Which of the following language used to create web 
pages?
(a) HTML   (b) ASP
(c) JAVA   (d) VB [Ans. (a) HTML]

3. Which of the following are coded by HTML 
commands to display the content in the browser?
(a) language   (b) tags
(c) keywards  (d) statements 
 [Ans. (b) tags]

4. HTML language is made up of
(a) tags   (b) attributes
(c) Text   (d) a and b 
 [Ans. (d) a and b]

5. Which of the following known as elements of 
HTML?
(a) Attributes  (b) Tags
(c) Operators  (d) Data types 
 [Ans. (b) Tags]

6. Additional Information included in the HTML 
tags are known as?
(a) Tags   (b) Operators
(c) Data types  (d) Attributes 
 [Ans. (d) Attributes]

7. Which of the following is used to improve the 
appearance of an HTML document?
(a) Tags   (b) Information
(c) Attributes  (d) Symbols 
 [Ans. (c) Attributes]

8. Which of the following defines the structure and  
appearance of  the document?
(a) HTML document (b) HTML tags
(c) HTML attributes (d) HTML symbols 
 [Ans. (a) HTML document]

9. How many  sections are there in Every Web 
document?
(a) 2   (b) 3
(c) 6   (d) only one [Ans. (a) 2]

10. Which sections is used to show the title of a 
webpage in title bar in browser?
(a) Body   (b) Head
(c) Title   (d) Browser 
 [Ans. (b) Head]

11. Which tag is used to specify the title of the webpage?
(a) <HTML>  (b) <Body>
(c) <Head>   (d) <Title> 
 [Ans. (d) <Title>]

12. Which section is used to display the main content 
on the browser window?
(a) Head   (b) Title
(c) Body   (d) Window 
 [Ans. (c) Body]

13. Which tag is used to display the web content on the 
browser window?
(a) <HTML   (b) <Head>
(c) <Content>  (d) <Body> 
 [Ans. (d) <Body>]

14. How many tag are known a structural tag?
(a) 3   (b) 4
(c) 5   (d) 2 [Ans. (b) 4]

15. Which of the following tag is not a structural tag?
(a) <body>   (b) <Head>
(c) <Title>   (d) <Html>
(e) None of these [Ans. (e) None of these]

16. The tag <title> should be entered with in
(a) <Title>   (b) <Head>
(c) <body>   (d) <p> 
 [Ans. (b) <Head>]

17. Which of the following is a structural tag?
(a) <img>   (b) <br>
(c) <title>   (d) <bgcolor>
 [Ans. (c) <title>]
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18. Which of the following not needed to start writing 
HTML?
(a) Web server  (b) Web hosting
(c) Internet   (d) All of these
 [Ans. (d) All of these]

19. Which of the following cannot be done with 
webpages without a network?
(a) write   (b) test
(c) upload   (d) link [Ans. (c) upload]

20. Which of the following is need to write HTML 
code?
(a) Compiler  (b) Interpreter
(c) Text Editor  (d) Linker
 [Ans. (c) Text Editor]

21. Which of the following is need to view HTML code?
(a) Browser   (b) Editors
(c) Compiler  (d) System Software
 [Ans. (a) Browser]

22. The shortcut key to save the HTML document is
(a) Ctrl +H   (b) Ctrl+D
(c) Ctrl+S   (d) Ctrl+V
 [Ans. (c) Ctrl+S]

23. The menu used to save the HTML document is
(a) edit   (b) file
(c) save   (d) view [Ans. (b) file]

24. The shortcut key to view the webpage in a browser 
is
(a) Ctrl +B   (b) Ctrl+W
(c) Ctrl+F   (d) Ctrl+O
 [Ans. (d) Ctrl+O]

25. The shortcut key used to view the HTML source file 
is
(a) Ctrl +S   (b) Ctrl+O
(c) Ctrl+U   (d) Ctrl+F1
 [Ans. (c) Ctrl+ U]

26. The command to open an  HTML source file 
(a) View → Source (b) File → Source
(c) Edit → Source (d) File → Pageview
 [Ans. (a) View → Source]

27. Which of the following menu is used to open the   
HTML source file? 
(a) File   (b) View
(c) Format   (d) Edit  [Ans. (b) View]

28. Which of the following operation can be done 
using HTML text editor? 
(a) Create   (b) Edit
(c) Open   (d) All of these
 [Ans. (d) All of these]

29. HTML  source file can be edit only through the 
(a) Text Editor  (b) Compiler
(c) Interpreter  (d) Browser
 [Ans. (a) Text Editor]

30. Which icon on the address bar to refresh the 
changes of the HTML document in Firefox? 
(a) Refresh   (b) Reload current page
(c) Reload this page (d) Reload 
 [Ans. (b) Reload current page]

31. Which icon is used for reload the changes in HTML 
document? 
(a) Refresh   (b) Reload this page
(c) Reload current page (d) Refresh this page
 [Ans. (a) Refresh]

32. Which of the following should be placed within the 
opening tag? 
(a) Operators  (b) Punctuators
(c) Variables  (d) Attributes
 [Ans. (d) Attributes]

33. How many attributes are there in <Html> tag? 
(a) 2   (b) 3
(c) 1   (d) no attributes
 [Ans. (a) 2]

34. Which of the following tag does not have any effect 
on apperance of HTML document? 
(a) <Head>   (b) <Html>
(c) <Body>   (d) <Title>
 [Ans. (b) <Html>]

35. Which attribute used to in <Html> tag to specify 
the text direction? 
(a) text   (b) direction
(c) direct   (d) dir  [Ans. (d) dir]

36. Which attribute used to in <Html> tag to specify 
the language? 
(a) dir   (b) language
(c) lang   (d) en [Ans. (c) lang]

37. Which of the following is Global attribute? 
(a) align   (b) dir
(c) text   (d) bgcolor 

 [Ans. (b) dir]
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15. Write a note on <p> tag

Ans. In HTML, paragraphs are created using the <p> 
tag. The content between <p> and </p> is identified 
as a paragraph and display as a paragraph by the 
browser. Because, the browser does not recognize 
returns (Pressing “Enter” Key). Remember that in 
word processors, pressing “Enter” key is identifying 
a paragraph.

16. What are the keys not recoganized by the Browser?

Ans. Browser applications are having some special rules 
for displaying text. They do not recognize returns, 
tabs or even more than one space between words.

17. Name the types of HTML elements.
Ans. The HTML elements (Tags) can be classified as two 

types - (1) Container elements (2) Empty elements.

Short Answers. 3 MARKS

1. What is HTML?
Ans. HTML stands for Hyper Text Markup Language. 

HTML is a special markup language used to create 
web pages. This language tells the browsers, how 
to display the text, images, animations and other 
contents of a hypertext document on the screen. 
The language also tells how to make a document 
interactive through special hyper links.

2. Explain HTML document structure.
Ans. An HTML document contains the text of the page 

itself and HTML tags, which defined the structure 
and appearance of the document. It also contains 
hyperlinks to other pages or to include multimedia 
elements such as audio, video, animations etc. Entire 
HTML document is bounded within a pair of <html> 
and </html> tags.

3. Write the steps for viewing webpage in a Browser.
Ans. Step 1 :   Open a Browser (Internet Explorer / 

Mozilla Firefox or any) 
  Step 2 :  Click File → Open File (or) Press Ctrl + O 

 Step 3 : From the “Open” dialog box, browse the 
folder in which the HTML document is 
saved. Choose the File name and click 
“Open” button.

4. Explain two attributes used in HTML.
Ans. 

attribute
Value to 
be set to 
attribute

Description

dir

ltr (align left-
to-right)
rtl (align 
right-to-left)

dir attribute specifies the 
direction of the text to be 
aligned within the entire 
document.  It is global 
attribute.
1.   ltr is the default value
2.    rtl is used for Arabian 

languages.

lang

Predefined 
language 
code
English - en
Tamil - ta
Telugu - te

lang attribute specify the 
language used with in the 
document. Predefined 
language code will be used 
for this purpose.
Malayalam - ml; 
Kannada - Kn; Hindi - hi; 
French - fr; German - de;

5. What is use of <!> tag?
Ans. Comments are used to describe the page or provide 

some kind of indication of the status of the page. 
The tag <!> is used to create comments. In HTML, 
the text what you type within this tag is considered 
as comments and it is ignored by the browser. 
Comments never show up onscreen. Comments can 
be placed anywhere in HTML document.
The general form of comments:
  <! comments >

Long Answers. 5 MARKS

1. Explain the steps to create a webpage.
Ans. Creating a Webpage :

 Step 1 : Open a text editor

    Windows7 :  Start → All Programs 
Accessories → Notepad 

    Linux :  Applications → Accessories 
→ Text Editor

 Step 2 :   In the appearing Note pad / Text Editor, 
type the HTML document.
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 Step 3 : Save the file as HTML

(i) Click File → Save (or) Press Ctrl + S

(ii) Save as dialog box appears.

(iii) In “File Name” text box, type a file 
name with .htm or .html extension.

(iv) Select “All Files” from “Save as type” 
list box.

  Click “Save” button.

2. Explain how will you edit and reload the source file 
in a HTML document.

Ans. Source file can be edit only through the text editor. 
So, to edit the source file, open the source file with 
a text editor. When you edit a source file, no need 
to close browser in which displaying the HTML 
document. The following steps are to be followed to 
open a source file.

(i) Go to the folder in which your source files are 
located.

(ii)  According to you default browser, your source 
file icon is displayed. 

(iii) Right click on the source file that you want to 
edit.

(iv) From the pop-up menu, select Open With → 
Notepad.

(v) Source file will be opened in text editor.

(vi) Make the changes and save the file using 

 File → Save or Ctrl + S. 

Reload / Refresh the changes :

(i) After modify and save the source file, minimize 
your source file.

(ii) Go to the browser.

(iii) Click Refresh (Internet Explorer) / Reload 
Current Page (Firefox) / Reload this page 
(Chrome) icons on the address bar.

(iv)  Press Ctrl + R or F5 will be used to refresh / 
reload the modifications.

3. Create a webpage in HTML documents.

Ans. Create a web page (HTML document) to the 
following specification.

(i)  Title: My First Web Page :

(ii) Text to be display: Welcome to Computer 
Applications.

(iii) Background color: Lime

(iv) Body text color: Blue

(v) Margin: from left and top 1 inch

 <html>

  <head>

   <title> My First Web Page </title>

  </head>

   <body bgcolor = Lime text = blue 
 leftmargin = 72 topmargin = 72> 

  Welcome to Computer Applications 

  </body>

 </html>
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JAvASCRIPTUNIT- IV
Chapter14 IntroductIon to JavascrIpt

CHAPTER SNAPSHOT
 14.1. Introduction to JavaScript 
 14.2.  Advantages of JavaScript Programming Language
 14.3.  Using JavaScript in HTML page with <script>tag
  14.3.1. Steps to follow to code Javascript Language
  14.3.2. First Javascript Program
 14.4.  Lexical Structure of a JavaScript Program
 14.5.  JavaScript Variables
  14.5.1. Basic Data types and Declaring Variables
  14.5.2. Rules for naming variable
  14.5.3. Scope of variables
  14.5.4. Assigning Values to Variables
  14.5.5. Javascript Literals
  14.5.6. Type Casting in Javascript
 14.6.  JavaScript Operators and Expressions
  14.6.1. Arithmetic Operators
  14.6.2. Assignment Operator
  14.6.3. Relational or comparison operators
  14.6.4. Logical Operators
  14.6.5. String Operators
  14.6.6. Increment and Decrement Operators
  14.6.7. Unary + and - Operator
  14.6.8. Type of Operator
  14.6.9. Conditional Operator (?:)
 14.7.  JavaScript Popup or Dialog Boxes
  14.7.1. Alert Dialog Box
  14.7.2. Confirm Dialog Box
  14.7.3. Prompt Dialog Box
 14.8.  Comments in JavaScript
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Evaluation
8. How many attributes specifies that <script> tag in 

the scripting
(a) 2   (b) 3
(c) 4   (d)  5 [Ans. (a) 2]

9. Which attribute is used to indicate the scripting 
language and its value should be sent to “ Text/
JavaScript”
(a) Language  (b) Textl
(c) Type   (d)  Body [Ans. (c) Type]

10. The file reload into the browser use the shortcut 
key is  [March '19; Aug '22]
(a) F2   (b)  F3
(c) F4   (d) F5 [Ans. (d) F5]

11. JavaScript ignores spaces that appear between
(a) Command  (b)  Scripts
(c) Tokens   (d) Text
 [Ans. (c) Tokens]

12. A Data value for variable that appears directly in a 
program by using a
(a) loop   (b)  Literal 
(c) Statement  (d) Text
 [Ans. (b) Literal]

13. Which is mostly used to give a warning message to 
users? [May '22]
(a) Alert Dialog Box (b)  Confirm box
(c) Prompt box  (d) Display box
 [Ans. (a) Alert Dialog Box]

14. In the below snippet, value of x is 
var x = 250 + 2 – 200;
(a) 50   (b)  52
(c) 48   (d) 42 [Ans. (b) 52]

Part - II
Very Short Answers.  
1. Write  a syntax of <script> tag. [Sep. 2020]

Ans. <script language="javascript" type="text/javascript">
JavaScript code
</script>

Part - I
Choose the Correct Answer.
1. Which provided a common scripting language to 

web developers to design, test and deploy Internet 
Application
(a) C   (b) C++
(c)  Java   (d) JavaScript
 [Ans. (d) JavaScript]

2. Expand CGI [Sep. 2020]
(a) Common Gateway Interface  
(b) Complex Gateway Information 
(c)  Common Gateway Information
(d) Complex Gateway Interface
 [Ans. (a) Common Gateway Interface]

3. JavaScript programming language is used to 
develop the
(a)  Dynamic Web Page (b) Window
(c)  Web Page  (d)  Home Page
 [Ans. (a) Dynamic Web Page]

4. The Dynamic Web Page help to save server’s
(a) Work   (b) Route
(c)  Traffic      (d)  Pvath 

 [Ans. (c) Traffic]

5. User entered data, is validated before sending it to 
server is called
(a) Server traffic  (b) Dynamic Web Page
(c) Server Route  (d) Web server 

 [Ans. (b) Dynamic Web Page]

6. Java Scripts can be implemented using which 
statements? [June '19]
(a) <head>   (b) <Java> 
(c) <script>   (d) <text>
 [Ans. (c) <script>]

7. Expand DHTML
(a) Distance Hyper Text Markup language
(b)  Dynamic Hyper Text Markup language
(c) Distance High Text Markup language 
(d)  Dynamic High Text Markup language
 [Ans. (b) Dynamic Hyper Text Markup language]
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2. What is scope of variables and types of scope 
variable? [Aug '22]

Ans. The scope of a variable is the life time of a variable of 
source code in which it is defined.
•	 A	 global	 variable	 has	 global	 scope;	 it	 can	 be	

defined everywhere in the JavaScript code.
•	 Variables	declared	within	a	function	are	defined	

only within the body of the function. They are 
local variables and have local scope.

3. Write a notes to type casting in JavaScript.
Ans. Type casting is the act of converting one data type 

into a different data type which is also called as 
casting. In JavaScript there are two type of casting,
(i) Implicit casting and
(ii) Explicit casting
 Implicit casting occurs automatically in 

JavaScript when you change the data stored in a 
variable:

4. How many Literals in JavaScript and mention its 
types.

Ans. There are 5 type of literals in JavaScript.  They 
are Integer, Floating Point, Character, String and 
Boolean.

5. What is conditional operator give suitable example?
Ans. The?: is the conditional operator in JavaScript, which 

requires three operands, hence it is called the ternary 
operator. The syntax is
var	variablename=(condition)	?	value	1:	value2;
Example : var	result=(10>15)	?100	:150;

6. What are the comments in Java Script?
Ans. There are two types of comments, Single line and 

Multiple line comments. Single-line comments begin 
with a double slash (//), causing the interpreter to 
ignore everything from that point to the end of the 
line. Multiple line comments begins with /* and ends 
with */.

7. Write note on types of Operator.
Ans. The type of operator is used to get the data type 

(returns a string) of its operand. The operand can be 
either a literal or a data structure such as a variable, a 
function, or on object.

8. Write the role of a variable in JavaScript. 
Ans. Variables	are	declared	in	JavaScript	using	var	keyword	

that allocates storage space for new data and indicates 
to the interpreter that a new identifier is in use. 

9. What is the uses of prompt dialog box?
Ans. The prompt dialog box is very useful when the user 

want to pop-up a text box to get user input. Thus, it 
enables you to interact with the user.s

Part - III
Short Answers.
1. What are the advantages of programming 

language?
Ans. (i) JavaScript programming language is used to 

develop interactive web pages called Dynamic 
Web pages.

(ii)  User entered data in the Dynamic Web page can 
be validated before sending it to the server. This 
saves server traffic, which means less load on 
your server. 

(iii)  JavaScript includes items such items as Text 
boxes, Buttons, drag-and-drop components and 
sliders to give a Rich Interface to site visitors.

2. Brief the basic data types in Java Scripts.
Ans. The basic data types in JavaScript are Strings, 

Numbers, and Booleans.
(i) A string is a list of characters, and a string literal 

is indicated by enclosing the characters in single 
or double quotes. Strings may contain a single 
character or multiple characters, including 
whitespace and special characters such as \n 
(the newline).

(ii) Numbers can be integer or floating-point 
numerical value and numeric literals are 
specified in the natural way.

(iii) Boolean can be any one of two values: true or 
false. Boolean literals are indicated by using true 
or false directly in the source code.

3. Write note on string Operator. [Sep. '21]
Ans. One of the built-in features of JavaScript is the 

ability to concatenate strings. The + operator 
performs addition on numbers but also serves as the 
concatenation operator for strings. Because string 
concatenation has precedence over numeric addition, 
+ will be interpreted as string concatenation if any 
of the operands are strings. + operator which is also 
called as the string concatenation operator.
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Sura’s  XI Std - Computer Applications ➠ Introduction to Javascript 191

Government Exam Questions and Answers
5 Marks

1. Write the rules of naming variables in Javascript program.               [June '19]

Ans. Rules for naming variable : 
(i) The first character must be a letter or an underscore (_). Number cannot be as the first character.
(ii) The rest of the variable name can include any letter, any number, or the underscore. You can't use any other 

characters, including spaces, symbols, and punctuation marks.
(iii) JavaScript variable names are case sensitive. That is, a variable named Register Number is treated as an entirely 

different variable than one named register number.
(iv) There is no limit to the length of the variable name.
(v) JavaScript's reserved words cannot be used as a variable name. All programming languages have a supply of 

words that are used internally by the language and that cannot be used for variable names.

2. Explain about logical operator with suitable example.            [Aug '22]
Ans. Logical operators perform logical (boolean) operations. Logical operators combine or invert boolean values. Once 

comparisons are made, the logical operators && (AND), || (OR) and ! (NOT) can be used to create more complex 
conditions.

Logical Operator Example Meaning Result

&&
((4>5( && )10<5))
((expr1) && (expr2))

(Logical AND) Returns true if expr1 and 
expr2 both true. True

||
((4>5( || )10<5)) 
((expr1) || (expr2))

(Logical OR) Returns true if either expr1 
or expr2 is true, or both are true. True

!
!(10<5)
!(expr1)

(Logical NOT) Returns true if expr1 is 
false;	otherwise,	returns	false. False

3. Which of the following language is used to create 
Dynamic web pages?
(a) Java   (b) HTML
(c) HTML 5.0  (d) JavaScript 
 [Ans. (d) JavaScript]

4. Which type of language used to static web page?
(a)	 Javascript	 	 (b)	 Visual	Basic	Script
(c) HTML   (d) ASP 
 [Ans. (c) HTML]

5. Which of the following tag used to create Javascript?
(a) <java>   (b) <script>
(c) <sup>   (d) <javascript> 
 [Ans. (b) <script>]

6. The <script> tag recommended to kept with in the 
tags 
(a) <sub> (b) <head> (c) <body>  (d) <sup>
 [Ans. (b) <head> ]

additional questions and Answers
Choose the Correct Answers. 
 1 MARK 
I.  Choose the Correct options for 

the below Questions.
1. Which language bridged the gap between the 

HTML and CGI programes?
(a) C++   (b) Java
(c) JavaScript  (d) HTML 5.0 
 [Ans. (c) JavaScript]

2. Which of the following language provides many 
advantages over traditional CGI server-side 
scripts?
(a) JavaScript  (b) C++
(c) Java   (d) Python 
 [Ans. (a) JavaScript]
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194 Sura’s  XI Std - Computer Applications ➠ Unit IV ➠ Chapter 14  

7. JavaScript dialog boxes are also called _______.
(a) list boxes  (b) dropdown list boxes
(c) combo boxes  (d) popup boxes
 [Ans. (d) popup boxes]

III. Choose the Correct Statement.
1. (i) Java script not used to create interactive webpages

(ii) Java script can be placed only in <Head>tags
(iii) The syntax of Java script segment in HTML or 

DHTML
(a) Only (i)   (b) Both (i) and (iii)
(c) Only (iii)  (d)  Only (iii) and (ii) 
 [Ans. (c) Only (iii)]

2. (i) Javascript is a case sensitive language
(ii) /* */ is treated as a single line comment in 

Javascript
(iii) Javascript can not use keywords
(a) Only (i)   (b) Only (ii)
(c) Only (iii)  (d) All the above 
 [Ans. (a) Only (i)]

3. (i) An expression is formed by joining operators
(ii) An expression is evaluated and produces result
(iii) There are three types of expressions in Javascript
(a) Only (i)   (b) Only (ii)
(c) Only (iii)  (d)  All the above
 [Ans. (d) All the above]

4. (i)  ++ is used before the operand is known as 
preincrement operator

(ii) - - is used before the operand is known as 
postdecrement operator

(iii) ++ is used after the operand is known as 
postincrement operator

(a) Only (i)   (b) Only (ii)
(c)  Both (i) and (iii) (d) Both (i) and (ii)
 [Ans. (b) Only (ii) ]

5. (i) The prompt dialog box is used to get user input
(ii) The confirm dialog box is used to take user 

consent
(iii) The alert dialog box is used to give a warning 

message
(a) Only (i)   (b)  Only (ii)
(c) Only (iii)  (d)  All the above 
 [Ans. (d) All the above]

IV. Choose the Incorrect Statement.
1. (i)  Lexical structure is not the lowest-level syntax of 

a language
(ii) Lexical structure is the set of elementary rules of 

the language
(iii) Lexical structure specifies variable names

(a) Only (i)    (b) Both (ii) and (iii)
(c) Both (i) and (iii) (d) Only (iii) 

 [Ans. (a) Only (i)]
2. (i)  The first character of a variable name must be 

letter or underscore
(ii) Java script variable names are not case sensitive
(iii) There is no limit to the variable name length
(iv) Javascript keywords cannot be used as a variable 

name

(a) Only (i)   (b) Only (ii)

(c) Both (ii) and (iv) (d)  All the above 
 [Ans. (b) Only (ii)]

Very Short Answers. 2 MARKS

1. What does CGI provides?
Ans. It provides a common scripting language for Web 

developers to design, test and deploy Internet 
Applications.

2. Expand (i) DHTML (ii) XHTML.
Ans. (i) DHTML :  Dynamic Hyper Text Markup 

Language. 
(ii) XHTML :   Extensible Hyper Text Markup 

Language.

3. What is meant lexical structure of a programming 
language?

Ans. The lexical structure of a programming language is 
the set of elementary rules that specifies how to write 
programs in that language. It is the lowest level syntax 
of a language.

4. What does lexical structure specifies?
Ans. The Lexical structure specifies variable names, the 

delimiter characters for comments, and how one 
program statement is separated from the next.

5. Define variable? How variable declared in 
JavaScript?

Ans. Variable	 is	 a	memory	 location	 where	 value	 can	 be	
stored.	 Variable	 is	 a	 symbolic	 name	 for	 a	 value.	
Variables	 are	 declared	 with	 the	 var	 keyword	 in	
JavaScript. Every variable has a name, called identifier.
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6. Write the general syntax of write statement.
Ans. General Syntax:

document	write	("string	"	+	var);

7. Define JavaScript literal.
Ans. A literal is a fixed value given to a variable in source 

code. Literals are often used to initialize variables. 
Values	 may	 be	 Integer,	 Floating	 point,	 Character,	
String and Boolean.

8. What is meant by JavaScript expression?
Ans. An expression is a phrase of JavaScript that a 

JavaScript interpreter can evaluate to produce a value. 
The data types are used directly as literals or within 
variables in combination with simple operators, 
such as addition, subtraction, and so on, to create an 
expressions. 

9. Write the three types of expressions in JavaScript
Ans. There are three types of expressions as follows,

(i) Arithmetic expressions
(ii) Relational expressions
(iii) Logical expressions

10. What is the use of assignment operator?
Ans. An assignment operator is the operator used to 

assign a new value to a variable. Assignment operator 
can also be used for logical operations such as bitwise 
logical operations or operations on integral operands 
and Boolean operands.

11. Write the shorthand arithmetic operators 
supported by JavaScript.

Ans. JavaScript supports  shorthand arithmetic operators 
like +=, -=, *=, /= and %= to evaluate arithmetic 
calculations.

12. What is the value of Y if x = 10 where
(i)  y = x++ (ii) y = ++x

Ans. (i)  10
(ii)  11

13. Write a note on unary + and - operator.
Ans. Unary + and - Operator: + has no effect on numbers 

but causes non-numbers to be converted into 
numbers - Negation (changes the sign of the number 
or converts the expression to a number and then 
changes its sign)

14. What is type of operator?
Ans. The type of operator is used to get the data type 

(returns a string) of its operand. The operand can be 
either a literal or a data structure such as a variable, a 
function, or an object. The operator returns the data 
type.

15. Write the syntax of type of operator.
Ans. Syntax

 type of operand 
 or
 typeof(operand)

16. List the type of value returned by type of operand
Ans. Type of Operand

Number
Boolean
String
Functions
Undefined

17. What is the use of JavaScript dialog boxes?
Ans. JavaScript supports three important types of dialog 

boxes. Dialog boxes are also called as Popup Boxes. 
These dialog boxes can be used to raise an alert, or 
to get confirmation on any input or to have a kind of 
input from the users. 

18. Give an example of two type of comment statement 
in  JavaScript.

Ans. (i)  // JavaScript single line comment//
(ii)  Multiple line comments begins with /* and ends 

with */
19. Write the syntax of prompt ( ) in JavaScript.
Ans. The Syntax of prompt dialog box is,

	 Prompt(“Message”,”defaultValue”);
   (or)
window.prompt("sometext","defaultText");

Short Answers. 3 MARKS
1. Explain the prompt Dialog Box.
Ans. The prompt dialog box is displayed using a method 

called prompt() which takes two parameters:  
(i) a label which you want to display in the text box 
and (ii) a default string to display in the text box. This 
dialog box has two buttons: OK and Cancel. If the 
user clicks the OK button, the prompt() will return 
the entered value from the text box. If the user clicks 
the Cancel button, the prompt() returns null.

2. Write the syntax of confirm ( ) dialog box.
Ans. The syntax of confirm dialog box is

confirm(“message”);
  (or)
window.confirm(“message”);
Example :
	 confirm(“Hai	Do	you	want	to	continue:”);
   (or)
 window.confirm(“Hai Do you want to 

	 continue:”);
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3. Write the syntax of alert dialog box.
Ans. The syntax of alert box is 

Alert(“Message”);
(or)	Window.alert(“Message”);
Example :
alert(“Name	is	compulsory	entry”);
(or)	window.alert(“Name	is	compulsory	entry”);

4. Write the rule of operands used in logical 
expression.

Ans. The strict rules are as follows:
(i)  For && (AND) the result is false if the first 

operand	 is	 false;	 otherwise,	 the	 result	 is	 the	
Boolean value of the second operand.

(ii) For  (OR) the result is true if the first operand 
is	true;	otherwise,	the	result	is	the	Boolean	value	
of the second operand.

(iii) For ! (NOT) the result is true if the operand is 
false;	otherwise,	the	result	is	true.

5. Write a note on Relational operators.
Ans. Relational operators are also called as Comparison 

operators, they compares two values and the result 
is true or false. JavaScript provides a rich set of 
relational operators including == (equal to), != (not 
equal to), < (less than), > (greater than), <= (less than 
or equal to), and >= (greater than or equal to). Using 
a relational operator in an expression causes the 
expression to evaluate as true if the condition holds 
or false if otherwise.

6. Write a note on important attributes of <script> 
tag.

Ans. The <SCRIPT> tag takes two important attributes -
(i) Language : This attribute specifies that the 

scripting language. Typically, its value will be 
javascript. Although recent versions of HTML 
(Extensible HyperText Markup Language - 
XHTML, its successor) have phased out the use 
of this attribute is optional.

(ii) Type : This attribute is used to indicate the 
scripting language and its value should be set to 
"text/javascript".

Long Answers. 5 MARKS
1. Explain the steps to follow to code Javascript 

language.
Ans. Steps to follow to code JavaScript Language

(i) Enter HTML and JavaScript code using any text 
editor.

(ii) Save the latest version of this code.
(iii) Use any browser to see the result. For example : 

Internet Explorer, Google Crome, etc.,
(iv) If this is a new document, open the file via 

browser's Open Menu. If the document is 
already loaded in the Memory, to reload the 
file into the browser use "Refresh" or press F5 
button.

2. Explain the lexical structure of a Javascript 
program.

Ans. The lexical structure of a programming language is 
the set of elementary rules that specifies how to write 
programs in that language. It is the lowest-level syntax 
of a language. The Lexical structure specifies variable 
names, the delimiter characters for comments, and 
how one program statement is separated from the 
next.
(i) Though JavaScript is a case-sensitive language. 

It is good programming practice to type the 
command in lowercase.

(ii) JavaScript ignores spaces that appear between 
tokens (identifiers, operators, punctuator, 
constants and keywords) in programs.

(iii) JavaScript supports two styles of comments. 
Any text follow a “//” and the end of a line is 
treated as a single line comment and is ignored 
by JavaScript. Any text between the characters “ 
/* */” is also treated as a multiline comment.

(iv)	 JavaScript	 uses	 the	 semicolon	 (;)	 to	 separate	
statements. Many JavaScript programmers 
use semicolons to explicitly mark the ends of 
statements.

(v) A literal is a data value for variable that appears 
directly in a program.

(vi) An identifier is simply a name. In JavaScript, 
identifiers are used to name variables, functions 
and to provide labels for certain loops in 
JavaScript code.

(vii) In JavaScript certain keywords are used as 
reserved words, These words cannot used as 
identifiers in the programs.
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additional questions and Answers
Choose the Correct Answers. 
 1 MARK 
I.  Choose the Correct options for 

the below Questions.
1. How many types of control statements in 

JavaScript?
(a) 3 (b) 2 (c) 4 (d) 7 

 [Ans. (b) 2]

2. Which of the following statements used to perform 
different actions based on different conditions 
which are supported by JavaScript?
(a)	 branching	 	 (b)	 looping
(c) break   (d) continue and default 
 [Ans. (a) branching]

3. Which of the following alters the execution 
sequence?
(a) loop (b) break (c) default (d) branch 
 [Ans. (d) branch]

4. How many types of branching statements are there 
in Javascript?
(a) 3 (b) 4 (c) 5 (d) 7 

 [Ans. (b) 4]
5. Which of the following is not a branching  statement 

in Javascript?
(a) if (b) if-else (c) else if (d) for 

 [Ans. (d) for]
6. Which of the following statement is the 

fundamental control statements?
(a) if-else   (b) else-if
(c) switch   (d) none of these 
 [Ans. (d) none of these]

7. How many forms of if statement in  Javascript?
(a) 3 (b) 2 (c) 4 (d) 7 

 [Ans. (b) 2]
8. Which of the following expression is evaluated in  

form statement of javascript?
(a)	 Arithmetic	 	 (b)	 Assignment
(c)	 relational/logical	 (d)	 all	of	these	
 [Ans. (c) relational/logical]

9. Which of the following expression not evaluated in  
form statement of javascript?
(a) relational  (b) Arithmetic
(c)	 logical	 	 	 (d)	 a	or	b	

 [Ans. (d) a or b]
10. Which of the following  is only for true condition?

(a) if-else   (b) if
(c) else-if   (d) switch [Ans. (b) if]

11. Which of the following  statement to specify a new 
condition if the first condition is false?
(a) if-else   (b) else-if
(c) if   (d) for [Ans. (b) else-if]

12. else if is also called
(a)	 nested	if		 	 (b)	 logical	if
(c) conditional if (d) alternate if 
 [Ans. (a) nested if]

13. Which of the following statement is an alternate to 
using if-else structure in Javascript?
(a) do-while   (b) else if
(c) switch   (d) if [Ans. (c) switch]

14. The switch statement beings by evaluating an 
expression placed between
(a) { } (b) < > (c) [ ] (d) ( ) 

 [Ans. (d) ( )]
15. Which of the following statement used commonly 

within switch to exit if choice is found?
(a) break   (b) case
(c) default   (d) label 

 [Ans. (a) break]
16. The same portion of coole needs to be excuted 

many times is called
(a)	 brancing		 	 (b)	 selections
(c)	 loops	 	 	 (d)	 conditional	brancing	
 [Ans. (d) conditional brancing]

17. How many types of looping statements in 
Javascript?
(a) 4 (b) 3 (c) 2 (d) many

 [Ans. (b) 3]
18. Which of the following is not a loop statement in 

Javascript?
(a) for   (b) while
(c) while-do   (d) do-while 
 [Ans. (c) while-do]
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	 	<Title>Program	-	To	test	do..while	statement	in		
JavaScript	</Title>

	 </Head>
 <Body>
	 	 	 	<script	 language="javascript"	 type="text/

	 javascript">	
	 	 	 	document.write("<h2>	 Using	 do..while	

	 Statement	</h2>");	
	 	 	 var	no2=0;	do
 {
   document. write(no2+""); 
	 	 	 no2=no2+2;
	 }while(no2<=10);
	 </script>
	 </Body>
	 </Html>

4. Write a Javascript to find whether the given number 
is positive or negative.

Ans. Code : 
<Html>
<Body>
<script	language="javascript"	type="text/	javascript">
var		N=0;
var		N	=	promt	("Enter	the	number","0");
if (N > 0)
{
alert	("The	Number	is	Positive")
}
else {
alert	("The	Number	is	Negative")
}
</script>
</body>
</Html>

5. Write a Javascript to find whether the given number 
is even or odd.

Ans. Code : 
<Html>
<Body>
<script	language="javascript"	type="text/	javascript">
var		N=0;
var		N	=	promt	("Enter	the	number","0");

if	(N	%	2	=	=	0)
{
alert	("The	Number	is	Even")
}
else {
alert ("The Number is Odd")
}
</script>
</body>
</Html>

6. Write a Javascript to display the  given number is 
words using switch-case (Number between only 1 
and 5)

Ans. Code: 
<Html>
<Body>
<script	language="Javascript"	type="text/	javascript">
var		N=0;
var		N	=	promt	("Enter	the	Number","0");
switch (N)
{
case 1 :
 document.write ("One");
 break;
case 2 :
 document.write ("Two");
 break;
case 3 :
 document.write ("Three");
 break;
case 4 :
 document.write ("Four");
 break;
case 5 :
	 document.write	("Five");
 break;
default:
document.write	("Invalid!	Enter	between	1	and	5");
 }
	 </script>
	 </body>
	 </Html>
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Chapter JavascrIpt functIons16
CHAPTER SNAPSHOT

 16.1. Introduction

 16.2. Some common pre-defined functions

 16.3. User defined functions

Evaluation
Part - I

Choose the Correct Answer.
1. The parameters work as

(a) Local Variable (b) Global Variable
(c)  File Variable  (d) block variable 

 [Ans. (a) Local Variable]

2. Predefined functions are also called as  
[Mar. '19, Sep. 2020; May '22]

(a) Library functions (b) storage functions
(c)  instructions  (d) commands
 [Ans. (a) Library functions]

3. Larger programs are divided into smaller are called
 [HY. '19](a)  modules   (b) block
(c)  sets   (d)  Group  
 [Ans. (a) modules]

4. Which of the following is used to enhance 
reusability and program clarity.
(a) functions  (b) modules
(c)  sets      (d)  instructions 
 [Ans. (a) functions]

5. Which of the following allow the programmer to 
modularize a program. [Aug '22]
(a) Library functions (b) User defined functions
(c) Normal functions (d) Ordinary functions 
 [Ans. (b) User defined functions]

Part - II
Very Short Answers.  
1. What is a function in JavaScript?
Ans. A function is a block of JavaScript code that is defined 

once but may be executed or  invoked any number of 
times.

2. What is the use of function? [HY. '19]
Ans. Functions are used to encapsulate code that performs. 

a specific task. Sometimes functions are defined for 
commonly required tasks to avoid the repetition 
entailed in typing the same statements over and over. 
More generally, they are used to keep the code that 
performs a particular job in one place in order to 
enhance reusability and program clarity.

3. Write a note on Library functions. 
 [Mar. '19; Sep. '21]

Ans. Pre-defined functions are already defined in the 
JavaScript library which are also called Library 
functions. For example isNaN(), toUpperCase(), 
toLowerCase(), length(), alert(), prompt(), write() 
etc., are pre-defined functions.

4. Write a note on user defined functions.    [HY. '19]
Ans. User-defined functions allow the programmer to 

modularize a program. Most computer programs that 
solve real-world problems are much large, occupy 
more space in the computer memory and takes more 
time to execute. Hence such large programs are 
divided into small programs are called modules.

5. Write the syntax of functions.
Ans. The format of a function definition is 

 Function function-name(parameters list)
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  </script>
  </body>
  </Html> 

2. Write a Program in JavaScript to find the sum of 10 
numbers using function.

Ans. <html>
 <body>
   < script language = "JavaScript" type = "text/

 JavaScript">
  var N ;
    var N = prompt("Enter the N terms", "O");
   var  x = parse Int(N);
   var s = sum(x);
   document.write in("The sum of 10 numbers = "+8);
   function sum (x)
  {
  var s = o ;
  var s = (x*(x +1))/2;
  return s ;
 }
 return
   </script>
    </body>
    </html>  

 {

      
Declaration of variable
Executable statements;{ { Function Body

 
 }

Part - III
Short Answers. 
1. Write a program in JavaScript to find the cube of a 

number using function.
Ans. <html>

 <body>
  < script language = "JavaScript" type = "text/

 JavaScript">
   var N = window.prompt("Enter the number to find 

 cube", "O");
  var  x = parse Int(N);
  vary s = cube(x);
   document, written ("The cube of a number" + x + 

 "is" +s); function cube(m)
  {
  var s = m*m*m;
  returns s ;
  }

2 Marks
1. Write any four common Library functions.  

 [March '19 & 2020]

Ans. isNaN(), toUpperCase(), toLowerCase(), length().

3 Marks
1. Write any three predefined functions with its 

description and example [May  '22]

Ans. 

Function Description Example Result

toUpperCase()

Used to 
convert given 
string into 
uppercase

x=”java”
x.toUpperCase(); JAVA

toLowerCase()

Used to 
convert given 
string into 
lowercase

x=”JAVA”
x.toLowerCase(); java

length
Used to find 
length of the 
given string

x=”JAVA”
x.length(); 4

Government Exam Questions and Answers
5 Marks

1. Describe any five pre-defined functions in 
JavaScript with examples. [March '19]

Ans. 

Function Description Example Result
toUpperCase() Used to convert 

given string into 
uppercase

x=”java”
x.toUpperCase();

JAVA

toLowerCase() Used to convert 
given string into 
lowercase

x=”JAVA”
x.toLowerCase();

java

length Used to find 
length of the 
given string

x=”JAVA”
x.length();

4

parseInt() Used to convert 
the given float 
value into an 
integer

parseInt(34.234); 34

parseFloat() Used to convert 
the given string 
into a integer

parseInt(“34.23”); 34.23
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210 Sura’s  XI Std - Computer Applications ➠ Unit IV ➠ Chapter 16  

additional questions and Answers
Choose the Correct Answers. 
 1 MARK 
I.  Choose the Correct options for 

the below Questions.
1. Which of the following is defined once but invoked 

any number of times in JavaScript?
(a) Branch   (b) Loop  
(c) Function  (d) Script 

 [Ans. (c) Function]
2. Which of the following are used to encapsulate 

code that performs a specific task?
(a) Loops   (b) Functions 
(c) Conditional statements  
(d) Tokens [Ans. (b) Functions]

3. How many types of functions in JavaScript 
supports?
(a) 2   (b) 3
(c) 4   (d) many [Ans. (a) 2]

4. Which of the following is not a library function?
(a) prompt()  (b) script()
(c) write()   (d) is NaN()
 [Ans. (b) script()]

5. Which of the following in JavaScripts 
paprameterized or non-parameterized?
(a) literals   (b) identifies 
(c) punctuators  (d) functions 
 [Ans. (d) functions]

6. Which library function returns the element that 
has the ID attribute with the specified value.
(a) isNAN ( )  (b) stElementBy ID ( )
(c) getelement By ID ( ) (d) get element ID ( )
 [Ans. (c) getelement By ID ( )]

II. Choose and Fill in the Blanks.
1. Function invocations provide value for the 

function's __________.
(a) body   (b) execution
(c) parameters  (d) expression
 [Ans. (c) parameters]

2. The result of parseInt("5.68") is ______.
(a) 5    (b) 5.68
(c) 5.6   (d) error [Ans. (a) 5]

3. The result of parseFloat("5.68") is ___________.
(a) 5   (b) 5.6
(c) 5.68   (d) error [Ans. (c) 5.68]

4. The functions parameter lists must be seperated by 
_____________.
(a) comma   (b) dot
(c) semi-colon  (d) colon 
 [Ans. (a) comma]

5. The result of "Sura" length( ) is ________.
(a) 3   (b) 4
(c) "sura"   (d) sura.4 [Ans. (b) 4]

6. The function is NaN ("A") returns _______.
(a) 0   (b) 1 
(c) true   (d) false [Ans. (d) false]

7. The function body enclosed with ________.
(a) ( ) (b) < > (c) [ ] (d) { } [Ans. (d) { }]

8. The punctuator used to identify the function is 
____________.
(a) { } (b) < > (c) ( ) (d) [ ]  [Ans. (c) ( )]

III. Choose the Correct Statement.
1. (i) In JavaScript, there are 3 types of functions

(ii) User-defined functions allow the programme to 
modularize the program.

(iii) Larger programs divided into smaller are called 
modules.

(iv) The function isNAN( ) checks whether the given 
value is valid number or not.

(i) Only (iv)  (b) Only (ii) and (iii)
(c) Only (i)   (d) Both (ii), (iii) and (iv) 
 [Ans. (d) Both (ii), (iii) and (iv)]

IV. Choose the Incorrect Statement.
1. (i)  JavaScript function is defined once and executed 

once.
(ii) Pre-defined functions are not called library 

functions.
(iii) A parametered function definition may include a 

list of identifiers.
(a) Only (i)   (b) Both (i) and (iii)
(c) Only (iii)  (d) Both (i) and (ii)
 [Ans. (d) Both (i) and (ii)]

2. (i) The function name is any valid identifier
(ii) The function parameter list contians only one 

valid variable name.
(iii) The function parameter lists parameters  are 

seperated by
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(a) Only (ii)   (b) Only (iii)
(c) Only (i)   (d) Both (ii) and (iii) 

 [Ans. (d) Both (ii) and (iii)]
V. Match the Following.
1. Result function

i) 7 1) tolowerCase()

ii) 74.36 2) to uppercase()

iii) Java 3) parseInt()

iv) JAVA 4) parsefloat()

(a) 3, 4, 2, 1   (b) 3,4,1,2 
(c) 3,1,4,2   (d) 4,3,1,2 
 [Ans. (b) 3, 4, 1, 2]

Very Short Answers. 2 MARKS
1. What are the two types of functions supports by 

JavaScript?
Ans. JavaScript supports two types functions. They are

(i) Pre-defined or Library Functions.
(ii) User-defined Functions.

2. What are the rules followed while defining  
functions  in JavaScript?

Ans. The function-name is any valid identifier.
(i)  For Example: sum
(ii) The parameter list contains one or more valid 

variable name.
(iii) Parameter list contains more than one variable 

then comma must be there between the variable.
(iv) The function body must be enclosed by braces.

3. Write a note on isNAN( ) function.
Ans. (i)        The isNaN( ) function is used to check whether 

the given value or variable is valid number. 
(ii)   This function returns true if the given value is not 

a number. For example isNaN("12"), isNaN(''A'').

Long Answers. 5 MARKS

1. Write a JavaScript to find sum of two numbers 
using function.

Ans. <html>
 <head>
  <title> Function Example  </title>
 <script type = "text/JavaScript">
  var input 1 = window.prompt("Enter Valuel :", "0");
 var input2=Window.prompt("Enter VaIue2:","0");
 var vl=parseInt(inputl);
 var v2=parseInt(input2);

 var s=sum(vl,v2);
  document.writeln("<br><h4><u>Example for 
 Function</u></h4>");
  document.writeln("First No:"+v1+<br>Second 
 No:"+ v2+"<br>The Sum = " + s);
 function sum(x, y)
  {
 var s=x+y;
 return s;
 }
 </script>
 </head>
 <body>
 </body>
 </html>    

2. Write a JavaScript to find the given value is a 
number or not. Using functions and form.

Ans. <html>
  <title>Example Program to test isNan( ) Function</title>
 <head> </head>
 <body>
 <h4><u>Example Program to test isNan( ) Function
  </u></h4>
 <script language="JavaScript">
 function checknum( )
 {
 var n=document.form1.text1.value;
 if(isNaN(n)==true)
 {
 document.form1.text2.value="Not a Number:"+n;
 }
 else
 {
 document.forml.text2.value="It is Number: "+n;
  }
 }
 </script>
 <form name="forml">
 Enter a Number1:
 <input type="text" name="textl" size=3>
 <br><br>
 <input type="button" value="Click to Check"   
 onClick="checknum( )">
 <input type="text" name="text2" size=30>
 <br>
 </form>
 </body>
 </html>
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Chapter tamIl computIng18
CHAPTER SNAPSHOT

 18.1.  Introduction
 18.2.   Tamil in Internet
 18.3.  Search Engines in Tamil
 18.4.  e-Governance
 18.5.  e-Library
 18.6.  Tamil Typing and Interface Software
  18.6.1. Familiar Tamil Keyboard Interface
 18.7. Tamil Office Automation Applications
 18.8.  Tamil Translation Applications
 18.9.  Tamil Programming Language
 18.10.  Tamil Information Interchange Coding Systems
 18.11.  Tamil Operating System
 18.12. Organisation and Projects to develop Tamil

Evaluation
3. Write a short note about Tamil  Programming 

Language.
Ans. Programming languages to develop software to 

computers and smart phones are available only 
in English. Now, efforts are taken to develop 
programming languages in Tamil. Basedon Python 
programming language,the first Tamil programming 
language "Ezhil" (vÊš) is designed. With the help of 
this programming  language, you can write simple 
programs in Tamil.

Very Short Answers. 
1. List the search engines supported by Tamil 

language. [March 2020; May '22]

Ans. (i)        Google     (ii)   Bing
(iii)   yahoo.

2. What are  the keyboard layouts used in Android?
Ans. Sellinam and Ponmadal – are familiar Tamil keyboard 

layouts that works on Android operating system in 
Smart phone using phonetics.
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4. What is TSCII? [March 2020]

Ans. TSCII (Tamil Script Code for Information 
Interchange) is the first coding system to handle our 
Tamil language in an analysis of an encoding scheme 
that is easily handled in electronic devices, including 
non-English computers. This encoding scheme was 
registered in lANA (Internet Assigned Numbers 
Authority) unit of ICANN.

5. Write a short note on Tamil Virtual Academy.
Ans. With the objectives of spreading Tamil to the entire 

world through internet, Tamil Virtual University was 
established on 17th February 2001 by the Govt. of 
Tamilnadu. Now, this organisation functions with the 
name  of "Tamil VIrtual Academy': It offers different 
courses in Tamil language, Culture, heritage etc., 
from kindergarten to under graduation level. 

Government Exam Questions and Answers

1 Mark
1. Getting Government services through internet is known as ___________. [HY. '19]

(a) e-filling     (b) e-payment 
(c) e-governance   (d) e-shopping [Ans. (c) e-governance]

2. ________ is a Tamil translation application. [Sep. '21]

(a) Lippikar   (b) Thamizpori  (c)  Azhagi  (d)   Ezhil [Ans. (b) Thamizpori]

3. The first Tamil programming language is ______. [Sep. 2020; May '22]

(a) Ezhil   (b) Kuzhal   (c)  Thamizpori  (d)   kamban [Ans. (a) Ezhil]

2 Marks
1. What are the familiar keyboard used for Tamil typing? [HY. '19]

Ans. (i)        NHM Writer, E-Kalappai and Lippikar - are familiar Tamil keyboard interfaces software that is used for Tamil 
typing which works on Tamil Unicode, using phonetics.

(ii)   Sellinam and Ponmadal - are familiar Tamil Keyboard layouts that works on Android operating system in smart 
phone using phonetics.

2. Write a note on Unicode. [Sep. 2020]
Ans. Unicode is an encoding system, designed to handle various world languages, including Tamil. Its first version 1.0.0 

was introduced on October 1991. While introduction of this scheme, can be able to handle nearly 23 languages 
including Tamil. Among the various encoding scheme, Unicode is the suitable to handle Tamil.

additional questions and Answers
Choose the Correct Answers. 1 MARK 

I.  Choose the Correct options for the below Questions.

1. Which of the following plays a vital role in ever man's life?
(a) Mobile   (b) Computer  (c)   Internet  (d)   Laptop [Ans. (c) Internet]
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2. Which of the following  is the best information 
technological device?
(a) Computer  (b) Internet
(c) Mobile   (d) Notebook Computer

 [Ans. (b) Internet]

3. How many percentage of people using Internet is 
Tamil?
(a) 40%   (b) 43%
(c) 50%   (d) 42% [Ans. (d) 42%]

4. In India, Which is the most widely language in 
Internet?
(a) Tamil   (b) Hindi
(c) Kannada   (d) Malayalam
 [Ans. (a) Tamil]

5. How many percentage of Internet users consider 
local language digital content to be more reliable 
than english?
(a) 42%   (b) 52%
(c) 68%   (d) 48% [Ans. (c) 68%]

6. Which year onwards, 74% if people in India will 
access Internet using Tamil?
(a) 2019    (b) 2021
(c) 2023   (d) 2030 [Ans. (b) 2021]

7. Which of the following are used to search any 
information from the cyberspace?
(a) Operating System (b) Compiler
(c) Search engines  (d) Web clients
 [Ans. (c) Search engines]

8. Which of the following provide searching facilities 
in Tamil?
(a) Google   (b) Bing
(c) Safari   (d) Both a and b
 [Ans. (d) Both a and b]

9. Which of the following is not provide searching 
facilities in  Tamil?
(a) Yahoo (b) Safari (c) Bing (d) Google 
 [Ans. (b) Safari]

10. Which of the following search engine gives Tamil 
virtual keyboard?
(a) Bing (b) Yahoo (c) Safari (d) Google
 [Ans. (d) Google]

11. Which country provides all their services through 
the official website in Tamil?
(a) Srilanka   (b) America
(c) Singapore  (d) Malaysia
 [Ans. (a) Srilanka]

12. Which of the following are portal or website of 
books collection?
(a) E-Papers   (b) E-Commere
(c) E-languages  (d) E-libraries 

 [Ans. (d) E-libraries]

13. Which of the following is not a familiar Tamil 
keyboard interfaces software?
(a) NHM Writer  (b) Ponmadal
(c) E-Kalappai  (d) Lippikar 
 [Ans. (b) Ponmadal]

14. In white OS, Sellinam Tamil keyboard layout 
works?
(a) windows   (b) linux
(c) Android   (d) iOS
 [Ans. (c) Android]

15. Which of the following Tamil keyboard layout not 
used by Android OS?
(a) NHM Wirter  (b) E-Kalappai
(c) Lippikar   (d) All of these
 [Ans. (d) All of these]

16. Which of the following application have more than 
30000 Tamil words equivalent to English words?
(a) Kamban   (b) Thamizpori
(c) Vani   (d) Ponmozhi
 [Ans. (b) Thamizpori]

17. Which of the following language used to design 
''Ezhil''? Tamil programming language?
(a) C (b) C++ (c) Java (d) Python
 [Ans. (d) Python]

18. Which of the following coding systems specially 
designed for Indian languages?
(a) ASCII   (b) TSCII
(c) ISCII   (d) EBCDIC
 [Ans. (c) ISCII]
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19. Which encoding scheme is suitable to handle 
Tamil?
(a) ASCII   (b) ISCII
(c) Unicode   (d) BCD
 [Ans. (c) Unicode]

20. In India, 42% of users mostly used language in 
india?
(a) Tamil   (b) Kannada
(c) Malayalam  (d) Telugu
 [Ans. (a) Tamil]

II. Choose and Fill in the Blanks.

1. The first programming language "Ezhil" is designed 
by  ____________.
(a) C++   (b) Java
(c) Python   (d) Visual Basic
 [Ans. (c) Python]

2. The ASCII encoding system is applicable only for 
handling the language ____________.
(a) English   (b) Hindi
(c) Tamil   (d) All of these
 [Ans. (a) English]

3. The first version of Unicode is __________.
(a) 1.0.0   (b) 1.0.1
(c) 0.0.1   (d) 0.1.1 [Ans. (a) 1.0.0]

4. The first version of Unicode introduced in the year 
________.
(a) 1990   (b) 1998
(c) 1991   (d) 1981 [Ans. (c) 1991]

Very Short Answers. 2 MARKS

1. What is e-governance?
Ans. Getting Government services through internet is 

known as e-Governance. Govt. of Tamilnadu has 
been giving its services through Internet.

2. What is the use of e-libraries?

Ans. E-Libraries are portal or website of collection of 
e-books. Tamil e-Library services provide thousands 
of Tamil Books as e-books mostly at free of cost. It is 
the most useful service to Tamil people who live far 
away from their home land.

3. What is the use of Tamil interfaces software?

Ans. Tamil interface software .is the familiar one among the 
different methods of typing. This is the simplest method 
of typing Tamil in both Computer and Smart phones.

4. List some Tamil Automation softwares.

Ans. Tamil Libra Office, Tamil Open Office, Azhagi 
Unicode Editor, Ponmozhi, Menthamiz, Kamban, 
Vani are office automation software working 
exclusively for Tamil.

5. Write a short note on "Thamizpori".

Ans. Thamizpori (jÄœbgh¿) is a Tamil translation 
application having more than 30000 Tamil words 
equalent to English words. Using this application. we 
can transalte small English sentences into Tamil.

6. Expand 

(i) TSCII (ii) ISCII   (iii) ASCII

Ans. (i)        Tamil Script Code for Information Interchange

(ii)   Indian Script Code for Information Interchange

(iii)   American Standard Code for Information 
Interchange.

7. Write a short note on Madurai project.

Ans. Project Madurai is an open and voluntary initiative to 
collect and publish free electronic editions of ancient 
tamil literary classics. This means either typing-in 
or scanning old books and archiving the text in one 
of the most readily accessible formats for use on all 
popular computer platforms.
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Part - I
Note:  (i) Answer all the questions.  (15 × 1 = 15)

 (ii)  Choose the most appropriate answer from the 
given four alternatives and write the option code 
and the corresponding answer. 

1. The main component of first generation computers is :

(a) Vacuum tubes (b) Transistors
(c) Integrated circuits (d) Microprocessors

2. Expansion of ASCII :
(a) American School Code for Information 

Interchange
(b) American Standard Code for Information 

Interchange
(c) All Standard Code for Information Interchange
(d) American Society Code for Information 

Interchange
3. The file management system used by Linux is :

(a) ext 2   (b) NTFS
(c) FAT   (d) NFTS

4. The shortcut key used to rename a file in windows :
(a) F2 (b) F4 (c) F5 (d) F6

5. Which button selects all instances of the search text in 
the document?
(a) Find  (b) Find all
(c) Replace (d) Replace All

6. Which is the first electronic spreadsheet?
(a) Excel (b) Lotus 1-2-3
(c)	 Visicalc	 (d)	 OpenOffice	Calc

7. W3C was established in 1994 by : 
(a) Tim Berners - Lee (b) Tim Burnard Lee
(c) Kim Berners (d) Kim Bernard Lee

8. How many levels of heading tags available in HTML?

(a) 6 (b) 4 (c) 8 (d) 3

9. The tags <sub> and <sup> used for :

(a) Subject and Super

(b) Subscript and Super 

(c) Subject and Superscript

(d) Subscript and Superscript

10. The important attributes used with the <Form> tag are:

(a) method and action (b) name and size

(c) post and get  (d) type and name

11. Which of the following is the page level style?

(a) <Page>   (b) <Style>

(c) <Link>   (d) <H>

12. The file reload into the browser use the shortcut key is :

(a) F2 (b) F3 (c) F4 (d) F5

13. _________ statement can be used as alternative to if 
-else statement.

(a) while   (b) if

(c) Else - if   (d) Switch

14. Which of the following allows the programmer to 
modularize a program?

(a) Library functions

(b)	 User	defined	functions

(c) Normal functions

(d) Ordinary functions

15. Commercial programs made available to the public 
illegally are known as :

(a) Freeware  (b) Warez

(c) Free software (d) Software

Instructions :  1.    Check the question paper for fairness of printing. If there is any lack of fairness, inform the Hall 
Supervisor immediately.

   2.  Use Blue or Black ink to write and underline pencil to draw diagrams.
Note   : This Question Paper contains four parts.
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Part - II
Note :   Answer any six questions. Question No. 24 is  

Compulsory. (6 × 2 = 12)
16. What are the components of a CPU?
17. What are the security management features available 

in operating system?
18. How will you rename a file?
19. What are the types of toolbars available in OpenOffice 

Calc?
20. What is phishing?
21. What are the types of list in HTML?
22. Write down the general format of <marquee> Tag.
23. What is scope of variables? Mention its types.
24. What are the guidelines that should be observed by 

computers users?

Part - III 
Note :   Answer any six questions. Question No. 33 is 

Compulsory. (6 × 3 = 18)
25. Write note on binary number system.
26. Differentiate PROM and EPROM.
27. Write a note on Recycle bin.
28. What are the advantages of email?
29. How do you view a source file?
30. What are ethical issues? Name them.
31. Explain the different values of <input> tag’s type 

attribute.
32. Difference between the increment and decrement 

operator.
33. What are the uses of <strong> and <em> tag?

Part - IV
Note : Answer all the questions.  (5 × 5 = 25)
34. (a) Explain the basic components of a computer with a 

neat diagram.
(Or)

 (b) What is header and footer? How do you insert 
page numbers in footer area?

35. (a) Explain the concept of a distributed operating 
system with its advantages.

(Or)
  (b) Explain the attributes used with <table> tag in 

HTML.
36. (a)	 Explain	any	five	types	of	internet	services.

(Or)
 (b) How will you insert images with HTML 

document?

37. (a) Explain about logical operator with suitable 
example.

(Or)
 (b) Explain switch case statement with example.
38. (a) List and explain the font and text element 

properties and values used CSS.
(Or)

 (b) Explain the structure of e-mail.

Answers
 Part - I

1. (a) Vacuum tubes
2. (b) American Standard Code for Information 

Interchange
3. (a) ext 2
4. (a) F2
5. (b) Find all
6. (c) Visicalc
7. (a) Tim Berners - Lee
8. (a) 6
9. (d) Subscript and Superscript
10. (a) method and action
11. (b) <Style>
12. (d) F5
13. (d) Switch
14.	 (b)	 User	defined	functions
15. (b) Software

Part - II
16. The CPU has three components which are Control unit, 

Arithmetic and Logic Unit (ALU) and Memory unit.
17. The Operating System provides three levels of securities 

to the user end. They are
 (i) File access level (ii)  System level
 (iii) Network level.
18.	 There	are	number	of	ways	to	rename	files	or	folders.	

You can rename using the File menu, left mouse button 
or right mouse button.

19. There are three toolbars available by default. They are: 
 (i) Standard Toolbar 
 (ii) Formatting Toolbar (iii)  Formula bar
20. Phishing scams are fraudulent attempts by cyber criminals 

to obtain private information. Phishing scams often appear 
in the guise of email messages designed to appear as 
though they are from legitimate sources.
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