
 
 

 

 

 
 

 
(Based on the new syllabus and new text book for the year 2024-2025) 

 
 

 
 
 

 
       PREPARED BY., 

      B. MOHAMED YOUSUF M.C.A., B.Ed., 

      Pg asst in computer science 
                                           [yousufaslan5855@gmail.com] 

 
 

www.Padasalai.Net                                                                     www.Trb Tnpsc.Com

Kindly Send Me Your Key Answer to Our email id - Padasalai.net@gmail.com

www.P
ad

as
al

ai
.N

et

www.P
ad

as
al

ai
.N

et

https://www.padasalai.net/
https://www.padasalai.net/


 
 

 

 

Index.., 
s.no                                            topics Pg.no 
 PART-  I (ONE WORDS)  
1.  ch-1 to 18 Book back & PUBLIC one word question with answers  1 
2.  ch-1 to 18 Book INSIDE one word question with answers 9 
3.  Important short cut keys & important years 33 
4.  Author names & ABBREVIATIONS   34 
5.  Short cut keys with functions 36 
6.  glossary 38 
7.  CHAPTER 1 TO 18 LIST OUTS / TYPES / SUB HEADINGS 42 
 PART – II (TWO MARKS)  
8.  ch-1 to 18 Book back & PUBLIC two marks question with answers 53 
 PART – III (THREE MARKS)  
9.  ch-1 to 18 Book back & PUBLIC three marks question with answers  65 
 PART – Iv (five MARKS)  
10.  ch-1 to 17 Book back & PUBLIC five mark question with answers 82 
11.  ch-1 to 18 BOOK INSIDE (2,3,5) MARKS QUESTION & ANSWERS   113 
 PART – v (important programs)  
12.  CH-1 TO 16 Important procedures, formats and methods 144 
13.  Public examination 2 & 3 mark COMPULSORY QUESTIONS WITH answers 153-155 

 
 
 
 
 
 
 
 
 
 
 

 

www.Padasalai.Net                                                                     www.Trb Tnpsc.Com

Kindly Send Me Your Key Answer to Our email id - Padasalai.net@gmail.com

www.P
ad

as
al

ai
.N

et

www.P
ad

as
al

ai
.N

et

https://www.padasalai.net/
https://www.padasalai.net/


 
 

1 

PREPARED BY…  B.MOHAMED YOUSUF   M.C.A.., B.Ed.,   (PG ASST IN COMPUTER SCIENCE) 
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CHAPTER 1 TO 18 ONE WORD BOOK BACK & PUBLIC QUESTION with ANSWERS 
(CHAPTER-1) (Introduction to Computers) 

1. First generation computers used --- [S-2022, J-2024] 

(a)Vacuum tubes    (b) Transistors   (c) Integrated circuits   (d) Microprocessors 

2. Name the volatile memory---- [M-2022] 

(a) ROM     (b) PROM    (c) RAM    (d) EPROM 

3. Identify the output device  

(a) Keyboard    (b) Memory    (c) Monitor    (d) Mouse 

4. Identify the input device [J-2019] 

(a) Printer     (b) Mouse    (c) Plotter    (d) Projector 

5. …………… Output device is used for printing building plan, flex board, etc. 

(a) Thermal printer   (b) Plotter    (c) Dot matrix     (d) inkjet printer 

6. In ATM machines, which one of the following is used to ------ [S-2020] 

(a) Touch Screen    (b) speaker    (c) Monitor   (d) Printer 

7. When a system restarts ………………..which type of booting is used.  [M-2019, M-2023] 

(a) Warm booting   (b) Cold booting    (c) Touch boot   (d) Real boot 

8. Expand POST [J-2023] 

(a) Post on self-test             (b) Power on Software Test (c) Power on Self-Test   (d) Power on Self Text 

9. Which one of the following is the main memory? [M-2024] 

(a) ROM     (b) RAM   (c) Flash drive    (d) Hard disk 

10. Which generation of computer used IC’s? [S-2021] 

      (a) First    (b) Second    (c) Third   (d) Fourth 

 
(CHAPTER-2) (Number Systems)  
1. Which refers to the number of bits processed by a computer’s CPU?  

(a) Byte    (b) Nibble   (c) Word length   (d) Bit 

2. How many bytes does 1 Kilo Byte contain?  

(a) 1000    (b) 8    (c) 4    (d) 1024 

3. Expansion for ASCII [J-2024]         (a) American School Code for Information Interchange.  

(b) American Standard Code for Information Interchange 

(c) All Standard Code for Information Interchange (d) American Society Code for Information Interchange 

4. 2^50 is referred as 

(a) Kilo    (b) Tera    (c) Peta    (d) Zetta 

5. How many characters can be handled in Binary Coded Decimal System? 

(a) 64   (b) 255    (c) 256    (d) 128 

6. For 11012 what is the Hexadecimal equivalent? [M-2022] 

(a) F    (b) E    (c) D    (d) B 

7. What is the 1’s complement of 00100110? [M-2023] 

(a) 00100110   (b) 11011001   (c) 11010001   (d) 00101001 

8. Which amongst this is not an octal number?  

(a) 645    (b) 234    (c) 876    (d) 123 

1. For 11102 the hexadecimal equivalent is: [J-2023] 

(a) C   (b) B   (c) E   (d) A 

2. How many bits are there in Nibble? [J-2019]  

     (a) 2    (b) 4   (c) 8   (d) 1024 

3. What is the 1’s complement of 11011001? [S-2020] 

(a) 00100110   (b) 11100110   (c) 11011000  (d) 11011111 

4. 2^30 is referred as [M-2019] 

(a) Peta    (b) Mega   (c) Giga   (d) Tera 

5. What is the ASCII value for blank space? 

(a) 65   (b) 32   (c) 90   (d) 98 
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(CHAPTER-3) (Computer Organization) 

1. Which of the following is said to be the brain of a computer? 

       (a) Input devices    (b) Output devices  (c) Memory device   (d) Microprocessor 

2. Which of the following is not the part of a microprocessor unit? [J-2019] 

       (a) ALU    (b) Control unit    (c) Cache memory  (d) register 

3. How many bits constitute a word? [J-2024]       

      (a) 8    (b) 16       (c) 32     (d) determined by the processor used 

4. Which of the following device identifies the location when address is placed in the memory address register? 

      (a) Locator    (b) encoder    (c) decoder    (d) multiplexer 

5. Which of the following is a CISC processor? [M-2020] 

       (a) Intel P6     (b) AMD K6     (c) Pentium III    (d) Pentium IV 

6. Which is the fastest memory? 

      (a) Hard disk    (b) Main memory  (c) Cache memory  (d) Blue-Ray disc 

7. How many memory locations are identified by a processor with 8 bits address bus at a time?   

      (a) 28    (b) 1024    (c) 256     (d) 8000 

8. What is the capacity of 12cm diameter DVD with single sided and single layer? 

       (a) 4.7. GB    (b) 5.5 GB   (c) 7.8GB   (d) 2.2 GB 

9. What is the smallest size of data represented in a CD? [M-2023] 

       (a) Blocks    (b) sectors   (c) pits    (d) tracks 

10.  Display devices are connected to the computer through. [M-2019] 

       (a) USB port    (b) Ps/2 port    (c) SCSI port      (d) VGA connector 

1. Which of the following is a RISC processor? [M-2024] 

       (a) Pentium III   (b) Pentium IV    (c) Intel 386    (d) Pentium II 

 
(CHAPTER-4) (Theoretical concepts of Operating System) 
1. Operating system is a -------- [M-2019, J-2024] 

(a) Application Software   (b) Hardware   ` (c) System Software    (d) Component 

2. Identify the usage of Operating Systems 

(a) Easy interaction between the human and computer  (b) Controlling input & output Devices    

       (c) Managing use of main memory       (d) All the above 

3. Which of the following is not a function of an Operating System? [M-2023] 
(a) Process Management  (b) Memory Management  (c) Security management  (d) Complier Environment 

4. Which of the following OS is a commercially licensed Operating system? 

(a)Windows   (b) UBUNTU   (c) FEDORA   (d) REDHAT 

5. Which of the following Operating systems support Mobile Devices? [S-2020, S-2021] 

(a) Windows 7    (b) Linux    (c) BOSS    (d) iOS 

6. File Management manages [M-2022] 

(a) Files    (b) Folders   (c) Directory systems  (d) All the Above 

7. Interactive Operating System provides------- 

(a) Graphics User Interface (GUI)         (b) Data Distribution   

(c) Security Management                  (d) Real Time Processing 

8. An example for single task operating system is  

(a) Linux                             (b) Windows   (c) MS-DOS              (d) UNIX 

9. The File management system used by Linux is [S-2022, M-2024] 

(a) ext2    (b) NTFS   (c) FAT    (d) NFTS 

1. Android is a ---- [J-2019] 

(a) Mobile O.S  (b) Open source  (c) Developed by google (d) All the above 

 
(CHAPTER-5) (Working with typical operating systems) 
1. From the options given below, choose the operations managed by the operating system. [S-2021] 

          (a) Memory      (b) Processor        (c) I/O devices      (d) all of the above 

2. Which is the default folder for many Windows Applications to save your file? [M-2020] 

 (a)  My Document    (b) My Pictures    (c) Documents and Settings    (d) My Computer 

3. Under which of the following OS, the option Shift + Delete – permanently deletes a file or folder? 

(a) Windows 7  (b) MS-DOS  (c) Linux   (d) Android OS 
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4. What is the meaning of "Hibernate" in Windows XP/Windows 7? 

            (a) Restart the Computer in safe mode     (b) Restart the Computer in hibernate mode 

            (c) Shutdown the Computer terminating all the running applications 

            (d) Shutdown the Computer without closing the running applications 

5. The shortcut key used to rename a file in windows [S-2021, M-2023, J-2023] 

 (a) F2    (b) F4    (c) F5    (d) F6 

 

(CHAPTER-6) (Office Automation Tools - Word Processor) 
1. Which is the opening screen of Open Office?  

(a) Star desktop    (b) Star center   (c) Star screen   (d) Star window 

2. Which option allows you to assign text, tables, graphics and other items to a key or key combination 

(a) Auto format  (b) Automatic    (c) Auto text    (d) Auto graphics 

3. Which menu contains the numbering option? [M-2024] 

(a) File    (b) Edit    (c) Tools   (d) Format 

4. Which is displayed at the top most part of the window? [M-2019, M-2022] 

 (a) Menu bar   (b) Tool bar    (c) Title bar    (d) Format bar 

5. Which is changing the default appearance of the text called? 

(a) Text formatting    (b) Page formatting  (c) Special formatting  (d) Paragraph formatting 

6. The Find & Replace option is available in which menu? [J-2019, M-2022, J-2024] 

(a) File    (b) Edit    (c) Format   (d) Tools 

7. Which button selects all instances of the search text in the document? [S-2022] 

(a) Find    (b) Find All   (c) Replace   (d) Replace All 

8. What is the shortcut key to go to the start of the document? 

(a) Ctrl + Home   (b) Ctrl + End   (c) Home   (d) End 

9. What is the shortcut key for finding and replacing text in a document? 

(a) Ctrl + F1    (b) Ctrl + F   (c) Ctrl + F5   (d) Ctrl +F7 

10.  What is the short cut key for Undo? [M-2023, J-2024] 

 (a) Ctrl +E    (b) Ctrl + U   (c) Ctrl + Z   (d) Ctrl + N 

1. What is the shortcut key to go to the beginning of the line? [J-2023] 

(a) Ctrl + Home   (b) Ctrl + End   (c) Home   (d) End 

 
(CHAPTER-7) (Office Automation Tools - Working with Open Office Calc) 
1. Which is the first electronic spreadsheet?  [J-2019, M-2020, S-2020] 

            (a)Excel    (b) Lotus 1-2-3    (c) Visicalc   (d) Open Office Calc 

2. Which of the following applications was the parent to Open Office Calc? [S-2021] 

            (a) Visicalc    (b) LibreCalc   (c) Lotus 123   (d) Star Office Calc. 

3. Grid of cells with a programmable calculator: [S-2020] 

(a) Spreadsheet   (b) Database  (c) Word processor  (d) Linux 

4. A column heading in Calc is represented using [M-2022] 

            (a)Number    (b) Symbol  (c) Date    (d) Alphabet 

5. Which key is used to move the cell pointer in the forward direction within work sheet? [M-2020, J-2023, J-2024] 

               (a)Enter    (b) Tab            (c) Shift + Tab   (d) Delete 

6. A formula in calc may begin with-------- [M-2019, M-2023] 

             (a) = .    (b) +       (c) -      (d) All the above 

7. What will be the result from the following formula (Assume A1=5, B2=2)? + A1^B2  

             (a) 7    (b) 25   (c) 10    (d) 52 

8. What will be the result from the following expression (Assume H1=12, H2=12)? =H1<>H2 

            (a) True    (b) False  (c) 24    (d) 1212 

9. Which of the following symbol is used to make a cell address as an absolute reference? [S-2020] 

             (a) +    (b) %   (c) &    (d) $ 

10.  Which of the following key combinations is used to increase the width of the current column? 

  (a) Alt + Right arrow  (b) Ctrl + Right arrow  (c)Alt + Left arrow  (d) Ctrl + Left arrow 

1. Match the followings : [M-2020] 

1) Applications   i)  .ods  (a)1-iii,2-iv,3-i,4-ii  

2) Open office document ii) .odp  (b)1-ii,2-iv,3-i,4-iii 

3) Open office calc  iii) .exe  (c)1-iv,2-ii,3-iii,4-i 

4) Open office Impress  iv) .odt  (d)1-iii,2-i,3-iv,4-i 
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2. What will be the result from the following formula (Assume A1=25, B2=2) + A1^B2 [M-2024] 

             (a) 252   (b) 27   (c) 625    (d) 50 

 

(CHAPTER-8)   (Office Automation Tools - Presentation Basics) 
1. Which is used to move quickly from one slide to another?  

(a) Compass    (b) Navigator    (c) Fill color    (d) Page border 

2. Which is the shortcut key to view the slideshow in impress? [S-2021, M-2024] 

(a) F6     (b) F9     (c) F5     (d) Both (b) or (c) 

3. In Impress, which views shows thumbnail versions of all your slides arranged in horizontal rows. 

(a) Notes    (b) Outline   (c) Handout    (d) Slide Sorter 

4. Identify the default view in Impress. 

(a) Normal     (b) Slide Sorter   (c) Handout    (d) Notes 

5. Which menu contains the Slide Transition option? 

          (a) Slide Show   (b) View   (c) Tools   (d) Format 

6. Identify the extension of the Impress presentation. [M-2023] 

(a) ,odp     (b).ppt    (c).odb    (d),ood 

7. In presentation tools, the entry effect as one slide replaces another slide in a slide show. Identify the option that 

suits after reading the statement. 

(a) Animation    (b) Slide Transition   (c) Custom animation  (d) Rehearse Timing 

8. Vanya has made a presentation on “Global Warming”. She wants to progress her slide show automatically 

while speaks on the topic in the class. Which features of Impress would she use? 

(a) Custom Animation    (b) Rehearse Timing    (c) Slide Transition     (d) Either (a) or (b) 

 
 (CHAPTER-9)  (Introduction to Internet and Email) 

1. What is the expansion of WLAN? [M-2020] 

                 (a)Wireless Local Area Network      (b) Wired local Area Network     

 (c) Wireless Local Area Netware      (d) Wireless Area Netbande 

2. Range of Campus Network is--- [S-2020] 

          (a) 10 KM    (b) 5 KM    (c) 25 KM    (d) 20 KM 

3. Each computer on net is called   [J-2019] 

  (a) Host     (b) server    (c) workstation   (d) node 

4. The internet is governed by    

          (a) ICANM    (b) ICANN    (c) ICMA    (d) ICNNA 

5. Expansion of W3C [M-2022, J-2024] 

               (a) World Wide Web Consortium    (b) Wide World Web Consortium  

               (c) World Web Wide Consortium    (d) World Wide Web Consortum 

6. W3C was established in 1994 by ---- [S-2022] 

               (a) Tim Berners-Lee      (b) Tim Burnard Lee  (c) Kim Berners                (d) Kim Bernard Lee 

7. Hotspot uses which type of network services? [J-2023, M-2024] 

              (a) LAN    (b) PAN   (c) WLAN   (d) CAN 

8. USB WiFi adapters are often called as [M-2023] 

              (a) Data Card   (b) Pen Drive   (c) Dongles   (d) Memory Card 

9. Looking for information on the internet is called  

  (a) Surfing    (b) Searching   (c) Finding   (d) glancing 

10.  Safari web browser was developed by  

                (a) Google    (b) Apple   (c) Microsoft   (d) Linux Corpn 

11.  How many types of websites are available? [M-2019] 

           (a) 3       (b) 2      (c) 4      (d) 6  

 
(CHAPTER-10) (HTML - Structural Tags) 
1. HTML is acronym for [S-2021] 

             (a) Hyper Transfer Markup Language     (b) Hyper Text Markup Language  

             (c) Hyper Transfer Makeup Language     (d) Hyper Text Makeup Language 

2. The coded HTML keywords that indicates how web browser should format and display the content is called…….   

(a) Tags      (b) Attributes     (c) Headings     (d) Body 
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3. Which of the following is a special word used inside tag to specify additional information to the tag?     

(a) Tags        (b) Attributes       (c) Headings      (d) Body 

4. HTML tags should be specified within: [M-2019] 

(a) [ ]       (b) { }      (c) ( )        (d) < > 

5. An HTML document is bounded within a pair of ….. tags [M-2020] 

           (a) <body> ……. </body>       (b) <title> ……. </title>  

             (c) <html> ……. </html>        (d) <head> …… </head> 

6. Which of the following symbol is used to define a closing tag? [M-2022] 

          (a) < >     (b) %        (c) /     (d) \ 

7. Which section of the browser window displays the main contents? [S-2020] 

           (a) Head    (b) Body   (c) Title    (d) Heading 

8. Which of the following tag is a structural tag?  

(a) <html>      (b) <h1>      (c) <br>     (d) <p> 

9. In HTML, colors are represented as  

(a) Binary values   (b) Octal values   (c) Decimal values  (d) Hexadecimal values 

10.  Which of the following symbol is used to prefix with hexadecimal value representing color in HTML?        

 (a) %        (b) #         (c) @         (d) & 

11.  Which of the following attribute is used to change text color within body tag?  

             (a) bgcolor    (b) background   (c) text    (d) color 

12.  Within body section, which of the following attribute is used to set top margin?  

           (a) margin    (b) top    (c) top margin   (d) left margin 

13.  How many levels of heading tags available in HTML? [S-2022, J-2023, J-2024] 

            (a) 6     (b) 4    (c) 8    (d) 3 

14.  The tag used to insert a line break: [J-2019, S-2022] 

            (a) <h1>        (b) <br>           (c) <html>        (d) <p> 

15.  The tag used to define a paragraph in HTML:  

          (a) <para>        (b) <p>        (c) <q>        (d) <br> 

1. Which of the following tag is a structural tag? [M-2024] 

(a) <p>      (b) <h1>      (c) <br>     (d) <body> 

(CHAPTER-11)(HTML- Formatting text, Creating Tables, List and Links) 
1. Which of the following tags are called as physical style tags? [M-2020, J-2023] 

             (a) <html>, <b>, <br>           (b) <b>, <br>, <u>  (c) <A>, <b>, <i>               (d) <b>, <i>, <u> 

2. Which feature is used to call attention to the reader? [M-2019, J-2024] 

             (a) Highlight   (b) Bold   (c) Italics   (d) Underline 

3. The tags <sub> and <sup> used for: [S-2020, S-2022] 

             (a) Subject and Super            (b) Subscript and Super  (c) Subject & sub       (d) Subscript and Superscript 

4. A named set of certain style of character and number is:  

             (a) Style    (b) Character   (c) Font   (d) List 

5. Pick odd one from the list….  [S-2021]   

       (a) <tr>    (b) <th>    (c) <dh>   (d) <td> 

6. Match the following:   

       (a) tfoot   -  (1) Order list       (A)  4 1 2 3 

       (b) start   -  (2) Hyperlink      (B)  1 4 3 2 

       (c) href   -  (3) Highlight       (C)  4 3 2 1 

       (d) mark  -  (4) Table             (D)  1 2 4 3 

7. Definition list has how many parts? [J-2019]   

       (a) 5    (b) 4    (c) 3    (d) 2 

8. A list block can be defined inside another list is: [M-2022, M-2023] 

            (a) Inner List    (b) Nested List   (c) Outer List   (d) Listing List 

9. Read the following statement and choose the correct statement(s):  

             (I) Link in HTML is used to create hyperlinks to web content.  

             (II) HREF is abbreviated as Hypertext Markup File  

        (a) I is correct   (b) II is correct   (c) I and II is correct  (d) Both are wrong  
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10.  To create internal link, which of the following attribute should be used? [M-2024] 

            (a) link    (b) name  (c) local    (d) Inter 

 

(CHAPTER-12) (HTML - Adding multimedia elements and Forms) 
1. Which image format was standardize by W3C?  [M-2020, M-2024] 

             (a) JPEG    (b) SVG   (c) GIF    (d) PNG 

2. The tag used to insert an image in HTML:  [M-2019, M-2022] 

(a) Image    (b) Picture   (c) Img    (d) Pic 

3. In HTML, a piece of text or image can be moved horizontally or vertically by using:     

(a) <marquee>   (b) <img>   (c) <embed>    (d) <text> 

4. In Inline sound can be inserted using which of the following tag? [J-2019, S-2021] 

           (a) <inline>    (b) <backgroundsound>  (c) <bgsound>  (d) <sound> 

5. Which value causes the audio play as long as the page is in view?  

          (a) Stop    (b) Never Stop   (c) Continue   (d) Infinite 

6. The important attributes used with the <form> tag are [M-2020, S-2022, J-2023, J-2024] 

           (a) method and action  (b) name and size  (c) post and get   (d) type and name 

7. The tag is used to create dropdown list box in HTML is: [M-2023] 

            (a) <dropdown>   (b) <select>    (c) <listbox>     (d) <input> 

8. Match the following:   

             (a) <textarea>  - (1) inline                        (a)  3 1 4 2 

             (b) <input>      - (2) Video                       (b)  3 4 1 2 

             (c) <bgsound> - (3) Multiline input         (c)  2 3 4 1 

             (d) <embed>   - (4) Password                 (d)  1 2 3 4 

 
(CHAPTER-13)  (CSS - Cascading Style Sheets) 
1. Expansion of CSS   

             (a) Cascading Style Schools         (b) Cascading Style Scheme  

(c) Cascading Style Sheets     (d) Cascading Style Shares 

2. Which of the following is the page level style? [S-2022] 

             (a) <Page>    (b) <Style>   (c) <Link>  (d) <H> 

3. CSS is also called as: [S-2020, M-2023] 

             (a) Sitewide Style Sheets     (b) Internal Style Sheets  

(c) Inline Style Sheets     (d) Internal Inline Sheets 

4. The extension of CSS file is------ [M-2019, J-2024] 

            (a) .ssc    (b) .css    (c) .csc    (d) .htm 

5. What is selector in CSS? [J-2019] 

           (a) Property    (b) Value   (c) HTML tag   (d) name 

6. The Declaration block of CSS is surrounded by [S-2021] 

           (a) ( )    (b) [ ]    (c) { }    (d) <> 

7. The declaration should be terminated by [M-2022] 

            (a) :     (b) ;    (c) .    (d) , 

8. What is the property to set text as bold?  

            (a) Font-Style   (b) Font-Weight   (c) Font-Property  (d) Font-Bold 

9. Which of the following indicates that the text included is a comment? [S-2020, J-2023] 

             (a) /* */    (b) !* *!    (c) <* *>   (d) \* *\ 

10.  Which of the following ways below is correct to write a CSS?  

        (a) p{color:red; text-align:center};        (b) p {color:red; text-align:center}  

        (c) p {color:red; text-align:center;}    (d) p (color:red;text-align:center; 

 

(CHAPTER-14) (Introduction to JavaScript) 

1. Which provided a common scripting language to web developers to design, test and deploy Internet Application    

(a) C      (b) C++      (c) Java     (d) JavaScript 

2. Expand CGI ----- [S-2020] 

             (a) Common Gateway Interface    (b) Complex Gateway Information  

              (c) Common Gateway Information    (d) Complex Gateway Interface 
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3. JavaScript programming language is used to develop the  

(a) Dynamic Web Page  (b) Window   (c) Web Page   (d) Home Page 

4. The Dynamic Web Page help to save server’s  

(a) Work    (b) Route   (c) Traffic   (d) Path 

5. User entered data, is validated before sending it to server is called  

(a) Server traffic  (b) Dynamic Web Page  (c) Server Route   (d) Web server 

6. Java Scripts can be implemented using which statements? [J-2019, J-2024] 

          (a) <head>    (b) <Java>   (c) <script>  (d) <text> 

7. Expand DHTML ----- [M-2024] 

(a) Distance Hyper Text Markup language    (b) Dynamic Hyper Text Markup language  

             (c) Distance High Text Markup language   (d) Dynamic High Text Markup language 

8. How many attributes specifies that <script> tag in the scripting  

(a) 2    (b) 3    (c) 4    (d) 5 

9. Which attribute is used to indicate the scripting language and its value should be sent to “ Text/JavaScript”    

(a) Language.   (b) Text    (c) Type    (d) Body 

10.  The file reload into the browser use the shortcut key is [M-2019] 

 (a) F2    (b) F3    (c) F4    (d) F5 

11.  JavaScript ignores spaces that appear between  

 (a) Command   (b) Scripts   (c) Tokens   (d) Text 

12.  A Data value for variable that appears directly in a program by using a  

 (a) loop    (b) Literal   (c) Statement   (d) Text 

13.  Which is mostly used to give a warning message to users? [M-2022] 

(a) Alert Dialog Box   (b) Confirm box    (c) Prompt box   (d) Display box 

14.  In the below snippet, value of x is var x = 250 + 2 – 200;  

           (a) 50    (b) 52    (c) 48    (d) 4 

1.   What is the output of the following snippet: x=”JavaScript”; x.length(); [J-2019]  

  (a) 8   (b) 9   (c) 10   (d) 15 

 

(CHAPTER-15) (Control Structure in JavaScript) 
1. Which conditional statement is used to transfer control from current statement to another statement? [M-2022, S-2020, J-2023] 

                (a) Branching   (b) Sequencing   (c) Looping   (d) Interacting 

2. _______statement can be used as alterative to if-else statement [M-2020, M-2024] 

            (a) While    (b) If    (c) else-if   (d) Switch 

3. Which statement in switch case is used to exit the statement once the appropriate choice is found?  

               (a) Exit    (b) Default   (c) Case    (d) Break 

4. Which of the following is not a looping statement? [S-2021, M-2023, J-2023] 

              (a) Switch    (b) While   (c) Do-While   (d) For 

5. Which part of the loop statement determines the number of times, the loop will be iterated?    

        (a) First      (b) Second   (c) Third   (d) Final 

6. Which of the following is not a branching statement?  

          (a) Loop    (b) If-else   (c) Switch   (d) For 

7. What will be the output for the following snippet: [M-2019]  

For (var n=0; n<10; n+1)  

{  

if (n==3)  

{  

break;  

} 

document write (n+"<br>");  

} 

                (a) 0 1 2    (b) 0 1 2 3     (c) 0 1 2 3 4     (d) 0, 1, 3 

8. In which loop the condition is evaluated, before executing a statement?   
      (a) While    (b) Do while   (c) Break   (d) Continue 
9. The _______ statement is especially useful when testing all the possible results of   an expression.    
       (a) While    (b) Do while   (c) Switch  (d) If 
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10. In the _____ loop, body of the loop always executed at least once before the condition can be executed  

(a) For    (b) While   (c) If    (d) Do while 

11. <script type =”text/java script”> x=6+”3” document .write(x); <script> what will be output? 

(a)  6   (b) 9   (c) 63   (d) Error 

1. In the blow snippet Value of X is ….Var  X=102+5-50 [J-2023[ 

(a) 57   (b) 47   (c) 50   (d) 52 

 

(CHAPTER-16) (JavaScript Functions) 
1. The parameters work as-------  [M-2024] 

(a) Local variable   (b) Global Variable   (c) File variable   (d) block variable 

2. Predefined functions are also called as----- [M-2019, S-2020, M-2022]   

(a) Library functions  (b) storage functions  (c) instructions    (d) commands 

3. Larger programs are divided into smaller are called [M-2023] 

(a) modules    (b) block   (c) sets    (d) Group 

4. Which of the following is used to enhance reusability and program clarity.  

           (a) functions    (b) modules  . (c) sets    (d) instructions 

5. Which of the following allow the programmer to modularize a program [J-2024]       

           (a) Library    (b) user defined functions  (c) Normal     (d) Ordinary  

1. Library functions are also called as----- [J-2023] 

(a) Predefined functions  (b) storage functions  (c) instructions    (d) commands 

 
(CHAPTER-17) (Computer Ethics and Cyber Security) 
1. Which of the following deals with procedures, practices and values?  

(a)  Piracy    (b) programs   (c) virus   (d) computer ethics 

2. Commercial programs made available to the public illegally are known as [S-2021, J-2024] 

(a) Freeware    (b) warez   (c) Free software   (d) software 

3. Which one of the following are self-repeating and do not require a computer program to attach themselves?  

(a) Viruses     (b) worms   (c) spyware   (d) Trojans  [M-2019] 

4. Which one of the following tracks a user visits a website? [M-2020, J-2023] 

(a) Spyware   (b) cookies  (c) worms  (d) Trojans 

5. Which of the following is not a malicious program on computer systems?  

(a) Worms    (b) Trojans   (c) spyware   (d) cookies 

6. A computer network security that monitors and controls incoming and outgoing traffic is  ------  

(a) Cookies    (b) virus   (c) Firewall   (d) worms 

7. The process of converting cipher text to plain text is called [M-2024] 

(a) Encryption   (b) Decryption   (c) key    (d) proxy server 

8. e-commerce means  

(a) Electronic commerce    (b) electronic data  (c) electric data     (d) electronic commercialization 

9. Distributing unwanted e-mail to others is called. [S-2020] 

(a)  Scam    (b) spam   (c) fraud   (d) spoofing 

10.   Legal recognition for transactions are carried out by  

        (a) Electronic Data Interchange    (b) Electronic Data Exchange  

        (c) Electronic Data Transfer              (d) Electrical Data Interchange 

 
(CHAPTER-18) (TAMIL COMPUTING) 
1. Which is not a search engine? [J-2019]  

        (a) Android   (b) Bing   (c) Yahoo  (d) Google 

2. Which of the following is the first Tamil Programming language? [S-2020, M-2022] 

(a)  Kamban   (b) Azhagi  (c) Tamil Open Office (d) Ezhil 

3. ---is a Tamil translation application [S-2021] 

(a) Lippikar   (b) Tamizpori  (c) Kamban  (d) Ezhil 
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CHAPTER 1 TO 18 ONE WORD BOOK INSIDE QUESTION WITH ANSWERS 
 (CHAPTER-1) (Introduction to Computers) 

1. Which generation of computer used transistors?  

        (a) First   (b) Second   (c) Third   (d) Fourth 

2. --- is the main component of second generation computers  

(a) Vacuum tubes  (b) Transistors  (c) IC   (d) Microprocessors 

3. ………………….. is the father of computer. 

(a) John Napier  (b) William   (c) Blaise Pascal  (d) Charles Babbage 

4. The expansion of ALU is: 

(a) Arithmetic Logic Unit  (b) Arithmetic Long Unit  (c) Arithmetic Law Unit  (d) Arithmetic Logo Unit 

5. The first generation was in the year: 

(a) 1940-1956  (b) 1955-1964  (c) 1964-1975  (d) 1975-present 

6. The first generation computers used: 

(a) assembly    (b) machine   (c) high level   (d) word processor  

7. …………………. used in second generation computers. 

(a) Punched cards  (b) Plotter  (c) Printers  (d) Keyboard 

8. Second generation computers used: 

(a) vaccum tube  (b) transistor  (c) integrated circuit (d) micro processor 

9. Batch processing and multi programming operating system were used in: 

(a) first   (b) second   (c) third    (d) fourth  

10. The second generation was in the year: 

(a) 1942-1955  (b) 1956-1964  (c) 1964-1975  (d) 1975-1980 

11. Third generation computers used: 

(a) vaccum tube  (b) transistor  (c) integrated circuit (d) microprocessor 

12. The third generation was in the year: 

(a) 1955 – 1964  (b) 1964 – 1971  (c) 1975 – 1980  (d) 1942 – 1955 

13. High level language appeared in: 

(a) first    (b) second   (c) third   (d) fourth  

14. Fourth generation computers used: 

(a) vaccum tube  (b) transistor  (c) integrated circuit (d) microprocessor 

15. Portable computers are introduced in generation. 

(a) first   (b) second  (c) third   (d) fourth 

16. Fourth generation computers was in the year: 

(a) 1942-1955  (b) 1955-1964  (c) 1964-1975  (d) 1971-1980 

17. Microcomputer series such as IBM and APPLE developed in …………. generation. 

(a) first   (b) second  (c) third   (d) fourth 

18. Fifth generation was in the year: 

(a) 1980-1990  (b) 1955-1964  (c) 1980 – till date (d) 1942-1955 

19. Computers can recognize images and graphs in: 

(a) first    (b) second  (c) fourth   (d) fifth  

20. Introduction of Artificial intelligence is in ………………….. generation. 

(a) sixth   (b) third   (c) fourth  (d) fifth 

21. ………………….. is in the sixth generation. 

(a) Introduction of portable computers   (b) Introduction of artificial intelligence 

(c) Development of robotics    (d) Introduction of word processors 

22. Sixth generation computers are: 
(a) batch processing   (b) parallel processing (c) natural language processing (d) natural networks 

23. Voice Recognition is in the generation. 

(a) sixth   (b) fourth  (c) fifth   (d) third 

24. ………………….. is the ability of a computer program to understand human language. 

(a) NLP   (b) CPU   (c) ANN   (d) AI 

25. ……………………. is a component of artificial intelligence. 

(a) CPU   (b) ANN   (c) NLP   (d) ALU 

26. ……………………. deals with the design, construction, operation and use of robots. 

(a) NLP   (b) Robotics  (c) AI   (d) ANN 

27. …………………… is the study and application of extremely small things. 
(a) Nano technology  (b) ANN   (c) NLP   (d) Bio Engineering 
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28. …………………… involves the ability to see and to control individual atoms and molecules. 
(a) Robotics   (b) Artificial neural networks (c) Nanotechnology (d) NLP 

29. . that applies engineering principles of design and analysis to biological systems and biomedical technologies. 

(a) Nanotechnology  (b) Robotics  (c) Bio-engineering (d) NLP 

30. ……………………… is the term used for raw facts and figures. 

(a) Data   (b) Information  (c) Mother board  (d) Data processing 

31. Data represented in useful and meaningful form is: 

(a) data processing  (b) information  (c) data   (d) information set 

32. The conversion of data to information is called: 

(a) computer   (b) information  (c) data processing (d) software 

33. The computer is the combination of: 

(a) hardware and software    (b) mother board and memory devices 

(c) monitor and keyboard    (d) monitor and CPU 

34. …………………. is the physical components of a computer. 

(a) Software   (b) Hardware  (c) Mouse  (d) CPU 

35. ……………………. is the set of programs or instructions. 
(a) Hardware   (b) Software  (c) Input – Process – Output  (d) Data 

36. Every task given to a computer follows an: 
(a) instruction  (b) input – process – output cycle (c) data    (d) process cycle 

37. holds the data and instructions during the processing. 

(a) Input unit  (b) Memory unit   (c) Output unit  (d) Storage unit 

38. …….. is the component through which data and instructions are provided to the computer. 

(a) Input device  (b) Output device  (c) Memory unit  (d) Storage device 

39. …………………. is the heart of the computer. 

(a) Memory   (b) Software  (c) Storage devices (d) CPU 

40. The ……. is the component which delivers the data and information processed by the CPU. 

(a) memory storage device (b) input device  (c) CPU   (d) output device 

41. The expansion of CPU is: 
(a) Central Processing Unit (b) Central Prefix Unit (c) Central Power Unit (d) Central Printer Unit 

42. …………….. is the logical machine which interprets and executes software instructions. 

(a) CPU   (b) Mother Board  (c) Input Device  (d) Storage Device 

43. The CPU has ………………….. units. 

(a) four   (b) five   (c) two   (d) three 

44. The ……………………… performs arithmetic operations. 

(a) ALU   (b) CPU   (c) control unit  (d) memory unit 

45. The …………. operations of ALU promote the decision making ability of a computer. 

(a) arithmetic  (b) logical  (c) comparison  (d) text 

46. The unit controls the flow of data between the CPU, memory and I/O devices. 

(a) memory   (b) ALU   (c) CPU   (d) control 

47. The memory unit is of ………………………. kinds. 

(a) three   (b) four   (c) five   (d) two 

48. ………………… memory is used to temporarily store the programs and data. 

(a) Primary   (b) Secondary  (c) PROM  (d) EPROM 

49. ………………….. is the most common input device used today. 

(a) Keyboard  (b) Mouse  (c) Scanner  (d) Light Pen 

50. ……………….. is a pointing device used to control the movement of the cursor on the display screen. 

(a) Keyboard   (b) Scanner  (c) Trackball  (d) Mouse 

51. ……………………… are used to enter information directly into the computer’s memory. 

(a) Mouse   (b) Keyboard  (c) Scanner  (d) Trackball 

52. …………………… used for computer security equipped with the fingerprint recognition. 

(a) Fingerprint scanner (b) Retinal scanner (c) Optical character  (d) Touch Screen 

53. ……………………. uses the unique patterns on a person’s retina blood vessels. 

(a) Scanners   (b) Finger print scanner (c) Barcode reader (d) Retinal scanner 

54. ……………………. is an input device which is used to draw lines or figures on a computer screen. 

(a) OCR   (b) Light pen  (c) Mouse  (d) Keyboard 

55. ………………. is a device which detects alpha numeric characters printed or written on a paper. 

(a) Optical Character Reader(b) Light Pen  (c) Scanner  (d) Bar code Reader 
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56. ………….. reads bar codes and converts them into electric pulses to be processed by a computer. 

(a) Scanner   (b) Track Ball  (c) Mouse  (d) Bar Code Reader 

57. A ……………………. convert human speech into electrical signals. 

(a) digital camera  (b) touch screen  (c) microphone  (d) keyboard 

58. …………………….. converts graphics directly into the digital form. 

(a) Microphone  (b) Light pen  (c) Touch screen  (d) Digital Camera 

59. ……. is a display device that allows the uses to interact with a computer by using the finger. 

(a) Microphone  (b) Light pen  (c) Touch screen  (d) Digital Camera 

60. …………………….. is a device for signaling by hand. 

(a) Keyer   (b) Microphone  (c) Touchscreen  (d) Scanner 

61. …………………… is the most commonly used output device to display the information. 

(a) Printer   (b) Monitor  (c) Plotter  (d) Keyer 

62. ……………………. is used to produce graphical output on papers. 

(a) Printers   (b) Plotters  (c) Monitor  (d) Scanners 

63. ……………………. are used to print the information on papers. 

(a) Plotters   (b) Monitor  (c) Printers  (d) Scanners 

64. Printers are divided into ……………………… main categories. 

(a) three   (b) two   (c) four   (d) five 

65. The printing speed.of serial dot matrix printers varies from: 

(a) 50 to 1000 cps  (b) 100 to 1000 cps (c) 40 to 1550 cps (d) 30 to 1550 cps 

66. Line printers are capable of printing much …………… lines per minute. 

(a) more than 500  (b) more than 800  (c) more than 100 \\ (d) more than 1000 

67. ……………………. produces voice output. 

(a) Printer   (b) Projector  (c) Speakers  (d) Plotters 

68. …………………….. is used to produce computer output on a big screen. 

(a) Monitor   (b) Multimedia projector (c) Speakers  (d) Plotters 

69. Booting process is of types. 

(a) two   (b) three   (c) four   (d) five 

70. Cold Booting is also called as: 

(a) hard booting  (b) soft booting  (c) rough booting  (d) fast booting 

71. ……………………. transfers from hard disk into main memory. 

(a) Assembler  (b) Complier  (c) Bootstrap loader (d) Loader 

72. The first computer monitor was part of the ________ computer system.  

a) Xerox Alto   b) IBM 1620   c) ENIAC1800   d) Pentium I  

73. Expansion of BIOS is  

a) Basic Input Output Software    b) Basic Input Output System  

c) Beginners Input Output Services    d) Basic Input Output Strategy 

 
(CHAPTER-2) (Number Systems)  
1. For 10102 the hexadecimal equivalent is:  

(a) C   (b) B   (c) E   (d) A 

2. How many bytes does contain 1 zeta byte contain? 

(a) 290   (b) 270   (c) 230   (d) 240 

3. 2^30 is referred as  

(a) Kilo    (b) Tera    (c) Giga   (d) Zetta 

4. What is the 1’s complement of 11011001?  

(a) 00100110   (b) 11100110   (c) 11011000  (d) 11011111 

5. For 11102 the hexadecimal equivalent is:  

(a) F   (b) D   (c) E   (d) B 

6. A bit is the short form of: 

(a) binary data  (b) binary digit  (c) binary decimal (d) big digit 

7. A ……………………… is a collection of 4 bits. 

(a) bit   (b) byte   (c) nibble  (d) word length 

8. A collection of 8 bits is called: 

(a) bit   (b) byte   (c) word length  (d) nibble 

9. 2^40 is referred as: 

(a) mega   (b) giga   (c) peta   (d) tera 
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10. 2^70 is referred as: 

(a) peta   (b) exa   (c) zetta   (d) yotta 

11. 1024 GB is referred as: 

(a) kilo byte   (b) mega byte  (c) giga byte  (d) tera byte 

12. ……………………. are used to represent characters in a text. 

(a) Bits   (b) Bytes  (c) Nibble  (d) Word length 

13. The ASCII value for blank space is: 

(a) 32   (b) 91   (c) 48   (d) 65 

14. The ASCII value for numeric 0 is: 

(a) 32   (b) 91   (c) 48   (d) 65 

15. Each number system is uniquely identified by its: 

(a) decimal value  (b) binary value  (c) base value or radix (d) octal value 

16. The range of ASCII values for lower case alphabets is from: 

(a) 97 to 122   (b) 65 to 90  (c) 98 to 122  (d) 97 to 123 

17. The range of ASCII values for upper case alphabets is from: 

(a) 97 to 122   (b) 65 to 90  (c) 66 to 90  (d) 65 to 97 

18. The expansion of MSB is: 

(a) most significant bit (b) most signed bit (c) must significant bit (d) must signed bit 

19. The expansion of LSB is: 

(a) lower significant bit (b) least significant bit (c) lower signed bit (d) least signed bit 

20. Radix of octal number is: 

(a) 2   (b) 10   (c) 16   (d) 1 

21. The binary sequence (1101)2 has the decimal equivalent: 

(a) (25)10   (b) ( 15)10  (c) (17)10  (d) (13)10 

22. In hexadecimal C represents: (a) 11      (b) 0  (c) 12   d) 15 

23. The simplest method to represent negative binary numbers is called: 

(a) signed magnitude (b) unsigned magnitude (c) magnitude bit (d) un magnitude bit 

24. EBDIC coding system can handle …………………….. Character. 

(a) 64   (b) 255   (c) 256   (d) 128 

25. The most commonly used coding scheme is the: 

(a) Binary Coded Decimal     

(b) Extended Binary Coded Decimal Interchange Code 

(c) Indian Standard Code for Information Interchange   

(d) American Standard Code for Information Interchange 

26. ‘0’ and ‘1’ that the Computer can understand is called  
a) Machine language   b) High-level language bit  c) Assembly language  d) Query structure language  

27. Binary numbers like 0 or 1 are called ________.  

a) Byte    b) Bit    c) Nible    d) Word  

28. Nibble is a collection of ________ bits.  

a) 2     b) 4    c) 8    d) 16  

29. 1 Kilobyte represents 1024 i.e. _______ bytes.  

a) 240    b) 230    c) 220    d) 210  

30. Expansion of BCD is  
a) Binary Coded Decoder  b) Basic Coded Decimal  c) Binary Coded Decimal  d) Beginners Coded Decimal  

31. The ASCII value for blank space is ________  

a) 32    b) 42    c) 48    d) 28 

32. The ASCII value of zero (0) is ________  

a) 32    b) 42    c) 48    d) 28  

33. The range of ASCII values for lower case alphabets is from  

a) 97 to 122    b) 87 to 112   c) 65 to 90   d) 85 to 110  

34. The range of ASCII values for the upper-case alphabets is  

a) 97 to 122    b) 87 to 112   c) 65 to 90   d) 85 to 110  

35. MSB is  

a) Most Significant Byte  b) Most Significant Bit  c) Most simple bit  d) Most successful bit  

36. LSB is  

a) Least successful bit  b) Linear significant bit  c) Least simple bit  d) Least significant bit 
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(CHAPTER-3) (Computer Organization) 
1. Which is used to connect a monitor or any display device like LCD projector to a computer? 

(a) SCSI port   (b VGA connector (c) USB port  (d) PS/2 port 

2. Pick the RISC processor:  

(a) Intel P6   (b) Intel 386&486 (c) Pentium II  (d) Motorola 6800 

3. Which of the following is a very high speed and expensive memory?  

(a) Cache   (b) ROM  (c) RAM  (d) EPROM 

4. ……………….. deals with the engineering considerations involved in designing a computer. 
(a) Computer organization  (b) Computer architecture  (c) Microprocessor   (d) Registers 

5. Microprocessor is made up of ……………………. units. 

(a) 3   (b) 2   (c) 4   (d) 5 

6. The speed at which the microprocessor executes instructions is called: 

(a) clock speed  (b) instruction set  (c) word size  (d) control flow 

7. The number of bits that can be processed by a processor in a single instruction is called its: 

(a) clock speed  (b) instruction set  (c) word size  (d) control flow 

8. ……………………….. is unidirectional. 

(a) Data bus   (b) Control bus  (c) Register  (d) Address bus 

9. …………………… is bidirectional. 

(a) Data bus   (b) Control bus  (c) Register  (d) Address bus 

10. ……………………. is a volatile memory. 

(a) ROM   (b) EPROM  (c) PROM  (d) RAM 

11. The areas between pits are known as: 

(a) sector   (b) track   (c) layer   (d) lands 

12. The capacity of an ordinary CD-ROM is: 

(a) 800 MB   (b) 700 MB  (c) 900 MB  (d) 600 MB 

13. ……… is the type of disc used for play station games and for playing high-definition (HD) movies. 

(a) Hard disks  (b) CD   (c) DVD   (d) Blu-ray disc 

14. The first general purpose microprocessor ________ was developed by Intel Inc .  

a) 1011    b) 4004    c) 0386    d) 0486  

15. RISC stands for  

a) Reduced Instruction Set Computers   b) Reduced Information Set Computers  

c) Random Instruction Set Computers    d) Reduced Informal System Computers  

16. CISC stands for  

a) Complete Instruction Set Computers    b) Complex Instruction Set Calculators  

c) Complex Instruction Set Computers   d) Complete Instruction Set Calculators  

17. Which of the following is not a RISC computer?  

a) Pentium IV   b) Intel P6   c) AMD K6   d) Pentium II 

 
(CHAPTER-4) (Theoretical concepts of Operating System) 
1. How many Level of securities is provided by operating system to the user? 

(a) 3   (b) 2   (c) 5   (d) 4 

2. Which of the following algorithm is based on queuing? 

(a) Priority   (b) SJF   (c) Round Robin  (d) FIFO 

3.  Android is a ----  

(a) Mobile O.S  (b) Open source  (c) Developed by google (d) All the above 

4. There are types of software. 

(a) 2   (b) 3   (c) 4   (d) 6 

5. …………………… is a set of programs to perform specific task. 
(a) Software   (b) System software (c) Application software (d) Hardware 

6. ………………….. is an application software. 

(a) Linux   (b) Unix   (c) MS-Word  (d) Windows 

7. ………………….. is an system software: 

(a) Windows  (b) MS-Word  (c) MS-Excel  (d) Lotus 

8. An operating system allows only a single user to perform a task at a time is called as a: 

(a) single user   (b) multi-user   (c) time sharing  (d) distributed  

9. The operating system provides …………… levels of securities to the end user. 

(a) four   (b) five   (c) six   (d) three 
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10. The expansion of FIFO is ………………………. 
(a) First In First Out  (b) Fast in Fast Out  (c) Fast In First Out  (d) First in Fast Out 

11. The expansion of SJF is …………………….. 
(a) Slower Job First  (b) Slower Job Front (c) Shortest Job First (d) Shortest Job Front 

12. ………… Security is offered by the password in a multi-user environment: 

(a) System level  (b) File level  (c) Network level  (d) Software level 

13. The Linux operating system was originated in the year: 

(a) 1991   (b) 1997   (c) 1980   (d) 1993 

14. ………………….. is an example for a single user operating system: 

(a) Windows   (b) Linux  (c) Unix   (d) MS-Dos 

15. ……….. management is the process of controlling and coordinating computer’s main memory: 

(a) Memory   (b) Process  (c) Security  (d) Fault tolerance 

16. The … operating system is used to access shared data and files that residue in any machine around the world: 

(a) multi user   (b) single user  (c) distributed  (d) time sharing 

17. The scheduling algorithm is designed especially for time sharing system: 

(a) FIFO   (b) SJF   (c) Round Robin  (d) Based on priority 

18. iOS was created and developed by: 

(a) Apple Inc  (b) IBM   (c) Apple Ios  (d) Microsoft 

19. …………………. is a computer related mistake: 

(a) Data   (b) Program  (c) File   (d) Error 
20. _________ is a set of instructions used to perform a specific task in a computer.  

a) Hardware    b) Software   c) Program   d) Statements  

21. MS Word and VLC Player are  

a) Application software  b) System software  c) Databases   d) Hardware 

22. It is a type of computer program that is designed to run the computer’s hardware and application programs.  

a) Application software  b) System software  c) Databases   d) Hardware  

23. A compiler belongs to which of the following software?  

a) Application software  b) System software  c) Databases   d) Hardware  

24. It is a system software which serves as an interface between a user and a computer.  

a) Application software  b) Compiler   c) Operating system  d) Hardware  

25. Which operating system is most commonly used in mobile devices?  

a) Windows    b) UNIX   c) Linux   d) Android  

26. Expansion of GUI  

a) Graphical User Internet  b) Graphical Used Interconnection  

c) Group User Interface  d) Graphical User Interface 

 
(CHAPTER-5) (Working with typical operating systems) 
1. Which of the following key combination is used to permanently delete a file or folder without sending to recycle bin?  

(a) Shift and delete  (b) Alt and delete  (c) Tab and delete (d) Ctrl and delete 

2. Which command is used to ‘paste’?  

       (a) Edit→ Paste   (b) view → Paste  (c) File → Paste   (d) All the above 

3. – is a special folder to keep the files or folders deleted by the user. 

(a) My documents  (b) Recycle bin  (c) My computer  (d) Compressed folder 

4. Which one of the following is located above the menu bar in a window? 

(a) Tool bar   (b) Ruler  (c) Standard TB  (d) Title bar 

5. How will you open the paste special dialog box in writer? 

(a) Edit-Paste special  (b) Ctrl+Shift+V  (c) Alt+E+S  (d) All of these 

6. En, Fr, Ku are 
(a) Data entry settings  (b) Message entry (c) Keyboard layouts (d) Desktop settings 

7. Plug and play features was introduced in which version of windows… 
(a) Windows 98  (b) Windows 95  (c) Windows NT  (d) Windows me 

8. Microsoft windows is a …………………… based operating system. 

(a) GUI   b) command driven (c) window  (d) menu driven 

9. Multiple applications which can execute simultaneously in windows is known as: 

(a) multi programming (b) multi tasking  (c) time sharing  (d) based on priority 

10. …………………….. is used to interact windows by clicking its elements. 

(a) Keyboard   (b) Light pen  (c) Mouse  (d) Scanner 
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11. …………………… is used to enter alphabets and characters. 

(a) Light pen   (b) Mouse  (c) Notes taker  (d) Keyboard 

12. Multiple desktop is available in: 

(a) windows XP  (b) windows vista  (c) windows 8  (d) windows 10 

13. The opening screen of windows is called: 

(a) desktop   (b) icons   (c) windows  (d) documentation 

14. The …………. is an area on the screen that displays information for a specific program. 

(a) desktop   (b) icons   (c) window  (d) document 

15. The larger window is called the: 

(a) document window  (b) application window (c) workspace  (d) scroll bar 

16. The first level in a multilevel or hierarchical directory system is: 

(a) root directory  (b) additional directory (c) sub directories (d) directories 

17. The first level in a multilevel or hierarchical directory system is: 

(a) Ctrl + X   (b) Ctrl + C  (c) Ctrl + V  (d) Ctrl + S 

18. The shortcut keyboard command to cut is: 

(a) Ctrl + X   (b) Ctrl + C  (c) Ctrl + V  (d) Ctrl + A 

19. The shortcut keyboard command to paste is: 

(a) Crtl + X   (b) Ctrl + C  (c) Ctrl + V  (d) Ctrl + A 

20. The paste option is on …………………… menu. 

(a) edit   (b) file   (c) view   (d) tools 

21. …. switches to another user account on the computer without closing the open programs and windows processes. 

(a) Log off   (b) Restarting the computer (c) Shut down  (d) Switch user 

22. ………………….. shows the name of the currently selected directory. 

(a) Tool bar   (b) menu bar  (c) Task bar  (d) Title bar 

23. … displays your directory browsing history, location in the file system, a search button and options for the 

current directory view. 

(a) Toolbar   (b) Menu bar  (c) Task bar  (d) Title bar 

24. Windows 7 was released in: 

(a) October 2012  (b) September 2014 (c) October 2009  (d) October 2015 

25. At the very bottom of the screen is a horizontal bar called the: 

(a) tool bar   (b) menu bar  (c) task bar  (d) title bar 

26. We can select multiple files by holding down the key. 

(a) Alt   (b) Shift   (c) Ctrl   (d) Home 

27. …………………. is located at the top of the screen. 

(a) Tool bar   (b) Menu bar  (c) Task bar  (d) Title bar 
28. Which version of Windows was introduced as a mouse input device?  

a) Windows 1.x   b) Windows 2.x   c) Windows 3.x   d) Windows 95  

29. Which version of Windows was introduced in Control Panel feature?  

a) Windows 1.x   b) Windows 2.x   c) Windows 3.x   d) Windows 95  

30. Which version of Windows was introduced the Concepts of Multitasking?  

a) Windows 1.x   b) Windows 2.x   c) Windows 3.x   d) Windows 95  

31. Windows version designed like a server on the network.  

a) Windows 95   b) Windows NT   c) Windows 98   d) Windows XP  

32. In which windows version the Start button, Taskbar, Windows Explorer and Start menu were introduced?  

a) Windows 95   b) Windows NT   c) Windows 98   d) Windows XP  

33. Windows XP was introduced in the year  

a) 1987    b) 1995    c) 2001    d) 2009  

34. The opening screen of Windows is called  

a) Work place   b) Desktop   c) Icon    d) Window  

35. The horizontal bar below the desktop is called _________.  

a) Taskbar    b) Scroll bar   c) Title bar   d) Menu bar  

36. Which consist of volume control, network, date and time etc.?  

a) Scroll bar    b) Control Panel   c) System tray   d) Settings 

37. In Windows XP and Vista versions, the System icon is called as  

a) My computer   b) This PC   c) This computer   d) My PC  

38. In Windows 8 and Windows 10 versions, the System icon is called as  

a) My computer   b) This PC   c) This computer   d) My PC  
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39. Match:  

a.16-bit - (i) Windows 95   b.32-bit - (ii) Windows XP  

c.64-bit - (iii) Windows 8   d.Start button was removed - (iv) Windows 1.x  

        a) (i), (ii), (iii), (iv)   b) (iv), (iii), (ii), (i)  c) (iv), (i), (ii), (iii)  d) (ii),(iv),(i),(iii) 

 
(CHAPTER-6) (Office Automation Tools - Word Processor) 
1. Which option removes highlighting in writer? 

(a) No color   (b) No fill  (c) Empty color  (d) Remove fill 

2. Which menu is used to select Find & Replace Dialog?  

(a) Format   (b) View   (c) Tools  (d) Edit 

3. What is the shortcut key to go to the beginning of the line?  

(a) Ctrl + Home   (b) Ctrl + End   (c) Home   (d) End 

4. Which is the leading open-source office software to works on all common computers and available in many languages. 

(a) Open Office  (b) Star Office  (c) MS Office  (d) None of these 

5. Which company has developed by Open Office writer? 

(a) Microsoft   (b) King soft  (c) Apache  (d) Sun micro systems 

6. The open screen of the Open Office is known as: 

(a) star center  (b) desktop  (c) window  (d) screen 

7. The keyboard shortcut key can be used to open a new text document in Open Office: 

(a) Ctrl + O   (b) Ctrl + A  (c) Ctrl + N  (d) Ctrl + S 

8. The bar, that displayed at the top most part of the window: 

(a) Toolbar   (b) Title bar  (c) Menu bar  (d) Scroll bar 

9. Which is called a flashing vertical bar appears at the beginning of the screen? 

(a) Insertion pointer  (b) Cursor  (c) Horizontal ruler (d) Vertical ruler 

10. The keyboard shortcut key can be used to close a document in Open Office: 

(a) Ctrl + N   (b) Ctrl + A  (c) Ctrl + W  (d) Ctrl + Q 

11. The keyboard shortcut key can be used to open an existing document in Open Office: 

(a) Ctrl + O   (b) Ctrl + A  (c) Ctrl + N  (d) Ctrl + S 

12. Which key is used to delete the character left of the insertion pointer? 

(a) Backspace key  (b) Delete key  (c) Shift key  (d) Home key 

13. Which key is used to delete the character right of the insertion pointer? 

(a) Backspace key  (b) Delete key  (c) Shift key  (d) Home key 

14. The key is used toggle between Insertion mode and overwritten mode: 

(a) Insert key  (b) Home key  (c) Shift key  (d) Ctrl key 

15. The Open Office writer provides help window, which function key is used to getting the help window? 

(a) F1   (b) F2   (c) F3   (d) F4 

16. Which option is used to remove by selecting highlighted text? 

(a) Cancel   (b) No fill  (c) Change  (d) None of these 

17. For selecting whole document which shortcut key is used? 

(a) Ctrl + A   (b) Ctrl + W  (c) Ctrl + M  (d) Ctrl + S 

18. Which shortcut key is used to clear the formatting document? 

(a) Ctrl + A   (b) Ctrl + W  (c) Ctrl + M  (d) Ctrl + A 

19. A first-line indentation indents value is: 

(a) positive   (b) negative  (c) zero   (d) none of these 

20. The hanging indent value can be entered as: 

(a) positive   (b) negative  (c) zero   (d) none of these 

21. In page orientation, the height of the document is more than the width is called: 

(a) portrait   (b) landscape  (c) legal   (d) A4 size 

22. In page orientation-the width of the document is more than height is called: 

(a) portrait   (b) landscape  (c) legal   (d) A4 size 

23. Which shortcut key is used to find the replace the text? 

(a) Ctrl + F   (b) Ctrl + B  (c) Ctrl + P  (d) Ctrl + S 

24. Which menu option is choose to open AutoCorrect dialog box? 
(a) Tools → Change  (b) Tools → AutoCorrect (c) Tools → Add  (d) Tools → Ignore 

25. Which command is used to deselect the size of the picture? 

(a) Crop   (b) Format  (c) Cut   (d) Delete 
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26. Which option is used to inserts an image that overlaps the text which result will be hidden? 

(a) Drawing toolbar  (b) Wrap through  (c) Format  (d) Transparency 

27. Which key is assign the AutoText shortcut? 

(a) Ctrl + FI   (b) Ctrl + F2  (c) Ctrl + F3  (d) Ctrl + F4 

28. A specified number of rows and columns are called: 

(a) Table   (b) Cell   (c) Column  (d) Row 

29. Which combination key is used to insert table dialog box? 

(a) Ctrl + F10  (b) Ctrl + F11  (c) Ctrl + F11  (d) Ctrl + F12 

30. Multiple copies of a document to send to a list of different recipients is called: 

(a) Mail merge  (b) Copy   (c) address book  (d) all of the above 

31. Which opition can choose to print all colour text and graphics as gray scale in Open Office? 

(a) Tools > options > OpenOffice.org > print  (b) Tools > options > OpenOffice.org > ok 

(c) Tools > options > OpenOffice.org > Next  (d) None of the above 

32. When using Tab key in Open Office writer by default moving insertion point is: 

(a) 1 inch   (b) 1/4 inch  (c) 1/2 inch  (d) 2 inch 

33. Which rules you can add to decorate any or all the four sides of a paragraph? 

(a) Highlighted  (b) Borders  (c) Shading  (d) Bold 

34. Which can you use as background for enhancing the appearance of a text or paragraph? 

(a) Highlighted  (b) Borders  (c) Shading  (d) Bold 

35. The section ‘of the document that appears in the top margin: 

(a) header   (b) footer  (c) margin  (d) window 

36. The section of the document that appears in the bottom margin: 

(a) header   (b) footer  (c) margin  (d) window 

37. Which is the shortcut key to insert a comment within the text? 

(a) Ctrl + Alt + C  (b) Ctrl + Alt + I  (c) Ctrl + Alt + V  (d) Ctrl + Alt + C 

38. Which shortcut key is used to undo last action? 

(a) Ctrl + C   (b) Ctrl + F  (c) Ctrl + Z  (d) Ctrl + E 

39. Which shortcut key is used to center aligned text? 

(a) Ctrl + C   (b) Ctrl + F  (c) Ctrl + Z  (d) Ctrl + E 

40. Which combination of shortcut is used subscript a number? 

(a) Ctrl + Shift + B  (b) Ctrl + Shift + V (c) Ctrl + Shift + P (d) Ctrl + Shift + S 

41. Which combination of shortcut key is used superscript a number? 

(a) Ctrl + Shift + B  (b) Ctrl + Shift + V (c) Ctrl + Shift + P (d) Ctrl + Shift + S 

42. Which shortcut key is used to inserting a new paragraph without numbering? 

(a) Alt + Shift  (b) Alt + Enter  (c) Alt + Tab  (d) Ctrl + Enter 

43. Which shortcut key is used to apply default paragraph style? 

(a) Ctrl + 0   (b) Ctrl + 1  (c) Ctrl + 2  (d) Ctrl + 3 

44. ……………………. is the pictorial representation of data. 

(a) Object   (b) Charts  (c) Shapes  (d) Colour 

45. Which Open Office suite is used to create databases?  

a) Open Office Writer  b) Open Office Base  c) Open Office Formula  d) Open Office Calc  

46. Drawing software  

a) Open Office Draw  b) Open Office Base  c) Open Office Formula  d) Open Office Calc  

47. Which of the following option not in File menu bar?  

a) New    b) Open    c) Print    d) Copy  

48. Which menu contains the options of various text and page formatting features like page size, layout, font 

characteristics, bullets and numbering etc.?  

a) Edit    b) View    c) Format   d) Insert  

49. It is the blank area which is used to type the content of the file.  

a) Document area   b) Status bar   c) Text area   d) Work space  

50. A flashing vertical bar that appears at the beginning of the screen which is called as  

a) Insertion pointer   b) Scroll bar   c) Mouse   d) Platform  

51. The shortcut key to be pressed to move one cell to right in the table is  

a) Tab    b) Ctrl + Tab   c) Alt + Tab   d) Shift + Tab 

52. The shortcut keys to be pressed to go to the end of the document  

a) Alt + End    b) Ctrl + End   c) End    d) Shift + End  
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53. The shortcut keys to be pressed to move a character left are  

a) Shift + ←    b) Ctrl + ←   c) ←    d) Alt +  ← 

54. The shortcut keys to be pressed to move one word right  

a) Ctrl + →    b) Ctrl + ←   c) Ctrl + ↑   d) Ctrl + ↓ 

55. Match the following:  

a) To save - i) Ctrl + W     b) To open - ii) Ctrl + S  

c) To close - iii) Ctrl + P     d) To print - iv) Ctrl + O  

a) i), ii), iii), iv)   b) iv), ii), iii), i)   c) ii), iv), i), iii)   d) i), iii), ii), iv)  

56. Match the following:  
a) To select continuous text - i) Ctrl + A   b) Select text in different locations - ii) Shift  

c) To switch to type over mode or insertion mode - iii) Ctrl  d) Select the entire document - iv) Insert key  

       a) i), ii), iii), iv)   b) ii), iii), iv), i)   c) ii), iv), i), iii)   d) i), iii), ii), iv)  

57. Deletes the characters to the left of the insertion point.  

a) Backspace   b) Insert   c) Home   d) Delete  

58. Deletes the characters to the right of the insertion point.  

a) Backspace   b) Insert   c) Home   d) Delete 

59. Match the following:  

a) Cut - i) Ctrl + C     b) Copy - ii) Ctrl + P  

c) Paste - iii) Ctrl + X     d) Undo - iv) Ctrl + V     - v) Ctrl + Z  

       a) iii), i), iv), v)   b) iv), ii), iii), i)   c) ii), iv), i), v)   d) v), iii), ii), iv)  

60. Match the following:  

a) Bold - i) Ctrl + M     b) Italic - ii) Ctrl + B  

c) Underline - iii) Ctrl + I     d) Clear the format - iv) Ctrl + U  

       a) iii), i), iv), ii)   b) iv), ii), iii), i)   c) ii), iii), iv), i)   d) i), iii), ii), iv)  

61. Match the following:  

a) Left alignment - i) Ctrl + J    b) Right alignment - ii) Ctrl + E  

c) Centre clearance - iii) Ctrl + R    d) Justify alignment - iv) Ctrl + L   - v) Ctrl + C  

       a) iii), i), iv), v)   b) iv), iii), ii), i)   c) ii), iii), iv), i)   d) v), iii), ii), iv)  

62. Expansion of DDE.  
a) Dynamic Data Exchange  b) Direct Data Exchange  c) Data Dynamic Exchange  c) Dynamic Data Elements  

63. Match the following:  

a) Edit → Paste Special - i) F1    b) Help → Open Office Help - ii) Ctrl + W  

c) Edit → Select All - iii) Ctrl + Shift + V   d) File → Close - iv) Ctrl + A  

       a) iii), i), iv), ii)   b) iii), i), iv), ii)   c) ii), iv), i), iii)   d) i), iii), ii), iv) 

(CHAPTER-7) (Office Automation Tools - Working with Open Office Calc) 
1. …………. is a very useful office automation tool for a tabular form. 

(a) Word   (b) Calc   (c) Spreadsheet  (d) Database 

2. Which name of the spreadsheet software is Microsoft Corporation introduced? 

(a) Lous 1-2-3  (b) Excel  (c) StarCalc  (d) VisiCalc 

3. The father of the spreadsheet is called: 
(a) Charles Babbage  (b) Daniel Singer Dan Bricklin (c) Stephen Hawking   (d) Bill Gates 

4. The popular open source spreadsheet software presently maintained by Apache foundation: 

(a) VisiCalc   (b) Open Office Calc (c) Excel  (d) Star Calc 

5. Which feature help you to add the contents of a cluster of adjacent cells? 

(a) Auto sum  (b) Auto fill  (c) Function  (d) Chart 

6. Which feature guides you to work effectively while you work by displaying various helpful tips and techniques? 

(a) Charts   (b) Wizard  (c) Function  (d) Auto sum 

7. Which feature can be used to create formulas to complex calculation? 

(a) Charts   (b) Wizard  (c) Function  (d) Auto sum 

8. The main area of the Open Office code Calc window is called: 

(a) Work area  (b) cell   (c) box   (d) function bar 

9. How many worksheet available in the spreadsheet by default? 

(a) 1   (b) 2   (c) 3   (d) 4 

10. Which menu contains the commands which are used to modify the environment of Calc? 

(a) View   (b) Insert  (c) Tools  (d) Help 

11. Which menu lists inbuilt help features available with Open Office? 

(a) View   (b) Insert  (c) Tools  (d) Help 
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12. The bar, which is used a very important elements in a spreadsheet: 

(a) Formula bar  (b) Formatting toolbar (c) Standard bar  (d) Scrolling bar 

13. Which box is used to show the contents of the current cell and shows what you typed in a cell? 

(a) Address box  (b) Name box  (c) Input line  (d) None of the above 

14. Which button is used to move the screen the relative distance? 

(a) Scroll buttons  (b) Vertical   (c) Horizontal   (d) None of the above 

15. The intersection of every row and column makes a box, which is called: 

(a) cell   (b) row   (c) column  (d) table 

16. The combination of column headings and row number: 

(a) row number  (b) cell address  (c) column heading (d) table 

17. A rectangle element which can be moved around the worksheet: 

(a) cell   (b) cell address  (c) cell pointer  (d) active cell 

18. The cell in which the cell pointer is currently located is known as: 

(a) cell   (b) cell address  (c) cell pointer  (d) active cell 

19. How many navigation buttons are used to move the different worksheet? 

(a) 1   (b) 2   (c) 3   (d) 4 

20. At the bottom of the sheet tabs and horizontal scrolling bar is called: 

(a) status bar  (b) formula bar  (c) standard bar  (d) scroll bar 

21. Which is shows current serial number of the sheet / total number of sheets available? 

(a) Sheet count  (b) Page style  (c) Selection mode (d) Zoom 

22. How many modes shows the selection mode of the current sheet? 

(a) 1   (b) 2   (c) 3   (d) 4 

23. When you open a new spreadsheet, the cell pointer is located in cell A1. So the cell A1 is known as: 

(a) Cell pointer  (b) Home cell  (c) Bottom cell  (d) Direct cell 

24. Which keys are used to move the cell pointer anywhere in the worksheet? 

(a) Shift key   (b) Tab key  (c) Direction keys (d) Home key 

25. How many direction keys are available to move the cell pointer in the worksheet? 

(a) 1   (b) 2   (c) 3   (d) 4 

26. How many data types are generally classified using spreadsheet? 

(a) 2   (b) 3   (c) 4   (d) 5 

27. In generally, the data can be entered in the cell, the default aligned is: 

(a) left   (b) right   (c) center  (d) justify 

28. The Indian data format in the system: 

(a) DD / MM / YYYY (b) YYYY / MM / DD (c) MM / DD / YYYY (d) None of these 

29. Combination of values, operators and cell references is called as: 

(a) Data   (b) Operators  (c) Expression  (d) Reference 

30. How many operators can support the OpenOffice Calc? 

(a) 1   (b) 2   (c) 3   (d) 4 

31. Relational operators are also known as: 

(a) Comparative   (b) Arithmetic   (c) Logical   (d) Boolean  

32. A continuous group of cell is called as: 

(a) range   (b) reference  (c) relational  (d) text 

33. How many types of reference operators are used in the spreadsheet? 

(a) 1   (b) 2   (c) 3   (d) 4 

34. Which is the range reference operator using worksheet? 

(a) ,    (b) ;   (c) :   (d) – 

35. Which is the reference concatenation operator used in calc? 

(a) ,    (b) ;   (c) ~   (d) : 

36. Which is the Intersection Operator using Open Office calc? 

(a),    (b) \   (c) ~   (d) ! 

37. Which of the following operator is used as text operator? 

(a) \    (b) ~   (c) &   (d) : 

38. How many types of cell reference are used in the worksheet? 

(a) 1   (b) 2   (c) 3   (d) 4 

39. The Open Office calc, spreadsheets are stored the default extension file name is: 

(a) .xls   (b) .ods   (c) .txt   (d) .doc 
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40. The extension file name of the animated image is: 

(a) .gif   (b) .ods   (c) .jpg   (d) .mp3 

41. Which of the following combination key can be used as close the document? 

(a) Ctrl + W   (b) Ctrl + C  (c) Ctrl + E  (d) Ctrl + L 

42. If you are not willing to save the file, then click: 

(a) open   (b) discard  (c) ok   (d) save 

43. The process of copy and paste can be replaced by a click and drag it is called as: 

(a) auto fill   (b) copy the cell  (c) move the cell  (d) delete the cell 

44. How many options having insert cells dialog box? 

(a) 1   (b) 2   (c) 3   (d) 4 

45. The user gives additional effect to the text in a cell is known as: 

(a) formatting  (b) deleting  (c) copying  (d) moving 

46. Which of the shortcut key is to align the center the data within the cell? 

(a) Ctrl + C   (b) Ctrl + E  (c) Ctrl + B  (d) Ctrl +1 

47. Which of the following shortcut key is used to visually change the format of a numeric content in currency symbol? 
(a) Ctrl + Shift + 4  (b) Ctrl + Shift + 5 (c) Ctrl + Shift + 6 (d) Ctrl + Shift + 3 

48. How many types are there to inserting functions into worksheet? 

(a)     (b) 2   (c) 3   (d) 4 

49. Which operator can be used in begins a function? 

(a) +   (b) –   (c) =   (d) i 

50. Which combination of shortcut key can be involved in function wizard? 

(a) Ctrl + FI   (b) Ctrl + F2  (c) Ctrl + F3  (d) Ctrl + F4 

51. How many types of tabs are used in function wizard? 

(a) 1   (b) 2   (c) 3   (d) 4 

52. How many types function are categorized? 

(a) 9   (b) 10   (c) 11   (d) 12 

53. The Open Office Calc, arguments are separated by: 

(a) ,    (b) –   (c) :   (d) . 

54. The one of the most important feature of spreadsheet is the ability to create that based on numeric data is: 

(a) charts   (b) data   (c) series  (d) range 

55. The chart should be created in the specify the range of data is called: 

(a) charts   (b) data range  (c) series  (d) format 

56. Which one of the method is used to re-arrange the items in ascending or descending order based on alphabets? 

(a) Filtering   (b) Sorting  (c) Range  (d) Series 

57. Which method are used to show only the selected portion of data from a large size database? 

(a) Sorting   (b) Filters  (c) Series  (d) Data range 

58. How many types of filters are available? 

(a) 1   (b) 2   (c) 3   (d) 4 

59. The formatting aspect of the data tools lies in the virtualization of those data for easy understanding of the user 

that can you specify: 

(a) conditional formatting (b) filter  (c) sorting  (d) None of these 

60. The first electronic spreadsheet VisiCalc was developed by __________ and __________  

a) Bill Gates and Dennis Ritchie   b) Elon Musk and Sundar Pichai  

c) Don Bricklin and Bob Frankston   d) Allen and Charles Babbage  

61. VisiCalc was developed in the year  

a) 1969    b) 1979   c) 1989    d) 1999  

62. Lotus 1-2-3 was introduced in the year  

a) 1982    b) 1992   c) 1979    d) 2009  

63. Naming cells and macros were introduced in which spreadsheet?  

a) VisiCalc    b) Lotus 1-2-3  c) Excel    d) None  

64. In which year and by whom was the spreadsheet Excel introduced?  

a) 1987, Microsoft     b) 1982, Sun Microsystems  

c) 1982, Lotus 1-2-3 company    d) 1972, A & D Bell Laboratories  

65. Current cell and its contents displayed in _____  

a) Cell pointer   b) Formula bar  c) Standard toolbar  d) Status bar  

66. Intersection of each row and column makes a box which is called as  

a) Cell    b) Table  c) (a) or (b)   d) Grid  
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67. It is the combination of column heading and row number.  

a) Cell address   b) Table  c) Worksheet   d) Cell  

68. Which option in the Insert Cells dialog box is used to insert a new cell in the present location and the existing 

cells are shifted downwards?  
a) Shift cells down   b) Shift cells right  c) Entire row   d) Entire column  

69. Which option in the Insert Cells dialog box is used to insert a new cell in the present location and the existing 

cells are shifted towards right?  
a) Shift cells down   b) Shift cells right  c) Entire row   d) Entire column  

70. You should enter dates in Calc spreadsheet as  

a) DD/MM/YY   b) YY/MM/DD  c) MM/DD/YY   d) MM/YYYY  

71. You should enter time in Calc spreadsheet as  

a) HH:MM:SS   b) HH:MM  c) SS:MM:HH   d) HH:SS:MM  

72. It is used to group a range of cells.  
a) Dot ( . )    b) Semicolon ( ; )  c) Colon ( : )   d) Comma ( , )  

73. What is Reference concatenation operator?  

a) ~    b) &   c) !    (d) ;  

74. Intersection operator is used to join two set of groups and it is represented by  

a) ~    b) &   c) !    (d) ;  

75. Function Wizard can be invoked by pressing  

a) Ctrl + F2    b) Ctrl + F1  c) Ctrl + F4   d) Ctrl + F10  

76. In Calc, the functions are categorized into ________ types.  

a) 9     b) 10   c) 11    d) 12  

77. A Spreadsheet is a _______ database.  

a) Flat file    b) Relational  c) Hierarchy   d) Network 

78. It is a repository of collections of related data or facts.  

a) Table    b) Record  c) Database   d) Field  

79. Which menu is used to open the Page style dialog box?  

a) Format → Page     b) Format → Paragraph  

c) Tools → Page     b) View → Paragraph 

(CHAPTER-8)   (Office Automation Tools - Presentation Basics) 
1. The no. of tabs in the workspace of impress is ----- 

(a)  2   (b) 5   (c) 4   (d) 6  

2. In impress shortcut key used to make changes in text style is ----- 

(a) F5   (b) F7   (c) F11   (d) F12 

3. Which is the following software package used to show information in the form of a slide show? 

(a) Presentation  (b) Spreadsheet  (c) Database  (d) Application 

4. The most commonly known presentation program are OpenOffice.org: 

(a) power point  (b) impress  (c) keynote  (d) none 

5. Which of the following is one of the way to start Impress? 

(a) All programs → Openoffice → Impress  (b) All programs → Staroffice → Impress 

(c) All programs → Office → Powerpoint  (d) All programs → Office → Presentation 

6. How many types of presentation backgrounds that you provided by Impress? 

(a) 15   (b) 20   (c) 25   (d) 30 

7. Which is you can select to start with a blank presentation? 

(a) <ORIGINAL>  (b) <NEXT>  (c) <NEW>  (d) <OUTPUT> 

8. Generally, presentations are created for computer screen display, that you would select the option: 

(a) <ORIGINAL>  (b) <SCREEN>  (c) <NEW>  (d) <OUTPUT> 

9. Which is good choice for the transition between the different slides speed? 

(a) Normal   (b) Medium  (c) Fast   (d) None 

10. How many parts are there main Impress Window? 

(a) 1   (b) 2   (c) 3   (d) 4 

11. How many sections are there tasks pane? 

(a) 2   (b) 3   (c) 4   (d) 5 

12. The name that you see at the top of your Impress window? 

(a) Title bar   (b) Tool Bars  (c) Menu bar  (d) Scroll bar 

13. Which is used to hides the window from view but it remains as a button on the task bar? 

(a) Minimize button  (b) Maximize button (c) Restore button (d) Close button 
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14. Which is a measurement tool in the software programs that allow the user to align on a page? 

(a) view   (b) ruler  (c) menu  (d) format 

15. The bar which is at the bottom of the window is called: 

(a) horizontal   (b) vertical   (c) standard   (d) formatting  

16. The bar which is at the side of the window is called: 

(a) horizontal   (b) vertical   (c) standard   (d) formatting  

17. How many tabs are available in the workspace view buttons? 

(a) 2   (b) 3   (c) 4   (d) 5 

18. The shortcut keys are used to display the navigator? 

(a) Ctrl + Shift + F5  (b) Ctrl + Shift + F2 (c) Ctrl + Shift + F3 (d) Ctrl + Shift + F4 

19. Which is the main view for creating individual slides? 

(a) Normal view  (b) Outline view  (c) Notes view  (d) Handout view 

20. Use this view to rearrange the order of slides and produce a timed slide show: 

(a) normal view  (b) slide sorter view (c) outline view  (d) notes view 

21. Which view contains all the slides of the presentation in their numbered sequence? 

(a) Normal view  (b) Slide sorter view (c) Outline view  (d) Notes view 

22. Which view is used for setting up the layout of your slides? 

(a) Normal view  (b) Outline view  (c) Notes view  (d) Handout view 

23. The normally a title slide is: 

(a) first slide   (b) last slide  (c) second slide  (d) none 

24. Which function key is used to adjustments for the formatting of the title? 

(a) F9   (b) F10   (c) F11   (d) F12 

25. Which slide is used as the starting point for other slides? 

(a) Master slide  (b) Slide show  (c) Notes master  (d) None 

26. All of the characteristics of slide masters are controlled by: 

(a) Slide master  (b) Styles  (c) Slide show  (d) None 

27. You can create new slide, that inherited from the slide is known as: 

(a) Slide master  (b) Slide show  (c) Styles  (d) None 

28. To start creating a custom animated image, open the Animator dialog box from: 

(a) apply   (b) insert  (c) move   (d) create 

29. During the slide show that allowed displays all frames of animated GIF files: 

(a) animation  (b) slide sorter  (c) slide show  (d) none 

30. Slide animation are similar to: 

(a) transitions  (b) slide sorter  (c) slide show  (d) none 

31. Which view is used that Animation effects need to applied that can you select individual object on a single slide?  

(a) Normal view   (b) Outline view  (c) Notes view  (d) Handout view 

32. The Edit points toolbar should be displayed. If not select it from: 

(a) Edit → Toolbars → Edit points   (b) View → Toolbars → Edit points 

(c) Edit → Toolbars → View points   (d) View → Toolbars 

33. Rearranging slides can be done using ________ view.  

a) Normal    b) Outline   c) Handout   d) Slide Sorter  

34. To insert a new slide into the presentation, choose  

a) Insert → slide   b) slide show → slide  c) Edit → insert slide  d) Tools → slide  

35. The menu option to remove the selected slides  
a) Edit → Delete Slide   b) Tools → Delete Slide  c) File → delete slide  d) Slide show → delete slide  

36. To run the slide show, choose  
a) Slide → Slide Show   b) Slide Show → Slide Show c) Tools → slide show  d) Edit → slide show  

37. To exit the presentation slide show at any time, press the key  

a) Esc    b) Insert   c) Del    d) Backspace 

 
(CHAPTER-9)  (Introduction to Internet and Email) 

1. The protocol by used Internet: 

(a) TCP/IP   (b) http   (c) HTT   (d) TC/IP 

2. A private network that uses Internet Technologies: 

(a) Internet   (b) Network  (c) Extranet  (d) LAN 

3. Who is called Father of the Internet? 

(a) Vinton Gray Cerf  (b) Tim Berners-Lee (c) Charless Babbage (d) William Cerf 
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4. Who was also involved in the formation of ICANN? 

(a) Vinton Gray Cerf (b) Tim Berners-Lee (c) Bob Kahn  (d) William Cer 

5. Which name is used to online identity and can be access by the web browser when connected the Internet? 

(a) E-mail   (b) Domain name (c) FTP   (d) Profocol 

6. The Generic domain name system of Government Institutions: 

(a) .com   (b) .gov.   (c) –org   (d) .edu 

7. The Generic domain nam? system of Educational Institution: 

(a) .com   (b) .gov   (c) .org   (d) .edu 

8. The heart of intranets and the Internet is called as: 

(a) DNS   (b) IP   (c) TCP   (d) FTP 

9. Which is used as Internet address information? 

(a) IP   (b) DNS   (c) TC   (d) FTP 

10. Which system is used to deliver mail and other information from computer to computer? 

(a) IP   (b) DNS   (c) TC   (d) FTP 

11. The country level domain name system in India is: 

(a) . in   (b) .us   (c) –sg   (d) .ru 

12. The country level domain name system in USA is: 

(a) .in   (b) .us   (c) sg   (d) .ru 

13. The country level domain name system in Singapore is: 

(a) .in   (b) .us   (c) .sg   (d) .ru 

14. How many parts are IP address? 

(a) 2   (b) 3   (c) 4   (d) 5 

15. IP address is separated by: 

(a) dots   (b) comma  (c) ‘semi-colon’  (d) colon 

16. URL abbreviation is: 

(a) Uniform Resource Locator   (b) Uniform Reserve Locator 

(c) Uniform Resistance Locator   (d) Uniform Read Locator 

17. ICANN stands for: 

(a) Internet Corporation for Assigned Names and Numbers 

(b) Intranet Corporation for Assigned Names and Numbers 

(c) Internet Corporation for Assigned Names and Natives 

(d) Internet Community for Assigned Names and Numbers 

18. ICANN head quarters is: 

(a) Los Angeles  (b) New York  (c) Playa Vista  (d) San Francisco 

19. W3C stands for: 

(a) World Wide Work Consortium   (b) World Wide Web Consortium 

(c) World Wide Web Connector   (d) World Wide Web Council 

20. What is the greatest advantage of Wireless Internet Connection? 

(a) Fast   (b) Easy way  (c) Always-on  (d) Accessed 

21. Which device is used to pick up and send Internet signals? 

(a) Modem   (b) Cable  (c) Telephone  (d) Wireless 

22. Which device provides good speed and allow you to access the Internet anywhere? 

(a) Cellphone  (b) Desktop computer (c) Removable device (d) None 

23. Which technology allows to connect the Internet or exchanges data wirelessly through radio waves? 

(a) Wi-Fi   (b) LAN   (c) WAN  (d) PAN 

24. The term broadband is shorthand for: 

(a) broad bandwidth  (b) broad banding  (c) broad band length (d) none 

25. DSL stands for: 

(a) Digital Subscriber Line (b) Digital Super Line (c) Digital Secondary Line (d) Digital Source Line 

26. Which network allows user to send data, voice and video content? 

(a) Wireless   (b) ISDN  (c) WLAN  (d) DSL 

27. ISDN stands for: 

(a) Integrated Services Digital Network  (b) International Services Digital Network 

(c) International Source Digital Network  (d) Integrated Services Digital Node 

28. ADSL stands for: 

(a) Asymmetric Digital Subscriber Line  (b) Assume Digital Subscriber Line 

(c) Arrange Digital Subscriber Line   (d) Asymmetric Digital Secondary Line 
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29. VoIP stands for: 

(a) Value-over Internet Protocol   (b) Voiee-over Internet Protocol 

(c) Volume-over Internet Protocol   (d) Visual-over Internet Protocol 

30. Which system is sending message over the phone and they can listen to their message later? 

(a) Video conferencing (b) Voice mail  (c) Chatting  (d) e-Banking 

31. Which technology allows to connect the Internet or exchanges data wirelessly through radio waves? 

(a) Wi-Fi   (b) LAN   (c) WAN  (d) PAN 

32. The term broadband is shorthand for: 

(a) broad bandwidth  (b) broad banding  (c) broad band length (d) none 

33. DSL stands for: 
(a) Digital Subscriber Line (b) Digital Super Line (c) Digital Secondary Line (d) Digital Source Line 

34. Which network allows user to send data, voice and video content? 

(a) Wireless   (b) ISDN  (c) WLAN  (d) DSL 

35. ISDN stands for: 

(a) Integrated Services Digital Network  (b) International Services Digital Network 

(c) International Source Digital Network  (d) Integrated Services Digital Node 

36. ADSL stands for: 

(a) Asymmetric Digital Subscriber Line  (b) Assume Digital Subscriber Line 

(c) Arrange Digital Subscriber Line   (d) Asymmetric Digital Secondary Line 

37. VoIP stands for: 

(a) Value-over Internet Protocol   (b) Voiee-over Internet Protocol 

(c) Volume-over Internet Protocol   (d) Visual-over Internet Protocol 

38. Which system is sending message over the phone and they can listen to their message later? 

(a) Video conferencing (b) Voice mail  (c) Chatting  (d) e-Banking 

39. Which system is taking in Internet can be on going or scheduled for a particular time or duration? 

(a) Video conferencing (b) Voice mail  (c) Chatting  (d) e-Banking 

40. Which system is known as Internet banking? 

(a) Video conferencing (b) Voice mail  (c) Chatting  (d) e-Banking 

41. The system is utilizing electronic technologies to access educational curriculum outside of a traditional class room: 

(a) video mail  (b) c-learning  (c) chatting  (d) e-banking 

42. Who was sent a first e-mail? 

(a) Ray Tomlinson  (b) Bob Kahn  (c) Vinton Gray Cerf (d) Tim Berners-Lee 

43. What is the use of compose button in die mail window? 
(a) Writting e-mail content (b) Searching files  (c) Copy the file  (d) Modifing the file 

44. Which software is created by cyber criminals to spy on their victims? 

(a) Virus   (b) Malicious spyware (c) Spam  (d) Phishing 

45. Which software program can copy itself from one computer to another without human Interaction? 

(a) Malware   (b) Botnet  (c) Computer worm (d) Spam 

46. The group of computers connected to the Internet that have been compromised by a hacker using a computer virus: 

(a) malware   (b) botnet  (c) computer worm (d) spam 

47. Which is described as unwanted messages in your e-mail box and is a nuisance as it can clutter your mail box? 

(a) Malware   (b) Botnet  (c) Computer worm (d) Spam 

48. The scams are fraudulent attempts by cyber criminals to obtain private information: 

(a) phishing   (b) malware  (c) botnet  (d) spam 

49. Which tools are used to obtain administrator- level access to a computer or a network of computers? 

(a) Phishing   (b) Malware  (c) Root kit  (d) Spam 

50. Browsing for information on the Internet is called: 

(a) surfing   (b) phishing  (c) spam  (d) worm 

51. To browse the Internet, a software is called: 

(a) Botnet   (b) Spam  (c) Web browser  (d) Phishing 

52. Google Inc. was developed for familiar web browser is: 

(a) chrome   (b) firefox  (c) safari   (d) Vivaldi 

53. Safari is a web browser, who was developed by: 

(a) Google Inc.  (b) Mozilla foundation (c) Apple Inc  (d) Microsoft Corp 

54. A collection of webpages is called: 

(a) website   (b) e-mail  (c) web service  (d) home page 

55. Every web page has a unique address called the: 

(a) URL   (b) ICANN  (c) CC   (d) BCC 
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56. Which type of websites remain the same whenever it is visited? 

(a) Static   (b) Dynamic  (c) Both (a) & (b)  (d) URL 

57. Which website content and layout may change during run time? 

(a) Static   (b) Dynamic  (c) Both (a) & (b)  (d) URL 

58. The activity of buying or selling of products on online services or over the Internet: 

(a) e-mail   (b) e-commerce  (c) e-leaming  (d) e-govemance 

59. Which term is used by transactions happen between business and consumers? 

(a) B2C   (b) B2B   (c) C2B   (d) C2C 

60. Which term is used to pertain transactions conducted between two businesses? 

(a) B2C   (b) B2B   (c) C2B   (d) C2C 

61. The application of information and communication technology for delivering government services are: 

(a) G2   (b) e-govemance  (c) e-commerce  (d) e-leaming 

62. A great role to play, that improves and supports all tasks performed by the government department and agencies are: 

(a) e-commerce  (b) e-govemance  (c) e-leaming  (d) e-mail 

63. Which month can be celebrated ‘Safer Internet Day’of every year? 

(a) January   (b) February  (c) March  (d) May 

64. Which is a software managing technique through which programs that are suspected to be infected with a virus can be run? 

(a) Sandboxing  (b) Spam  (c) Phishing  (d) Botnet 

65. IoT – means: 
(a) Internet of Things   (b) International of Things  (c) Internet of Timings  (d) Internet of Teachings 

66. USB, Wi-Fi are removable component and it refers: 

(a) device   (b) dongle  (c) electronic parts  (d) electronic governance 
67. Expansion of DNS  

a) DOMAIN NAME SERVER    b) DOMAIN NAME SYSTEM  

c) DATABASE NAME SYSTEM    d) DOMAIN NAMING SERVICES  

68. Expansion of ADSL  

a) ASYMMETRIC DIGITAL SUBSCRIBER LINE  b) ASYMMETRIC DATA SUBSCRIBER LINE  

c) ASYMMETRIC DIGITAL SATELLITE LINE  d) ASYMMETRIC DATA SUBSCRIBER LINK 

69. Match the following  

a) Stock Exchange - i) Face book   b) Travels - ii) Amazon India  

c) E-commerce - iii) goibibo.com   d) Social network - iv) ndtvprofit.com  

       a) iii), i), iv), v)   b) iv), iii), ii), i)   c) ii), iii), iv), i)   d) v), iii), ii), iv)  

70. Safer Internet Day (SID) 2018 is celebrated every year with a theme of "Create, connect and share respect: A 

better internet starts with you".  

a) January    b) February   c) March   d) April  

71. VOIP means  

a) Voice – Over – Internet Protocol    b) Voice – Over – Internet Phone  

c) Voice – Over – Intermediate Protocol   d) Voice – Over – Internal Protocol 

 
(CHAPTER-10) (HTML - Structural Tags) 
1. HTML is a: 

(a) word processing   (b) programming language  (c) markup language  (d) high level language 

2. HTML made up of: 

(a) tags   (b) comments  (c) modify  (d) symbols 

3. The <title> tag contains the: 

(a) title of the document  (b) beginning document  c) body of the document  (d) end of the document 

4. To write the HTML coding using text editor is: 

(a) MS-Word  (b) Notepad  (c) StarWriter  (d) Open Source Editor 

5. What is the shortcut key used to save the HTML file? 

(a) Ctrl + S   (b) Ctrl + A  (c) Ctrl + W  (d) Ctrl + Q 

6. What is the extension of the HTML file name while saving the document? 

(a) .htm or html  (b) .htm or.doc  (c) .html or .xls  (d) .html or .bar 

7. How can you save the HTML file from the menu? 

(a) Open → Save  (b) File → Save  (c) Edit → Save  (d) Tools → Save 

8. How can you open the text editor from Windows 7? 
(a) Start → All programs → Accessories → Notepad (b) Start → All programs → MSOffice → MS-Word 

(c) Start → All programs → Application → Notepad  (d) Start → All programs → Accessories → Start Writer 

www.Padasalai.Net                                                                     www.Trb Tnpsc.Com

Kindly Send Me Your Key Answer to Our email id - Padasalai.net@gmail.com

www.P
ad

as
al

ai
.N

et

www.P
ad

as
al

ai
.N

et

https://www.padasalai.net/
https://www.padasalai.net/


 
 

26 

PREPARED BY…  B.MOHAMED YOUSUF   M.C.A.., B.Ed.,   (PG ASST IN COMPUTER SCIENCE) 
                            [yousufaslan5855@gmail.com] 

9. How can you open the text editor from the Linux? 
(a) Applications → All programs → Text editor  (b) Applications → Accessories → Text editor 

(c) Applications → Accessories → Notepad   (d) Applications → Accessories → MS-Word 

10. What is the short cut key used to open the file? 

(a) Ctrl + O   (b) Alt + O  (c) Ctrl + A  (d) Alt + A 

11. How can you open the file name from the menu? 

(a) File → Browse  (b) File → Open  (c) Edit → Browse (d) Edit → Open 

12. Getitisa: 

(a) software   (b) hardware  (c) text editor  (d) document 

13. What is the shortcut key used to view the source file? 

(a) Ctrl + V   (b) Ctrl + O  (c) Ctrl + R  (d) Ctrl + U 

14. How can you open the source file from the Internet Explorer? 

(a) File → source  (b) View → source (c) Edit → source  (d) Tools → source 

15. Which function key is used to refresh / reload the modification? 

(a) F2   (b) F3   (c) F4   (d) F5 

16. What is the combination of shortcut key that is used to refresh/reload the modification? 

(a) Ctrl + R   (b) Ctrl + M  (c) Ctrl + A  (d) Ctrl + V 

17. How many attributes has <html> tag? 

(a) 1   (b) 2   (c) 3   (d) 4 

18. What is the default background colour of the browsers to display the text? 

(a) Black   (b) Blue   (c) White  (d) Red 

19. What is the Hexadecimal value for black colour? 

(a) #000000   (b) #0000FF  (c) #008000  (d) #FFfiOOO 

20. How many colours are supported for modem browsers? 

(a) 150   (b) 140   (c) 130   (d) 120 

21. What is the default text colour of body section? 

(a) White   (b) Black  (c) Blue   (d) Red 

22. What should be specified while including the image file name in the body background? 

(a) within double quotes (b) within single quotes (c) within underlined (d) within bolded 

23. How many pixels to an inch? 

(a) 62   (b) 12   (c) 64   (d) 74 

24. Which tag is included within the head tag? 

(a) Body   (b) Head   (c) Title   (d) None 

25. What is the default alignment of the heading section? 

(a) Left   (b) Right  (c) Centre  (d) Justify 

26. Which tag is used for line break? 

(a) <br>   (b) <hl>   (c) <LI>   (d) <p> 

27. Which tag is used to create comments in the HTML? 

(a) <#>   (b) <!>   (c) <*>   (d) <@> 

28. How many types are classified in the HTML elements? 

(a) 3   (b) 4   (c) 2   (d) 5 

29. An application to view web pages or websites: 

(a) editor   (b) browser  (c) web page  (d) note pad 

30. Which is the default browser available with Linux? 

(a) Chrome   (b) Internet explorer (c) Getit   (d) Mozilla firefox 
31. ________ is made up of tags and its attributes.  

a) C    b) HTML   c) Python   d) C++  

32. Tags are also called as ________ of HTML.  

a) Attributes    b) Elements   c) Statements   d) Headings  

33. You can also refresh or reload the web page by selecting ________ or ________.  

a) Ctrl + S or F2   b) Ctrl + F or F5   c) Ctrl + R or F5  d) Ctrl + R or F2  

34. The six-digit hexadecimal value is the combination of three, the first two digits represent ___ color.  

a) Red    b) Green   c) Blue    d) White 

35. The third and fourth digits of the hexadecimal value used to represent _______ color.  

a) Red    b) Green   c) Blue    d) White 

36. The last two digits in the hexadecimal value used to represent _______ color.  

a) Red    b) Green   c) Blue    d) White  
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37. The RGB hexadecimal value 000000 represent _______ color.  

a) Red    b) Black   c) Blue    d) White  

38. The RGB hexadecimal digit value FFFFFF represent _______ color.  

a) Red    b) Green   c) Blue    d) White  

39. The RGB hexadecimal digit value FF0000 represent _______ color.  

a) Red    b) Bright Red   c) Blue    d) White  

40. Modern browsers support nearly 140 colors.  

a) 120    b) 110    c) 130    d) 140  

41. Color code should be prefixed with #.  

a) #    b) @    c) ~    d) $  

42. The default text colour of body and it is often called as automatic color is  

a) Red    b) Black   c) Blue    d) White  

43. Which attribute within body tag is used to change the text colour?  

a) text    b) color    c) font_color   d) text_color 

 
(CHAPTER-11)(HTML- Formatting text, Creating Tables, List and Links) 
1. Which is one of the following tag is a phrase tag? 

(a) <strong>   (b) <em>  (c) <small>  (d) <big> 

2. Which tag is used emphasized text? 

(a) <strong>   (b) <em>  (c) <small>  (d) <big> 

3. What is the similar tag of <b>? 

(a) <strong>   (b) <em>  (c) <small>  (d) <big> 

4. What is the similar tag of <i>? 

(a) <strong>   (b) <em>  (c) <small>  (d) <big> 

5. What is the highlight-and a container tag? 

(a) <strong>   (b) <em>  (c) <small>  (d) <mark> 

6. What is the default colour displayed using <mark>tag? 

(a) Red   (b) Black  (c) Yellow  (d) Green 

7. Which tag can be used to show the text as strike through style? 

(a) <s>…. </s>  (b) <b>…. </b>  (c) <del>…. </del> (d) <ins>…. </ins> 

8. Which tag is used to replaced or deleted text? 

(a) <strong>   (b) <em>  (c) <ins>  (d) <del> 

9. Which tag is used non-paragraph text contents can be centered? 

(a) <p>   (b) <center>  (c) <em>  (d) <ins> 

10. Which tag is used to change the style, size and colour of text? 

(a) <colour>   (b) <size>  (c) <font>  (d) <style> 

11. Which font is usually used for office documents? 

(a) Arial   (b) Times New Roman (c) Arial Black  (d) Bookman Old Style 

12. Which font is generally used for publishing work? 

(a) Arial   (b) Times New Roman (c) Arial Black  (d) Bookman Old Style 

13. Which attribute is used to set different font style? 

(a) Colour   (b) Style   (c) Face   (d) Size 

14. Which tag is used as thematic breaks? 

(a) <font>   (b) <br>   (c) <hr>   (d) <p> 

15. How many pixel is equal to an inch? 

(a) 62   (b) 72   (c) 82   (d) 92 

16. What is the default size of the pixel? 

(a) 1   (b) 2   (c) 3   (d) 4 

17. The default view of a horizontal rule line is: 

(a) 2D   (b) 3D   (c) no shade  (d) normal 

18. What is the default colour by horizontal line? 

(a) Blue   (b) Yellow  (c) Gray   (d) Black 

19. The grid of rows and columns are: 

(a) row   (b) column  (c) table   (d) cell 

20. Which tag is used to define table column? 

(a) <tr>   (b) <th>   (c) <td>   (d) <br> 

www.Padasalai.Net                                                                     www.Trb Tnpsc.Com

Kindly Send Me Your Key Answer to Our email id - Padasalai.net@gmail.com

www.P
ad

as
al

ai
.N

et

www.P
ad

as
al

ai
.N

et

https://www.padasalai.net/
https://www.padasalai.net/


 
 

28 

PREPARED BY…  B.MOHAMED YOUSUF   M.C.A.., B.Ed.,   (PG ASST IN COMPUTER SCIENCE) 
                            [yousufaslan5855@gmail.com] 

21. Which tag is used to specify the data in a cell? 

(a) <tr>   (b) <th>   (c) <td>   (d) <br> 

22. Which attribute is used to specify the horizontal alignment of content within a cell? 

(a) Width   (b) Align  (c) VAlign  (d) Rowspan 

23. Which attribute is used to specify the vertical alignment of the contents within a cell? 

(a) Width   (b) Align  (c) VAlign  (d) <Rowspan> 

24. Which attribute is used to specify the width of a cell in terms of pixels or percentage? 

(a) Width   (b) Align  (c) VAlign  (d) <Rowspan> 

25. Which attribute is used to apply a particular colour to the background of a cell? 

(a) Width   (b) VAlign  (c) BG Color  (d) Background 

26. Which attribute is used to apply an image or picture as background of a cell? 

(a) Width   (b) BG Color  (c) Background  (d) Rowspan 

27. Which attribute is used to merge two or more cells in a row as a single cell? 

(a) Rowspan   (b) Colspan  (c) VAlign  (d) Align 

28. Which attribute is used to merge to two or more cells in a column as a single cell? 

(a) Rowspan   (b) Colspan  (c) VAlign  (d) Align 

29. Which attribute is used to set the space between the contents of a cell and its border? 

(a) Cellspacing  (b) Cellpading  (c) Align  (d) Height 

30. Numbered list is created, the list item is: 

(a) Numerical  (b) alphabetical  (c) both (a) & (b) (d) None of these 

31. Unordered lists are often referred as: 

(a) numerical   (b) alphabetical  (c) bullet symbol  (d) images 

32. Default of bullet style unordered list of elements are: 

(a) solid circle  (b) solid square  (c) solid symbol  (d) None of these 

33. A list block can be defined inside another list is called: 

(a) nested list  (b) bulleted list  (c) numerical list  (d) symbol list 

34. Which tag is used to create links along with HREF attributes? 

(a) <URL>   (b) <A>   (c) <BR>  (d)<L> 

35. HREF is abbreviated as: 

(a) Hypertext Reference    (b) Highertext Reference 

(c) Hyper markable Reference    (d) Higher Structure Reference 

36. Creating a link to a particular section of the same document is known as: 

(a) internal link  (b) external link  (c) URL   (d) HREF 

37. The text will be in old typewriter style i.e. fixed with font.  

a) <sup>...</sup>   b) <tt>..</tt>   c) <sub>...</sub>  d) <text>...</text>  

38. The ______ tag is used to define the text bigger in size than the normal size.  

a) <long>    b) <text>   c) <big>   d) <max>  

39. The ______ tag is used to define the text smaller than the current size.  

a) <min>    b) <small>   c) <tiny>   d) <short>  

40. ___ and __ tags are used to indicate whether the text you see in the browser has been deleted or added respectively.  

a) <del> and </del>   b) <s> and </s>   c) <ins> and </ins>  d) a) and c)  

41. The text what you specify between ____ and _____ will be displayed as strike through.  

a) <del> and </del>   b) <s> and </s>   c) <ins> and </ins>  d) a) and b)  

42. The text you specify between ____ and _____ will be shown as underlined.  

a) <add> and </add>   b) <str> and </str>  c) <ins> and </ins>  d) (a) <und> and </und>  

43. It is used to show the wrong text.  

a) <strong>    b) <s>    c) <del>   d) <em>  

44. Non-paragraph text contents can be centered with ______ tag.  

a) <align>    b) <space>   c) <p>    d) <center>  

45. The default thickness/size of <hr> tag is  

a) 3 pixels    b) 4 pixels   c) 5 pixels   d) 6 pixels  

46. If you specify the attribute ________ of <hr> tag turn off 3D view, turns on 2D view.  

a) noeffect    b) noshade   c) nofill    d) no3d 

(CHAPTER-12) (HTML - Adding multimedia elements and Forms) 
1. HTML – 5 introduces ………………….. image. 

(a) GIF   (b) JPEG  (c) SVG   (d) PNG 
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2. The popular format for animated images: 

(a) GIF   (b) JPEG  (c) SVG   (d) PNG 

3. GIF was developed by: 

(a) google   (b) microsoft  (c) sun   (d) Compuserve 

4. Which format does not support animated sound and playback control? 

(a) GIF   (b) JPEG  (c) SVG   (d) PNG 

5. Which format is suitable for photographic images? 

(a) GIF   (b) JPEG  (c) SVG   (d) PNG 

6. The PNG format is designed as a replacement format for: 

(a) GIF   (b) JPEG  (c) SVG   (d) PNQ 

7. The <IMG> tag along with the attribute is: 

(a) src   (b) width  (c) height  (d) vspace 

8. The default direction of the <marquee> is: 

(a) left   (b) right   (c) top   (d) bottom 

9. The default value of marquee scrolls: 

(a) finite   (b) infinite  (c) 1 second  (d) many seconds 

10. Which is referred to audio or video files are handled as part of the page? 

(a) inline   (b) embed  (c) src   (d) img 

11. …………………. tag is used to attach an audio or video file easily within webpage. 

(a) inline   (b) embed  (c) src   (d) no embed 

12. What is the primary attribute used with <embed> tag? 

(a) inline   (b) embed  (c) src   (d) no embed 

13. What is the special element of the form in html? 

(a) Name   (b) Submit  (c) Text   (d) Box 

14. What is the method will append the names of the form elements and their values? 

(a) Form   (b) Get   (c) Post   (d) Action 

15. What method will send the names and values of the form elements as packets? 

(a) Form   (b) Get   (c) Post   d) Action 

16. What is the special command button used to clear all the entries made in the form? 

(a) Reset   (b) Submit  (c) Button  (d) Text 

17. What is the standard graphical button on the form used to call function? 

(a) Reset   (b) Submit  (c) Button  (d) Text 

18. Which tag is used to receive multiline text data as input? 

(a) <form>   (b) <submit>  (c) <textarea>  (d) <inline> 

19. Which of the following is not Image Editing Application?  

a) Photoshop   b) Ms Word   c) Picassa   d) GIMP  

20. It is not suitable for photographic work  

a) JPEG    b) SVG    c) GIF    d) PNG  

21. If the photo does not appear in the web page, which attribute of <img> tag can be used to give the description of the image?  

a) alt    b) image   c) source   d) none  

22. The tag used to create form elements like text box, radio buttons etc. is  

a) <dropdown>   b) <select>   c) <listbox>   d) <input>  

23. This attribute of _ tag is used to set the length of the input character (number of characters) to the textbox and 

password boxes.  

a) length    b) value    c) size    d) maxlength  

24. Data received from the user can be send to receiver through mail using ________ action.  

a) to    b) mail to   c) CC    d) BCC  

25. Which tag is used to receive multi line text data as input?  

a) <text>    b) <textarea>   c) <select>   d) <input> 

 
(CHAPTER-13)  (CSS - Cascading Style Sheets) 
1. Which tag is used to change the default characteristics of web document? 

(a) Style   (b) Font   (c) Text   (d) Colour 

2. Which is used to define style for a particular tag anywhere in a HTML document? 

(a) Internal style  (b) Inline style  (c) External style  (d) Page style 

3. CSS was invented by: 

(a) Hakon Wium Lie  (b) Hakon Willium Lee  (c) Hakon Street Man      (d) Hakon Lee 
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4. The <style> tag are also called as: 

(a) page-level styles  (b) inline styles  (c) external styles  (d) both (a) & (c) 

5. Which section is used by the <link> tag to add CSS file? 

(a) Body   (b) Head  (c) Style   (d) Title 

6. Expand XHTML: 

(a) Extensible Hypertext Markup Language  (b) Extended Hypertext Markup Language 

(c) Executed Hypertext Markup Language  (d) Except Hypertext Markup Language 
7. It is easy to learn and understand but it provides powerful control over the presentation of an HTML document.  

a) <style>    b) CSS    c) HTML   d) XHTML  

8. Professional web developers don't use _______ styles  

a) Surface    b) Internal   c) a) and b)   d) External 

(CHAPTER-14) (Introduction to JavaScript) 

1. JavaScript 1.0 was introduced by: 
(a) Java corporation   (b) Netscape and Sun Inc  (c) Oracle corporation (d) Microsoft corporation 

2. Which client-side technology provides many advantages over traditional CGI server-side scripts? 

(a) C   (b) C + +  (c) JavaScript  (d) Java 

3. Which tag is normally recommended that JavaScript should be kept it within the tag? 

(a) <head>   (b) <title>  (c) <body>  (d) None of these 

4. Which <script> tag attribute specifies that the scripting language? 

(a) Type   (b) Language  (c) Name  (d) Value 

5. Which button can be used to reload the file into the browser? 

(a) OK   (b) Refresh  (c) Submit  (d) Ignore 

6. JavaScript is a: 
(a) Case-sensitive language (b) Low level language (c) Machine language (d) Assembly language 

7. What is the JavaScript single line comment? 

(a) “/”   (b) “//”   (c) */*   (d) *//* 

8. What is the JavaScript multiline comment? 

(a) “/**/”   (b) “*/ /*”  (c) “//”   (d) /* /* 

9. Which is used to separate the statements in JavaScript? 

(a) (:) colon   (b) (;) semicolon  (c) (,) comma  (d) (.) full stop 

10. Which is a data value for variable that appears directly in a program? 

(a) Variable   (b) Constant  (c) Literal  (d) Boolean 

11. An identifier is simply a: 

(a) Variable   (b) Name  (c) Value  (d) Boolean 

12. In JavaScript certain are used as reserved words? 

(a) Keywords  (b) Identifiers  (c) Variable  (d) String 

13. Which is the keyword for declared variable? 

(a) Float   (b) Var   (c) Int   (d) Str 

14. Variable name is also known as: 

(a) Identifier  (b) Constant  (c) String  (d) Float 

15. ……………. is a list of characters, and a string literal by enclosing single or double quotes? 

(a) Numbers   (b) Boolean  (c) String  (d) Constant 

16. Which literals are indicated by any one of two values true or false? 

(a) String   (b) Numbers  (c) Boolean  (d) Constants 

17. Which is the first character for naming a variable? 
(a) Letter   (b) An underscore (_) (c) ($) doller sign  (d) both (a) and (b) 

18. Which type of variable can be defined everywhere in the JavaScript? 

(a) Global   (b) Local  (c) String  (d) Numeric 

19. Which type of variable can be defined only within the body of the function? 

(a) Global   (b) Local  (c) String  (d) Numeric 

20. Which is a fixed value given to a variable in source code? 

(a) String   (b) Global  (c) Literal  (d) Numeric 

21. The act of converting one data type into a different data types: 
(a) Type conversion  (b) Arithmetic expression (c) Relational   (d) Logical  

22. Which casting occurs automatically in JavaScript when you change the data stored in a variable? 

(a) Implicit   (b) Explicit  (c) Internal  (d) External 

23. Which is the formation of one or more variables and / or constants joined by operators? 

(a) Constant   (b) An expression (c) Variable  (d) String 
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24. Which is known as the remainder / modulus operator? 

(a) I    (b) *   (c) –   (d) % 

25. Which is an assignment operator? 

(a) /    (b) *   (c) =   (d) – 

26. .Relational operators are also called as: 

(a) Assignment   (b) Arithmetic   (c) Comparison   (d) Relational  

27. Which symbol is used as ‘not equal to’ in relational operator? 

(a) = =   (b) \ =   (c) !<    (d)\> 

28. Which operator is used as the string concatenation of JavaScript? 

(a) &   (b) +   (c) ++   (d) I 

29. Which operator is used to increment value? 

(a) +   (b) + +   (c) ~~   (d) ~ 

30. Which operator is used to decrement value? 

(a) +   (b) + +   (c) – –   (d) – 

31. Which operator is used to get the data type of its operand? 

(a) Numeric   (b) Typeof  (c) String  (d) Float 

32. Which is the conditional operator? 

(a) d   (b) :   (c) ?:   (d) ! : 

33. How many dialog boxes are supported by Java Scripts? 

(a) 1   (b) 2   (c) 3   (d) 4 

34. Dialog boxes are also called as: 

(a) Text boxes  (b) Combo boxes  (c) List boxes  (d) Popup boxes 

35. Which is mostly used to give a warning message to the users? 

(a) Alert dialog box  (b) Confirm box  (c) Prompt box  (d) Textbox 

36. What is the puipose of prompt dialog box? 

(a) User input  (b) User output  (c) Read data  (d) None of these 

37. …………………. you include will be ignored by the Java script interpreter. 

(a) Constant   (b) Comment  (c) Logical operator (d) Relational Operator 
38. Netscape and _______ jointly introduced JavaScript 1.0.  

a) Microsoft Corp.   b) Oracle   c) IBM    d) Sun Inc.  

39. JavaScript 1.0 was introduced in the year  

a) 1985    b) 1995    c) 2005    d) 2015  

40. It is a fixed value given to a variable in source code.  

a) Literal    b) Shapes   c) Statement   d) Identifier  

41. Which operator is used to get the data type of its operand?  

a) typeof()    b) ++    c) ternary operator  d) && 

 

(CHAPTER-15) (Control Structure in JavaScript) 
1. The simple if construction, no special processing is performed when the condition evaluates to false? 

(a) if else   (b) switch  (c) nested if  (d) if 

2. The statement begins by evaluating an expression placed between parenthesis, much like the if statement? 

(a) break   (b) default  (c) continue  (d) switch 

3. … is can be at the end of a switch structure if the result of the expression that do not match any of the case labels? 

(a) break statement  (b) switch structure (c) continue statement (d) default structure 

4. The loop initialize a variable which is also called as control variable ……………………….. 

(a) Third   (b) First   (c) Second  (d) All the above 

5. …… statement is executed, the current iteration of the enclosig loop is terminated and the next iteration begins? 

(a) switch   (b) break  (c) continue  (d) if 

6. The purpose of a …. is to execute a statement/block of’statement repeatedly as long as an expression is true? 

(a) for loop   (b) do while loop  (c) while loop  (d) all the above 
7. If none of the case match with switch expression, then control goes to  

a) break    b) continue   c) goto    d) default  

8. This statement is used to exit the loop.  

a) break    b) continue   c) goto    d) default  

9. __ statement goes to the next iteration of the loop without executing the remaining statements of the loop body.  

a) break    b) continue   c) goto    d) default  
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10. It is not one of the three logical operators in JavaScript.  

a) &    b) !!    c) !    d) ^  

11. __________ loop will be run on a predetermined number of times.  

a) for    b) while    c) do-while   d) all 

 
(CHAPTER-16) (JavaScript Functions) 
1. In the blow snippet Value of X is ….Var  X=102+5-50  

(a) 57   (b) 47   (c) 50   (d) 52 

2. Library functions are also called as-----  

(a) Predefined functions  (b) storage functions  (c) instructions    (d) commands 

3. … often use their argument values to compute a return value that becomes the value of the function invocation expression. 

(a) function   (b) parameter  (c) non-parameter  (d) expression 

4. …………………… method returns the element that has the ID attribute with the specified value. 

(a) elements [o]  (b) getElementByid( ) (c) Nan ( )  (d) NaN (“A”) 
5. Parameters list of a function contains more than one variable then which is separated by  

a) Point ( . )    b) Semicolon ( : )  c) Colon ( ; )   d) Comma ( , )  

6. Which of the following function is used to check whether the given value or variable is valid number?  

a) isNaN()    b) isNum()   c) isNo()   d) isNalpha()  

7. Which library function in JavaScript converts a given string to uppercase letters?  

a) toUpper()    b) IsUpperCase()   c) toUpperCase   d) toCapital()  

8. x=”JAVA”;  x.toLowerCase(); What is the output of the above code?  

a) Java    b) java    c) JAVA   d) javA  

9. Which library function in JavaScript returns number of characters of the given string?  

a) len()    b) strlen()   c) length()   d) strlength()  

10. Which library function of JavaScript converts a given float number to an integer?  

a) parseInt()   b) Int()    c) toInt()   d) towhole()  

11. Which library function of JavaScript converts a given string into a floating number?  

a) StrtoFloat()   b) Float()   c) parseFloat()   d) toFloat() 

 
(CHAPTER-17) (Computer Ethics and Cyber Security) 
1. The act of gaining illegal access to a computer is called --- 

(a) Hacking   (b) Cracking  (c) Phishing  (d) Piracy 

2. A moral code that is evaluated as right is ………………….. 

(a) viruses   (b) cracking  (c) ethics  (d) Phishing 

3. …………… is a crime where the criminals impersonate individuals for financial gain. 

(a) intellectual theft  (b) Identity theft  (c) Salami slicing  (d) Spoofing 

4. Stealing data from a computer system without the knowledge or permission is called 

(a) warez   (b) hacking  (c) cracking  (d) phishing 

5. One of the most common virus is …………………….. 

(a) Ransomware  (b) Spyware  (c) worms  (d) Trojan 

6. ………….. is the intermediary between the end users and a web browser. 

(a) Firewall   (b) Proxy server  (c) Cookies  (d) Warez 

7. “unauthorized copying of software” is referred as  

a) Hardware theft   b) Theft    c) Correct operation  d) Software piracy  

8. ____ refer to the generally accepted standards of right and wrong in the society.  

a) Justice    b) Morals   c) Honesty   d) Discipline 

 
(CHAPTER-18) (Tamil Computing) 
1. Which is not a search engine?  

        (a) Android   (b) Bing   (c) Yahoo  (d) Google 

2. Which of the following is the first Tamil Programming language?  

(a)  Kamban   (b) Azhagi  (c) Tamil Open Office (d) Ezhil 

3. Which one of the following is Harass through online? 

(a) Cyber terrorism  (b) Scam  (c) Cyber stalking  (d) Fraud 

4. Getting Government services through internet is known as --- 

(a) e-filling   (b) e-Payment  (c) e-governance (d) e-shopping 
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5. ---is a Tamil translation application  

(a) Lippikar   (b) Thamizpori  (c) Azhagi  (d) Ezhil 

6. Human civilization developed with the innovation of computer in the ……………………. 

(a) 11th century  (b) 13th century  (c) 16th century  (d) 20th century 

7. ………… is not just a language, it is our identity, our life and our source. 

(a) English   (b) Sanskrit  (c) Tamil  (d) Hindi 

 

   Important Shortcut keys:  
1. Cut   - Ctrl+ X                

2. Copy   - Ctrl+ C            

3. Paste   - Ctrl+ V        

4. Save   - Ctrl+ S  

5. Close   - Ctrl+ W         

6. Print   - Ctrl+ P              

7. Undo   - Ctrl+ Z         

8. Redo   - Ctrl+ Y       

9. Refresh   - F5     

10. Rename file - F2      

11. Help   - F1    

12. Shutting Down  - Alt+F4   

13. Find and Replace  - F5 (MS-Word)                                                                              

14. Spelling mistake check - F7                   

 

Important years: 
1. Analytical engine   -1837 

2. First generation  -1940-1956 

3. Second    ,,  - 1956-1964 

4. Third    ,,  -1964-1971 

5. Fourth ,,  -1971-1980 

6. Fifth ,,  -1980 – till date 

7. Optical mouse invented -1988 

8. Mechanical mouse - 1968 

9. First computer monitor -1973 

10. Mouse Patented  - 1970 

11. Mouse introduced  - 1960 

12. Microprocessor first intro -1970 

13. Windows 1.x  - 1985 

14. Windows 2.x  -1987 

15. Windows 3.x  -1992 

16. Windows  95  -1995 

17. Windows 98  -1998 

18. Windows Me  -2000 

19. Windows 2000  -2000 

20. Windows XP  - 2001 

21. Windows Vista  -2006 

22. Windows 7   - 2009 

23. Windows 8  - 2012 

24. Windows 10  - 2015 

25. Visicalc (Apple II) -1979  

26. Lotus 123  -1982 

27. Star office calc   -1985 

28. Ms excel   -1987 

29. ICANN created  -1998 (SEP 18) 

30. Safer internet day  -2018 

31. Java Script (Netscape) -1995(DEC 4) 

32. Unicode first version intro -1991 

33. Tamil virtual academy -2001 

34. Tamil language council -2001 

35. Madurai project   - 1998 

36. Tamil Unicode started -2004 

37. 42% people using tamil Net -2016 

38. 72% people will access ,, -2021 
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Author names / Etc: 
1. Computer (AE Concept)   -  Charles Babbage (Father of computer)(1837) 

2. ENIAC    - J.Presper Eckert / John Mauchly (1943-1946) 

3. Mouse     - Douglas Engelbart (1960, Patented Nov 17,1970) 

4. First computer Monitor  - Xerox Alto computer system (March 1, 1973) 

5. First spread sheet (Visicalc)  - Daniel Bricklin and Bob Frankston (1972) 

6. The Father of Spreadsheet   - Daniel Bricklin 

7. WWW    -  Tim Berners Lee (1994) 

8. First mail send   - Roy Tomlinson (1971) 

9. CSS     - HakonWium Lie (1994) (OCT-10) 

10. Tamil Virtual University  - 17 Feb 2001 (Established TN Govt )(Tamil Virtual Academy) 

11. Unicode (Tamil)    - First version (Oct-1991) 

12. Tamil language council   - Singapore (2001) “Valar Tamil Iyakkam” 

13. Madurai Project   - Lanch – 1998 ; Release – 2004 

14. Tamil Wikipedia    -  More than one lakh articles 

 
Abbreviations 
1. COMPUTER   – Commonly Operating Machine Purposely Used for Technological and Educational Research 

2. AE    –  Analytical Engine 

3. ENIAC   –  Electronic Numerical Integrator and Calculator 

4. EDVAC   –  Electronic Discrete Variable Automatic Computer 

5. UNIVAC   –  Universal Automatic Computer 

6. IBM   –  International Business Machines 

7. IC   –  Integrated Circuits 

8. VLSI   –  Very Large Scale Integrated Circuits 

9. ULSI   –  Ultra Large Scale Integration 

10. NLP   –  Natural Language Processing 

11. AI    –  Artificial Intelligence  

12. OCR   –  Optical Character Recognition / Reader 

13. OGR   –  Optical Grapheme Recognition 

14. IPO Cycle   –  Input Process Output Cycle 

15. CU   -  Control Unit 

16. ALU   – Arithmetic and Logic Unit 

17. MU   – Memory Unit 

18. QR    – Quick Response 

19. CCD   – Charge Coupled Device  

20. GUI   – Graphical User Interface 

21. LCD   – Liquid Crystal Display 

22. LED   – Light Emitting Diodes 

23. CRT  - Cathode Ray Tube 

24. VGA   – Video Graphics Array 

25. CPS   – Character Per Second 

26. DPI   – Dots per Second 

27. PPM   – Page per Minute 

28.  OS    – Operating System 

29. POST   – Power On Self-Test 

30. BIOS   –  Basic Input Output System 

31. RUR   – Rossum’s Universal Robots. 

32. BIT   – Binary Digit 

33. ASCII  – American Standard Code for Information Interchange 

34. KB ; MB  - Kilo Byte ; Mega Byte 

35. GB ; TB  - Giga Byte ; Tera Byte 

36. PB ; EB  - Peta Byte ; Exa Bye 

37. ZB ; YB  - Zetta Byte ; Yotta Byte 

38. MSB   – Most Significant Bit 

39. LSB  -  Least  Significant Bit 

40. BCD  - Binary Coded Decimal 
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41. EBCDIC  -  Extended Binary Coded Decimal Interchange Code 

42. ISCII  - Indian Standard Code for Information Interchange. 

43. X-OR  - Exclusive-OR 

44. X-NOR  - Exclusive-NOR 

45. MHz & GHz  - Mega Hertz & Giga Hertz 

46. CPU  - Central Processing Unit 

47. MDR  - Memory Data Register 

48. MAR  - Memory Address Register 

49. PC   - Program Counter / Personal Computer 

50. RISC  - Reduced Instruction Set Computers 

51. CISC  - Complex Instruction Set Computers 

52. RAM  - Random Access Memory 

53. ROM  - Read Only Memory 

54. PROM  -  Programmable Read Only Memory 

55. EPROM  - Erasable Programmable Read Only Memory 

56. EEPROM  - Electrically Erasable Programmable Read Only Memory 

57. CD   - Compact Disc 

58. DVD  - Digital Versatile Disc or Digital Video Disc 

59. HD   - High-Definition 

60. PDA  - Personal Digital Assistance 

61. USB  - Universal Serial Bus 

62. HDMI  - High Definition Multimedia Interface 

63. VGA  - Video Graphics Array 

64. SCSI   -  Small Computer System Interface 

65. MS-Word  - Micro Soft Word 

66. UI   - User Interface 

67. FIFO  - First In First Out 

68. SJF   - Shortest Job First 

69. RRS  - Round Robin Scheduling  

70. FAT  - File Allocation Table 

71. NTFS  - Next Generation File System 

72. ios   - iPhone Operating System  

73. DOS  - Disk Operating System 

74. SSD  - Solid State Drives 

75. CD-ROM  - Compact Disc Read Only Memory 

76. I/O Operator  - Input and Output Operator 

77. DDE  - Dynamic Data Exchange 

78. TCP/IP  - Transmission Control Protocol / Internet Protocol 

79. DNS  - Domain Name System 

80. URL  - Uniform Resource Locator 

81. W3C  - World Wide Web Consortium 

82. MITM  - Man-in-the-middle attack 

83. EDI   - Electronic Data Interchange 

84. LAN  - Local Area Network 

85. MAN  - Metropolitan Area Network 

86. WAN  - Wide Area Network 

87. PAN  - Personal Area Network 

88. CAN  - Campus Area Network 

89. WLAN  - Wireless Local Area Network 

90. WWW  - World Wide Web 

91. VSNL  -  Videsh Sanchar Nigam Ltd 

92. VOIP  - Voice Over Internet Protocol 

93. EC   - Electronic Commerce 

94. SERP  - Search Engine Result Page 

95. ICT   - Information and Communication Technology 

96. DSL  - Digital Subscriber Line 

97. ASL  - Asymmetric Digital Subscriber Line 
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98. ISDN  - Integrated Services Digital Network 

99. CL or CSL  - Cyber Law / Cyber Space Law 

100. E-mail  - Electronic Mail 

101. CC   - Carbon Copy 

102. BCC  - Blind Carbon Copy 

103. SID   - Safer Internet Day (2018) 

104. WLAN  - Wireless Local Area Network 

105. HTML  - Hyper Text Markup Language 

106. SGML  - Standard Generalized Markup Language 

107.  Sub / Sup  -  Sub Script / Super Script 

108.  OL / UL  - Ordered List / Un-ordered List 

109. DL / DT/ DD - Definition List / Definition Term / Definition Description 

110. ITL  or IL  - Information Technology Law / Internet Law 

111. GIF   - Graphical Interchange Format 

112. JPEG  - Joint Photographic Experts Group 

113. PNG  - Portable Network Graphics 

114. SVG  - Scalable Vector Graphics 

115. CGI   - Common Gateway Interface 

116. ASP  - Active Server Pages 

117. HTTP  -  Hyper Text Transfer Protocol 

118. CSS   - Cascading Style Sheets 

119. DHTML  - Dynamic Hyper Text Mark-up Language 

120. XHTML  - Extensible Hypertext Mark-up Language 

121. E-Commerce  - Electronic Commerce 

122. IDS   - Intrusion Detection Systems 

123. IANA  - Internet Assigned Numbers Authority 

124. ICANN  - Internet Corporation for Assigned Names and Numbers 

125. TSCII  - Tamil Script Code for Information Interchange 

 

 

   SHORT CUT KEYS WITH FUNCTION: 
Shortcut Key FUNCTION KEY ACTION 
Ctrl+A Select the whole document.  → To move a character right 

Ctrl+B Makes text bold.  ← To move a character left 

Ctrl+C Copy the text. ↑ To move one line up 

Ctrl+D Double Underline text.  ↓ To move one line down 

Ctrl+E Text is center aligned.  Ctrl + → One word right 

Ctrl+F Find and Replace.  Ctrl + ← One word left 

Ctrl+I Makes text Italics.  Ctrl + ↑ One paragraph up 

Ctrl+J Text is Justifed.  Ctrl + ↓ One paragraph down 

Ctrl+L Text is left aligned.  Home To the beginning of line 

Ctrl+R Text is right aligned.  End To the end of line 

Ctrl+U Underlines text.  Ctrl + Home To the beginning of document 

Ctrl+V Paste the text. Ctrl + End To the end of document 

Ctrl+X Move the text. Tab To move one cell to right 

Ctrl+Y Redo last action.  Shift + Tab To move one cell to left 

Ctrl+Z Undo last action.  Pg up(Page Up) To scroll one screen up 

Left Arrow Move cursor one character left.  Pg Down(Page Down) To scroll one screen down 

Right Arrow Move cursor one character right.  Familiar File Type EXTENSION 
UpArrow Move cursor one line up.  Text Files .txt 

DownArrow Move cursor one line down.  Microsoft Word Documents .doc / .docx  
Shift+ LeftArrow Move cursor with selection to the left.  OpenOffice Documents .odt 

Shift+ RightArrow Move cursor with selection to the right.  Microsoft Excel .xls / .xlsx 

Ctrl+ LeftArrow Go to beginning of word.  OpenOffice Calc .ods 

Ctrl+ RightArrow Go to end of word.  Microsoft PowerPoint .ppt / .pptx 

Home Go to beginning of line.  OpenOffice Impress .odp 

End Go to end of line.  Executable Files /Applications  .exe 

Ctrl+Home Go to start of document.  Web Pages .htm / .html 
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Ctrl+End Go to end of document.  Portable Document Format .pdf 

Shift+Home Go and select from the beginning of line.  Photos  .jpg / .jpeg  

Shift+End Go and select till end of line.  Animated Images .gif (Graphical Image Format) 

Insert Insert mode on/off.  Audio .mp3 

Page Up Move one screen up.  Audio / Video .mp4  

Page Down Move one screen down.  

Ctrl+Shift+B Subscript.  

Ctrl+Shift+P Superscript.  

Font Format: 
Formatting Option Keyboard Shortcut Description 

Font style -- Used to change Font style 

Font size -- Used to change Font size 

Bold Ctrl + B Used to make the data as Bold 

Italic Ctrl + I Used to italicize data  

Underline Ctrl + U Used to underline the data 

Left Align Ctrl + L Left Align data within a cell  

Right Align Ctrl + R Right Align data within a cell 

Center Align Ctrl + E Center the data within a cell 

Justify Ctrl + J Align the data evenly both on left and right side of a cell 

Merge cell -- Makes selected cells as a single cell 

Domain Names: 
Generic Domain Name Description Country Level Domain Name Description 

.com Commercial Organisation .in India 

.gov Government institution .au Australia 

.org Non-profit Organisation .us United States of America 

.net Network Support Group .jp Japan 

.edu Educational Institution  .ru Russia 

  .sg Singapore  

HTML 
Opening Tag Closing Tag Type Function Attributes Contains Used inside 

<html> </html> Container Delimits a complete 

HTML document 
Dir, Lang <head>,  

<body> 

  

- 

<head> </head> Container Defines the function 

header 
-- <title> <html> 

<title> </title> Container Defines the document 
title 

-- Text <head>  

body> </body> Container Defines the document 

body 

Background, 

Bgcolor, Text, 
Leftmargin, 

Topmargin 

All tags that controls the 

appearance of body of 
the web page 

<html> 

<h1>, 

<h2>…. <h6> 

</h1>, </h2>,… 
</h6> 

Container Defines one of six 
levels of headings 

Align Text <body> 

<p> </p> Container Defines a paragraph of 
text 

Align Text <body> 

<br> -- Empty Insert a line break --- --- Text 

 
Opening Tag Closing Tag Description 

<b> </b> Text will be bold 

<i> </i> Text will be italics 

<u> </u> Text will be Underlined 

<tt> </tt> Text will be old type writer style i.e. fixed width font 

 
Tag Usage Tag Usage Final Output 

<b> To show the text in bold <strong> To show important text Bold 

<i> To show the text as italics <em> To Call attention  Italics 

<u> To show the text as underlined <ins> To insert a text Underline 

<s> To show the wrong text <del> To display text as striked through. Strike through  
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Tags to create table elements:  
1. <table> tag is used to create a table.  2.<tr> tag defines table rows  3.<th> tag defined table columns 

4. <td> tag is used to specify the data in a cell  5. <caption> tag defines title for the table 

 
Predefined functions: 
Function Description Example Result 

toUpperCase() Used to convert given string into uppercase  x=”java”       x.toUpperCase(); JAVA 

toLowerCase() Used to convert given string into lowercase x=”JAVA”   x.toLowerCase(); java 

length Used to find length of the given string x=”JAVA”    x.length(); 4 

parseInt() Used to convert the given float value into an integer parseInt(34.234); 34 

parseFloat() Used to convert the given string into a integer parseInt(“34.23”); 34.23 

GLOSSARY 
CHAPTER-1  INTRODUCTION TO COMPUTERS 
Computer ▪ It is an electronic device that processes the input according to the set of instructions provided to 

it and gives the desired output at a very fast rate.  

Vacuum tube ▪ Vacuum tubes contain electrodes for controlling electron flow and were used in early computers 

as a switch or an amplifier. 

Transistors ▪ The transistor ("transfer resistance") is made up of semi-conductors.  

▪ It is a component used to control the amount of current or voltage used for 

amplification/modulation of an electronic signal. 

Punched cards  ▪ Punch cards also known as Hollerith cards are paper cards containing several punched or 

perforated holes that were punched by hand or machine to represent data.  

Machine Language ▪ Machine language is a collection of binary digits or bits that the computer reads and interprets.  

Assembly language ▪ An assembly language is a low-level programming language.  

Integrated Circuits   ▪ The IC is a package containing many circuits, pathways, transistors, and other electronic 

components all working together to perform a particular function or a series of functions. 

Microcomputer ▪ Micro computer is used to describe a standard personal computer.  

High-level 

languages 

▪ A high-level language is a computer programming language that isn't limited by the computer, 

designed for a specific job, and is easier to understand. 

Natural Language 

Processing (NLP) 

▪ Natural Language Processing is a method used in artificial intelligence to process and derive 

meaning from the human language. 

Robotics  ▪ Robot is a term coined by Karel Capek in the 1921 to play RUR (Rossum's Universal Robots).  

▪ It is used to describe a computerized machine designed to respond to input received manually or 

from its surroundings. 

Nanotechnology ▪ Nanotechnology is an engineering, science, and technology that develops machines or works 

with one atom or one molecule that is 100 Nano-meters or smaller. 

Bioengineering ▪ A discipline that applies engineering principles of design and analysis to biological systems and 

biomedical technologies  

CHAPTER-3 COMPUTER ORGANISATION 
Computer 

hardware 

▪ The physical parts or components of a computer, such as the CPU, mother board, monitor, 

keyboard, etc.  

Intel ▪ Intel Corporation is an American multinational corporation and technology company involving 

in hardware manufacturing, especially mother board and processors 

Silicon chip ▪ Silicon chip is an integrated, set of electronic circuits on one small flat piece of semiconductor material, silicon. 

Multipurpose ▪ Multipurpose is several purpose 

Address bus ▪ Address bus is a collection of wires that carry the address as bits 

Data bus ▪ Data bus is a collection of wires to carry data in bits 

Control bus ▪ Control bus is a control line/collection of wires to control the operations/functions 

Arithmetic  ▪ Arithmetic operations are the mathematical operations on data like add, subtract etc 

Data Transfer ▪ Data Transfer means moving data from one component to another 

Logical operations ▪ Logical operations are the operations on binary/Boolean data like AND, OR , NOT 

Bidirectional ▪ Bidirectional means both the directions/ways  

Unidirectional ▪ Unidirectional means only one direction 

Access time ▪ Access time is the time delay or latency between a request to an electronic system, and the 

access being completed or the requested data returned  
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CHAPTER – 5 WORKING WITH WINDOWS OPERATING SYSTEM 
Operating System  ▪ System software that enables the hardware to communicate and operate with other software. 

Mouse ▪ Handheld hardware input device that control a cursor in a GUI and can move and select text, 

icons, files, and folders. 

Windows ▪ Familiar operating system developed by Microsoft Corporation. 

Desktop ▪ Opening screen of windows operating system. 

Icon ▪ Tiny image represent a command.  

Folder ▪ Container of files 

Linux ▪ An operating system.  

CHAPTER – 6 INTRODUCTION TO WORD PROCESSOR 

Word processor ▪ A software used to create, edit, view, manipulate, transmit, store, print and retrieve a text document. 

OpenOffice writer ▪ A word processor component of OpenOffice. 

Proprietary ▪ Owner or ownership. 

Embedding ▪ To surround tightly or firmly. 

Highlighting ▪ Highlighting is used to draw attention to important information in a text. 

Indents ▪ Indents is the distance from the margin that is used to improve the efficiency and readability of the paragraph. 

DDE ▪ Dynamic Data Exchange – a mechanism where source data can be pasted into a destination with 

a link of the original. 

Paste Special  ▪ The PasteSpecial option is used when only some aspects of the data, like only its formatting or 

only value is send while moving or copying. 

Headers ▪ This is the section at the top of the page where any references like title, chapter name, author 

name can be given which gets repeated on all pages. 

Footers  ▪ This is the section at the bottom of the page where any references like page number can be given 

which gets repeated on all pages. 

AutoText ▪ This helps to assign shortcuts to some text which are frequently used. 

Auto spell check ▪ This feature automatically checks the spelling while typing and underlines the misspelt words 

with wavy lines which can be corrected later. 
Automatic Correction ▪ This feature automatically corrects the common misspellings and typing errors automatically.  

CHAPTER -7 WORKING WITH OPEN OFFICE CALC 
Spreadsheet ▪ Sheet of paper that shows accounting or other data in rows and columns 

What-if analysis ▪ It is a process of changing the values in a cell to see how those changes will affect output. 

VisiCalc ▪ The first electronic spreadsheet application 

GUI ▪ Graphical User Interface 

Excel ▪ Familiar spreadsheet application developed by Microsoft Corporation.  

Cell ▪ Intersection of rows and column 

Cell Pointer ▪ A rectangular box, highlighting the cell in a spreadsheet. 

Active cell ▪ A cell in which the cell pointer is presently located. 

Formula ▪ A formula is an expression that performs mathematical operation on specific data. 

Operator ▪ A symbol that usually represents an action or process 

Range ▪ Group / Collection of cells 

BODMAS Rule ▪ Order of mathematical calculation: 

▪ Brackets - Orders (powers or square roots) - Division – Multiplication – Addition - Subtraction. 

Drag fill handle ▪ A small black box at the bottom right corner of the cell pointer. 

Function ▪ Predefined formula / A group of instructions to return a single result or a set of results. 

Chart ▪ Graphical representation of data. 

Database ▪ A large quantity of indexed digital information. 

Flat file database ▪ Single table, non relative database  

S Function Description Syntax 

1 Averageif Averages the arguments that meet the condition Average (range; criteria; 

average_range) 

2 Celling Rounds a number up to the nearest multiple of significance Celling (number; significance; 

[mode]) 

3 Countif Count the argument which meet the set conditions Countif (range; criteria) 

4 Fact Calculates the factorial of a number. Fact (number) 

5 Floor Rounds number down to the nearest multiple of significance Floor (number1; number2) 
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6 Product Multiples the arguments Product (number1; number2) 

7 Quotient Returns the integer portion of a division  Quotient (numerator; 

denominator) 

8 Round Rounds a number to a predefined accuracy Round (number; count) 

9 SQRT Returns the square root of a number  SQRT (number) 

10 Sum Returns the sum of all arguments Sum (number1; number2;….) 

11 Sumif Totals the arguments that meet the condition Sumif (range; criteria; sum-range) 

12 Sumsq Returns the sum of the squares of the arguments Sumsq (number1; number2;…) 

13 DB Returns the real depreciation of an asset for a specified period 

using the fixed-declining balance method 

Db (cost; salvage; life; 

period;[month]) 

14 N Converts a value to a number N (value) 

15 Date Provides an internal for the date given Date (year; month; day)  

16 Days Calculates the number of days between two dates Days (date2; date1) 

17 Days360 Calculates the number of days between two dates based on a 

360 days year 

Days360 (date1; date;[type]) 

18 Average Returns the average of a sample Average (number1; number2;…) 

19 Count Counts how many numbers are there in the list of arguments Count (value1; value2;…) 

20 Concatenate Combines several text items into one Concatenate (text1; text2;..) 

21 Len Calculates length of a string Len (text) 

22 Lower Converts text to lower case Lower (text) 

23 Mid Returns a partial text string of a text Mid (text; start; number) 

24 Proper Capitalizes the first letters in all words Proper (text) 

25 Upper Converts text to upper case Upper (text)  

CHAPTER -9 Introduction to internet and email 

VSNL ▪ Videsh Sanchar Nigam Ltd 

TCP ▪ Transmission Control Protocol 

IP ▪ Internet Protocol 

Host ▪ A host is a computer connected to a computer network  

ICANN ▪ Internet Corporation for Assigned Names and Numbers 

W3C ▪ World Wide Web Consortium 

WWW ▪ World Wide Web 

Tim Berners-Lee ▪ Creator of WWW 

DSL ▪ Digital Subscriber Line 

ISDN ▪ Integrated Services Digital Network 

URL ▪ Uniform Resource Locator 

Dongle ▪ A sbmall device able to be connected to and used with a computer, allowing access to wireless 

broadband or use of protected software. 

ADSL ▪ Asymmetric Digital Subscriber Line 

Browser ▪ A browseris software that is used to access the internet Eg. Chrome, FireFox 

Search Engine ▪ A search engine is a web-based tool that enables users to locate information on WWW. Eg. Google 

SERP. ▪ The list of content returned via a search engine to a user is known as a search engine results page. 

Phishing ▪ Phishing scams are fraudulent attempts by cybercriminals to obtain private information 

WebSite ▪ Collection of Webpages 

WebPage ▪ It is page of Website. 

EDI ▪ Electronic Data Interchange 

Voice mail ▪ System of sending messages over the phone. 

e-commerce ▪ Electronic Commerce, Buying and selling goods and services over an electronic network. 

e-governance ▪ Electronic governance. Application of information and communication technology for delivering 

government services. 

Internet ▪ Several networks, small and big all over the world, are connected together to form a Global 

network called the internet. 

Intranet ▪ It is a website used by organizations to provide a place where employees can access company related information. 

Extranet ▪ It is a private network using internet technology to share part of business information with 

supplier’s partners and customers. 
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CHAPTER -10  HTML STRUCTURAL TAGS 
HTML ▪ Hyper Text Mark-up Language used to create web pages. 

Tag ▪ A coded HTML command. It is also called as element. 

Attribute ▪ Special word, carrying special meaning used inside on HTML tag. 

Heading Section ▪ Refers title bar of a browser. 

Body Section ▪ Refers main client area of a browser. 

Browser ▪ An application to view web pages or web sites. 

Web Page ▪ An Online page contains hypertext. 

Hypertext ▪ Text which contains links to other texts. 

Text Editor ▪ An application used to type and modifies text contents, but it is not a word processor. 

Word Processor ▪ An application used to create and manipulate text documents. 

Notepad ▪ A default text editor available with Windows. 

Getit ▪ A default text editor available with Linux. 

Windows ▪ Familiar GUI Operating system developed by Microsoft. 

Linux ▪ Familiar Open Source operating system. 

Internet Explorer ▪ A browser available with Windows. 

Mozilla Firefox ▪ A default browser available with Linux. Open Source Third party browser can be installed in windows. 

Chrome ▪ A familiar web browser developed by Google. 

CHAPTER -11 HTML – Formatting text, Creating Tables, List and Links 
Text Formatting ▪ Showing text with different style and colour. 

Font ▪ Named set of certain style of character and numbers. 

Table ▪ A Structure of rows and columns or grid of cells. 

Cell ▪ An individual box in a table. 

Border ▪ A line surrounded by cells. 

Column ▪ Vertical structure of a table. 

Row ▪ Horizontal structure of a table. 

Ordered List ▪ Indents lists having numbers or letters in front of every list item. 

Unordered List ▪ Indents lists having a bullet symbol in front of every list item. 

Definition List ▪ Lists showing definition terms and definition descriptions. 

Link ▪ Make connection with a part of content of same document or an external document. 

Hyperlink ▪ A link from a hypertext document. 

Internal Link ▪ Connecting with another part of the same document. 

Local Link ▪ Internal Link 

External Link ▪ Connection with another hypertext document. 

CHAPTER – 12 HTML ADDING MULTIMEDIA ELEMENTS AND FORMS 
GIF ▪ Graphical Interchange Format. 

JPEG ▪ Joint Photographic Experts Group. 

PNG ▪ Portable Network Graphics. 

SVG ▪ Scalable Vector Graphics. 

Photoshop ▪ Familiar Photo editing tool developed by adobe. 

Picasa ▪ Free image organizer and editing tool developed by Life scape. 

GIMP ▪ Open source image editing tool. 

HTML 5 ▪ Latest version of HTML authorized by w3c 

W3C ▪ The World Wide Web Consortium; an International standards organization for the www. 

CHAPTER -13 CSS – CASCADING STYLE SHEET 
Style Sheet ▪ A separate file contains the style of appearance. 

Selector ▪ An HTML element 

Property ▪ Attribute of an HTML tag 

Link ▪ Connecting with another file 

CHAPTER – 17 COMPUTER ETHICS AND CYBER SECURITY 
Cyber Terrorism ▪ Hacking, threats, and blackmailing towards a business or a person. 

Cyber stalking ▪ Harassing through online. 

Malware ▪ Malicious programs that can perform a variety of functions including stealing, encrypting or deleting sensitive data, 

altering or hijacking core computing functions and monitoring user’s computer activity without their permission.  
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Denial of service attack ▪ Overloading a system with fake requests so that it cannot serve normal legitimate requests. 

Fraud ▪ Manipulating data, for example changing the banking records to transfer money to an 

unauthorized account. 

Harvesting ▪ A person or program collects login and password information from a legitimate user to illegally 

gain access to others’ account(s). 

Identity theft ▪ It is a crime where the criminals impersonate individuals, usually for financial gain. 

Intellectual 

property theft  

▪ Stealing practical or conceptual information developed by another person or company. 

Salami slicing ▪ Stealing tiny amounts of money from each transaction. 

Scam ▪ Tricking people into believing something that is not true. 

Spam ▪ Distribute unwanted e-mail to a large number of internet users. 

Spoofing ▪ It is a malicious practice in which communication is send from unknown source disguised as a 

source known to the receiver. 

Vulnerability ▪ The possibility of being attacked or harmed. 

Ethics ▪ Moral principles that govern a person's behaviour or the conducting of an activity. 

Cyber ▪ Characteristic of the culture of computers, information technology, and virtual reality. 

Computer Crime ▪ Computer crime is an intellectual crime to manipulate computer system. 

Authenticity ▪ The quality of being real or true. 

Sabotage ▪ Deliberately destroy, damage, or obstruct. 

Perpetrator ▪ A person who carries out a harmful, illegal, or immoral act. 

Software Piracy ▪ Software Piracy is the copyright violation of software created originally by one person and 

illegally used by someone else. 

Hacking ▪ Hacking is gaining unauthorized access to computer system without the owner’s permission. 

Cracking ▪ Cracking is gaining unauthorized access to computer systems to commit a crime, such as stealing the code 

to make a copy-protected program run thus denying service to legitimate users. 

Malicious ▪ Intentionally doing harm. 

Freeware ▪ Freeware is a software available free of charge. 

Shareware ▪ Shareware is a software that is distributed free of charge on a trial basis for a limited time. 

 

      CHAPTER 1 TO 18 16 LIST OUTS / TYPES / SUB HEADINGS 
 CHAPTER – 1 Introduction to Computers 
1.  Computer applications: 

1.Education, 2.Research, 3.Travel, 4.Tourism, 5.Weather forecasting, 6.Social networking,  

7.E-commerce,8.Weather forecasting, 9.Booking airlines, 10.Railway  

2.  Computer Generations: 

1. First generation -1940- 1956               (VACCUM TUBES) 

2. Second generation -1956-1964           (TRANSISTERS) 

3. Third generation -1964-1971             (INTEGRATED CIRCUIT) 

4. Fourth generation -1971-1980           (MICROPROCESSOR )(VLSI)) 

5. Fifth generation -1980 to till date      (ULTRA LARGE SCALE INTEGRATION) 

6. Sixth generation - in future. 

3.  Computer Generation languages: 

1. First  - Machine Language        2.Second - Assembly language 

3.Third  - High Level Languages  4. Sixth – Natural Language Processing 

4.  Computer Generation examples: 

1. First generation - ENIAC , EDVAC , UNIVAC 1 

2.Second generation - IBM 1401, IBM 1620, UNIVAC 1108 

3.Third generation - IBM 360 series, Honeywell 6000 series 

4. Fourth generation – IBM and APPLE were developed 

5.  Computer Generation merits: 

1..Second – Batch processing and multi programming 2..Third  - Smaller, faster, more reliable   

3. Fourth– IBM,APPLE developed and portable computer introduced 

4.Fifth- Introduced AI, Parallel processing 5.Sixth-Developemnt of robotics, Voice recognition s/w 

6.  Computer components:   

1) Hardware, 2) Software. 

7.  Hardware example: 1) Motherboard, 2) Memory devices, 3) Monitor, 4) Keyboard 
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8.  CPU components:   

1) Control unit, 2) Arithmetic and logic unit (ALU), 3) Memory unit. 

9.  Control Unit:  

1) CPU, 2) Memory, 3) I/O devices 

10.  Memory Unit Types:  

1) Primary memory, Secondary memory 

11.  Primary memory and secondary memory examples: 

1) Primary-Volatile –RAM,  2)Secondary-Non Volatile - Hard disk, CD-ROM and DVD ROM 

12.  Input Devices types: 

1.Keyboard, 2.Mouse, 3.Scenner 4.Finger print Scanner, 5.Track ball, 6.Retail Scanner,  

7.Light pen 8.OCR, 9.Bar &QR  Code,  10.Voice Input Systems 11.Digital Camera, 12.Touch Screen 13.Keyer. 

13.  Output devices types: 

1.Monitor, 2.Printer 3.Plotter, 4.Speakers, 5.Multimedia projectors 

14.  Keyboard types:  

1) Wired, 2) Wireless, 3) Virtual 

15.  Character keys:  

1) Letters, 2) Numbers 3) Special characters 

16.  Keys Types: 

1) Character keys, 2) Modifier keys, 3) System, 4) GUI keys, 5) Enter, 6) Editing keys, 7) Function keys,  

8) Navigation keys, 9) Numeric keypad,10) Loc k keys. 

17.  Mouse Types: 

1) Mechanical Mouse, 2) Optical, 3) Laser Mouse, 4) Air Mouse, 5) 3D Mouse, 6) Tactile Mouse,  

7) Ergonomic Mouse 8) Gaming Mouse. 

18.  Mouse some actions: 

1.Move, 2.Click, 3.Double click, 4.Right click, 5.Drag and drop. 

19.  Touch screen usages: 

1.Computers, 2.Laptops, 3.Monitors, 3.Smart phones, 4.Tablets, 5.Cash registers, 6.Information Kiosks. 

20.  Monitor types: 

1.CRT (Cathode Ray Tube), 2.LCD (Liquid Crystal Display), 3.LED (Light Emitting Diodes). 

21.  Printer types:  

1.Impact Printers,2.Non-Impact printers 

22.  Impact printers types:  

1) Dot matrix 2) Line matrix 

23.  Non-Impact Printers: 1) Laser printers,2) Inkjet printers 

24.  Inkjet Printers use colour cartridges:  

1) Magenta, 2) Yellow, 3) Cyan 

25.  Speakers common places:  

1) Airlines, 2) Schools, 3) Banks, 4) Railway Stations, Etc 

26.  Multimedia Projectors:  

1) Meeting halls or in classrooms 

27.  What are the different types of booting process?  1) Cold Booting, 2) Warm Booting 

 CHAPTER – 2 Number Systems 
1.  Data Representation : 

1) Bit (0 or 1), 2)Nibble (4 bits), 3)Byte (8 bits), 4)KiloByte (1024 bytes), 

5) MegaByte (1024 KB),6) GigaByte (1024 MB),7)TeraByte (1024 GB) 

2.  Computer memory: 

1.Decimal system, 1 Kilo -1000,(or) 103.  

2.Binary system, 1 KiloByte - 1024 bytes (or) 210.  

3.  American Standard Code for Information Interchange: 

1) Binary value 0 and 127 is used to represent a specific character.   

2) The ASCII value - 32  

3) ASCII value of numeric 0 is 48.  

4) Range of ASCII values for lower case alphabets is from 97 to 122  

5) Range of ASCII values for the upper case alphabets is 65 to 90 
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4.  Different types of Number  System: 

❖ Binary – Base value             : 2       (0,1) 

❖ Octal – Base value               : 8       (0,1,2,3,4,5,6,7) 

❖ Decimal – Base value          :10      (0,1,2,3,4,5,6,7,8,9) 

❖ Hexadecimal – Base value  :16     (0,1,2,3,4,5,6,7,8,9 ,A,B,C,D,E,F) 

5.  Encoding systems: 

1) BCD – Binary Coded Decimal  2) Unicode  

3) EBCDIC – Extended Binary Coded Decimal Interchange Code 

4) ASCII – American Standard Code for Information Interchange 

5) ISCII - Indian Standard Code for Information Interchange 

6.  Binary Representation for Signed Numbers:  

❖ Signed Magnitude representation:  1) 1’s Complement  2) 2’s Complement 

7.  Signed Magnitude representation example: 

❖ 1) +43 or 43 is a positive number 2) –43 is a negative number 

 CHAPTER – 3 Computer Organization 
1.  Microprocessor is made up of 3 main units: 

1) Arithmetic and Logic unit (ALU),2) Control unit, 3) Registers (Internal Memory) 

2.  Characteristics of Microprocessors:  

1) Clock speed ,2) Instruction set, 3) Word size 

3.  Clock speed is measured:  

❖ MHz (Mega Hertz) or in GHz (Giga Hertz). 

4.  Instruction set carries out the operations:  

1) Data transfer, 2) Arithmetic operations, 3) Logical operations, 4) Control flow,5)Input/output 

5.  Data communication between CPU and memory: 

1) Memory Data Register (MDR)  2) Memory Address Register (MAR)3)Program Counter (PC) 

6.  Types of Microprocessors : 

1.The width of data that can be processed, 2.The instruction set 

7.  Classification of Microprocessors based on the Data Width: 

1) 8-bit Microprocessor, 2) 16-bit  3) 32-bit  4) 64-bit Microprocessor 

8.  Classification of Microprocessors based on Instruction Set: 

1) Reduced Instruction Set Computers (RISC), 2) Complex Instruction Set Computers (CISC) 

9.  Examples of Reduced Instruction Set Computers (RISC): 

1) Pentium IV, 2) Intel P6, 3) AMD K6 and K7. 

10.  Examples of Complex Instruction Set Computers (CISC): 

1) Intel 386 & 486, 2) Pentium, Pentium II and III, 3) Motorola 68000. 

11.  Memory access types:  

1.Sequential access  2) Random access 

12.  Memory Hierarchy:  

1) Cache Memory 2) Main Memory 3) Hard Disk 

13.  Types of RAM:  

1) Dynamic RAM (DRAM) 2) Static RAM (SRAM) 

14.  Secondary Storage Devices: 
1) Hard Disks, 2) Compact Disc (CD), 3) Digital Versatile Disc (DVD), 4) Flash Memory Devices, 5) Blu-Ray Disc, 

15.  Examples for Flash memories:  

Pen drives, Memory cards etc. 

16.  Ports and Interfaces: 
1) Serial Port, 2) Parallel Port, 3) USB Ports, 4) USB 3.0, 5) VGA Connector, 6) Audio Plugs, 7) PS/2 Port, 8) SCSI Port 

 CHAPTER – 4 Theoretical Concepts of Operating System 
1.  Types of Software:  

1) Application Software 2) System Software 

2.  Application Software example:  

❖ MS-word ,VLC player 

3.  System Software example: Operating System and Language Processor 

4.  O.S controls:  

1) Disk drives, 2) Printers, 3.Electronic gadgets. 

5.  O.S used in Laptop and personal computers: 1.Windows, 2.UNIX, 3.Linux.  Mobile devices: 1.Android, 2.IoS . 
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6.  Types of Operating System:  

1. Single user- M.S Dos 2.Multi user – Windows, Linux and UNIX  

7.  Key features of the Operating System: 

1.User Interface, 2.Memory Management, 3.Process management, 4.Security Management. 

8.  Algorithms are mainly used to allocate the job (process) to the processor: 

1. FIFO 2. SJF 3. Round Robin, 4. Based on Priority 

9.  Security management level:  

1) File access level,  (2) System level,(3) Network level 

10.  File management techniques available:  

1.Next Generation File System (NTFS),  2.ext2(Linux). 

11.  Prominent OS:  

1.UNIX, 2. Microsoft Windows, 3.Linux, 4.Ios, 5.Android 

 CHAPTER – 5 Working with Windows Operating System 
1.  Functions of Windows Operating System: 

1) Access applications - Word processing, Games, Spread sheets, Calculators. 

2) Manage hardware - Printers, Scanners, Mouse, Digital cameras etc.,  

3) File Management Activities - Creating, Modifying, Saving, Deleting files and folders 

4) Change computer settings - colour scheme, screen savers. 

5) Load any new program.  

2.  Versions of Windows Operating System:   

Versions Year Specific features 

Windows  

1.x 

1985 ❖ Introduction of GUI in 16 - bit. processor  

❖ Mouse was introduced as an input device. 

Windows 2.x 1987 ❖ Supports to minimize or maximize windows.  

❖ Control panel feature was introduced  

Windows  

3.x 

1992 ❖ Introduced the concept of multitasking.  

❖ Supported 256 colours  

Windows NT 1993 ❖ Designed to act as servers in network. 

Windows 95 1995 ❖ Introduced Start button, the taskbar, Windows Explorer and Start menu.  

❖ Introduced 32 - bit processor.. 

Windows 98 1998 ❖ Internet Explorer with the Operating System.  

❖ Plug and play feature was introduced. 

Windows Me 2000 ❖ It introduced automated system diagnostics and recovery tools. 

Windows 

2000 

 

2000 ❖ Served as an Operating System for business desktop and laptop systems.  

Four versions of Windows 2000 were released:  

1.Professional, 2.Server, 3.Advanced Server 4.Data Centre Server 

Windows XP 2001 ❖ Introduced 64-bit Processor. 

❖ Improved Windows appearance with themes. 
WindowsVista 2006 ❖ Updated the look and feel of Windows. 

Windows 7 2009 ❖ Booting time was improved,  

❖ Introduced Internet Explorer 8 

❖ Introduced new user interfaces like Aero Peek, pinning programs to taskbar, 

handwriting recognition etc.  

Windows 8 2012 ❖ Windows 8 is faster than previous versions of Windows.  

❖ Start button was removed.  

Windows 10 2015 ❖ Start Button was added again.  

❖ Multiple desktop.  
 

3.  Mouse actions:  

1) Click, 2) Right click, 3) Double- click, 4) Drag 5) Drop 

4.  Standard Icons:  

1) My Computer, 2) Documents 3) Recycle Bin. 

5.  Types of icon: 1) Folder Icon, 2) Application Icon 

6.  Disk drive icons:   1) Hard disk, 2) CD-ROM/DVD Drive, 3) Pen drive, 4) Network drives 

                               5) Other removable storage: Mobile, smart phone, tablet etc.,  

7.  Elements of a window: 1.Title Bar, 2.Menu Bar, 3.The Workspace, 4.Scroll bars, 5.Corners and borders 

8.  List out Title bar:   
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1) Minimize, 2) Maximize, 3) Close button 

9.  List out Scroll bars :  

1) Horizontally or vertically 

10.  List out Task bar:  

1) Volume control, 2) Network, 3) Date and time etc. 

 CHAPTER – 6 Introduction to Word Processor 
1.  Tamil Word Processors:  

1.Tamil open office writer, 2.Tamil Libre Office Writer, 3.Kamban 3.0, 4.Mentamizh 2017 

2.  Open Office different packages: 

1. Open Office Writer - Word Processor to create text documents  

2. Open Office Calc - Spreadsheet to create worksheets  3.Open Office Base - Database  

4. Open Office Impress - Presentation software               5.Open Office Draw - Drawing Software  

6.Open Office Formula - Create formula and equations              

3.  Open Office Writer important features: 

1. Templates and styles.         2. Page layout methods, including frames, columns, and tables. 

3. Built-in drawing tools.       4. Export to PDF.        5. Change tracking during revisions. 

6. Embedding or linking of graphics, spreadsheets, and other objects.  

7. Master documents-to group a collection of documents into a single document. 

8. Database integration, including a bibliography database.  

4.  Parts of Writer Window:  

1.Title bar, 2.Menu bar, 3.Standard Toolbar, 4.Formatting Tool bar, 5.Ruler, Work space, 6. Status bar. 

5.  Title bar / Control Buttons:  

(1) minimize, (2) maximize/restore (3) close 

6.  Menu Bar: 

1.File, 2.Edit, 3.View, 4.Insert, 5.Format, 6.Table, 7.Tools, 8.Window, 9.Help 

7.  Tool Bar:   

(1) Standard Toolbar, (2) Formatting Toolbar 

8.  Standard Toolbar :  

1) Cut, 2) Copy, 3) Paste, 4) Undo etc 

9.  Formatting Toolbar:   

1) Bold, 2) Underline, 3) Italics, 4) Font type, 5) Font color etc. 

10.  Ruler:  

(1) Horizontal ruler –Left and right margins,   (2) Vertical ruler - Top and bottom setting. 

11.  Status Bar:  

1) Number of pages, 2) Current page number, 3) Default language etc. 

12.  Tamil Typing Interface:  

1.Using Tamil Font, 2.Using Tamil Interface. 

13.  Selecting Text:  

i) Selecting the continuous text.  ii) Selecting the non-continuous text. 

14.  Changing Case:  

1.Uppercase (Capital letters)  2.toggle case (Reverse case),  

3.Sentence case (First letter of each sentence in capital),  

4.Capitalize every word (First letter of each word in capital), 5.Lower case. (Small letters)  

15.  Paragraph Alignment:  

1.Left - alignment, 2.Right - alignment, 3.Center - alignment, 4.Justify - alignment. 

16.  Indenting text:  1) Left Indent, 2) Right Indent, 3) First Line Indent, 4) Hanging Indent. 

17.  Orientation: 1.Landscape, 2. Portrait 

 CHAPTER -7 Working with Open Office Calc 
1.  Features of Open Office Calc:1.Connecting with Excel, 2.AutoSum, 3.List AutoFill, 4.AutoFill, 5.Charts,6.Functions 7.Database functions 

2.  Parts of the Open Office Calc Window: 

1. Title Bar, 2. Control Buttons, 3. Menu Bar, 4. Tools Bar, 5. Name Box / Address Box,  

6. Quick Function Wizard, 7. Formula Bar / Input Line, 8. Formatting Properties, 9. Zoom,  

10. Scroll bar, 11. Status Bar 

3.  Control Buttons:   

(1) Minimize, (2) Maximize / restore and (3) Close 

4.  Menu Bar: 1) File, 2) Edit, 3) View, 4) Insert, 5) Format,  6) Tools, 7) Data, 8)Window, Help 
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5.  Tools Bar:  

(1) Standard Toolbar (2) Formatting Toolbar (3) Formula bar 

6.  Formula bar:  

Name box, Function Wizard, Sum button, Function button and Input line. 

7.  Scroll bar: (1) Vertical Scrollbar and (2) Horizontal Scrollbar 

8.  Worksheet tabs: sheet tab, four navigation buttons: 

(1) Move to the First sheet (2) Move to the previous sheet (3) Move to Next sheet  

(4) Move to the Last sheet 

9.  Status bar:  

1) Sheets count, 2) Page Style, 3) Selection Mode, 4) Unsaved Changes, 

10.  Selection Mode:  

1) Standard (STD), 2) Extend (EXT) 3) Add (ADD). 

11.  Data types: 

1. Alphabetic data type – Alphabets only, 2.Date data type – Only of date  

3.Time data type – Consists only time, 4.Alphanumeric data types – Alphabets and numerals  

5.Numeric data type – Only of numbers (whole number or fractional numbers)  

12.  Different Date Formats  

Order styles         Countries  

DD/MM/YYYY Asia ,Australia, New Zealand, North Africa, India 

YYYY/MM/DD Bhutan, Canada, China, Koreas, Taiwan, Hungary, Iran, Japan, Lithuania. 

MM/DD/YYYY United States, Federated States of Micronesia, Marshall Islands 

DD/MM/YYYY   

MM/DD/YYYY 

Malaysia, Nigeria, Philippines, Saudi Arabia, Somalia 

DD/MM/YYYY 

YYYY/MM/DD 

Afghanistan, Albania, Austria, Czech Republic, Germany, Kenya, Maldives, 

Namibia, Nepal, Singapore, South Africa, Sri Lanka, Sweden. 
 

13.  Operators:  

1) Arithmetic, 2) Relational 3) Reference 4) Text Operator 

14.  Arithmetic Operators:  

1) Addition, 2) Subtraction, 3) Multiplication, 4) Division etc., 

15.  Relational Operators:  

Greater than, Less than, Equal to etc. 

16.  Reference Operator:  

(1) Range Reference Operator, (2) Range Concatenation (3) Intersection  

17.  When arithmetic operators are used in a formula, Calc calculates the results using the rule of precedence 

followed in Mathematics: 

I. Exponentiation ( ^ ), II. Negation ( - ),   III. Multiplication and Division ( *, /), 

IV. Addition and Subtraction (+, -) 

18.  Generating series using command: 

1.Direction , 2.Series type, 3.Linear, 4.Growth ,5.Date , 6.AutoFill, 7.Time Unit, 8.Start Value, 

9.End Value, 10.Increment, 

19.  Formatting toolbar : 

1.Currency Symbol, 2.Standard, Percent, 3.Add Decimal Place, 4.Delete Decimal Place 

20.  Function Wizard has two tabs: Functions and Shortcuts 

21.  In Calc, the functions are categorized into 11 types: 

1. Database, 2. Date and Time, 3. Financial, 4. Information, 5. Logical, 6. Mathematical,  

7. Array, 8. Statistical, 9. Spreadsheet, 10. Text, 11. Add-in 

22.  Chart wizard dialog box has 4 steps : (1) Chart type (2) Data Range (3) Data Series and (4) Chart Elements. 

23.  Editing Chart elements: 

(i) Double click on the element  (ii) Right click on the selected element  

(iii) Select Format from the popup menu. 

24.  Sorting: (1) Simple Sorting, (2) Multi Sorting, (3) Sort by selection 

25.  Simple Sorting: 

1.Sort Ascending – Arrange data in alphabetical order (A to Z / Small to Large) 

2.Sort Descending – Arrange data in reverse order (Z to A / Large to Small) 

26.  Filtering: 1.AutoFilter, 2.Standard Filter, 3.Advanced Filter. 

 CHAPTER- 8 Presentation Basics 
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1.  Presentation software is used: 

1.Create presentations, 2.Quizzes, 3.E-learning packages, 4.Multimedia products. 

2.  Creating a new presentation: 

1. By selecting an Empty presentation 2. By selecting From template. 

3. By selecting from Open existing presentation 

3.  Parts of the main Impress window:  

1.The Slides pane, 2.The Workspace, 3.The Task pane. 

4.  Window elements of Impress:  

1.Title Bar, 2.Menu Bar, 3.Tool Bar, 4.Ruler Bar 5.Scroll Bar 

5.  View Buttons: The Workspace has five tabs:  

1.Normal, 2.Outline, 3.Notes, 4.Handout, 5.Slide Sorter 

6.  Outline view serves for two purposes: 

1.Making changes in the text of a slide. 2.Comparing the slides with your outline 

7.  Master slides in two styles:   

1. Slide Master, 2. Notes Master 

8.  The Drawing toolbar: 

1.Select,  2.Line, 3.Arrow, 4.Rectangle, 4.Ellipse, 5.Text, 6.Vertical text, 7.Curve,8.Connectors 

 CHAPTER- 9 Introduction to Internet and Email 
1.  Examples of few  internet services : 

1.Email 2.Online movies and gaming 3.Instant messaging 4.Internet forums 5.Social networking 

6.Online shopping 7.Financial services 8.Web-enabled audio/video conferencing services 

2.  Domain Name: 

I.Generic top level domain: 

1..com - Commercial Organisation, 2..gov- Government institution 

3..org- Non-profit Organisation,. 4.net- Network Support Group 5..edu - Educational Institution 

II.Country Level Domain Name: 

1) .in- India 2) .au- Australia 3).us- United States of America,  4) .jp- Japan 5).ru – Russia 6).sg- Singapore 

3.  URL 4 parts:     

1.Protocol, 2)Sub domain 3) Domain name 4) Top level domain 

4.  Types of Internet Service:  

1) Wireless 2) Mobile 3) Hotspots 4) Broadband 5) DSL 6) Cable 7)  Satellite 8) ISDN 

5.  USB Dongles: 

1.WiFi Dongles 2.BlueTooth Dongle 3.Memory Dongle 

6.  Types of data card :  

1.Expansion Card 2.Memory Card or Flash Card 3.Identification Card 

7.  Internet Connection and Access Methods:  

1.Indirect Access,  2.Direct Access 

8.  Types of network: 

1.Internet - Email, Social networking, Online shopping, Financial services 

2.Intranet - Policies, procedures, staff, directory, department 

3.Extanet- Suppliers, vendors, partners, customers, or other businesses 

9.  Examples of popular search engines : 

1.Yahoo, 2.Lycos, 3.Altavista, 4.Hotbot, 5.Google, 6.Askjeeves. 

10.  Most popular web browsers :   

1.Internet Explorer, 2.Chrome, 3.Firefox, 4.Safari  

11.  Internet Applications: 

1. Internet telephony using VoIP (Voice-over-Internet Protocol) Example Skype,  

2. Job search  3. Online Shopping  4. Stock market updates  5. Travel  6. Research 

7. Video conferencing  8. e –commerce  9. Online payments 10. Social Networking   

11. Voicemail  12. Chatting 13. e-banking 14. e-learning 

12.  Benefits of E-governance 

1.Reduced corruption 2.High transparency 3.Increased convenience 4.Reduction in overall cost. 

5.Expanded reach of government 

13.  Structure of email:Compose button, To , From , Subject , CC (Carbon Copy) , BCC  , Message Body  

14.  Advantages of email: 
1.Free delivery , 2.Global delivery , 3.Instant delivery, 4.File attachment,5.Long-term storage , 6.Environmentally friendly  
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15.  Internet Threat:  

1. Computer virus, 2. Malware 3. Trojan horse 4.  Malicious spyware, 5. Computer worm,  

6. Botnet 7. Spam,8.Phishing,9.Rootkit 

16.  Familiar Internet Browser: 

1.Google Chrome, 2.Mozila Firefox, 3.Internet Explorer, 4.Safari  

17.  Webpage:  

❖ Home, About Us, Contact Us, Testimonials, Products, Services, FAQ’s,  

18.  Web pages are classified:  

❖ Static and Dynamic Webpages 

19.  Do’s and don’t of safe Surfing on Internet: 

1.Don’t give out your personal information 2.What goes online, stays online  

3. Check your security and privacy settings 4. Password safety 

5. Always protect your mobile device          6. Don’t talk to strangers online or offline  

7. Listen to the adults who know                  8. Be wary of unsecured or unknown websites  

9. Be careful what links you click on  

20.  Two things required for TCP/IP needed are  

a) Message to transmit  b) Means to reliably transmit the message 

21.  Social networking:  

1) Friends, 2) Family, 3) Classmates, 4)Customers 5) Clients. 

 CHAPTER- 10 HTML - Structural Tags 
1.  Structural Tags of HTML:   

<html>, <head>, <title> and <body> 

2.  Attributes for Structural Tags: 

1. Attributes of <html> tag,  2. Attributes of <body> tag 

3.  <html> tag has two attributes:  

dir and lang 

4.  Attributes of <body> tag: 

(i) Background Colour: bgcolor = color         (ii) Body text Colour: text = color 

(iii) Background image: background=image  (iv) Setting Margins: margin = value 

5.  Headings:  

❖ HTML has six levels of headings viz. <h1> to <h6>. 

6.  Four paragraph alignments:  

❖ Left, Right, Center and Justify 

7.  The HTML elements (Tags):  

(1) Container elements (2) Empty elements. 

8.  Container elements example:   

<html>, <body>, <title>, <p> etc. 

9.  Empty elements example: <br> 

10.  Web document has two sections:  

Heading Section and Body Section 

 CHAPTER- 11 HTML - Formatting text, Creating Tables, List and Links 
1.  Text Formatting Tags of HTML: 

1.Bold, 2.Italic, 3.Underline, 4.Changing 5.Font style, 6.Font size, 7.Font color and more. 

2.  Comparison of tags:  <b> and <strong>, <i> and <em>, <u> and <ins> and so on 

3.  <hr> tag having four attributes:  

❖ Size, width, noshade and color 

4.  Tags to create table elements: 

1. <table> tag - create a table.  2. <tr> tag - table rows  3. <th> tag - table columns 

4. <td> tag - data in a cell        5. <caption> tag - title for the table. 

5.  Attributes of table: 

1. Cellspacing, 2. Cellpadding, 3. Border 4. Bordercolor 5. Align 6.BGcolor 7. Height and Width 

6.  Attributes of <TD>, <TH> and <TR> tags: 

1. Align 2. VAlign 3. Width 4. BGcolor and Background 5. Rowspan and Colspan 

7.  Lists in HTML: 1. Numbered List / Ordered List,  2. Un-numbered List / Unordered List 

8.  Attributes of Ordered List:  

(1) Type - changing numbering style (2) Start - changing numbering order. 

9.  Attribute of Unordered List: 

1. Disc- A solid circle, 2. Square-  A solid square, 3. Circle- O An unfilled circle 

10.  Definition List:  
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(1) A definition term,  (2) The definition description 

11.  Two important things needs to create a link in HTML: 

(1) The name of the file or URL to which you want to link  

(2) The text that will serve as the clickable link. 

12.   <font> tag is used:  

Change the style, size and color of text. 

13.  Physical Style tags:  

<b> - bold    <i>- italic   <u>- underline  

 CHAPTER- 12 HTML - Adding multimedia elements and Forms 

1.  Most of the browsers supports image formats:   

1) GIF, 2) JPEG 3) PNG  

2.  Image editing applications:  

1) Photoshop, 2) Picasa, 3) GIMP. 

3.  Familiar Image Formats: 

1. GIF (Graphical Interchange Format), 2. JPEG (Joint Photographic Experts Group),  

3. PNG (Portable Network Graphics),    4. SVG (Scalable Vector Graphics),  

4.  Other Attributes of <img> tag: 

1. Alt (Alternative Text), 2. Width and Height, 3.Vspace and Hspace , 4. Align,  

5. Left and Right values of Align attribute. 

5.  Attributes of <marquee> 

1. Height and Width, 2. Direction, 3. Behaviour, 4. Scrolldelay, 5.  Scrollamount, 6. Loop,  

7. Bgcolor, 8. Hspace and Vspace  

6.  Form elements:  

1.Text boxes, 2.Radio buttons, 3.Check boxes, 4.Buttons 5.Drop-down lists. 

7.  Forms are commonly used:  

❖ Allow users to register on a Web site, to log in to a Web site, to order a product, and to send feedback 

8.  Attributes frequently used with <form> tag:  

1. Method and action attributes. 

9.  Action:  Common Gateway Interface (CGI) program written in programming languages: 

1.Perl, 2.JavaScript, 3.PHP or Active Server Pages (ASP). 

10.  Form Controls: 

1.Text box, 2.Password, 3.Checkbox, 4.Radio buttons, 5.Text area, 6.Select box, 7.Submit 8.Reset Button. 

11.  <Input> Tag:  

1.Text box, 2.Radio buttons 

12.  Attributes of <input> tag:  

1. Type, 2. Name, 3. Value, 4. Size, 5. Max length 

13.  Value of type attribute:  

1. Text, 2. Password, 3. Checkbox, 4. Radio Button 5. Reset, 6. Submit, 7. Button 

14.  Attributes of <Select> tag:  

1.Name  2.Size  3.Multiple  

15.  Attributes of <Option> tag:  

1.Selected 2.Value  

16.  The main attributes of <Text area>   

1.Name 2.Rows 3.Cols  

 CHAPTER- 13 CSS - Cascading Style Sheets 

1.  Advantages of CSS:  

1. Maintainability, 2. Reusability, 3. Easy to understand 

 CHAPTER- 14 Introduction to Java script 

1.  Basic Data types and Declaring variables:  

1. A string, 2. Numbers, 3. Boolean  

2.  Scope of variables:  

1.Global 2.Local scope 

3.  Assigning values to variables 

1. var numericData1 = 522;  2.var stringData = "JavaScript has strings\n It sure does";  

3. var numericData = 3.14;   4.var booleanData = true; 

4.  JavaScript Literals:  1.Integer, 2.Floating point, 3.Character, 4.String 5.Boolean 

5.  JavaScript Literals examples: 

1. var int_const=250; //Integer constant//   2.var float_const=250.85; //Floating point constant//  

3. var char_const=’A’; //Character constant//  4.var string_const=”Raman”; //String constant//  

5. var boolean_const=true; //Boolean constant// 

6.  Type casting in JavaScript:  1.Implicit casting 2.Explicit casting  
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7.  Operators :  1.Arithmetic expressions, 2.Comparison expressions, 3.Logical expressions, 4.Assignment 

8.  Arithmetic Operators: 

1.Addition (+), 2.Subtraction (–), 3.Multiplication (*), 4.Division (/), 5.Modulus (%, 

9.  JavaScript supports some shorthand arithmetic operators:  +=, -=, *=, /= and %= 

10.  Relational or Comparison Operators: 

1. == (equal to), 2. != (not equal to),  3. < (less than),  4. > (greater than),  

5. <= (less than or equal to), 6.  >= (greater than or equal to). 

11.  Logical Operators:  1) && (AND), 2) || (OR) and 3) ! (NOT 

12.  JavaScript Popup or Dialog Boxes:  1) Alert box, 2) Confirm box, 3) Prompt box. 

13.  Comments in JavaScript:  1) Single line, 2) Multiple lines comments 

 CHAPTER- 15 Control Structure in Java script 
1.  Conditional Statements in JavaScript: 1.Branching / Selection 2.Looping / repetitive 

2.  Branching Statements: 1.if statement, 2.if … else statement, 3.else if statement,4. switch statement 

3.  Looping / repetitive: 1.for loop, 2.while loop,  3.do..while loop 

 CHAPTER- 16 JavaScript Functions 
1.  JavaScript supports two types functions:1.Pre-defined or Library Functions, 2.User-defined Functions 

2.  Pre-defined functions examples: isNaN(), toUpperCase(), toLowerCase(), length(), alert(), prompt(),write() 

 CHAPTER – 17 Computer Ethics and Cyber Security 
1.  Types of cyber – crimes:  

1.PHISHING, 2.VIRUSES,3.HACKING,4.PIRACY, 5.IDENTITY THEFTS, 

6. PHARMING, 7.ONLINE FINANCIAL TRANSACTIONS 

2.  ETHICS:  

1.Do not use pirated software,2.Do not use unauthorized user accounts 

3.Do not steal others’ passwords,,4.Do not hack  

3.  GUIDELINES OF ETHICS: 

1.Honesty, 2.Confidentiality, 3.Respect, 4.Professionalism, 5.Obey The Law, 6.Responsibility  

4.  Common ethical issues : 

1.Cyber crime, 2.Software Piracy 3.Unauthorized Access 4.Hacking  

5.Use of computers to commit fraud 6.Sabotage in the form of viruses  

7.Making false claims using computers 

5.  Computer Crime: 

1.Cyber Terrorism, 2.Cyber stalking, 3.Malware, 4.Denial of service attack, 5.Fraud, 6.Harvesting, 7.Identity theft, 8.Intellectual 

property theft, 9.Salami slicing, Scam, 10Spam, 11.Spoofing 

6.  SOFTWARE PIRACY:  1.Duplicating and selling copyrighted programs  2.Downloading software illegally through network 

7.  PHISHING:  

1.Users should always be cautious when opening emails or attachments 

2.This can lead to fraud or identity theft 

8.  PHARMING : 

1.Users should always be cautious when redirected to a fake site. 2.This can lead to fraud or identity theft 

 CHAPTER – 18 Tamil Computing 
1.  Searching facilities in Tamil: Google and Bing  

2.  Familiar Tamil Keyboard Interface: 

❖ Familiar Tamil keyboard: 1) NHM Writer, 2) E-Kalappai 3) Lippikar 

❖ Familiar Tamil keyboard layouts: 1) Sellinam 2) Ponmadal  

3.  Tamil Office Automation Applications : Microsoft Office, Open Office etc., 

4.  Tamil Information Interchange Coding Systems: 

1) TSCII (Tamil Script Code for Information Interchange) 

2) ISCII (Indian Script Code for Information Interchange) 3.Unicode 

5.  Organisation and projects to develop Tamil: 

1) Tamil Virtual Academy 2) Tamil Language Council, Singapore  3) Madurai Project  4) Tamil Wikipedia  
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     CHAPTER 1 TO 18 TWO MARK BOOK BACK & public QUESTION with ANSWERS 
 CHAPTER – 1 Introduction to Computers 
1. What is a computer? [M-2019]                                                                       

❖ It is an electronic device that processes the input according to the set of instructions provided to it and gives 

the desired output at a very fast rate. 

2. Distinguish between data and information. [M-2023] 

Data Information 

❖ Data is defined as an unprocessed collection of raw 

facts, suitable for communication, interpretation or 

processing.  

❖ Information is a collection of facts from 

which conclusions may be drawn. 

❖ It do not convey any meanings ❖ It conveys some meaning 

❖ Eg: 134,16, ‘kavitha’  ❖ Kavitha is 16 years old. 
 

3. What are the components of a CPU? [S-2022, J-2023, J-2024] 

❖ The CPU has three components which are , 

❖ Control unit, Arithmetic and logic unit (ALU) and Memory unit. 

4. What is the function of an ALU?  [J-2019, M-2022] 

❖ The ALU is a part of the CPU where various computing functions are performed on data.  
❖ The ALU performs arithmetic operations such as addition, subtraction, multiplication, division and logical operations.  

5. Write the functions of control unit. [M-2024] 

❖ The control unit controls the flow of data between the CPU, memory and I/O devices.  

❖ It also controls the entire operation of a computer. 

6. What is the function of memory?  

❖ The Memory Unit is of two types: Primary memory and Secondary memory.  

❖ The primary memory is used store the data temporarily store the programs and data when the instructions are 

ready to execute. 

❖ The secondary memory is used to store the data permanently. 

7. Differentiate Input and output unit. 

                Input unit                  Output unit 

❖ Input unit is used to feed any form of data to the 

computer, which can be stored in the memory 

unit for further processing. 

❖ An Output Unit is any hardware component that 

conveys information to users in an understandable 

form  

❖ Example: Keyboard, mouse, etc.  ❖ Example: Monitor, Printer etc.  
 

8. Distinguish Primary and Secondary memory. 

           Primary memory              Secondary memory 

❖ The primary memory is used temporarily store 

the programs and data when the instructions are 

ready to execute.   

❖ The Secondary memory is used to store the data 

permanently. 

❖ The Primary Memory is volatile, that is, the 

content is lost when the power supply is switched 

off. 

❖ The Secondary memory is non-volatile, that is, 

the content is available even after the power 

supply is switched off. 

❖ Ex : RAM ❖ Ex: Hard Disk, DVD ROM, CD-ROM 
 

 CHAPTER – 2 Number Systems 
1. What is data?                                                                             

❖ The term data comes from the word datum, which means a raw fact.  

❖ The data is a fact about people, places or some objects. 

2. Write the 1’s complement procedure.                                                  Example: 

Step 1: Convert given Decimal number into Binary                               46 is       = 1011102 

Step 2: Check if the binary number contains 8 bits.                                8bit        = 001011102  

             If less add 0 at the left most bit, to make it as 8 bits.                  1s           = 110100012 

Step 3: Invert all bits (i.e. Change 1 as 0 and 0 as 1) 

3. Convert  (46)10  into equivalent binary number  [M-2024] 

 2 46      LSB 

2  23-0           (46)10  = (101110)2 

2  11-1 

2  5-1  

2  2-1 

    1-0     MSB 

4. We cannot find 1’s complement for (28)10. State reason.  

❖ Reason: We cannot find 1’s complement for (28)10 .Because it is a positive number. 

❖ The 1’s complement method is applicable only to negative numbers. 
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5. List the encoding systems for characters in memory.  

1. BCD – Binary Coded Decimal   2. EBCDIC – Extended Binary Coded Decimal Interchange Code 

3. ASCII – American Standard Code for Information Interchange   4. Unicode 

5. ISCII - Indian Standard Code for Information Interchange. 

1. 11.0112 Binary to decimal equivalent  [M-2020] 

(11)2 = 3          21  20    . 2-1    2-2   2-3                                                    =3+ .( 0x0.5+1x0.25+1x0.125 ) 

                                                                                                    (0       + 0.25   +0.125) 

                       1    1     .  0     1     1                                   

                                                                           (11.011)2 = (3.375)10 

2. Convert (65)10 into Binary number  [S-2021, M-2022] 

2  65      LSB 

2  32-1           (46)10  = (1000001)2 

2  16-0 

2  8-0 

2  4-0 

    2-0     

    1-0     MSB 

3. What is meant by signed magnitude? [M-2023] 

❖ The simplest method to represent negative binary numbers is called Signed Magnitude. 

4. Convert  (1560)8  into equivalent Decimal number  [J-2023] 

Weight 512 64 8 1 

Positional 

Notation 

83 82 81 80 

Given  

number 

1 5 6 0 

(1560)8 = 512x1+64x5+8x6+1x5 

             = 512+320+48+0 

(1560)8 = (880)10 

5. Convert (150)10 into Binary number  [J-2024]                                                                                

2  150        (150)10 = (10010110)2 

2  75-0                                                    

2  37-1                                                                   

2  18-1                                                            

2  9-0                                                              

2  4-1 

2  2-0          

    1-0                          

 CHAPTER – 3 Computer Organization 
1. What are the parameters which influence the characteristics of a microprocessor?                                                                                        

❖ 1.Clock speed      2.Instruction set   3.Word size 

2. What is an instruction? [M-2019] 

❖ A command which is given to a computer to perform an operation on data is called an instruction. 

3. What is a program counter?  [M-2019, S-2020, M-2023] 

❖ The Program Counter (PC) is a special register in the CPU which always keeps the address of the next 

instruction to be executed. 

4. What is HDMI? [S-2020] 

❖ High-Definition Multimedia Interface is an audio/video interface transfers the uncompressed video and audio 

data from a video controller, to a compatible computer monitor, LCD projector, digital television etc. 

5. Which source is used to erase the content of an EPROM? [S-2021, J-2024] 

❖ Ultra violet light is used to erase the content of a EPROM. 

❖ EPROM retains its contents until it is exposed to ultraviolet light.  

❖ The ultraviolet light clears its contents, making it possible to reprogram the memory. 

1. What is an instruction set? [AUG-2022] 

Basic set of machine level instructions that a microprocessor is designed to execute is called as an instruction set. 

2. What is Bus? [J-2019] 

❖ A bus is a collection of wires used for communication between the internal components of a computer. 

 CHAPTER – 4 Theoretical Concepts of Operating System 
1. List out any two uses of Operating System?                                            

1. To ensure that a computer can be used to extract what the user wants it do. 

2. Easy interaction between the users and computers. 3.Controlling Input and Output Devices  

4. Providing security to user programs. 
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2. What is the multi-user Operating system?  [M-2019, M-2023] 

❖ It is used in computers and laptops that allow same data and applications to be accessed by multiple users at 

the same time.  

❖ The users can also communicate with each other. Example : Windows, Linux and UNIX  

3. What is a GUI? [J-2019, S-2021, M-2023] 

❖ The GUI is a window based system with a pointing device to direct I/O, choose from menus, selections and a 

keyboard to enter text. 

❖ Its vibrant colours attract the user very easily. 

4. What are the security management features available in Operating System? [S-2022, J-2024] 

❖ The Operating System provides three levels of securities to the user end.  

❖ They are, 1.File access level, , 3.Network level  

1. File access level: Permissions can either be granted by the creator of the file or by the administrator of the system.  

2. System level: System level security is offered by the password in a multi-user environment. 

3. Network level: Network security is an indefinable one. So people from all over the world try to provide such a security. 

5. What is multi-processing?  

❖ This is a one of the features of Operating System.  

❖ It has two or more processors for a single running process (job).  

❖ Processing takes place in parallel is known as parallel processing. 

❖ Since the execution takes place in parallel, this feature is used for high speed execution which increases the 

power of computing. 

6. What are the different Operating Systems used in computer? [M-2024] 

❖ Operating system used personal computers and laptops are Windows, UNIX and Linux. 

1. Name some popular operating system used in personal computer and mobile devices. [M-2022] 

1.Personal computer O.S – Windows, Linux, Unix  2.Mobile O.S – Android, Ios 

2. What are the security management levels available in Operating System? [S-2020] 

1. File access level  2.System level 3.Network level 

3. Define software and mention its types [AUG-2022] 

❖ A software is set of instructions that perform specific task.  

❖ It interacts basically with the hardware to generate the desired output. 

❖ Software is classified into two types: 1) Application Software 2) System Software 

 CHAPTER – 5 Working with Windows Operating System 
1. What is known as Multitasking?   (J-2023)                                                          

❖ Multiple applications can execute simultaneously in Windows, and this is known as “Multitasking”. 

2. What are called standard icons (M-2022) 

❖ The icons which are available on desktop by default while installing Windows OS are called standard icons.  

❖ The standard icons available in all Windows OS are My Computer, Documents and Recycle Bin. 

3. Differentiate Files and Folders. (AUG-2022) 

                   Files              Folders 

❖ All types of information are stored in the 

form of files in the computer 

❖ Folders are containers of files that is used to organize 

files. 

❖ A file consists of a collection of data. ❖ A folders stores and folders. It also called a directory. 

❖ Each file has its own extension ❖ A folder does not have any extension. 
❖ Folder and sub folders cannot be created in a file.  ❖ Folder and sub folders cannot be created in a file. 

 

4. Differentiate Save and save As option. 

Save Save As 
❖ Save command is used to save a file for the first time. ❖ Folders are containers of files that is used to 

organize files. 

❖ “Save” command is used to save a document by 

only one name 

❖ “Save As” command can save a file by two or 

more than two names. 

❖ Shortcut key : Ctrl+S ❖ Shortcut key : Ctrl+Shift+S 
 

5. How will you Rename a File? (S-2022)(M-2023) 

1. Select the File or Folder you wish to Rename. 2. Click File→ Rename. 

3. Type in the new name.  4. To finalise the renaming operation, press Enter as in Folder. 

Rename,Using the  File  menu, Using Right mouse button, Using left mouse button. 

1. What is open source? (M-2019) 

❖ Open source refers to a program or software in which the source code is available in the web to the general 

public free of cost. 

 CHAPTER – 6 Introduction to Word Processor 

1. How do you insert pictures in to your document?  (S-2021)                                

❖ Place the insertion pointer where you want the image to appear 

❖ Select Insert → Picture → From file 
❖ The insert picture dialog box appears where the picture gallery opens from which the desired picture can be selected. 
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❖ If the picture is not in the gallery, then browse the pictures from the folder, choose the desired picture. 

❖ Click on the Open button 

❖ The selected picture is inserted into the document. 

2. What are the different packages in Open Office writer? (S-2020) 

1.OpenOffice Writer    - Word Processor to create text documents  

2. OpenOffice Calc       - Spreadsheet to create worksheets  3.OpenOffice Base       - Database  

4. Open Office Impress - Presentation software                    5.OpenOffice Draw      - Drawing Software  

6. OpenOffice Formula - Create formula and equations. 

3. What is auto text in writer?  (S-2021)  

❖ AutoText allows you to assign text, tables, graphics and other items to a key or key combination.  
❖ For example, rather than typing “TamilNadu” every time you use that phrase, you might just type “tn” and press F3. 

❖ You can also save a formatted Tip as AutoText and then insert a copy by typing "tip" and pressing F3. 

4. How will you merge cells in a table? (J-2023) 

To merge a group of cells: 

1. Select the cells to merge. 

2. Right click and choose Cell → Merge or choose Table → Merge Cells from the menu bar. 

5. State the differences between proprietary software and open source software.  [M-2024] 

Proprietary software Open source software 

❖ Users must have to pay to get the proprietary software ❖ Users can get open source software free of cost. 
❖ Ex: Ms-office, Photoshop ❖ Ex: Libre office, python 

 

Proprietary software Open source software 

Package Developer Package Developer 

Microsoft Word Microsoft Corporation OpenOffice Writer Apache 

WPS Word King soft LibreOffice Writer The document foundation 

WordPro Lotus Corporation Abiword Abi source 
 

1 Write about short cut keys for LEFT,RIGHT, CENTER AND JUSTIFIED alignments. (M-2019) 

1.LEFT       -  Ctrl +L    2.RIGHT        –   Ctrl +R  3.CENTER -   Ctrl +E   4.JUSTIFIED -    Ctrl +J 

2. What is word wrap? (M-2020) 

❖ When the text reaches the end of the line, the word is automatically wrapped to the next line. 

❖ This is feature is my word processor is known as word wrap. 

3. What are the different types of data? (M-2020) 

1. Alphabetic data type 2.Numeric data type 3. Alphanumeric data type 4. Date data type 5.Time data type. 

 CHAPTER -7 Working with Open Office Calc 

1. What are the types of toolbars available in Open Office calc?    (S-2022)          

❖ There are three toolbars available by default.  

❖ They are: (1) Standard Toolbar (2) Formatting Toolbar (3) Formula bar 

2. What is a Cell pointer?  (M-2019)(S-2021)(M-2023) 

❖ Cell pointer is a rectangle box which can be moved around the worksheet.  

❖ The call in which the cell pointer is currently located is known as “Active cell” 

3. Write about the text operator in Open Office Calc. (J-2023, J-2024) 

❖ In Calc, “&” is a text operator which is used to combine two or more text. Joining two different texts is also 

known as “Text Concatenation”  

❖ Syntax: text reference 1 & text reference 2   Example:       =A1 & B1 

4. Write the general syntax of constructing a formula in Calc.  

❖ Formula:     = cell reference1 <operator> cell reference2 <operator> …... 

❖ Example:      =A1+B1*5   

5. What are the keyboard shortcuts to cut, copy and paste?  

1.Ctrl+x – Cut the cell; 2.Ctrl+C- Copy the cell ; 3.Ctrl+V  - Paste the cell 

6. Can you edit the contents of a cell? If yes, explain any one of the method of editing the cell content. 

❖ Yes we can edit the content of the cell. 

❖ Place the cell pointer in the cell and type the new data which replaces the old data. 

❖ Click the formula bar or press F2 key, then use the backspace key to delete unwanted and type the required one 

7. What are the options available in “Insert Cells” dialog box? 

❖ 1. Shift cells down 2. Shift cells right 3. Entire row 4. Entire column. 

8. Match the following 

A B Answer 

(a) Cut, Copy and Paste (1) Absolute Cell  Standard Toolbar 

(b) Cell pointer (2) Status bar  Active cell 

(c) Selection Mode (3) Standard Toolbar   Status bar 

(d) $A5$ (4) Active cell  Absolute Cell 
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9. Define the following (i) Text Operator (ii) Rows and Columns of spreadsheet 

i) Text Operator: 

❖ In Calc, “&” is a text operator which is used to combine two or more text. 

❖ Joining two different texts is also known as “Text Concatenation”  

❖ An expression using the text operator has the following syntax: text reference1 & text reference2 

ii) Rows and Columns of spreadsheet: 

❖ A row is a horizontal group of values within a table.  

❖ It contains values for multiple fields, which are defined by columns.  

❖ The rows are numbered from 1, 2, 3 

10 Differentiate between Copy -Paste and Cut-Paste. 

Copy –Paste Cut-Paste. 

❖ Copy leaves the cell information in its original 

location and makes copy of the cell information 

when pasted it. 

❖ But in moving it remove the information and paste 

it in another location. 

❖ Edit → Copy and  Edit → Paste ❖ Edit → Cut and Edit → Paste 
 

1. What are the different types of data? (M-2020) 

1.Alphabetic 2.Numeric 3.Alphanumeric 4. Date data type 5. Time data time 

2. What are the Backspace key and delete key functions in open office writer? (J-2019) 

Deleting data using Backspace Deleting data using Delete key. 

Backspace key is used to delete the character left of 

the insertion pointer of the cell. 

Delete key is used to delete the character right of the 

insertion pointer of the cell. 
 

3. Write the formula to find the sum of the contents of the cells A1,A2 and A3 in a worksheet (J-2019) 

Ans:       =A1+A2+A3 (Add the values in cells A1,A2 and A3) 

 CHAPTER- 8 Presentation Basics 

1. What is the difference between a slide and a slide show?                      

                     Slide               Slide Show 

❖ A slide is an editable format that contains different 

element like text, tables, charts, clip- art etc. 

❖ A slide show is a combination of a number of slides 

that run one after the other. 
 

2. How many in-built slide layouts does impress consist of?  

❖ Open office impress consist of 12 different in-built slide layouts. 

3. What do you understand by a presentation? (M-2022) 

❖ A presentation software is a computer software package used to show information, in the form of a slide show. 

❖ Each slide uses a variety of multimedia elements that grabs the viewer’s attention and retains it. 

4. Define a template in Impress. [M-2024] 

❖ Design already created as the basis for a new presentation 
❖ Premade design used to create a new presentation. 

5. What do you understand by the slide layout? 

❖ Slide layout are pre-packaged layout which contain formatting, positioning, and place holders for all of the 

content that appears on a slide. 

❖ Placeholders are the containers in layout that hold such content as text, tables, chats, smart Art, graphics, 

movies, sound, pictures, and clip art. 

1. Define Slide transition (M-2020) 

❖ A slide transition is the visual effect that occurs when you move from one slide to the next during presentation. 

❖ Transitions are available, including No Transition.  

❖ You can select the transition speed (slow, medium, fast)  

❖ You can also choose between an automatic or manual transition. 

2. What is presentation software? (S-2020) 

❖ A presentation software is a computer software package used to show information, in the form of a slide show. 

3. What is use of slide sorter view in impress? (J-2019) 

❖ The Slide Sorter view contains all of the slide thumbnails.  

❖ Use this view to work with a group of slides or with only one slide. 

Change the number of slides per row, if desired: 

❖ Check View → Toolbars → Slide View to show the Slide view toolbar. 

❖ Adjust the number of slides (up to a maximum of 15). 
❖ After you have adjusted the number of slides per row, View → Toolbars → Slide View will remove this toolbar from view 

 CHAPTER- 9 Introduction to Internet and Email 

1. Name the two important protocols for internet? 

1) Transmission  Control Protocol – TCP  2) Internet Protocol – IC 
2. What is a network? (M-2023) 

❖ A network is a collection of interconnected devices (such as computers, printers, etc.). 

❖ Several networks are connected together to from a global network is called the internet. 
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3. What is the role of ICANN?  
❖ Internet Corporation for Assigned Names and Numbers (ICANN) administers the domain name registration.  

❖ It helps to avoid a name already registered. 

4. What is a search engine?  

❖ A search engine is a software system that is designed to search for information on the World Wide Web. 

Examples: Google, Yahoo and Bing etc. 

5. What is a browser?  

❖ A browser is used to access websites and web pages. 

❖ To browse the internet, software called the web browser or browser.  

Example :  Internet Explorer, google Chrome, Firefox, Safari, 

6. What are the components of URL   addressing? 

URL: Uniform Resource Locator ex: http://www.google.com 

1.Protocol                         :http://       2.Subdomain                    :www. 

3.domain                          :google      4.top level domain(TLD)  : com 

7. What is a website? 

❖ 1. A website is a collection of web pages.   2.A webpage is a page of a website 

❖ 3. The first page of the website is called a Home Page. 

❖ 4. All of these pages together make up a Website. 

8. What is CC and BCC in an email? (M-2022)  

❖ The CC (Carbon Copy) field allows you to specify recipients who are not direct addressees  

❖ The BCC (Blind Carbon Copy) field is similar to CC, except the recipients are secret. 

❖ Each BCC recipient will receive the e-mail, but will not see who else received a copy. 

9. What is a Static web Page?  

❖ Web pages are called Static websites as they remain the same whenever it is visited.  

❖ Examples of static Websites are website owned by Small business organizations, School websites etc. 

10 What is a Dynamic web page? 

❖ Dynamic web page content and layout may change during run time. 

❖ Database use to generate dynamic content through queries. 

❖ Such websites are called dynamic webpage.Ex: Websites of Government and Entrance Exams. 

11 What are the benefits of e-governance?  

1.Reduced corruption  2.High transparency 3.Increased convenience 

4. Reduction in overall cost.    5.Expanded reach of government 

12 What is Phishing? 

❖ Phishing scams are fraudulent attempts by cybercriminals to obtain private information.  

❖ Phishing scams often appear in the guise of email messages designed to appear as though they are from 

legitimate sources. 

 CHAPTER- 10 HTML - Structural Tags 

1. Sandhiya is creating a webpage. She is entering HTML code on her    computer. In between, she keeps 

pressing “Refresh” / “Reload” button on her browser. What is the purpose?   

❖ You may want to preview the changes she has made to the web pages. 

❖ To do this, he can open the webpage in a browser and press the REFRESH / RELOAD button. 

❖ By pressing the F5 key (REFRESH / RELOAD button) the webpage it will display the latest version of the 

webpage with the changes he has made. 

2. Explain with the help of an example the difference between container and empty elements of HTML. (M-2019) (M-2020) 

Container Elements Empty  Elements 

❖ The tags which are required opening and closing 

is known as container elements or tags.  

❖ Ex : <html>, <body>, <title>, <p>  

❖ The tags which are required only opening tag is 

known as empty elements or tags.  

❖ Ex:   <br>, <hr> 
 

3. What is the wrong in the following coding?      Correct code 

<html>                                                                   <html> 

<my web page>                                                     <head> 

<title> Welcome to my web page                         <title> My web page </title> 

</head>                                                                   </head> 

</title>                                                                     <body>   

                                                                                          Welcome to my web page  

                                                                                 </body>  

                                                                                 </html> 

4. How do you define comments in HTML? (J-2019)(S-2020) (J-2023) 

❖ Comments are used to describe the page or provide some kind of indication of the status of the page.  

❖ The tag <!> is used to create comments.  

Syntax:      <! comments > 

Example:  < !This is my first my web side about my college> 

❖ In HTML, the text what you type within this tag is considered as comments and it is ignored by the browser 
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5. How do you include an image as your web page background?  

❖ Using <body tag, you can set the image as the background of the web browser. 

Syntax: 

<body background = “image_name_with_extenstion”> 

Example:  

<body background = “flower01.gif”> 

❖ If your image file name is long or split as two more words or along with path, should be specified within 

double quotes. 

1. Write an attribute of heading tag with example (M-2020) 

❖ Headings are used to include titles to sections of a web page.  

❖ HTML has six levels of headings viz. <h1> to <h6>. 

Syntax:    <h…> Heading text </h…> 

Example: 

<html>  

<head>  

<title> Heading </title> 

</head> 

<body>  

<h1> Welcome to Computer Application</h1>  (to) 

<h6> Welcome to Computer Application</h6> 

</body> 

</html> 

2 Write the output of the following HTML code.  (J-2019) 

<HTML>                               OUTPUT 

<BODY>                                 LAN 

<UL>                                       MAN 

   <LI> LAN                            WAN 

   <LI> MAN 

   <LI> WAN 

   </UL> 

</BODY> 

</HTML> 

3. Write the output of the following HTML code.  (M-2019) 

<HTML>                               OUTPUT 

<BODY>                                 KEY BOARD 

<OL>                                       MONITOR 

   <LI> KEY BOARD              SPEAKER 

   <LI> MONITOR 

   <LI> SPEAKER 

   </OL> 

</BODY> 

</HTML> 

4. Write the output of the following HTML code.  (J-2024) 

<html>                                                                                    OUTPUT 

<head>                                                                                    Tamil 

<title> Number List </title>                                                   Telugu 

</head>                                                                                   English 

<body>                                                                                    Computer Applications                           

<OL>                                                                                       Commerce                     

   <LI> Tamil                                                                           Accountancy                                                

   <LI> Telugu                                                                          Economics 

   <LI> English                                                                          

   <LI> Computer Applications 

   <LI> Commerce 

   <LI> Accountancy 

   <LI> Economics 

</OL> 

</body> 

</html> 
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 CHAPTER- 11 HTML - Formatting text, Creating Tables, List and Links 

1. Write a short note on    (i) <strong>    (ii) <em> (J-2019)(J-2023)(M-2020)(M-2023)                 
<strong> Important text : 

1. The <strong> tag is a phrase tag. 2. It is used to define important text by displaying text as bold. 

Ex: <strong> Computer Applications </strong>      Output: Computer Applications 

<em> - Emphasized text: 

1. The <em> tag is used to emphasize the text.  2. That means, when you use this tag, the text will be in italics. 

Ex: <em> Computer Applications </em>      Output: Computer Applications 

2. What is the use of <mark> tag? 

❖ Highlighting is an important formatting feature is used to call attention to the reader.  

❖ The <mark> tag is used to highlight the text in HTML. 

❖ This is also a container tag. 

Ex:   A computer is an  <mark>electronic </mark> devices. 

3. Write the following equation as HTML notation:   Pd = 2s – Q2   

<html>                                              i) Pd = 2s-Q2 

<head>                                                  Pd = 2s-Q<sub>2</sub> 

<title> html notation</title>  

</head>                                             ii) Pd = 25 –Q2 

<body> Pd = 2s – Q<sup>2</sup>         P<sub>d</sub> = 2 <sub> 5 </sub> - Q <sub> 2 </sub> 

</body> 

</html> 

4. Write about any two attributes of font tag. 

Face attributes : 

❖ The face is an attribute to set different font style.  

❖ The name of a font has multiple words it should be specified within double quote.  

Size attribute: 

❖ The size attribute is used to set size of the text.  

❖ The size can have an absolute value from 1 to 7. 

Color attribute: 

❖ The color attribute is used to set the color to the text.  

❖ As you leant earlier color name or color code in hexadecimal may be used. 

5. What is thematic break?  (M-2022) 

❖ The <hr> (Horizontal Rules) tag, which is known as “Thematic Breaks” separate sections of an 

HTML document visually. 

❖ It produces a horizontal line spread across the width of the browser. 

❖ This is an empty tag. 

6. What is pixel? 

❖ A pixel is one of the tiny dots that make up the display on computer.  

❖ 72 pixels equal to an inch.  

❖ Pixel is usually referred as points. 

7. What are the types of list in HTML? (M-2019)(S-2022)(M-2024) 

❖ HTML supports three types of lists. 

     1. Numbered List / Ordered List, 2.Un-numbered List / Unordered List 3.Definition List. 

8. How will you defined numbered list? 

❖ Numbered list is created within the tag pair <OL> ….. </OL> tag.  

❖ The tag <LI> is used to present the list item in the list. Ordered list displays items in a numerical or 

alphabetical order.  

❖ Both <OL> and <LI> tags are container tags.  

❖ But the usual the practice, closing tag </LI> never be used. 

1. Write an attribute of heading tag with example. (M-2020) 

❖ Align is an attributes to set right, center and justify alignment to headings. 

❖ Left if the default alignment, so that it is not supported in latest version of HTML. 

❖ Justify alignment is not supported by older browsers. 

Syntax:       <h# align = value>    Example:   <html> 
2. Name the tags used in text bigger and smaller than the normal size of the text  

❖ The <big> tag is used to define the text bigger in size than the normal size.  

❖ It is often used to call attention a text.  

❖ The <small> tag is used to define the text smaller than the current size.  

❖ These two tags are container tags. 

3. Write a short note on a) <big> b) <small> (S-2020) 

<big>   

❖ The <big> tag is used to define the text bigger in size than the normal size.  
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❖ It is often used to call attention to a text.  

<small>  

❖ The <small> tag is used to define the text smaller than the current size.  

❖ These two tags are container tags. 

 CHAPTER- 12 HTML - Adding multimedia elements and Forms 

1. List out the popular image formats: (M-2019) (M-2022)                                      
1. GIF (Graphical Interchange Format) 2. JPEG (Joint Photographic Experts Group) 

3. PNG (Portable Network Graphics)    4.SVG (Scalable Vector Graphics) 
2. Write down the general format of marquee (S-2022) (M-2023) 

❖ <marquee> Text or image to be scroll </marquee> 
3. What is inline sound or movie? (S-2020) 

❖ Music can be played in the background to a webpage, while the page is viewed.  

❖ This is known as ‘inline’ sound or movie. 

❖ The <bgsound> tag is used to attach an inline sound file in HTML. 

4. What is the purpose of <input> tag? (S-2021, J-2024) 

❖ Most of the form controls are created by using <input> tag. 
❖ The <input> is an empty tag used to create different form elements or controls such as text box, radio buttons so on. 

5. Which tag is used to specify the list of items in dropdown list box?  

❖ The <option> tag is used to specify list items. 

❖ The <select> tag is used to create dropdown list box in HTML.  

❖ It provides a list of various options as a dropdown list.  

❖ This element is more helpful when a number of options are to be displayed in a limited space.  

6. What are the major attributes are available in <text area> tag?  

❖ The <Text area> tag is used to receive multi line text data as input. It is a container tag.  

The main attributes of <Text area> are 

❖ Name – Used to define name to the control 

❖ Rows – Specifies the number of rows in the text area control 

❖ Cols – Specifies the number of columns in the text area. (Number of characters in a line) 

 CHAPTER- 13 CSS - Cascading Style Sheets 

1. What is the use of <style> tag?   (J-2023)                                                            

❖ A style tag is used to change the default characteristics of a particular tag in the entire web document 

wherever that tag is used. 

Ex:    <style>  

               h3  

               { color:blue;  font-family: "Copper plate Gothic Bold";  

               font-size:14pt; }  

               </style> 
2. What is CSS?  (J-2019)S-2020) 

❖ Cascading Style Sheets (CSS) are also called as Site wide Style sheets or external style.  

❖ CSS is a style sheet language used for describing the formatting of a document written in HTML. 

3. Write the general format of linking CSS with HTML. (M-2022) 

❖ <Link rel = “style sheet” type = “text/css” href = CSS_File_Name_with_Extension> 

4. What is Inline Style? 

❖ “Inline style” is used to define style for a particular tag anywhere in an HTML document.  

❖ “Inline Style” is applicable only on that line where it is defined. 

5. Write down general format of CSS declaration. (CSS Rules) (S-2021) 

Selector                         Declaration  

HTML Tag                { Properties : Values; } 

Example: 

Selector                               Declaration of properties and values 

P                                         {  

                                                Font-size : 16pt;  

                                                color : red;  

                                                font-weight : bold; 

                                             } 
 CHAPTER- 14 Introduction to Java script 

1. Write a syntax of <script> tag (S-2020) 

<script language="javascript" type="text/javascript">  

  JavaScript code 

</script> 
2. What is scope of variables and types of scope variable? (S-2022) 

❖ The scope of a variable is the life time of a variable of source code in which it is defined.  
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1.Global: A global variable has global scope; it can be defined everywhere in the JavaScript code. 

2.Local: Variables declared within a function are defined only within the body of the function. 

❖ They are local variables and have local scope. 
3. Write a notes to type casting in JavaScript. 

❖  Type conversion is the act of converting one data type into a different data type which is also called as casting.  

❖ Two type of casting, 1.Implicit casting, 2.Explicit casting. 

4. How many Literals in JavaScript and mention its types. 

❖ A literal is a fixed value given to a variable in source code. 

❖ Literals are often used to initialize variables. 

❖ Values may be Integer, Floating point, Character, String and Boolean 

5. What is conditional operator give suitable example? 
❖ The ?: is the conditional operator in JavaScript, which requires three operands, hence it is called the ternary operator. 

❖ Syntax :           var variablename=(condition) ? value1 : value2; 

Example: var result=(10>15) ?100 :150; 

6. What are the comments in Java Script?  

❖ There are two types of comments, Single line and multiple lines comments. 

❖ Single-line comments begin with a double slash (//), causing the interpreter to ignore everything 

from that point to the end of the line. 

❖ Multiple line comments begins with /* and ends with */. 

7. Write note on types of Operator  

1.Arithmetic operators 2.Relational operators 3.Logical operator 4.String operator 5.Assignment operator 

6.Condtional operator 7.Type of operator 8.Unary + and – operator. 

Typeof operator: 

❖ The typeof operator is used to get the data type (returns a string) of its operand.  

❖ The operand can be either a literal or a data structure such as a variable, a function, or an object.  

❖ The operator returns the data type. 

Syntax :  typeof operand    or typeof(operand) 

8. Write the role of variable in JavaScript. 

❖ Variables are declared in JavaScript using var keyword that allocates storage space for new data and indicates 

to the interpreter that a new identifier is in use.  

❖ Declaring a variable in JavaScript as follows:  var no; var no1,no2;  

❖ The var no; statement tells the interpreter that a new variable no is about to be used and var no1,no2; tells the 

interpreter that no1 and no2 are variables. 

9. What is the uses of prompt dialog box? 

❖ The prompt dialog box is very useful when the user want to pop-up a text box to get user input. 

❖ It enables you to interact with the user. 

❖ The user needs to fill in the text box field and then click OK. 

 CHAPTER- 15 Control Structure in Java script 

1. What are the different types of control statement used in JavaScript? 

❖ Control statements are two types. They are, 1.Branching / Selection 2. Looping / repetitive 

2. What is meant by conditional statements in JavaScript? 

❖ Statements are executed in the order they are found in a script.  

Conditional statements execute or skip one or set of statements depending on the value of a specified 
conditional expression 

3. List out the various branching statements in JavaScript? 

1.if  statement  2.if … else statement  3.switch statement 4.else if statement 

4. Write the general syntax for switch statement. 

switch(expression) 

{  

   case label1:  

           statements1;  

           break;  

   case label2:  

           statements2;  

           break;  

   case labeln;  

           statements - N;  

           break;  

    default:  

          statements; 

} 
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5. Differentiate the break and continue statement. 

Break statement. continue statement 

❖ The break statement will 

terminate the loop early 

❖ The continue statement will skip back to the loop condition check.  

❖ When the continue statement is executed, the current iteration of the 

enclosing loop is terminated, and the next iteration begins. 
 

 CHAPTER- 16 JavaScript Functions 

1. What is a function in JavaScript?   (J-2023)                                                         
❖ A function is a block of JavaScript code that is defined once but may be executed or invoked any number of times. 

2. What is the use of function?  

❖ Functions are used to encapsulate code that performs a specific task. 

❖ To avoid the repetition. Reusability and program clarity 
❖ A function is a block of JavaScript code that is defined once but may be executed or invoked any number of times.  

❖ Sometimes functions are defined for commonly required tasks to avoid the repetition entailed in typing the 

same statements over and over.  

❖ More generally, they are used to keep code that performs a particular job in one place in order to enhance 

reusability and program clarity. 

3. Write a note on Library functions. (M-2019)(S-2021)(M-2020) 

❖ Pre-defined functions are already defined in the JavaScript library which are also called Library functions.  

❖ Example: toUpperCase(), toLowerCase() , alert( ),write() etc. 

4. Write a note on user defined functions. 

❖ User-defined functions allow the programmer to modularize a program.  

❖ Some real-world problems are much large, occupy more space and time to execute. 

❖ So large programs are divided into small programs are called modules. 

5. Write the syntax of functions.  

Function function-name(parameters list) 

{ 

Function Body ; 

} Note: Function body include Declaration of variable and Executable statements. 

1. Write any four common library functions (M-2020) 

1.isNaN( ), 2.toUpperCase( ), 3.toLowerCase( ), 4.length( ), 5.alert( ), 6.prompt( ),    7.write( ) 

 CHAPTER – 17 Computer Ethics and Cyber Security 
1. What is harvesting? (M-2019)                                                                      

❖ A person or program collects login and password information from a legitimate user to illegally gain access to 

others’ account(s) is called harvesting. 

2. What are Warez? 

❖ Commercial programs that are made available to the public illegally are often called warez. 

3. Write a short note on cracking.  

❖ Cracking” means trying to get into computer systems in order to steal, corrupt, or illegitimately view data. 

❖ Cracking is where someone edits a program source so that the code can be exploited or modified. 

❖ A cracker is a malicious or criminal hacker. 

4. Write two types of cyber-attacks.  

1. Spyware : 

❖ It can be installed on the computer automatically when the attachments are open, by clicking on links or by 

downloading infected software. 

2.Ransomeware: 

❖ It is a type of malicious program that demands payment after launching a cyber-attack on a computer system. 

3.Malware:  

❖ It is a type of software designed through which the criminals gain illegal access to software and cause damage.  

Example: Virus, Worms, Spyware, etc..  

4.Cyber Security Threats:  

❖ In recent years, most of the individuals and enterprises are facing problems due to the weaknesses inherent in 

security systems and compromised organizational infrastructures.  

Example: Phishing, Pharming 

5. What is a Cookie? (J-2019, J-2024) 

❖ A cookie is a small piece of data sent from a website and stored on the user's computer memory (Hard drive) 

by the user's web browser while the user is browsing internet. 

1. What is Phishing? (S-2022)(M-2024) 

❖ Phishing is a type of computer crime used to attack, steal user data, including login name, password and credit 

card numbers etc. through emails. 

❖ Phishing scams are fraudulent attempts by cyber criminals to obtain private information. 
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2. What are the guidelines to be followed by any computer user? (S-2022) 

1.Honesty :  

❖ Users should be truthful while using the internet. 

2.Confidentiality:  

❖ Users should not share any important information with unauthorized people. 

3.Respect :  

❖ Each user should respect the privacy of other users.  

 

4.Professionalism:  

❖ Each user should maintain professional conduct. 

5.Obey The Law:  

❖ Users should strictly obey the cyber law in computer usage. 

6.Responsibility: 

❖ Each user should take ownership and responsibility for their actions. 

3. What are the two types of encryption? (S-2020) 

❖ Encryption is the process of translating the plain text data (plaintext) into random and mangled data (called cipher-text). 

❖ For example data being transferred via networks (e.g. the Internet, ecommerce), mobile telephones, wireless 

microphones, wireless intercom systems, Bluetooth devices and bank automatic teller machines.. 

4. What is cyber-crime? (M-2024) 

❖ A cyber-crime is a crime which involves computer and network. 

❖ Cyber-crime is an intellectual, white-collar crime. 

❖ Those who commit such crimes generally manipulate the computer system in an intelligent manner. 

 CHAPTER – 18 Tamil Computing 
1. List of the search engines supporting Tamil.  (M-2020)(M-2022)(J-2023)(M-2024)   

❖ Google and Bing 

2. What are the keyboard layouts used in Android?  

❖ Sellinam and Ponmadal  

3. Write a short note about Tamil Programming Language. (J-2024) 

❖ Programming languages to develop software in computers and smart phones are available only in English.  

❖ Based on Python programming language, the first Tamil programming language “Ezhil” (எழில்) is designed. 

4. What TSCII? (M-2020) 

❖ TSCII (Tamil Script Code for Information Interchange) is the first coding system to handle our Tamil language. 

❖ This encoding scheme was registered in IANA (Internet Assigned Numbers Authority) unit of ICANN. 

5. Write a short note on Tamil Virtual Academy. 

❖ With the objectives of spreading Tamil to the entire world through internet, Tamil Virtual University was 

established on 17th February 2001 by the Govt. of Tamil Nadu. 

❖ Now, this organisation functioning with the name “Tamil Virtual Academy”. 
❖ It offers different courses regarding Tamil language, Culture, heritage etc., from kindergarten to under graduation level. 

1. Write a note on Unicode. (S-2020) 

❖ Unicode is an encoding system, designed to handle various world languages, including Tamil.  

❖ Its first version 1.0.0 was introduced in October 1991.  

❖ Unicode is the best suitable to handle Tamil. 

2. What are the familiar keyboard used for Tamil typing? (J-2019) 

❖ NHM Writer, E-Kalappai and Lippikar – are familiar Tamil keyboard interfaces software that is used for Tamil 

typing which works on Tamil Unicode, using phonetics.  

❖ Sellinam and Ponmadal – are familiar Tamil keyboard layouts that works on Android operating system in 

Smart phone using phonetics.  
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         CHAPTER 1 TO 18 THREE MARK BOOK BACK & public QUESTION with ANSWERS 
 CHAPTER – 1 Introduction to Computers 
1. What are the characteristics of a computer? (M-2023)                                       

1. Speed: Computers can work very fast. 

2. Accuracy: The degree of accuracy of computer is very high. 

3. Consistency: Computer is consistent in their performance. 

4. Memory: Computer has the ability to store and retrieve data. 

5. Storage Capacity: Computers have high storage capacity. 

6. Automation: Computer can perform tasks automatically.  

2. Write the applications of computer. 

1. Business               2. Education        3. Marketing 4. Banking       5. Insurance 

6. Communication   7. Health Care      8. Military    9. Engineering Design 

3. What is an input device? Give two examples. (M-2023) 

❖ An input device is a hardware or peripheral device used to send data to a computer  
❖ Input device is used to feed any form of data to the computer, which can be stored in the memory unit for further processing. 

Example: 

1.Keyboard, 2.mouse, 3.Scanner, 4.Fingerprint scanner, 5.Track Ball, 6.Retinal Scanner, 7.Light pen etc. 

4. Name any three output devices. (S-2021, J-2024) 

1. Monitor: Monitor is the most commonly used output device to display the information. 

2. Printer: Printers are used to print the information on papers 

3. Plotter: Plotter is an output device that is used to produce graphical output on papers. 

4. Speaker: Using speaker along with speech synthesise software, the computer can provide voice output. 

5. Multimedia Projectors: Multimedia projectors are used to produce computer output on a big screen 

5. Differentiate optical and Laser mouse.  

Optical mouse Laser mouse 

❖ Uses Light source ❖ Uses Laser Light 

❖ It has 2 or 3 buttons ❖ It has as many as 12 buttons. 

❖ Less sensitive ❖ Highly sensitive 

❖ Less sensitive towards surface ❖ Highly sensitive and able to work on any hard surface. 
 

6. Write short note on impact printer  

❖ These printers print with striking of hammers or pins on ribbon.  

❖ These printers can print on multi-part (using carbon papers) by using mechanical pressure.  

For example, Dot Matrix printers and Line matrix printers are impact printers. 

7. Write the characteristics of sixth generation. (M-2022) 

❖ Sixth Generation, computers could be defined as the era of intelligent computers, based on Artificial Neural Networks. 

❖ One of the most dramatic changes in the sixth generation will be the explosive growth of Wide Area Networking. 

❖ Natural Language Processing (NLP) is a component of Artificial Intelligence. 

❖ It provides the ability to develop the computer program to understand human language. 

8. Write the significant features of monitor.  

❖ Monitor is the most commonly used output device to display the information. 

❖ Pictures on a monitor are formed with picture elements called PIXELS. 

❖ Monitors may either be Monochrome which display text or images in Black and White or can be colour, which 

display results in multiple colours. 

❖ There are many types of monitors available such as CRT (Cathode Ray Tube), LCD (Liquid 

Crystal Display) and LED (Light Emitting Diodes). 

❖ The monitor works with the VGA (Video Graphics Array) card.  

 CHAPTER – 2 Number Systems 
1. What is radix of a number system? Give example. (M-2022)                          

❖ Each number system is uniquely identified by its base value or radix.  

❖ Radix or base is the count of number of digits in each number system. 

❖ Radix or base is the general idea behind positional numbering system. 

Example:  

1.Binary –Radix 2 (1010)2      2.Octal – Radix 8 (457)8    

3.Decimal- Radix 10 (314)10   4.hexa-Decimal – Radix 16 (25F)16 

2. Write note on binary number system. (S-2022) 

❖ There are only TWO DIGITS in the Binary system, namely, 0 and 1. 
❖ The numbers in the binary system are represented to the base 2 and the positional multipliers are the powers of 2. 

❖ The left most bit in the binary number is called as the Most Significant Bit (MSB) and it has the largest 

positional weight. 

❖ The right most bit is the Least Significant Bit (LSB) and has the smallest positional weight. 

1 1 0 1 

                     MSB                            LSB 
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3. Convert (150)10 into Binary, then convert that Binary number to Octal (S-2020) 

Step :1  (Decimal to Binary)                                                                                   

2  150        (150)10 = (10010110)2 

2  75-0                                                     Step :2   (Binary to Octal) 

2  37-1                                                                   (10010110)2   (?)8            

2  18-1                                                             010  010  110           (150)10 = (226)8 

2  9-0                                                                 2      2      6        

2  4-1 

2  2-0          

    1-0                          

4. Write short note on ISCII. 

❖ ISCII is the system of handling the character of Indian local languages.  

❖ This as a 8-bit coding system. Therefore it can handle 256 (28) characters.  

❖ This system is formulated by the department of Electronics in India in the year 1986-88 and recognized by 

Bureau of Indian Standards (BIS).  

❖ Now this coding system is integrated with Unicode. 

5. Add a) -2210+1510  
2  22                                                 2  15 

2  11-0                                              2  7-1 

2  5-1                                                2  3-1 

2  2-1                                                     1-1 

    1-0 

22 (10110)2                              15      (1111)2 

8 bit   00010110                     8 bit             00001111 

1’s 11101001 

2’s  11101010 
-22       1  

1’s 1 1 1 0 1 0 0 1 

        1 

2’s 1 1 1 0 1 0 1 0 

 

    1 1 1   

-2210 1 1 1 0 1 0 1 0 

1510 0 0 0 0 1 1 1 1 

+ 1 1 1 1 1 0 0 1 

2310+1210 =   -710  =  ( 11111001)2 

 

b) 2010+2510 

2  20                                                 2  25 

2  10-0                                              2  12-1 

2  5-0                                                2  6-0 

2  2-1                                                2   3-0 

    1-0                                                     1-1                  

 

20 (10100)2                              25      (11001)2 

8 bit   00010100                         8 bit             00011001 

   1      

2010 0 0 0 1 0 1 0 0 

2510 0 0 0 1 1 0 0 1 

+ 0 0 1 0 1 1 0 1 

2010+2510 =   4510  =  ( 00101101)2 

1. Convert 34010 to its equivalent Binary, Octal and Hexadecimal (J-2019) 

Step :1    Decimal to binary 

2  340        (340)10 = (101010100)2 

2  170-0        Step :2   (Binary to Octal) 

2  85-0                 (101010100)2   (?)8            

2  42-1                 101  010  100             (340)10 = (524)8 

2  21-0                  5      2      4        

2  10-1 

2  5-0           Step : 3  (Binary to Hexadecimal) 

    2-1                    (101010100)2   (?)16 

    1-0                      0001   0101 0100                 (340)10 = (154)16 

                                   1        5      4      
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2. A) State whether the following numbers are valid or not. If invalid write reason. (S-2020) 

 1) (796)8  - Not valid (octal base value 0 to 7) 

2) (7GE)16  - Valid ( Hexadecimal base value 0 to 9 & A to F) 

3)(1110)2  - Valid ( Binary base value 0,1) 

B) Write the number system for the following numbers.  

1) (926)10   - Decimal number system 

2) (ABC)16    - Hexadecimal number system 

3) (450)8 – Octal number system 

3. A) Add : 11012+10102   B) Subtract : 101002-11112      (M-2019) 

A) Add : 11012+10102  

1     

 1 1 0 1 

 1 0 1 0 

1 0 1 1 1 

 Ans: 11012+10102 = 101112 

B) Subtract : 101002-11112 

0 1 10 1 10 

1 0 1   0 0 0 

 1 1 1 1 

0 0 1 0 1 

Ans: 101002-11112 = 1012 

4. What is the decimal equivalent sequence for (547)8 octal sequence? (M-2020) 

(547)8  = 5x82+4x81+7x80 

             =5x64+4x8+7x1 

             =320+32+7 

             =(359)10 

5. a) Convert the octal number (67)8 into decimal number   (J-2019) 

Weight 8 1 

Positional 

Notation 

81 80 

Given  

number 

6 7 

(67)8 = 8x6+1x7 

             = 48+7 

(67)8 = (55)10 

b) Convert the decimal number (57)10  into hexadecimal number 

16 57 

      3 – 8            (57)10 = (38)16 

6. Add: (A)  -2010 + 2510  (M-2024) 

Step:1                                          Step:2                                           Step:3 

2 20       -20   = 10100                  2 25       25    = 11001                     -20  = 11101100 

2 10-0   8bit = 00010100            2 12-1      8bit  = 00011001               25 = 00011001 

2 5-0     1s = 11101011               2 6-0 

2 2-1                           1                2 3-0                                                  -5 =1000001012   

   1-0      2s= 11101100                    1-1                                                       [-2010 + 2510 = -510=1000001012 ] 

6. (B) 2210 + 1510       (M-2024) 

Step:1                                          Step:2                                           Step:3 

2 22       22  = 10110                     2 15         15      = 1111                  22 = 00010110 

2 11-0    8bit = 00010110             2 7-1         8bit   = 00001111          15 = 00001111 

2 5-1                                              2  3-1                      

   2-1                                              1-1                                                   37 = 001001012        

   1-0                                                                                                      [2210 + 1510 = 3710=001001012 ] 

7. A) Add : 10112+10012   B) Subtract : 10010102-101002      (J-2024) 

A) Add : 10112+10012    

1 1 1  

     1 0 1 1 

     1 0 0 1 

 1  0 1 0 0 

  

10112+10012  = 101002 
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B) Subtract : 10010102-101002       

  1 10  10   

 10 0 0 1  0 0 1 0 

   1 0 1 0 0 

  1 1 0 1 1 0 

10010102-101002     = 1101102 

 CHAPTER – 3  Computer Organization 
1. Differentiate Computer Organization from Computer Architecture.   

Computer Organization Computer Architecture 

❖ Computer organization deals with the hardware 

components of a computer system. 

❖ Computer architecture also deals with how they are 

interconnected to implemented 

❖ It deals with the hardware components that are 

transparent to the programmer. 

❖ It deals with the engineering considerations 

involved in designing a computer. 
 

2. Classify the microprocessor based on the size of the data. (M-2023) 

❖ Depending on the data width, microprocessors can process instructions. 

❖ 8-bit microprocessor 16-bit microprocessor 32-bit microprocessor and 64- bit. 

3. Write down the classifications of microprocessors based on the instruction set. (M-2022)(M-2024) 

❖ The size of the instruction set is important consideration while categorizing microprocessors. 

❖ There are two types of microprocessors based on their instruction sets. 

Reduced Instruction Set Computers (RISC) : 

❖ Example: Pentium IV, Intel P6, AMD K6 and K7.  

Complex Instruction Set Computers (CISC) : 

❖ Example: Intel 386 & 486, Pentium, Pentium II and III, and Motorola 68000. 

4. Differentiate PROM and EPROM. (S-2022) 

PROM EPROM 

❖ Data can be written only once and cannot 

be erased. 

❖ The ultra violet light clears its contents, making is 

possible to reprogram the memory. 

❖ Programmable read only memory is also a 

non-volatile memory. 

❖ Erasable Programmable Read Only Memory is a special 

type of memory. 

❖ PROMs retain their contents even when 

the computer is turned off. 

❖ EPROM retains its contents until it is exposed to 

ultraviolet light. 
 

5. Write down the interfaces and ports available in a computer.  (J-2023) 

❖ Serial Port: To connect the external devices, found in old computers.  

❖ Parallel Port: To connect the printers, found in old computers.  

❖ USB Ports: To connect external devices like cameras, scanners, mobile phones, external hard disks and printers to the computer.  

❖ VGA Connector: To connect a monitor or any display device like LCD projector.  

❖ Audio Plugs: To connect sound speakers, microphone and headphones.  

❖ PS/2 Port: To connect mouse and keyboard to PC.  

❖ SCSI Port: To connect the hard disk drives and network connectors. 

6. Differentiate CD and DVD.  (J-2019) (M-2020, J-2024) 

                CD                 DVD 

❖ CD stands for Compact Disk ❖ DVD Stands for Digital Versatile Disc. 

❖ CD data is represented as tiny indentations 

known as “pits” 

❖ DVD-ROM can be visually determined by 

nothing the number of data sides of the disc. 

❖ Capacity: CD-ROM is 700MB ❖ Capacity: 4.7 GB 

❖ Single-layered sides are usually silver-coloured. ❖ Double-layered sides are usually gold-coloured. 
 

7. How will you differentiate a flash memory and an EEPROM?  

flash memory EEPROM 

❖ Flash memory is an electronic (solid-state) non-

volatile computer storage. 

❖ Electrically Erasable Programmable Read Only 

Memory is a special type of memory 

❖ Flash memory offers fast access times. ❖ EEPROM is slower in performance. 
❖ It can be erased by exposing it to an electrical charge. ❖ It can be electrically erased and reprogrammed. 

 

1. Explain the types of RAM (AUG-2022) 

❖ There are two basic types of RAM   1.Dynamic RAM (DRAM) 2.Static RAM (SRAM) 

❖ Dynamic RAM being a common type needs to be refreshed frequently.  

❖ Static RAM needs to be refreshed less often, which makes it faster. 

 CHAPTER – 4 Theoretical Concepts of Operating System 
1. What are the advantages and disadvantages of Time-sharing features? (M-2023)   

Advantage : 

❖ For each task a fixed time is allocated. 

❖ The processor switches rapidly between various processes after a time is elapsed or the process is completed. 
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❖ Avoids duplication of software 

❖ Many applications can run at the same time. 

Disadvantage : 

1. Unreliability during data transmission. 2. Problem of Reliability. 3.It consumes more resource 

2. List out the key features of Operating system (M-2022) 

1.User Interface (UI)          2.Memory  Management    3.Process management  

4. Security Management    5. Fault Tolerance               6.File Management 

3. Write a note on Multi processing. (J-2023) 

❖ This is a one of the features of Operating System.  

❖ It has two or more processors for a single running process (job).  

❖ Processing takes place in parallel is known as parallel processing. 
❖ The execution takes place in parallel, this feature is used for high speed execution which increases the power of computing.  

1. Write a note following process management system (a) FIFO  (b) SJF (S-2020) 

FIFO (First In First Out)Scheduling:  

❖ This algorithm is based on queuing technique.  

❖ Assume that a student is standing in a queue (Row) to get grade sheet from his/her teacher.  

❖ The other student who stands first in the queue gets his/her grade sheet first and leaves from the queue (Row).  

❖ Followed by the next student in the queue gets it corrected and so on.  

❖ This is the basic logic of the FIFO algorithm. 

SJF (Shortest Job First)Scheduling:  

❖ This algorithm works based on the size of the job being executed by the CPU.  

❖ Consider two jobs A and B. 

❖ 1) A = 6 kilo bytes 2) B = 9 kilo bytes  

❖ First the job “A” will be assigned and then job “B” gets its turn. 

2. What is GUI? (M-2023) 

❖ User interface is one of the significant features in Operating System.  

❖ The only way that user can make interaction with a computer.  

❖ This is a main reason for key success of GUI (Graphical User Interface) based Operating System.  

❖ The GUI is a Window based system with a pointing device to direct I/O, choose from menus, and make 

selections and a keyboard to enter text.  

❖ Its vibrant colour attracts the user very easily. 

3. Write about security management (J-2019) 

Security Management:  

❖ The major challenge in computer and software industry is to protect user’s legitimate data from hackers.  

❖ The Operating System provides three levels of securities to the user end.  

❖ They are (1) File access level, (2) System level, (3) Network level  

❖ In order to access the files created by other people, you should have the access permission. Permissions can 

either be granted by the creator of the file or by the administrator of the system.  

❖ System level security is offered by the password in a multi-user environment.  

❖ Both windows and Linux offer the password facility.  

❖ Network security is an indefinable one. So people from all over the world try to provide such a security.  

❖ All the above levels of security features are provided only by the Operating System. 

4. Explain and list out examples of mobile OS (M-2019) 

1.Android: 

❖ A popular Operating System for mobile phone technology which is not linked with Apple products 

2.Apple Ios: 

❖ It is a mobile operating system. 

❖ Created and developed by Apple Inc. 

5. Write any 6 of the most popular Linux server distributors (M-2020) 

1.Linux Mint 2.Arch Linux 3.Deepin 4.Fedora 5.Debian 6.CentOS 

 CHAPTER – 5 Working with Windows Operating System 
1. What are the functions of Windows Operating System?   (M-2022)               

1. Access applications on the computer (word processing, games, spread sheets, calculators and so on). 
2. Load any new program on the computer. 3. File management activities, 4.Change computer settings. 

5. Manage hardware such as printers, scanners, mouse, digital cameras etc.,  
2. Write a note on Recycle bin. (M-2020)(S-2022) 

❖ Recycle bin is a special folder to keep the files or folders deleted by the user, which means you still have an 

opportunity to recover them.  

❖ The user cannot access the files or folders available in the Recycle bin without restoring it 

❖ Restore option is used to restore file or folder from the Recycle bin. 

3. Write a note on the elements of a window. (S-2021) 

❖ The title bar will display the name of the application and the name of the document opened. 
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❖ The menu bar is seen under the title bar. Menus in the menu bar can be accessed by pressing Alt key and the 

letter that appears underlined in the menu title. 

❖ The workspace is the area in the document window to enter or type the text of your document. 

❖ The scroll bars are used to scroll the workspace horizontally or vertically. 

❖ The corners and borders of the window helps to drag and resize the windows. 

4. Write the two ways to create a new folder. (M-2023)(M-2024) 

Method I:  
Step 1: Open Computer Icon.                         Step 2: Open any drive where you want to create a new folder.  

Step 3: Click on File → New → Folder.        Step 4: A new folder is created with the default name “New folder”.  

Step 5: Type in the folder name and press Enter key. 

Method II:  
Step 1: In the Desktop, right click → New → Folder.         Step 2: A Folder appears with the default name “New folder”. 

Step 3: Type the name you want and press Enter Key.        Step 4: The name of the folder will change. 

5. Differentiate copy and move 

           Copy              Move 

❖ Copying is the process of moving a copy of a file 

or folder to a new location. 

❖ Moving a file or folder from source to a new 

location is called cutting. 

❖ Edit – Copy or Ctrl+C or Right click - Copy ❖ Edit – Cut or Ctrl+X or Right click - Cut 

❖ Copy option is used to copy a file or folder, and 

paste in a specified location. 

❖ Cut option is used to move a selected file or 

folder from one place to another. 

❖ It is the process of making duplicate copies of the 

block of a worksheet. 
❖ It is the process of making Move the files or 

folders. 
 

1. Write the procedure to create a file in word pad (AUG-2022) 

1. Click Start → All Programs → Accessories → Wordpad or Run → type Wordpad, click OK.  

Word pad window will be opened as folder. 

2. Type the contents in the workspace and save the file using File → Save or Ctrl + S. 

3. Save As dialog box will be opened.  

4. In the dialog box, select the location where you want to save the file by using look in drop down list box. 

5. Type the name of the file in the file name text box. 

6. Click save button. 

2. Compare CUT-PASTE and COPY- PASTE (M-2023) 

CUT and PASTE: 

 To move a file or folder, first select the file or folder and then choose one of the following: 

❖ Click on the Edit → Cut or Ctrl + X or right click → Cut from the pop-up menu. 

❖ To move the file(s) or folder(s) in the new location, navigate to the new location and paste it using Click Edit 

→ Paste or Ctrl + V or Right click → Paste from the popup menu.  

❖ The file will be pasted in the new location. 

COPY and PASTE:  

To copy a file or folder, first select the file or folder and then choose one of the following: 

❖ Click Edit → Copy or Ctrl + C or right click→ Copy from the pop-up menu. 

❖ To paste the file(s) or folder(s) in the new location, navigate to the target location and paste it using Click Edit 

→ Paste or Ctrl + V or Right click → Paste from the popup menu.  

❖ The file will be pasted in the new location 

3. Write down the steps involved in copying files and folders using Send To method. 

❖ Plug the USB flash drive directly into an available USB port. 

❖ Navigate to the folders in your computer containing files you want to transfer. 

❖ Right-click on the file you want to transfer to your removable disk. 

❖ Click Send To and select the Removable Disk associated with the USB flash drive. 

4. Name the methods followed while copying files and folders to removable disk (S-2020) 

1. Copy 2.Drag and Drop 3. Send To 4. Copy and Paste using keyboard shortcuts 

5. How can you move a file one location to another location in windows? (J-2019) 

CUT and PASTE:  

❖ Click on the Edit → Cut or Ctrl + X Or right click → cut from the pop-up menu.  

❖ To move the file(s) or folder(s) in the new location, navigate to the new location and paste it using Click Edit 

→ Paste from edit menu or Ctrl + V using keyboard.  

❖ Or Right click → Paste from the pop-up menu. The file will be pasted in the new location. 

 CHAPTER – 6 Introduction to Word Processor 
1. What is the difference between moving and copying text?    (S-2021)                  

Moving text Copying text 

❖ Move the original text from one  location to 

another. 

❖ Copies the original text in as many places as 

necessary without moving from its location. 

❖ Click Ctrl + X or Cut Icon  or Edit –Cut ❖ Click Ctrl + C or Copy Icon or Edit -Copy 
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❖ The text is removed from the source location and 

placed in the clipboard. 

❖ A duplicate copy of the text is made and send to 

the clipboard 
 

2. What are the different types of page orientation? (M-2019) 

❖ Page orientation refers to how the document will be displayed on screen and printed. 

❖ Landscape - The width of the document is more than the height. This is best suited for displaying professional 

photos, invitations, albums, tables etc. 

❖ Portrait – This is the most common and default orientation. Here, the height of the document is more than the width. 

3. How do you insert rows and columns? (M-2022)(M-2023) 

1. Place the insertion pointer in the row or in the column where you would like to add new rows or columns and right click. 

2. Choose Row -Insert – to insert a row or Column - Insert – to insert a column. 

3. A dialog box will appear, from which you can select the number of rows or columns to insert.  

4. You can also set the position of the new rows or columns to before or after. 

5. Click Ok to close the dialog box. 

4. What are the different ways to save a document? (S-2021, J-2024) 

1. Click File → Save (or) File → Save As (or) Ctrl + S 

2. The “Save As” dialog box appears as on screen. 

3. Select location to store your document.  

4. The default location to store all documents is “Documents” folder in Windows. 

5. Type your document name in the File Name box. 

6. All documents in Open Office Writer will be stored with .odt extension.  

7. You can store your Open Office document as Microsoft Word document or pdf.  

8. To do so, select file type from Save as type list box.  

9. This list box shows variety of formats to be saved. 

10. Finally, Click “Save” button. 

5. Write the steps to change the line spacing of text. 

1. Right click- line spacing, select the type single, 1.5 or double.  

2. Select the entire document by Edit - Select All Format - paragraph 

3. The paragraph dialog box appears, click Indents & Spacing tab 

4. In the line spacing option, select the type and click OK button. 

1. Write about auto correct option in Writer (S-2020) 

Automatic correction:  
❖ Auto Correct feature has the facility to correct the common misspellings and typing errors, automatically.  

❖ For example, “hte” will be changed to “the”, which can be done through the menu option, Tools → AutoCorrect to open 

the AutoCorrect dialog box which provides the chance to change the misspelled word with the correct word. 

To make an AutoCorrect entry 

• Select Tools → AutoCorrect                • AutoCorrect dialog box appears  • Click Replace Tab 

• In replace box, type the misspelt word  • In with box, the correct word      • Click New 

2. What is indenting text in writer? Write its types (J-2023) 

Indenting text: 

❖ Indent is the distance from the left and right margin of a paragraph.  
❖ It is used to improve the efficiency and readability of the paragraph and makes the paragraph look more attractive. 

There are four types of indentations:  

• Left Indent   • Right Indent   • First Line Indent  • Hanging Indent. 

3. What are the different types of operators supported by calc? What is range? (S-2020) 

Types of operators: 

(1) Arithmetic Operators (2) Relational Operators (3) Reference Operators (4) Text Operator 

Range: 

❖ Reference operators are used to refer cell ranges.  

❖ A continuous group of cells is called as “Range”. 

 CHAPTER -7 Working with Open Office Calc 
1. Write a short note on Open Office Calc. (M-2020)                                      

❖ Open Office Calc is a popular open source spread sheet application maintained by Apache Foundation. 

❖ Star Office calc was the parent application of Open Office Calc which was developed by a German Company 

namely, Star Division in 1985. 

❖ Calc is the spread sheet component of Open Office.  

❖ You can enter any kind of data in a spread sheet and then manipulate this data to produce certain results. 

2. Write about inserting columns and rows in Calc. (M-2023) 

1.Inserting Rows : 

❖ Step 1: Select the row where a new row to be inserted. 

❖ Step 2: Right-click on the row number, a pop-up menu appears  

❖ Step 3: click “Insert Rows” option from the menu. 

❖ Now, a new row will be inserted to above the current row. 

❖ Insert -Rows command is used to insert a new row. 
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2.Inserting a Column : 

❖ Step 1: Select the column where a new column should be inserted. 

❖ Step 2: Right-click on the selected column name that you selected.  

❖ Step 3: click the “Insert Columns” option from the menu. 

❖ Now, a new column will be inserted to the left of the current column.. 

3. Differentiate Deleting data using Backspace and Delete 

Deleting data using Backspace Deleting data using Delete key. 

Backspace key is used to delete the character left of 

the insertion pointer of the cell. 

Delete key is used to delete the character right of the 

insertion pointer of the cell. 
 

4. Write any three formatting options:   

Formatting Option Keyboard Shortcut Description 

1.Bold Ctrl + B Used to make the data as Bold 

2.Italic Ctrl + I Used to Italicize data 

3.Underline Ctrl + U Used to Underline the data 
 

5. In cell A1=34 A2=65 A3=89 write the formula to find the average. (M-2024) 

= AVERAGE (A1:A3)    (OR)   =SUM(A1:A3)/3  (OR)   =(A1+A2+A3)/3 

1. Write about date arithmetic (J-2019) 

❖ Manual date calculations can be tricky because you have to keep track of the number of days in a month.  

❖ In spread sheets, date calculations become very simple.  

❖ Here you can add a number to a date and arrive at a new date, find the difference between two dates and use a 

wide variety of function and formats to get what you want.  

❖ For example, enter a date 02/26/2018 in a cell, say A2.  

❖ Suppose you want to calculate the date 80 days after this date. To do so, enter the formula, = A2 + 80, in 

another cell, say A4. 

 CHAPTER- 8 Presentation Basics 
1. How many types of views are provided by Impress to its users? (M-2019)(S-2020)           

❖ Normal view - Normal view is the main view for creating individual slides. 

❖ Outline view - Outline view shows topic titles, bulleted lists and numbered list for each slide in outline format. 

❖ Notes view    - Notes view lets you add notes to each slide that are not seen when the presentation is shown. 

❖ Slide Sorter view - Slide Sorter view shows a thumbnail of each slide in order. 

❖ Hand out view – Hand out view lets you print your slides for a hand out. 

2. Who uses the presentation software and why? 

❖ Presentation software is used by different people and organizations for various purposes. 

❖ It is a popular tool in the field of business, marketing and education. 

❖ Companies use presentation software to share practices, ideas and goals with their employees. 

❖ Presentation software used to create presentations, quizzes, e-learning packages and multimedia products.    

3. Define the Slide Sorter view and its significance. (M-2020) 

❖ Slide Sorter view shows a thumbnail of each slide in order.  
❖ Use this view to rearrange the order of slides, produce a timed slide show, or add transitions between selected slides. 

❖ Use this view to work with a group of slides or with only one slide. 

❖ Change the number of slides per row, if desired: 

      1) Check View → Toolbars → Slide View to show the Slide view toolbar. 

      2) Adjust the number of slides (up to a maximum of 15) 

4. What is a Normal view? Explain. (J-2023) 

❖ Normal view is the main view for creating individual slides. 

❖ Use this view to format and design slides and to add text, graphics and animation effects. 

❖ There are two ways to place a slide in the Slide Design area of the Normal view:  

❖ 1. Clicking the slide thumbnail in the Slides pane (or) 2.Using the Navigator. 

5. How are transition effects helpful in creating an effective presentation in Impress? 
❖ Slide Transition are the effects special effects that occur when you move from one slide to the next during a presentation.  

❖ You can control the speed, add sound, and customize the properties using the transition effects. 

❖ You can also choose between an automatic or manual transition. 

❖ It can be used to grab the audience’s attention and keep them engaged throughout the presentation. 

1. How will you start open office impress? (J-2019) 

❖ In order to open impress using Start button, click Start button and select All Programs → Open Office → 

Open Office Impress.  

❖ If it is already pinned in the Start menu, just click and open it. 

2. What are the three methods of inserting slide in impress presentation? (S-2020) 

Step 1: Insert a new slide. This can be done in a variety of ways. 

• Insert → Slide. 

• Right-click on the present slide, and select Slide → New Slide from the pop-up menu.  

• Click the empty space after the last slide also to create a new slide by right clicking New Slide.  
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• Click the Slide icon in the Presentation toolbar.  

Step 2: Select the layout slide that best fits your needs. (Figure 8.28). 

Step 3: Modify the elements of the slide like removing unneeded elements, adding, and inserting text. 

 CHAPTER- 9 Introduction to Internet and Email 

1. What is TCP/IP?   (M-2022)                                                                                  

❖ The Transmission Control Protocol/ Internet Protocol) to transmit data via various types of media. 

❖ The internet protocol (IP) addressing system is used to keep track of the millions of users. 

❖ The internet uses TCP/IP is a set of protocols that comprise hierarchies. 

2. Write a note on Hotspot internet service. (S-2020) 

❖ Hotspot is a physical location where people can access the Internet.  

❖ Internet access over a wireless local area network (WLAN) by way of a router that then connects to an Internet 

service provider.  

❖ Hotspots utilize Wi-Fi technology, which allows electronic devices to connect to the Internet or exchange data 

wirelessly through radio waves.  

❖ Hotspots can be phone-based or free-standing, commercial or free to the public. 

3. Differentiate Data Card and Dongles. (M-2020)(M-2023) 

Dongle Data Card 

Refers to any removable component used for enabling 

extra security.  

USB Dongles can be divided into  

1.WiFi Dongles 2.BlueTooth Dongle 

3.Memory Dongle 

It is a removable electronic card which is used for 

storing for data.  

Types of data card are 

1.Expansion Card 2.Memory Card or Flash Card 

3.Identification Card 
 

4. Write a note on two access methods of connecting to internet. 

Indirect Access: 

❖ This is most common method used in home and office networks. 

❖ The device e.g. computer connects to a network using Ethernet or WiFi and 

❖ Internet using Asymmetric digital subscriber line ADSL (cable or fibre.) 

Direct Access: 

❖ This is most common method used when travelling. 

❖ The device e.g. smart phone connects directly to the Internet using 3G/4G mobile networks or public Wi-Fi. 

5. Differentiate browser and a search engine with suitable examples. 

          Browser             Search engine 

❖ A software used to access websites and  web 

pages  

❖ A software system that is designed to search for 

information on the World Wide Web. 
❖ Used to access the internet and to open search engines ❖ Used to search for particular information 
❖ Example: Internet Explorer, Chrome, Firefox, Safari, etc ❖ Example: Yahoo, Google, etc. 

 

6. Differentiate Website and Webpage. (M-2019)(S-2021) 
 

                Webpage                    Website 
❖ Consists of a Single document displayed by a browser ❖ A collection of multiple documents displayable by a browser 

❖ Shares a unique domain name ❖ Has its own unique domain name 

❖ Makes up a website ❖ Contains one or more web pages 

7. What is the difference between Static and dynamic web page? 

         Static Web Page              Dynamic Web Page 

The content and layout of a web page is fixed The content and layout may change during run time 

Never use databases Databases is used to generate dynamic content through queries 

It directly run on the browser and do not require 

any server side application program 

It runs on the server side application programs and displays 

the results 

Static web page are easy to develop Dynamic web page development requires programming skills 
 

8. What are Advantages of e-mail? (S-2022)(J-2023)(J-2024) 

1.Free delivery : 

❖ Sending an e-mail is virtually free, outside the cost of Internet service.  

❖ There is no need to buy a postage stamp to send a letter. 

2.Global delivery :  

❖ E-mail can be sent to nearly anywhere around the world, to any country.  

3.Instant delivery :  

❖ An e-mail can be instantly sent and received by the recipient over the Internet.  

4.File attachment:  

❖ An e-mail can include one or more file attachments, allowing a person to send documents, pictures, or other 

files with an e-mail. 
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5.Long-term storage : 

❖ E-mails are stored electronically, which allows for storage and archival over long periods of time. 

6.Environmentally friendly: 

❖ Sending an e-mail does not require paper cardboard, or packing tape, conserving paper resources. 

1. What is W3C? (J-2019) 

❖ W3C stands for "World Wide Web Consortium."  
❖ The W3C is an international community that includes a full-time staff, industry experts, and several member organizations.  

❖ These groups work together to develop standards for the World Wide Web.  

❖ The World Wide Web Consortium (W3C) is an international organization committed to improving the web.  

❖ It is made up of several hundred member organizations from a variety of related IT industries.  

❖ W3C sets standards for the World Wide Web (WWW) to facilitate better communication ability and 

cooperation among all web stakeholders.  

❖ It was established in 1994 by the creator of the WWW, Tim Berners-Lee. 

 CHAPTER- 10 HTML - Structural Tags 
1. Explain the attributes available with <body> tag.   (M-2019) 

❖ The <body> tag defines the document’s body.  

❖ <body> tag contains several attributes. 

(i) Background Colour: bgcolor = color:   <body bgcolor = color_name/color_code>  

(ii) Body text Colour: text = color:  <body text = color_name/color_code> 

(iii) Background image: background=image: <body background = “image_name_with_extenstion”> 

(iv) Setting Margins: margin = value : <body leftmargin = value topmargin = value> 

2. What are the attributes available in <html> tags? (M-2020)(M-2024) 
 

Attribute Value to be set to attribute                  Description 

1.Dir ltr  (align left-to-right) 

rtl  (align right-to-left) 

dir attribute specifies the direction of the text to be aligned within the 

entire document.It is  global attribute.  

2.Lang Predefined language code English – 

en Tamil – ta  

Telugu – te 

lang attribute specify the language used within the document.  

Malayalam – ml; Kannada – kn; Hindi – hi; French – fr; German – de; 

3. How do you view the source file? (S-2022) 

❖ Right click on the browser. 
❖ Select View Page Source (Firefox and Chrome) / View Source (Internet Explorer) or Press Ctrl + U (all browser)  

❖ Source file will be displayed. 

❖ In Internet Explorer, View → Source is also used to open source file. 

4. How do you save a file as HTML file?  

❖ Start→ All programs→ Notepad→ Accessories  (Windows 7) 

❖ Click File → Save (or) Press Ctrl + S 

❖ Save as dialog box appears 

❖ In “File Name” text box, type a file name with .htm or .html extension. 

❖ Select “All Files” from “Save as type” list box. 

❖ Click “Save” button. 

 CHAPTER- 11 HTML – Formatting text, Creating Tables, List and Links 
1. Write an HTML code to display the following text in exactly the same way as   given below.    

I am studying Computer Science Application.         

<html> 

<head> 

<title> My first Web page</title> 

</head> 

<body>   

 I am studying Computer Science Application  

</body> 

</html> 

2. Briefly explain the attributes of <hr> tag.  (S-2021) (J-2023) 

❖ The <hr> tag having four attributes viz. size, width, no shade and color. 

1. Size:          Thickness of the horizontal line can be changed with size attribute.  

                        The size is given in terms of pixels.  

2. Width:       The width attribute specifies the horizontal width of the rule line. 

3. Noshade:   The default view of a horizontal rule line is 3D.  

4. Color: The horizontal line is displayed in gray color by default.  

Syntax:         <hr size=valuewidth=valuenoshade, color=color_name/code> 

3. What are the core tags used to create table in HTML? (M-2022) 

1. <table> tag is used to create a table.    2. <tr> tag defines table rows 

3. <th> tag defined table columns                  4. <td> tag is used to specify the data in a cell. 

5. <caption> tag defines title for the table. 
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4. Write an HTML code to provide hyperlink to https://www.w3schools.com 
<html> 

<head> 

<title> hyperlink </title> 

</head> 

<body>  

      <h1 align=center> Welcome to <br> 

      <a href= http://www.w3schools.com>w3 schools </A> 

      </h1>  

</body> 

</html> 
5. Difference between <UL> and <OL> tags. (M-2023) 

Un ordered list Ordered list 

❖ Unordered lists are often referred as bulleted 

lists.  

❖ Ordered list displays items in a numerical or alphabetical 

order within the tag pair <OL> …… /OL> tag.  

❖ Instead of numbers, each element in the list has 

prefixed with a special bullet symbol.  

❖ Each list element is defined by <LI> tag. 

❖ Unordered list is surrounded within <UL>… </UL> tags.  ❖ Both <OL> and <LI> tags are container tags. 

❖ Each list element is defined by <LI> tag ❖ No closing tag. 
 

6. Write HTML code to produce the following table: 

A B 

C 

<html> 

<head> 

<title> Table </title> 

</head> 

<body> 

<table border  =  1 width = 50%> 

<tr> 

<th rowspan = 2> A </td><td> B </td>  

</tr> 

<tr> 

<td> C </td 

</tr> 

</table> 

</body> 

</html> 

1. What are the uses of <strong> and <em> tag? (S-2022) 

1.<strong> Important text: 

❖ The <strong> tag is a phrase tag.  

❖ It is used to define important text.  

❖ This tag displays the text as bold.  

2.<em> - Emphasized text:  

❖ The <em> tag is used to emphasize the text.  

❖ That means, when you use this tag, the text will be in italics. 

2. Write an HTML code to scroll the following message in a web page. (M-2019) 

“Welcome to HTML” 

<html> 

<head> 

<title> Marguee </title> 

</head> 

<body> 

<marguee > Welcome to HTML </marquee> 

</body> 

</html> 

 CHAPTER- 12 HTML – Adding multimedia elements and Forms 
1. Write a short note on familiar images format. (M-2020)                          

1.GIF (Graphical Interchange Format): 

❖ This format is one of the popular format for animated images. 

❖ JPEG is the most popular image format supported by all web browsers. 

❖ This format is suitable for presenting tiny animated images, logos, icons,etc., 

2.JPEG (Joint Photographic Experts Group): 

❖ This format is suitable for photographic images. 
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❖ JPEG can include any number of colours. 

3.PNG (Portable Network Graphics): 

❖ PNG is designed as a replacement for GIF. 

❖ It is also supported by all browsers. 

4.SVG (Scalable Vector Graphics)  

❖ SVG is a graphics format that was developed for web. 

❖ It was standardized by World Wide Web Consortium (W3C) in 2001. 

❖ All current web browsers supports basic features of SVG. 

2. How will you scroll the text in HTML?  

❖ In HTML, a piece of text or image can be moved horizontally or vertically by using <marquee> tag.  

❖ This feature makes a web page as more attractive.  

General format:     <marquee> Text or image to be scroll </marquee> 

Example :   <marquee> <b> The Government of Tamilnadu </b>, Directorate of School Education </marquee> 

3. Explain the main attributes used with <form> tag. (S-2020)(M-2022)(M-2024) 

Method: 
❖ The method attribute of the form tag is used to identify how the form element names and values will be sent to the server.  

❖ The get method will append the names of the form elements and their values to the URL. 

Action  

❖ The action attribute identifies the server side program or script that will process the form.  

❖ The action will be the name of a Common Gateway Interface (CGI) program written in programming 

languages like Perl, JavaScript, PHP or Active Server Pages (ASP). 

General Format of <form> tag  

<Form method=get/post action= “back_end_server_script”> 

Form elements  

</Form> 

4. Explain the values of <input> tag’s type attribute. (S-2022)(J-2023) 
 

1.Text Create a Text Box.  

The element used to get all kind of text input such as name, address. 

2.Password Similar as Text box. But, while entering data, the characters are appearing as coded symbols 

such as asterisk. 

3.Checkbox   

   Multi select box 

Check box is an element appearing like a small square box.  

4.RadioButton Radio button is used to select any one of the multiple options from the list.  

5.Reset It is a special command button used to clear all the entries made in the form. 

6.Submit It is also a special command button used to submit all the entries made in the form to the backend server. 

7.Button This is a standard graphical button on the form used to call functions on click. 

5. Explain the attributes of <select> and <option> tags. (J-2019)(S-2019)(S-2021) 

1.Attributes of <Select> tag: 

❖ Name – Provide the name to the control, which is sent to the server. 

❖ Size – Determine the style of dropdown list box.  

❖ Size = 1 dropdown list box  

❖ Size = 2 List box 

❖ Multiple – Allows user to select multiple values. 

2.Attributes of <Option> tag: 

1.Selected – Indicate default selection 

❖ Value – Value to be submitted to server 

 CHAPTER- 13 CSS – Cascading Style Sheets 
1. What are the advantages of using CSS?  (J-2019)(M-2019)(M-2024)                                 

1.Maintainability: 

❖ CSS are also defined and stored as separate files.  
❖ So, the style and appearance of a web page can be dynamically changed and maintain with less effort. 

2.Reusability :  

❖ The styles defined in CSS can be reused in multiple HTML pages. 

3.Easy to understand :  
❖ The tags in web pages are well organized with style specifications and therefore it is easy to understand 

2. Write a short note on rule of CSS. (J-2024) 

❖ CSS style declaration consists of two major parts; Selector and Declaration. 

❖ The Selector refers an HTML tag in which you want to apply styles.  

❖ The Declaration is a block of code contains style definition.  

❖ It should be surrounded by curly braces.  

❖ You can include any number of properties for each selector, and they must be separated by semicolons.  
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❖ The property name and its value should be separated by a colon.  

❖ Each declaration should be terminated by a semicolon (;) 

3. Write a CSS file to define text color and alignment to <p> tag. (S-2020) 

P 

{ 

color:pink;  

Text-align : center; 

}  

 The above code can be saved para.css 

Example: 
<html> 

<head> 

<title> Demonstration of using CSS </title> 

<link rel="stylesheet" type="text/css" href="mystyle.css"> 

</head> 

<body> 

<H1> Welcome to CSS </H1> 

<P>  

CSS was invented by HakonWium Lie on October 10, 1994 and maintained through a group of people within the W3C called 

the CSS Working Group. The CSS Working Group creates documents called specifications.  

</P> 

</body> 

</html> 
4. Write a CSS file to define font type, style and size to <h1> tag 

Mystyle.css 

H1 

{  

    font-family : "Comic Sans MS";  

    Font-weight : Bold;  

    border:2px solid blue;  

} 

Test.html 

<html> 

<head> 

<title> Demonstration of using CSS </title> 

<link rel="stylesheet" type="text/css" href="mystyle.css"> 

</head> 

<body> 

<H1> Welcome to CSS </H1> 

</body> 

</html> 

 CHAPTER- 14 Introduction to Java script 
1. What are the advantages of programming language?      

❖ Java script programming language is used to develop interactive pages (Dynamic Web page) JavaScript 

programming language is used. 

❖ User entered data in the Dynamic Web page can be validated before sending it to the server.  

❖ This saves server traffic, which means less load on your server. 

❖ JavaScript includes such items as Textboxes, Buttons, drag-and-drop components and sliders to give a Rich 

Interface to site visitors.  

❖ For example creating a new email account in any service provider. 

2. Brief the basic data types in Java Scripts. (J-2023)(M-2024) 

❖ The basic data types in JavaScript are Strings, Numbers, and Booleans. 

1.String: 

❖ String is a list of characters a string literal is indicated by enclosing the characters in single (single character) 

or double quotes. 

2.Numbers: 

❖ Number can be integer or floating-point numerical value and numeric literals are specified in the natural way. 

3.Boolean: 

❖ Boolean can be any one of two values: true or false. 

❖ Boolean literals are indicated by using true or false directly in the source code 

3. Write note on string Operator (S-2021) 

❖ + Operator is also called as the string concatenation operator. 

❖ Because string concatenation has precedence over numeric addition, + will be interpreted as string 

concatenation if any of the operands are strings. 
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Example:  String1:java       String2:script 

                  Concatenated string of string1 and string2:javascript 

4. Write about <script> tag. (M-2019)(J-2024) 

❖ The <script> …….</script> tag containing JavaScript can be placed anywhere within in the web 

page, but it is normally recommended that should be kept it within the <head> tags. 

❖ The <script> tag alerts the browser program to start interpreting all the text between these tags as a 

script commands. 

Syntax: 

<script language=”javascript” type=”text/javascript”> JavaScript code 

</script> 

❖ The <SCRIPT> tag takes two important attribute 1.language 2.type. 

5. What are the uses of Logical Operators? 

❖ Best practice is to use logical operators on Boolean operands.  
❖ However, operands of any type can be combined. The strict rules are as follows: 
❖ For && (AND) the result is false if the first operand is false; otherwise, the result is the Boolean value of the second operand. 

❖ For || (OR) the result is true if the first operand is true; otherwise, the result is the Boolean value of the second operand. 

❖ For ! (NOT) the result is true if the operand is false; otherwise, the result is true. 

6. Difference between the increment and Decrement operator. (S-2022) 

        Increment operator               Decrement operator 
❖ The ++ operator increments its single operand. ❖ The - - operator decrements its single operand 

❖ Its converts its operand to a number, 

adds 1 to that number, and assigns the 

incremented value back into the Operand 

❖ Its converts its operand to a number, subtracts 1 to 

that number, and assigns the decremented value 

back into the operand 

❖ Post increment: var m=3, n=m++; 

❖ Pre increment: var m=3, n=++; 

❖ Post decrement: var m=3, n=m--; 

❖ Pre decrement: var m=3, n=m--; 
 

1. Write the rules for naming a variable in java script (J-2019) 

❖ The first character must be a letter or an underscore (_). Number cannot be as the first character.  

❖ The rest of the variable name can include any letter, any number, or the underscore.  

❖ You can't use any other characters, including spaces, symbols, and punctuation marks. 

❖ JavaScript variable names are case sensitive.  
❖ That is, a variable named Register Number is treated as an entirely different variable than one named register number. 

❖ There is no limit to the length of the variable name. 

❖ JavaScript's reserved words cannot be used as a variable name.  

❖ All programming languages have a supply of words that are used internally by the language and that cannot be 

used for variable names.  

 CHAPTER- 15 Control Structure in Java script 
1. What is if statement and write its types.                                                 

❖ The if-statement is the control statement that allows to make decisions to execute statements conditionally. 

❖ This statement has two forms.  

❖ The form is for only true condition. 

The syntax:                        
if (condition)  

{                                              

True block;                       

} 

2.If..else…statement: 

❖ The second type of the if statement is the if..else contorl structure in either of the two branches depending on 

the condition is executed. 

Syntax: 
if (expression)   

{  

statements if true  

}  

else  

{  

statements if false 

 } 

2. Write the syntax for  else-if statement. (S-2021) 

If (condition 1)  

{   

   block 1;  

}  

else if (condition 2)  

{   

     block 2; }  
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else if (condition 3)  

{  

   block 3;  

}  

else  

{  

   block 4; 

} 

3. What is called a loop and what are its types? (M-2020) (M-2022)(J-2024) 

❖ In JavaScript there are times when the same portion of code needs to be executed many times with slightly 

different values is called Loops.  

❖ JavaScript supports three kinds of looping statements.  

❖ They are 1. For loop, 2.while loop 3.do..while loop 

4. Differentiate between while and do while statements. (S-2020) (J-2023) 

            While          do while  

❖ Entry check loop ❖ Exit check loop 

❖ The condition is checked at the beginning of the 

body of the while loop and executes the loop 

repeatedly until the condition is TRUE. 

❖ The condition is checked at the end of the body of the 

do while loop. 

❖ Therefore, the body of the loop is executed at least 

once when the condition is evaluated as false. 

Syntax:  

while (condition)  

{  

body of the loop  

} 

Syntax : 

do  

{  

body of the loop  

} while (expression); 
 

5. What message will be displayed, if the input for age is given as 20, for the following snippet? (M-2019)   

Answer : 

if (age> = 18 )                                                    Message will be display like, 

{                                                                       you are eligible to get Driving licence 

alert (“you are eligible to get Driving licence”}         

}                                                                           

else                                                            

alert (“you are not eligible to get driving licence”);  

 } 

1. List out various branching statements in java script (M-2023) 

• if statement  • if … else statement  • else if statement • switch statement 

2. Write a syntax of if statement (S-2021) 

if (condition)  

{                                              

True block;                       

} 

3. What message will be displayed, if the input marks is given as 60, for the following snippet? (J-2019)   

if (marks> = 40 )                                                    Message will be display like, 

{                                                                                    you have passed 

alert (“you have passed”}         

}                                                                           

else                                                            

alert (“you have failed”);  

 } 

 CHAPTER- 16 JavaScript Functions 
1. Write a program in JavaScript to find the cube of a number using function           

<html>  

<head>  

<title> Cube of a number using Function</title>  

</head>  

<body>  

<script type="text/JavaScript">  

function cube(x)  

{  

return x?x? x;  

}  

var n = window.prompt("Enter a number:", "0");  

var c = cube(n);  

document.writeln("The cube of " + n + " is " + s);  
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</script>  

</body>  

</html> 

2. Write a program in JavaScript to find the sum of 10 numbers using function. 

<html>  

<head> <title> Sum using Function</title> </head>  

<body>  

<script type="text/JavaScript">  

function sum(x)  

{  

var x, s = 0;  

for(var i = 1; i <= 10; i++)  

{  

x = prompt(“Enter a number: “, “0”);  

s = parseInt(s) + parseInt(x);  

}  

return s;  

}  

document.writeln("The sum of given 10 numbers = " + sum());  

</script>  

</body>  

</html> 

1. Write the syntax of functions (S-2020) 

Function function-name(parameters list)  

{ 

       Declaration of variable 

       Executable statements;         Function Body 

} 

2. Describe any three pre-defined functions in JavaScript with examples (M-2022) 

Function Description Example Result 

toUpperCase() Used to convert given string into uppercase  x=”java” 

x.toUpperCase(); 

JAVA 

toLowerCase() Used to convert given string into lowercase x=”JAVA” 

x.toLowerCase(); 

java 

length Used to find length of the given string x=”JAVA” x.length(); 4 

parseInt() Used to convert the given float value into an integer parseInt(34.234); 34 

parseFloat() Used to convert the given string into a integer parseInt(“34.23”); 34.23 
 

3. What is function in java script? Write its types. (M-2024) 

Function: 
❖ A function is a block of java script code that is defined once but may be executed or invoked any number of times. 

❖ Java script supports two types of functions, 1.Predefined or library functions 2.User-defined functions 

 CHAPTER – 17 Computer Ethics and Cyber Security 
1. What is the role of firewalls?                                                              

❖ A firewall is a computer network security based system that monitors and controls incoming and outgoing 

network traffic based on predefined security rules. 

❖ A firewall commonly establishes a block between a trusted internal computers.  

❖ A firewall commonly establishes a block between a trusted internal computer network and entrusted computer 

outside the network.  

2. Write about encryption and decryption. (M-2023) 

Encryption: 

❖ Processes that ensure confidentiality that only authorized persons can access the information. 

❖ The process of translating the plain text data into random and mangled data. 

❖ Used by militaries and governments to facilitate secret communication. 

Decryption: Reverse process of converting the cipher-text back to plaintext. 

3. Explain about proxy server. 

❖ A proxy server acts as an intermediary between the end users and a web server.  

❖ A client connects to the proxy server, requesting some service, such as a file, connection, web page, or other 

resources available from a different server.  

❖ The proxy server examines the request, checks authenticity and grants the request based on that.  
❖ Proxy servers typically keep the frequently visited site addresses in its cache which leads to improved response time.  
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4. What are the guidelines to be followed by any computer user? 

1.Honesty :  

❖ Users should be truthful while using the internet. 

2.Confidentiality:  

❖ Users should not share any important information with unauthorized people. 

3.Respect :  

❖ Each user should respect the privacy of other users.  

4.Professionalism:  

❖ Each user should maintain professional conduct. 

5.Obey The Law:  

❖ Users should strictly obey the cyber law in computer usage. 

6.Responsibility: 

❖ Each user should take ownership and responsibility for their actions. 

5. What are ethical issues? Name some. (M-2020)(S-2022) 

❖ An Ethical issue is a problem or issue that requires a person or organization to choose between alternatives that 

must be evaluated as right (ethical) or wrong (unethical).  

Some of the common ethical issues are listed below: 

1. Cyber-crime 2) Software Piracy 3) Unauthorized Access 4) Hacking 5) Use of computers to commit fraud 6) 

Sabotage in the form of viruses 7) Making false claims using computers. 

1. What is meant by computer ethics?  

❖ Computer ethics deals with the procedures, values and practices that govern the process of consuming 

computer technology and its related disciplines without damaging or violating the moral values and beliefs of 

any individual, organization or entity. 

❖ It is a set of moral principles that rule the behaviour of individuals who use computers.  

❖ An individual gains knowledge to follow the right behaviour, using morals that are also known as ethics. 

2. Write a short note on cracking.  (M-2023) 

❖ Cracking” means trying to get into computer systems in order to steal, corrupt, or illegitimately view data. 

❖ Cracking is where someone edits a program source so that the code can be exploited or modified. 

❖ A cracker is a malicious or criminal hacker. 

 CHAPTER – 18 (Tamil Computing) 

1. Write a short note on Tamil virtual Academy. (M-2023) 

❖ With the objectives of spreading Tamil to the entire world through internet, Tamil Virtual University was 

established by the Govt. of Tamilnadu. 

❖ This organization functions with the name of “Tamil Virtual Academy”. 

❖ It offers different courses in Tamil language, Culture, heritage etc., 

2. Define – Unicode (S-2020) 

❖ Unicode is an encoding system, designed to handle various world languages, including Tamil.  

❖ Its first version 1.0.0 was introduced in October 1991.  

❖ Unicode is the best suitable to handle Tamil. 
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      CHAPTER 1 TO 18 five mark BOOK BACK & public QUESTION with ANSWERS 
 CHAPTER – 1 Introduction to Computers 

1. Explain the basic components of a computer with a neat diagram.  (M-2019) (S-2020)(S-2022)   

❖ The computer is the combination of hardware and software.  

❖ Hardware is the physical component of a computer like motherboard, memory devices, monitor, keyboard etc.,  

❖ Software is the set of programs or instructions.  

❖ Both hardware and software together make the computer system to function.       

❖ Every task given to a computer follows an Input- Process- Output Cycle (IPO cycle).  

❖ It needs certain input, processes that input and produces the desired output.   

 
Input Unit  
❖ Input unit is used to feed any form of data to the computer, which can be stored in the memory unit for further processing.  

❖ Example: Keyboard, mouse, etc. 

Central Processing Unit  (CPU): 

❖ CPU is the major component which interprets and executes software instructions. 

❖ It also controls the operation of all other components such as memory, input and output units. 

❖ The CPU has three components which are Control unit, Arithmetic and logic unit (ALU) and Memory unit. 

1.Arithmetic and Logic Unit: 

❖ The ALU is a part of the CPU where various computing functions are performed on data. 
❖ The ALU performs arithmetic operations such as addition, subtraction, multiplication, division and logical operations. 

❖ The logical operations of ALU promote the decision-making ability of a computer. 

2.Control Unit: 

❖ The control unit controls the flow of data between the CPU, memory and I/O devices. 

❖ It also controls the entire operation of a computer. 

3.Output Unit: 

❖ An Output Unit is any hardware component that conveys information to users in an understandable form. 

❖ Example: Monitor, Printer etc. 

4.Memory Unit: 

❖ The Memory Unit is of two types which are primary memory and secondary memory. 

❖ The primary memory is used to temporarily store the programs and data. 

❖ The secondary memory is used to store the data permanently. 

❖ The Primary Memory is volatile, the Random Access Memory (RAM) is an example of a main memory. 
❖ The Secondary memory is non-volatile, hard disk, CDROM and DVD ROM are examples of secondary memory. 

2. Discuss the various generations of computers. (J-2019)(M-2020)(S-2021) (M-2022)(M-2023) (J-2024) 

Generation & 

Period       

Main Component 

used 

            Merits/Demerits 

First 

Generation 

1940-1956 

Vacuum tubes ❖ Big in size 

❖ Consumed more power 

❖ Malfunction due to overheat 

❖ Machine Language was used 

Second 

Generation 

1956-1964 

Transistors 

 

❖ Smaller compared to First Generation 

❖ Generated Less Heat 

❖ Consumed less power compared to first generation 

❖ Punched cards were used 

❖ First operating system was developed – Batch Processing and 

Multiprogramming Operating System 

❖ Assembly language was used. 

Third 

Generation 

   1964-1971 

 

Integrated 

Circuits (IC) 

 

❖ Computers were smaller, 

❖ faster and more reliable 

❖ Consumed less power 

❖ High Level Languages were used 

Fourth Microprocessor ❖ Smaller and Faster 
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Generation 

1971-1980 

Very Large Scale 

Integrated Circuits  (VLSI) 
❖ Microcomputer series such as IBM and APPLE were developed 

❖ Portable Computers were introduced. 

Fifth 

Generation 

1980 – till 

date 

Ultra Large Scale 

Integration(ULSI) 

 

❖ Parallel Processing  

❖ Super conductors 

❖ Computers size was drastically reduced. 

❖ Can recognise Images and Graphics 

❖ Introduction of Artificial Intelligence and Expert Systems  

❖ Able to solve high complex problems including decision making 

and logical reasoning 
Sixth 

Generation 

In future 

 

❖ Parallel and Distributed computing 

❖ Computers have become smarter, faster and smaller 

❖ Development of robotics 

❖ Natural Language Processing 

❖ Development of Voice Recognition Software 
 

3. Explain the following  a. Inkjet Printer b. Multimedia projector c. Bar code / QR code Reader (J-2023)(M-2024) 

1.Inkjet Printers:                                                                                                                       

❖ Inkjet Printers use colour cartridges which combined Magenta, Yellow and Cyan inks to create colour tones.  
❖ A black cartridge is also used for monochrome output. Inkjet printers work by spraying ionised ink at a sheet of paper.  

❖ The speed of Inkjet printers generally range from 1-20 PPM (Page Per Minute). 

❖ A tiny electric currents controlled by electronic circuits are used inside the printer to spread ink in jet speed. 

❖ An Inkjet printer can spread millions of dots of ink at the paper every single second. 

2.Multimedia Projectors:  

❖ Multimedia projectors are used to produce computer output on a big screen. 

❖ These are used to display presentations in meeting halls or in classrooms. 

3. i) Bar Code / QR Code Reader:  

❖ A Bar code is a pattern printed in lines of different thickness.  

❖ The Bar code reader scans the information on the bar codes transmits to the Computer for further processing.  

❖ The system gives fast and error free entry of information into the computer. 

ii) QR (Quick response) Code:  
❖ The QR code is the two dimension bar code which can be read by a camera and processed to interpret the image. 

1. Explain Data and information (M-2022) 

Data:  
❖ Data is defined as a un- processed collection of raw facts, suitable for communication, interpretation or processing.  

❖ For example, 134, 16 ‘Kavitha’, ‘C’ are data.  

❖ This will not give any meaningful message.  

Information:  

❖ Information is a collection of facts from which conclusions may be drawn.  
❖ In simple words we can say that data is the raw facts that is processed to give meaningful, ordered or structured 

information.  

❖ For example Kavitha is 16 years old.  

❖ This information is about Kavitha and conveys some meaning.  

❖ This conversion of data into information is called data processing. 

 CHAPTER – 2 Number Systems 

1. a) Write the procedure to convert fractional Decimal to Binary. (M-2020)(M-2023)         

❖ The method of repeated multiplication by 2 has to be used to convert such kind of decimal fractions. 

The steps involved in the method of repeated multiplication by 2: 

• Step 1: Multiply the decimal fraction by 2 and note the integer part.  

o The integer part is either 0 or 1. 

• Step 2: Discard the integer part of the previous product.  

o Multiply the fractional part of the previous product by 2.  

o Repeat Step 1 until the same fraction repeats or terminates (0). 

• Step 3: The resulting integer part forms a sequence of 0s and 1s that become the binary equivalent of decimal fraction. 

• Step 4: The final answer is to be written from first integer part obtained till the last integer part obtained. 

 

b) Convert  (98.46)10  to binary: (M-2023)  

I.Integer Part:                    II. Fractional Part:      Integer     

2  98      98 = (1100010)2        0.46x2= 0.92                   = 0 

2  49-0                                  0.92x2= 1.84                   = 1           (46)10 = (.0110010)2 

2  24-1                                  0.84x2= 1.68                   = 1 

2  12-0                                 0.68x2= 1.36                    = 1           (98.46)10 = (1100010.0111010….)2 

2  6-0                                    0.36x2 = 0.72                  = 0 

2  3-0                                    0.72x2= 1.44                   = 1 

    1-1                                    0.44x2= 0.88                   = 0 
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2. Find 1’s Complement and 2’s Complement for the following Decimal number a) -98  b)- 135     (J-2024)                                               

2  98                        (98)             1100010 

2  49-0                      8 bit                   01100010 

2  24-1                      1’s compliment                10011101 

2  12-0                         (-98)              (10011110)2 

2  6-0 

2  3-0 

    1-1 

       1  

1’s 1 0 0 1 1 1 0 1 

        1 

2’s 1 0 0 1 1 1 1 0 

b) (-135)                                                                                   

2  135                        (135)                    10000111 

2  67-1                      8 bit                    10000111 

2  33-1                      1’s compliment                   01111000 

2  16-1                       2’s compliment                01111001 

2  8-0                            (-135)        (01111001)2 

2  4-0 

2  2-0 

    1-0 

         

1’s 0 1 1 1 1 0 0 0 

        1 

2’s 0 1 1 1 1 0 0 1 
 

3. a) Add  11010102 + 1011012   (S-2020) (M-2023)                             

 1 1  1     

  1 1 0 1 0 1 0 

   1 0 1 1 0 1 

+ 1 0 0 1 0 1 1 1 

11010102+1011012  = 100101112 

 

b. Subtract 11010112 – 1110102 

  0 10 10     

  1 1 0 1 0 1 1 

   1 1 1 0 1 0 

-  0 1 1 0 0 0 1 

11010112  - 1112 =  1100012 

1. 1) Find the 2’s complement of (-46)10  2) Convert (145)8 to binary (S-2020) (J-2023) 

1. (-46) 

2  46                         (46)               101110 

2  23-0                      8 bit                00101110 

2  11-1                      1’s compliment                 11010001 

2   5-1 

2   2-1 

     1-0 

       1  

1’s 1 1 0 1 0 0 0 1 

        1 

2’s 1 1 0 1 0 0 1 0 

(-46)        11010010 

2) Convert (145)8 to binary 

(145)8   ( ? )2 

1          4         5         

 

001      100     101        (145)8 = (001100101)2 
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1. Covert the following Decimal numbers to its equivalent Binary, Octal, Hexadecimal (M-2019)(M-2022) 

1)  1920   2) 255   3) 126 

1. (1920)10  = ( ? )2 

Step :1 

2  1920         (1920)10 = (11110000000)2 

2  960-0        Step :2   (Binary to Octal) 

2  480-0                 (11110000000)2   (?)8            

2  240-0                 011  110  000  000              (1920)10 = (3600)8 

2  120-0                   3      6      0       0 

2  60-0 

2  30-0            Step : 3  (Binary to Hexa Decimal) 

2  15-0                   (11110000000)2   (?)16 

2  7-1                    0111  1000  0000              (1920)10 = (780)16 

2  3-1                     7          8        0  

    1-1 

2. (255)10  = ( ? )2 

Step :1 

2  255        (255)10 = (11111111)2 

2  127-1        Step :2   (Binary to Octal) 

2  63-1                 (11111111)2   (?)8            

2  31-1                 011  111  111             (255)10 = (377)8 

2  15-1                  3      7      7        

2  7-1 

2  3-1           Step : 3  (Binary to Hexa Decimal) 

    1-1                    (11111111)2   (?)16 

                            1111  1111               (255)10 = (FF)16 

                              F          F       

3. (126)10  = ( ? )2 

Step :1 

2  126        (126)10 = (1111110)2 

2  63-0        Step :2   (Binary to Octal) 

2  31-1                 (1111110)2   (?)8            

2  15-1                 011  111  110             (126)10 = (376)8 

2  7-1                    3      7        6       

2  3-1 

2  1-1           Step : 3  (Binary to Hexa Decimal) 

                                 (1111110)2   (?)16 

                            0111  1110               (126)10 = (7E)16 

                             7          E        

2. Convert (155)10 into Binary, Octal and Hexadecimal equivalent (M-2019) 

Step: 1                                  

2 155   (155)10 = (10011011)2 

2 77-1        Step: 2 

2 38-1         8  155      (155)10 = (233)8       Step: 3  

2 19-0         8  16-3                                         16  155            (155)10 = (9B)16    (11=b) 

2 9-0                2-3                                                 9-11 

2 4-1 

2 2-0 

    1-0 

3. Find 1’s Complement and 2’s Complement for the following Decimal number a) -89 b)- 128  (J-2019)                                               

2  89                        (-89)             1011001 

2  44-1                      8 bit                01011001 

2  22-0                     1’s compliment                    10100110 

2  11-0                         (-89)              (10100111 )2 

2  5-1 

2  2-1 

    1-0 

         

1’s 1 0 1 0 0 1 1 0 

        1 

2’s 1 0 1 0 0 1 1 1 
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b) (-128)                                                                                   

2  128                        (-128)      10000000 

2  64-0                      8 bit                   10000000 

2  32-0                      1’s compliment                    011111111 

2  16-0                       2’s compliment                  01111001 

2  8-0                            (-128)        (10000000)2 

2  4-0 

2  2-0 

    1-0 

 1 1 1 1 1 1 1  

1’s 0 1 1 1 1 1 1 1 

        1 

2’s 1 0 0 0 0 0 0 0 
 

4. a) Convert  (58.36)10  to binary: (J-2023) 

I.Integer Part:                    II. Fractional Part:      Integer     

2  58      58 = (111010)2           0.36x2= 0.72                   = 0 

2  29-0                                  0.72x2= 1.44                   = 1           (58)10 = (.011101)2 

2  14-1                                  0.44x2= 0.88                   = 1 

2  7-0                                   0.88x2= 1.76                    = 1           (58.36)10 = (111010.011101….)2 

2  3-1                                   0.76x2 = 1.52                  = 0 

2  1-1                                    0.52x2= 1.04                   = 1 

b) Find the 2’s complement of (-55)10  

2  55                         (-55)               101101 

2  22-1                      8 bit                00101101 

2  11-0                      1’s compliment                11010010 

2   5-1 

2   2-1 

     1-0 

         

1’s 1 1 0 1 0 0 1 0 

        1 

2’s 1 1 0 1 0 0 1 1 

(-55)        11010011 

7. b) Convert  (98.42)10  to binary: (M-2020)  

I.Integer Part:                    II. Fractional Part:      Integer     

2  98      98 = (1100010)2        0.42x2= 0.84                   = 0 

2  49-0                                  0.84x2= 1.68                   = 1           (42)10 = (.011101)2 

2  24-1                                  0.68x2= 1.36                   = 1 

2  12-0                                 0.36x2= 0.72                    = 1           (98.42)10 = (1100010.011101….)2 

2  6-0                                    0.72x2 = 1.44                  = 0 

2  3-0                                    0.44x2= 0.88                   = 1 

    1-1                              

8. a) Convert  (58.46)10  to binary: (M-2024) 

I.Integer Part:                    II. Fractional Part:      Integer     

2  58      58 = (111010)2           0.46x2= 0.92                   = 0 

2  29-0                                  0.92x2= 1.84                   = 1           (58)10 = (.0111010)2 

2  14-1                                  0.84x2= 1.68                   = 1 

2  7-0                                   0.68x2= 1.36                    = 1           (58.46)10 = (111010.0111...….)2 

2  3-1                                   0.36x2 = 0.72                  = 0 

2  1-1                                    0.72x2= 1.44                   = 1 

9. b) Write the 1’s complement number and 2’s complement number for the following decimal numbers: (M-2024) 

1) (-24) 

2  24        - 24     = 110002 

2  12-0     8 bit   = 00011000 

2  6-0       1s      = 111001112 

2  3-0                                  1 

    1-1       2s      = 111010002 
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2) (- 65) 

2  65          -65 = 100000012 

2  32-1       8bit = 01000001 

2  16-0       1s   = 101111102              

2  8-0                                 1  

2  4-0         2s   = 101111112 

2  2-0 

    1-0 

 CHAPTER – 3 Computer Organization 

1. Explain the characteristics of a microprocessor. (J-2019)(M-2020) (J-2023) (J-2024)                            

❖ A Microprocessor’s performance depends on the following characteristics:  

         a) Clock speed           b) Instruction set        c) Word size 

a) Clock Speed:  

❖ Every microprocessor has an internal clock that regulates the speed at which it executes instructions.  

❖ The speed at which the microprocessor executes instructions is called the clock speed.  

❖ Clock speed is measured in MHz (Mega Hertz) or in GHz (Giga Hertz). 

b) Instruction Set:  

❖ A command which is given to a computer to perform an operation on data is called an instruction.  
❖ Basic set of machine level instructions that a microprocessor is designed to execute is called as an instruction set.  

❖ This instruction set carries out the following types of operations:  

1.Data transfer, 2.Arithmetic operations, 3.Logical operations, 4.Control flow , 5.Input/output  

c) Word Size:  

❖ The number of bits that can be processed by a processor in a single instruction is called its word size.  

❖ Word size determines the amount of RAM that can be accessed by a microprocessor. 

2. How the read and write operations are performed by a processor? Explain. 

❖ A bus is a collection of wires used for communication between the internal components of a computer.  

❖ The read operation transfers the data (bits) from word to Memory Data Register.  

❖ The read operation fetches data from memory and transfers to MDR.  

❖ A single control line performs two operations like Read/Write using 1or 0. 

❖ Also, the write operation transfers data from the MDR to memory. 

❖ The word in the RAM has the same size (no. of bits) as the Memory Data Register (MDR).  

❖ If the processor is an 8-bit processor like Intel 8085, its MDR and the word in the RAM both have 8 bits. 

❖ If the size of the MDR is 8 bits, which can be connected with a word in the memory which can be connected 

with a word in the memory which is also 8 bits size. 

❖ The data bus has eight parallel wires to transfer data either from MDR to word or word to MDR based on the 

control(Read/write) 

❖ This controlled line label as R/W, which becomes 1 means READ operation and 0 means WRITE operation. 

3. Arrange the memory devices in ascending order based on the access time. (S-2020) (M-2023) 

 
Blu-Ray Disc:  

❖ Blu-Ray Disc is a high-density optical disc similar to DVD.  

❖ Blu-ray is the type of disc used for PlayStation games and for playing High-Definition (HD) movies. 

❖ A double-layer Blu-Ray disc can store up to 50GB (gigabytes) of data.  

❖ DVD uses a red laser to read and write data. But, Blu-ray uses a blue-violet laser to write.  

❖ Hence, it is called as Blu-Ray. 

Cache Memory : 
❖ The cache memory is a very high speed and expensive memory, which is used to speed up the memory retrieval process.  

❖ Due to its higher cost, the CPU comes with a smaller size of cache memory compared with the size of the main memory. 

Random-Access Memory (RAM): 

❖ The main memory is otherwise called as Random Access Memory.  

❖ It is the place in a computer where the Operating System, Application Programs and the data in current use are 

kept temporarily so that they can be accessed by the computer’s processor.  

❖ The smallest unit of information that can be stored in the memory is called as a bit.  

❖ RAM is a volatile memory 

Hard Disk : 

❖ Hard disk is a magnetic disk on which you can store data.  

❖ The hard disk has the stacked arrangement of disks accessed by a pair of heads for each of the disks.  

❖ The hard disks come with a single or double sided disk. 
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4. Explain the types of ROM. (S-2021)(M-2022)(M-2024) 

Read only memory(ROM) 

❖ Read Only Memory refers to special memory in a computer with pre-recorded data at manufacturing time 

which cannot be modified.  

❖ The stored programs that start the computer and perform diagnostics are available in ROMs.  

❖ ROM stores critical programs such as the program that boots the computer.  

❖ Once the data has been written onto a ROM chip, it cannot be modified or removed and can only be read. 

❖ ROM retains its contents even when the computer is turned off. So, ROM is called as a non-volatile memory. 

1.PROM: 

❖ Programmable read only memory is also a non-volatile memory on which data can be written only once.  

❖ Once a program has been written onto a PROM, it remains there forever.  

❖ Unlike the main memory, PROMs retain their contents even when the computer is turned off.  

❖ The PROM differs from ROM. PROM is manufactured as a blank memory, whereas a ROM is programmed 

during the manufacturing process itself.  

❖ PROM programmer or a PROM burner is used to write data to a PROM chip.  

❖ The process of programming a PROM is called burning the PROM. 

2.EPROM: 

❖ Erasable Programmable Read Only Memory is a special type of memory which serves as a PROM, but the 

content can be erased using ultraviolet rays.  

❖ EPROM retains its contents until it is exposed to ultraviolet light.  

❖ The ultraviolet light clears its contents, making it possible to reprogram the memory.  

❖ An EPROM differs from a PROM, PROM can be written only once and cannot be erased.  

❖ EPROMs are used widely in personal computers because they enable the manufacturer to change the contents 

of the PROM to replace with updated versions or erase the contents before the computer is delivered. 

3.EEPROM: 

❖ Electrically Erasable Programmable Read Only Memory can be erased by exposing it to an electrical charge. 

❖ Like other types of PROM, EEPROM retains its contents even when the power is turned off.  

❖ Comparing with all other types of ROM, EEPROM is slower in performance. 

1. Explain any three secondary storage devices. (J-2019) 

1.Hard Disk : 

❖ Hard disk is a magnetic disk on which you can store data.  

❖ The hard disk has the stacked arrangement of disks accessed by a pair of heads for each of the disks. 

❖ The hard disks come with a single or double sided disk. 

2.Compact Disc (CD): 

❖ A CD or CD-ROM is made from 1.2 millimetres thick, polycarbonate plastic material.  

❖ A thin layer of aluminium or gold is applied to the surface.  

❖ CD data is represented as tiny indentations known as “pits”, encoded in a spiral track moulded into the top of 

the polycarbonate layer.  

❖ The areas between pits are known as “lands”.  

❖ A motor within the CD player rotates the disk.  

❖ The capacity of an ordinary CD-ROM is 700MB. 

3.Digital Versatile Disc (DVD):  

❖ A DVD (Digital Versatile Disc or Digital Video Disc) is an optical disc capable of storing up to 4.7 GB of 

data, more than six times what a CD can hold.  

❖ DVDs are often used to store movies at a better quality.  

❖ Like CDs, DVDs are read with a laser.  

❖ The disc can have one or two sides, and one or two layers of data per side; the number of sides and layers 

determines how much it can hold.  
❖ Double-layered sides are usually gold-coloured, while single-layered sides are usually silver-coloured, like a CD. 

4.Flash Memory Devices:  

❖ Flash memory is an electronic (solid-state) non-volatile computer storage medium that can be electrically 

erased and reprogrammed.  

❖ They are either EEPROM or EPROM.  

❖ Examples for Flash memories are pen drives, memory cards etc.  

❖ Flash memories can be used in personal computers, Personal Digital Assistants (PDA), digital audio. 

4.Blu-Ray Disc:  

❖ Blu-Ray Disc is a high-density optical disc similar to DVD.  

❖ Blu-ray is the type of disc used for PlayStation games and for playing High-Definition (HD) movies. 

❖ A double-layer Blu-Ray disc can store up to 50GB (gigabytes) of data.  

❖ DVD uses a red laser to read and write data. But, Blu-ray uses a blue-violet laser to write.  
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 CHAPTER – 4 Theoretical Concepts of Operating System 

1. Explain the concept of a Distributed Operating System along with its advantages (M-2019)(S-2022)(M-2020) (J-2024)                                                                                                      
❖ The Distributed Operating System is used to access shared data and files that reside in any machine around the world.  

❖ The user can handle the data from different locations. 

❖ The users can access as if it is available on their own computer. 

Advantages : 

❖ A user at one location can make use of all the resources available at another location over the network. 

❖ Many computer resources can be added easily in the network 

❖ Improves the interaction with the customers and clients.  

❖ Reduces the load on the host computer.                                                                                                                 

2. List out the points to be noted while creating a user interface for an Operating system. (M-2019)(S-2021 b)(M-2024) 

❖ The user interface should enable the user to retain this expertise for a longer time.            

❖ The user interface should also satisfy the customer based on their needs. 

❖ The user interface should save user’s precious time.  

❖ The ultimate aim of any product is to satisfy the customer.  

❖ The User Interface is also to satisfy the customer. 

❖ The user interface should reduce number of errors committed by the user. 

3. Explain the process management algorithms in Operating System. (M-2020)(S-2020)(M-2023) (J-2024) 

❖ Process management is function that includes creating and deleting processes (program) and providing 

mechanisms for processes to communicate and synchronize with each other.  

❖ A system task, such as sending output to a printer or screen, can also be called as a Process.  

The following algorithms are mainly used to allocate the job (process) to the processor.  

1. FIFO    2. SJF    3. Round Robin     4. Based on Priority 

1.FIFO (First In First Out)Scheduling:  

❖ This algorithm is based on queuing technique.  
❖ Technically, the process that enters the queue first is executed first by the CPU, followed by the next and so on.  

❖ The processes are executed in the order of the queue (row). 

Example: Assume that a student is standing in a queue (Row) to get grade sheet from his/her teacher, according to 

the order of the queue that is first in first out. 

2.SJF (Shortest Job First)Scheduling:  

❖ This algorithm works based on the size of the job being executed by the CPU.  

Example:  Consider two jobs A and B.  1) A = 6 kilo bytes           2) B = 9 kilo bytes  

❖ First the job “A” will be assigned and then job “B” gets its turn. 

3.Round Robin Scheduling : 

❖ The Round Robin (RR) scheduling algorithm is designed especially for time sharing systems.  

❖ Jobs (processes) are assigned and processor time in a circular method.  

Example:  Take three jobs A, B, C.  

❖ First the job A is assigned to CPU then job B and job C and then again A, B and C and so on. 

4.Based On Priority:  

❖ The given job (process) is assigned based on a Priority.  

❖ The job which has higher priority is more important than other jobs.  

Example: Take two jobs A and B. Let the priority of A be 5 and priority B be 7. 

❖ Job B is assigned to the processor before job A. 

1. Classify operating system based on the availability. (S-2020) 

Single User Operating Systems:  

❖ An operating system allows only a single user to perform a task at a time.  

❖ It is called as a Single user and single Task operating system. 

❖ MS-DOS is an example for a single user and single task Operating System. 

Multi-user Operating Systems: 

❖ It is used in computers and laptops that allow same data and applications to be accessed by multiple users at 

the same time.  

❖ The users can also communicate with each other.  

❖ Windows, Linux and UNIX are examples for multi-user Operating System. 

2. Explain the different types of software (J-2019) 

Types of Software: 

❖ Software is classified into two types:  1) Application Software  2) System Software  

1.Application Software:  

❖ Application software is a set of programs to perform specific task.  

❖ For example MS-word is an application software to create text document and VLC player is familiar 

application software to play audio, video files and many more.  

2.System Software:  
❖ System software is a type of computer program that is designed to run the computer’s hardware and application programs.  

❖ Example Operating System and Language Processor 
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3, What is an user inter face? (S-2021 a) ) 

User Interface (UI):  

❖ User interface is one of the significant feature in Operating System.  

❖ The only way that user can make interaction with a computer.  

❖ This is a main reason for key success of GUI (Graphical User Interface) based Operating System. 

❖ The GUI is a window based system with a pointing device to direct I/O, choose from menus, make selections 

and a keyboard to enter text. 

❖ Its vibrant colours attract the user very easily 

 CHAPTER – 5 Working with Windows Operating System 

1. Explain the versions of Windows Operating System.   (S-2020) (M-2022) (M-2023)     

Versions Logo Year Specific features 

Windows  

1.x  
MICROSOFT 

WINDOWS 

1985 ❖ Introduction of GUI in 16 -–bit. processor  

❖ Mouse was introduced as an input device. 

Windows 

2.x  
MICROSOFT 
WINDOWS 

1987 ❖ Supports to minimize or maximize windows.  

❖ Control panel feature was introduced with various system settings 

and customising options. 

Windows  

3.x  
MICROSOFT 

WINDOWS 

1992 ❖ Introduced the concept of multitasking.  

❖ Supported 256 colours which brought a more modern, colourful look 

to the interface. 

Windows 

NT  
MICROSOFT 
WINDOWS 

1993 ❖ Designed to act as servers in network. 

Windows 

95  
MICROSOFT 

WINDOWS 

1995 ❖ Introduced Start button, the taskbar, Windows Explorer and Start 

menu.  

❖ Introduced 32 -–bit processor and focused more on multitasking. 

Windows 

98  
MICROSOFT 
WINDOWS 

1998 ❖ Integration of the Web browser (Internet Explorer) with the Operating 

System.  

❖ DOS gaming began to disappear as Windows based games improved.  

❖ Plug and play feature was introduced. 

Windows 

Me 
 
2000 ❖ It introduced automated system diagnostics and recovery tools. 

Windows 

2000 

 

2000 ❖ Served as an Operating System for business desktop and laptop 

systems.  
❖ Four versions of Windows 2000 were released: Professional (for business 

desktop and laptop systems), Server (both a Web server and an office 

server), Advanced Server (for line-of-business applications) and Data Centre 

Server (for high-traffic computer networks). 

Windows 

XP 
 

2001 ❖ Introduced 64-bit Processor. 
❖ Improved Windows appearance with themes and offered a stable version. 

Windows 

Vista  

2006 ❖ Updated the look and feel of Windows. 

Windows 

7 

 

2009 ❖ Booting time was improved,  

❖ Introduced new user interfaces like Aero Peek, pinning programs to 

taskbar, handwriting recognition etc. and Internet Explorer 8 

Windows 

8  
2012 ❖ Windows 8 is faster than previous versions of Windows.  

❖ Start button was removed.  

❖ Windows 8 takes better advantage of multi-core processing, solid 

state drives (SSD), touch screens and other alternate input methods.  

❖ Served as common platform for mobile and computer. 

Windows 

10 

 

2015 ❖ Start Button was added again.  

❖ Multiple desktop.  

❖ Central Notification Center for App notification and quick actions.  

❖ Cortana voice activated personal assistant. 
 

2. Explain the different ways of finding a file or Folder:  (M-2024) 

To find a file or folder: 

❖ Click the Start button, the search box appears at the bottom of the start menu.  

❖ Type the name of the file or the folder you want to search.  
❖ Even if you give the part of the file or folder name, it will display the list of files or folders starting with the specified name.  

❖ The files or the folders with the specified names will appear, if you click that file, it will directly open that file or the folder. 

❖ There is another option called “See more results” which appears above the search box.  
❖ If you click it, it will lead you to a Search Results dialog box where you can click and open that file or the folder. 
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Searching Files or folders using Computer icon: 

❖ Click Computer Icon from desktop or from Start menu.  
❖ The Computer disk drive screen will appear and at the top right corner of that screen, there is a search box option.  

❖ Type the name of the file or the folder you want to search.  
❖ Even if you give the part of the file or folder name, it will display the list of files or folders starting with the specified name. 

❖ Just click and open that file or the folder 

3. Write the procedure to create shortcut in Windows OS. 
❖ Shortcuts to your most often used folders and files may be created and placed on the Desktop to help automate your work. 

❖ Select file or folder that you wish to have as a shortcut on the desktop. 

❖ Right click on the file or folder. 

❖ Select send to from the shortcut menu, then select Desktop (create shortcut) from the sub-menu. 

❖ A shortcut for the file or folder will now appear on your desktop and you can open it from the desktop in the 

same way as any other icon. 

1. Explain about the different mouse actions (M-2019) 

Action Reaction 

Point to an item Move the mouse pointer over the item. 

Click  Point to the item on the screen, press and release the left mouse button. 

Right click  Point to the item on the screen, press and release the right mouse button. Clicking the 

right mouse button displays a pop up menu with various options. 

Double-click  Point to the item on the screen, quickly press twice the left mouse button. 
 

2. Write the procedure to copy and paste files and folders to removable disk (S-2020) 

METHOD I -–Copy and Paste 

❖ Plug the USB flash drive directly into an available USB port 

If the USB flash drive or external drive folder does NOT open automatically, follow these steps: 

❖ Click Start→Computer 

❖ Double-click on the Removable Disk associated with the USB flash drive. 

❖ Navigate to the folders in your computer containing files you want to transfer. 

❖ Right-click on the file you want to copy, then select Copy. 

❖ Return to the Removable Disk window, right-click within the window, then select Paste. 

METHOD II -–Send To  

❖ Plug the USB flash drive directly into an available USB port. 

❖ Navigate to the folders in your computer containing files you want to transfer. 

❖ Right-click on the file you want to transfer to your removable disk. 

❖ Click Send To and select the Removable Disk associated with the USB flash drive. 

 CHAPTER – 6 Introduction to Word Processor 
1. What are the different methods to change margin in writer?  (J-2019) (J-2023)        

❖ Page margins are the white space around the top, bottom, left, and right of your document.  

❖ Changing or setting page margins in Open office writer can be done in two ways: 

❖ Using the Rulers -–quick and easy, but does not have precise values. 

❖ Using the Page Style dialog box – can specify precise values for the margins. 

1.Changing page margins -–using Ruler: 

❖ The shaded sections of the rulers are the margins. 

❖ Hold the mouse pointer over the line between the gray and white sections. 

❖ The mouse pointer turns into a double headed arrow. 

❖ Hold down the left mouse button and drag the mouse to move the margin and release it at the required point. 

❖ The new margin is set. 

2.Using the Page Style dialog box: 

❖ To change margins using the Page Style dialog box 
❖ Right-click anywhere on the page and select Page from the popup menu and select page tab of page style dialog box. 

❖ In the Margins boxes, specify the values for left, right, top and bottom margins. 

❖ Click on ok button. 

2. What are Header and Footer? How do you insert page numbers? (S-2022)(M-2024) 

❖ The header is a section of the document that appears in the top margin, which displays the title or chapter 

name, author name of a document. 

❖ Select from the main menu Insert →Header →Default 

❖ The header text area is separated from the normal text area. 

❖ The footer is a section of the document that appears in the bottom margin of the page which displays the page 

number, date, time etc. which gets displayed on all the pages automatically. 

❖ Select from the main menu Insert → Footer →Default 

❖ Place the insertion pointer in the footer part of the page. 

❖ Select Insert →Fields→Date to insert date in all the pages. 
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Inserting and Formatting page numbers:  

❖ The page numbers can be inserted by performing the following steps: 

❖ Place the insertion pointer where you want to insert the page number 

❖ Choose Insert → Fields → Page Numbe 

❖ The page number appears with a gray background  

Normally, the page numbers appear as 1,2,3….., To change the numbering style, the following sequence of 

steps can be performed: 

❖ Position the insertion pointer where the page number has to appear 

❖ Select Format → page, which will display the Page Style dialog box. 

❖ Select Page Tab 

❖ In the Layout settings, select the Format drop down combo box 

❖ Select the desired style and click OK button. 

3. Write the steps to Find and Replace a word with another word in Open Office writer?  (S-2021)(M-2023) 

1. Click Edit → Find & Replace (or) Ctrl + F.  

The Find & Replace dialog box appears. 

2. Type the text you want to find in the Search for box.  

To replace the text with different text, type the new text in the Replace with box. 

3. Click Find button, to start the search, the found word is highlighted.  

To replace text, click Replace button.  

The highlighted word is replaced with the word given in the Replace with box. 

4. Click Find All, Writer selects all instances of the search text in the document.  

Click Replace all button, Writer replaces all matches. 
5. Enable Match case to perform the search case sensitively so that uppercase and lower cases are distinguished separately.  

Enable Whole Words only to make the search more specific to words. 

4. Explain Page formatting in writer. (Draw 2pic – pg no:85) 

 Page formatting: 

❖ The most important thing in a word processor in page formatting. 
❖ Formatting the page elements such as margins, numbering, page layout, headers and footers is called page formatting. 

1.Changing page size: 

❖ The default page size in Writer is 8.5 x 11”, the same as that of a standard A4 printing paper.  

❖ However, for different types of documents, you may need to change the page size.  

❖ To change the paper size: 

❖ Select the page to be resized. 

❖ Select Format → Page, the page style dialog box appears. 

❖ Select Page Tab 

❖ In the paper format group, select the format like A4, legal etc. 

❖ Or the width and height option can be used to set the page size. 

❖ Under the Orientation group, select Portrait or Landscape button. 

❖ Click ok button. 

2.Changing page margins: 

❖ Select page tab 

❖ In the Margins group, specify the values for left, right, top and bottom margins. Click ok button. 

3.Orientation: 

❖ Page orientation refers to how the document will be displayed on screen and printed.  

❖ There are two different orientations:  

Landscape:  

❖ The width of the document is more than the height.  

❖ This is best suited for displaying professional photos, invitations, albums, tables etc. 

Portrait:  

❖ This is the most common and default orientation. 

❖ Here, the height of the document is more than the width.  

❖ Normally books, newspapers will be displayed in this format. 

4.Page colour:  

❖ Changing the page color is not quite common.  

❖ To do so, in the Page Style dialog box, select Background tab,  

❖ In As option click on color and select the “color” from the color palette or select “graphic” to apply an image 

as a page background 

5.Borders:  
❖ Borders can be applied to an entire document, an entire page, paragraph, or just to certain sections of the document.  

❖ From the Page Style dialog box, select the Borders tab, the User-defined area helps to define the area of 

borders, the line style of borders, color of borders can be selected. 
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1 Write the steps to create the bullets and numbering in open office Writer. (M-2020) 

Bullets : 

❖ This is a paragraph level attribute that applies a bullet character to the start of the paragraph.  

❖ In bulleted lists, each paragraph begins with a bullet character. 

The style of bullets and numbering can be changed by applying the following steps: 

1.Select the text to be bulleted, 2.Format → Bullets and Numbering, 3.Select Bullets Tab 

4.The Bullets and Numbering dialog box appears where different styles of bullets are displayed 

5.Click on the required style, 6.Click Ok button, 7.The selected text is bulleted. 

Numbering: 

❖ This attribute applies a numeral to the start of the paragraph.  

❖ Numbering is more suitable when the text has to be presented as a sequence. 

To apply Numbering: 

1.Select the text to be numbered, 2.Format → Bullets and Numbering, 3.Select Numbering Type Tab 

4.The Bullets and Numbering dialog box appears where different styles of numbering are displayed 

5.Click on the particular style,  6.Click Ok button 7.The selected text is numbered. 

2 Parts of Writer Window: (J-2019) 

1.Title Bar:  
❖ The title bar is displayed at the top of the window, which displays the name of the document and its application.  

❖ By default, the document is given the name as Untitled1.  

Control Buttons: 

❖ At the right corner of title bar the control buttons available: (1) minimize, (2) maximize/restore and (3) close 

2. Menu Bar : 

❖ The menu bar is below the title bar which comprises of various menus consisting of various options. 

1. File -–ew, Open, Close, Save, Save As, Print, Export etc.  

2. Edit –cut, copy, paste, Undo, Redo   

3. View –Toolbars, web layout, print layout, navigator etc.  

4. Insert –Inserting various elements such as pictures, tables, charts, comments, headers, footers.  

5. Format – Page size, layout, font characteristics, bullets and numbering etc.  

6. Tables–To create a table, insert rows, insert columns, split cells, merge cells etc.  

7. Tools –Spell check, macros, mail merge, end notes/footnotes etc.  

8. Window –New Window, Close Windows, Split and Freeze.  

9. Help – The Help menu displays the inbuilt help features in Open Office. 

3.Tool Bar:  

• 1.Standard Tool Bar: Cut, Copy, Paste, Undo etc…  

• 2.Formatting Tool Bar: Bold, Underline, Italics, Font type, Font color etc 

• Ruler :  (1) Horizontal ruler and (2) Vertical ruler. 

4.Work Space : 

❖ The work space is the blank area which is used to type the content of the file. 

❖ A flashing vertical bar that appears at the beginning of the screen which is called as “Insertion pointer”.  

5.Status Bar:  

❖ The status bar is at the bottom of the window which shows the current status of the document such as number 

of pages, current page number, default language etc.  

3. Selection using other methods: 

To select the text using mouse: 

i) Move the insertion pointer to the beginning of the text 

ii) Hold down the Left mouse button and drag it across the text 

iii) Release the mouse button when the required portion of text is selected  

iv) The selected text will be highlighted. 

Selection using Keyboard:+ 

To select the text using keyboard: 

i) Move the insertion pointer to the beginning of the text 

ii) Hold the Shift key and use the movement keys to drag across the required portion. 

iii) when the required portion is selected release the Shift key  

iv) The selected text will be highlighted. 

Selection using Shortcut keys: 

❖ Shortcut keys help to select the text quickly and easily. 

❖ To select a word -–Double click on the word 

❖ To select the entire document -–Press Ctrl + A 
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4. Write any 10 shortcut keys and their actions in open office writer. (S-2020) 

KEY ACTION 

→ To move a character right 

← To move a character left 

↑ To move one line up 

↓ To move one line down 

Ctrl + → One word right 

Ctrl + ← One word left  

Ctrl + ↑ One paragraph up 

Ctrl + ↓ One paragraph down 

Home To the beginning of line 

End To the end of line 

Ctrl + Home To the beginning of document 

Ctrl + End To the end of document 

Tab To move one cell to right 

Shift + Tab To move one cell to left 

Pg up(Page Up) To scroll one screen up 

Pg Down(Page Down) To scroll one screen down 
 

5. Explain auto spell check option (M-2022) 

Auto Spell Check:  

❖ Auto Spell Check option checks each word as it is typed and displays a wavy red line under any misspelled 

word. Once the word is corrected, the red wavy line disappears.  

❖ This can be done by clicking the Auto Spellcheck icon  

❖ Right-click on a word with a wavy underline, to open a powerful context menu.  

❖ Correct words can be selected from the suggested words on the menu.  

❖ The selection will replace the misspelled word with correct word.  
❖ To perform a separate spelling check on the document (or a text selection) click the Spelling and Grammar icon  

❖ This checks the document or selection and opens the Spelling dialog box (Figure 6.31) if any misspelled words are found.  

❖ This can also be achieved by pressing F7 key. 

Here are some more features of the spelling command:  

❖ Not in Dictionary text area displays the misspelled word Suggestions box displays alternate spellings.  

❖ Ignore once button is to skip the word once, Ignore All button skip all occurrences of the word. 

❖ Change button will change only that particular occurrence.  

❖ Change All button will change all occurrences of the word.  

❖ The text language can be changed (for example, Spanish, French, or German) from the Spelling dialog box. 
❖ C The new words can be added to a dictionary. Click Add in the Spelling dialog box and pick the dictionary to add it to. 

 CHAPTER -7 Working with Open Office Calc 
1. Explain about changing the column width in Calc. (M-2023)                         

Method-I 

❖ Select the columns whose width is to be changed. 

❖ Choose Format→Column→Width option. 

❖ Column Width dialog box appears. 

❖ Enter the amount in Width spin box and click OK. 

Method-II 

❖ Right click at the column lable whose width is to be changed. 

❖ Choose Column Width from the popup menu. 

❖ Column Width dialog box appears. 

❖ Enter the amount in Width spin box and click OK. 

2. Write the steps to generate the following series. 5, 10, 20 ….. 2560   (S-2021)(J-2023)                             B 

❖ Select the required number of cells to generate the series.                                                                    5                                           

❖ Click Edit→Fill, the fill series dialog box appears show below.                                                         10 

❖ Select the direction as Down in fill series dialog box.                                                                         20 

❖ Select the Series type Growth.                                                                                                             40 

❖ Initial value of the series 5 should be typed in start value box                                                            80 

❖ Maximum value of the series 2560 should be typed in End value box                                             160 

❖ The value should be typed in increment box                                                                                     320 

❖ Click ok .Now the series is generated as given below                                                                       640   

                                        1280 

                                                                                                                                                                  2560 

3. Read the following table 
 A B C D E 

1 Year Chennai Madurai Tiruchi Coimbatore 

2 2012 1500 1250 1000 500 

3 2013 1600 1000 950 350 

4 2014 1900 1320 750 300 

5 2015 1850 1415 820 200 

6 2016 1950 1240 920 250 
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Above table shows the sales figures for “Air Cooler” sold in four major cities of TamilNadu from the year 2012 to 

2016. Based on this data, write the formula to calculate the following. 

Total sales in the year 2015. 

Total sales in Coimbatore from 2012 to 2016.   

Total sales in Madurai and Tiruchi during 2015 and 2016.  

Average sales in Chennai from 2012 to 2016  

In 2016, how many “Air Coolers” are sold in Chennai compared to Coimbatore?     

S.no Question Formula Answer 

1. Total sales in the year 2015 =SUM(B5:E5) 4285         

2. Total sales in Coimbatore from 2012 to 2016.   =SUM(E2:E6) 1600    

3. Total sales in Madurai and Tiruchi during 2015 and 2016 =SUM(C5 : D6) 4395   

4. Average sales in Chennai from 2012 to 2016 =AVERAGE(B2:B6) 1760 

5. In 2016, how many “Air Coolers” are sold in Chennai 

compared to Coimbatore?       

=B6-E6 

 

1700 

 

1. Parts of the Open Office Calc Window: (J-2019) 

1.Title Bar:  

❖ Top of the window is called the “Title Bar”.  

❖ It is used to show the name of the file and name of the application.  

❖ In Open Office calc, the default name for the first unsaved worksheet is “Untitled1”.  

❖ When you save the file, Untitled will change to the name in which you saved. 

2.Control Buttons:  

❖ In the right corner of title bar, (1) minimize, (2) maximize / restore and (3) close control buttons are available. 

3.Menu Bar  

❖ Below the title bar is menu bar. Most of the menus are very similar to what you learnt in Open Office Writer.  

❖ File- Create a new file, Open an existing file, Close the current file, Save a file, Save a file in another name, 

print file, Export file etc.  

❖ Edit - cut, copy, paste, Undo, Redo, Fill etc.,  

❖ View - used to modify the environment of calc.  

❖ Insert –cells, columns, rows, functions, charts etc.,  

❖ Format –text and cell formatting features.  

❖ Tools –spell check, protect document, insert pictures, macros, etc.,  

❖ Data –sort, filter, subtotal, validity etc.,  

❖ Window –New Window, Close Windows, Split and Freeze.  

❖ Help – menu lists in-built help features available with Open Office. 

4.Tools Bar: 

❖ Standard Toolbar –New Open Save, Send, print, print preview, Cut, Copy, Paste, Sorting, inserting chart etc.,  

❖ Formatting Toolbar –Changing font style, font size, font colour, alignments, cell formatting etc.,  

❖ Formula bar –Name box, Function Wizard, Sum button, Function button and Input 

5.Scroll bar :(1) Vertical Scrollbar and (2) Horizontal Scrollbar  

6. Row, Column, Cell and Cell Pointer: 
❖ The worksheet has number of rows and columns, where each column is labelled as A, B, C, D ….. AA, AB, AC ….. 

❖ Column heading starts from A and end with AMJ.  

❖ In the case of Microsoft Excel 2016, there are 16,384 columns (A to XFD) and 10,48,576 rows available. 

❖ Intersection of each row and column makes a box which is called as “Cell”.  

❖ Cell pointer is a rectangle box which can be moved around the worksheet.  

❖ The cell in which the cell pointer is currently located is known as “Active cell”. 

2. Operators: (J-2019) 

(1) Arithmetic Operators, (2) Relational Operators  (3) Reference Operators (4) Text Operator 

1. Arithmetic Operators  

❖ Arithmetic operators are symbols for performing simple arithmetic operations such as addition, subtraction, 

multiplication, division etc.,  

❖ These operators return a numerical result.  

Operator  Name Value in 

Column B 

Value in 

Column C 

Formula in 

Column D 

Result in Column D 

Operator 

+ Addition 98 25 = B3 + C3 123 

- Subtraction 125 25 = B3 – C3 100 

* Multiplication 25 5 = B3 * C3 125 

/ Division 90 10 = B3 / C3 9 

^ Exponent 25 2 = B3 ^ C3 625 

% Percent 600   = B3 * 35% 72 

Percentage (%) operator shows percentage of the content. 
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2. Relational Operators  

❖ Relational operators are symbols used for comparing two values such as greater than, less than, equal to etc.  

❖ The relational operators are also called as "Comparative operators". 

❖ These operators return either a True or a False. 

3.Reference Operator  

❖ Reference operators are used to refer cell ranges.  

❖ A continuous group of cells is called as “Range”.  

❖ There are three types of reference operators that are used to refer cells in calc; they are 

❖  (1) Range Reference Operator, (2) Range Concatenation (3) Intersection Operator. 

1. Range Reference Operator : Syntax: reference left : reference right 

2. Reference concatenation operator:  Syntax: reference left ~ reference right 

3. Intersection Operator:  reference left ! reference right 

4. Text Operator: 

❖ In Calc, “&” is a text operator which is used to combine two or more text.  

❖ Joining two different texts is also known as “Text Concatenation” 

3. Explain filters in open office calc (J-2023) 

Filtering: 

❖ Filter is a way of limiting the information that appears on screen.  

❖ Filters are a feature for displaying and browsing a selected list or subset of data from a worksheet. 

Types: 1.AutoFilter, 2. Standard Filter 3.Advanced Filter. 

1.Auto Filter:  

❖ Auto Filter applies a drop-down list box to each field (columns) filled with similar data available in that field.  

❖ Using the list box item, you can filter the data that matches the criteria of the data concerned.  

Using Auto Filter: 

• Click Auto Filter icon available on the “Standard tool bar” (or) click Data → Filter → Auto Filter 

• The list box contains similar data in the fields. 

• Each list box item will be considered as filter criteria. 

Removing Auto Filter: 

• To remove auto filter, click “Auto filter” icon once again. 

• The original table is displayed without filter. 

2.Standard Filter:  
❖ Auto filter is used only for single criteria on a data, whereas the Standard filter is used for multiple criteria to filter. 

Step 1: Select Data → Filter → Standard Filter. 

           Now, the entire data is selected and "Standard Filter" dialog box dispalys. 

Step 2: Select the column heading from the “Field name” list box for first criteria. 

            Select conditional opeator such as >, <, = etc., from “Condition” list box. 

            Type or select the value of critera in the “Value” box. 

Step 3: Select the one of the logical operator (And / Or) from “Operator” list box to fix second criteria. 

            Follow the step 2, for the next criteria. 

Step 4: Click “OK” to finish. 

 CHAPTER- 8 Presentation Basics 
1. Valarmathi’s teacher asks her to create a presentation in Open Office Impress. As Valarmathi has never 

worked in Impress before, help her to perform the following tasks:  
a) She wants that except for the first slide, all the slides should have the same design. For this, what does she need to do?  

❖ You can use the master slide to make the same design for all slides and change the format of the first slide.  
b) To easily communicate with her audience, she wants to provide them with a hard copy of the slides of the 

presentation. What should she create for it?  

❖ To provide an exclusive copy of the presentation, you need to create handouts that fit one or more slides on a 

page, print them and distribute them to the audience.  

c) She wants to insert some pictures and movie files in some slides. How can she do that?  

❖ Open the slide where you want to insert pictures and movie files into the presentation.  
❖ To insert pictures, click Insert → Picture → From File menu and to insert movie files, select Insert → Movie and Sound → 

Movie from File menu and select the appropriate picture and movie file in the dialog boxes that appear.  

d) Suggest her view that would be the most suitable for showing the presentation to the audience.  

❖ The slide show view is best suited for displaying a presentation.  
❖ Pressing F5 makes the presentation appear in the full window and also provides controls for moving between slides.  

e) To make her presentation more attractive, she wants to add some effects in it. How can she do it? Suggest.  

❖ To make her presentation attractive, she needs to add animation and transition effects to the slides. 
2. Explain how a presentation can help a sales person to promote his/her products. 

❖ A sales presentation can be a useful tool for promoting products.  

❖ This will help a salesperson articulate the features and benefits of their products clearly and concisely.  

Here are some ways a sales presentation can help a salesperson promote their products: 

1. Captivate the audience:  
❖ A well-crafted presentation will grab the audience's attention and keep them engaged throughout the presentation.  
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❖ This will help the salesperson communicate their message effectively.  

2. Highlight key features and benefits:  

❖ This will help the audience understand the value proposition of the product and how it can meet their needs.  

3. Demonstrate product use:  

❖ This will help audiences visualize the product and understand how they can use it in their daily lives.  

4. Answering the questions:  

❖ A sales presentation will give the audience an opportunity to ask questions about the product.  

❖ This will help the seller address any concerns or doubts.  

5. Help: 

❖ Help the salesperson to convert the audience into customers and achieve their sales goals by giving a clear 

invitation to the audience.  

3. Siva balan created a presentation to be shown at his school’s Annual Function. Just 5 minutes before the 

presentation, he noticed that he has misspelt the name of the school, which is appearing in all the 30 slides of 

the presentation.  How can he rectify this mistake in all the slides in one-shot? 

❖ By making a change in the master slide, Siva palan can change the name of the school on all the slides in his 

presentation at once.  

Here are the steps to change the name of the school on all the slides of the presentation using Star Impress:  

1. Open a presentation at Star Impress.  

2. Choose the View → Master → Slide Master.  

3. Now edit the name of the school.  

4. Click the Close Master View button to close the Master Slide.  

    By following these steps, Sivapalan can quickly and easily correct the mistake in all the slides in one-shot. 

4. List some advantages of using templates. 

1.Professional Graphic Design:  

❖ Templates will give professional Graphic Design which helps you to create branded PowerPoint presentation 

own logo to the mix. 

2.Speed:  

❖ With a good starting point in each slide, your presentation is made in a snap. 

3.Quick Customization:  

❖ It’s much easier to edit the template in its original form, not as a copy of a copy. 

4. Consistency: Ensures a uniform look.  

5. Time-saving: Pre-designed layouts save time.  

6. Efficiency: Focus on content creation.  

7. Professionalism: Reflects brand identity.  

8. Engagement: Enhances audience interest.  

9. Flexibility: Adaptable to different needs.  

1 Define Slide sorter view and write its significance. (M-2023) 

❖ Slide Sorter view shows a thumbnail of each slide in order.  
❖ Use this view to rearrange the order of slides, produce a timed slide show, or add transitions between selected slides. 

Significance: 

❖ Check View → Toolbars → Slide View to show the Slide view toolbar. 

❖ Adjust the number of slides (up to a maximum of 15). 
❖ After you have adjusted the number of slides per row, View → Toolbars →Slide View will remove this toolbar from view. 

❖ Use the Control (Ctrl) key: Click on the first slide and, while pressing Control, select the other desired slides. 

2. How many types of views are provided by impress to its users? Explain them. (M-2019)(S-2020) 

1.Normal view: 

❖ Normal view is the main view for creating individual slides. 

❖ Use this view to format and design slides and to add text, graphics and animation effects.  

2. Outline view: 

❖ Outline view shows topic titles, bulleted lists and numbered lists for each slide in outline format.  

❖ Use this view to rearrange the order of slides, edit titles and headings, rearrange the order of items in a list and 

add new slides.  

3. Notes view:  

❖ Notes view lets you add notes to each slide that are not seen when the presentation is shown.  

4. Slide Sorter view:  

❖ Slide Sorter view shows a thumbnail of each slide in order.  
❖ Use this view to rearrange the order of slides, produce a timed slide show, or add transitions between selected slides.  

5. Handout view:  

❖ Handout view lets you print your slides for a handout.  

❖ You can choose one, two, three, four, or six slides per page from Tasks pane → Layouts. 

❖ Thumbnails can be re-arranged in this view by dragging and dropping them. 
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 CHAPTER- 9 Introduction to Internet and Email 
1. Explain any five types of internet services. (S-2021)(S-2022)                                        

1.Wireless:  

❖ Radio frequency bands are used in place of telephone or cable networks.  

❖ One of the greatest advantages of wireless Internet connections is the "always-on" connection that can be 

accessed from any location that falls within network coverage.  
❖ Wireless connections are made possible through the use of a modem, which picks up Internet signals and sends them to other devices. 

2.Mobile:  

❖ Many cell phone and smartphone providers offer voice plans with Internet access.  

❖ Mobile Internet connections provide good speeds and allow you to access the Internet.  

3.Hotspots:  

❖ Hotspots are sites that offer Internet access over a wireless local area network (WLAN) by way of a router that 

then connects to an Internet service provider. 

❖ Hotspots utilize Wi-Fi technology, which allows electronic devices to connect to the Internet or exchange data 

wirelessly through radio waves.  

❖ Hotspots can be phone-based or free-standing, commercial or free to the public. 

4.Broadband:  

❖ This high-speed Internet connection is provided through either cable or telephone companies.  
❖ One of the fastest options available, broadband Internet uses multiple data channels to send large quantities of information.  

❖ The term broadband is shorthand for broad bandwidth. Broadband Internet connections such as DSL and cable 

are considered high-bandwidth connections.  

❖ Although many DSL connections can be considered broadband, not all broadband connections are DSL.  

5.DSL: 

❖ DSL, which stands for Digital Subscriber Line, uses existing 2-wire copper telephone line connected to one's 

home so service is delivered at the same time as landline telephone service.  

❖ Customers can still place calls while surfing the Internet. 

6.Cable:  

❖ Cable Internet connection is a form of broadband access.  

❖ Through use of a cable modem, users can access the Internet over cable TV lines.  

❖ Cable modems can provide extremely fast access to the Internet. 

7.Satellite: 

❖ In certain areas where broadband connection is not yet offered, a satellite Internet option may be available.  

❖ Similar to wireless access, satellite connection utilizes a modem. 

8.ISDN:  

❖ ISDN (Integrated Services Digital Network) allows users to send data, voice and video content over digital 

telephone lines or standard telephone wires. 

❖ The installation of an ISDN adapter is required at both ends of the transmission—on the part of the user as well 

as the Internet access provider. 

9.Dongles / Data Card:  

❖ Today, many dongles provide wireless capabilities.  

❖ For example, USB Wi-Fi adapters are often called dongles.  
❖ Since most computers now have built-in Wi-Fi chips, mobile data adapters, such as 3G and 4G dongles, are more prevalent.  

❖ These types of dongles allows to connect to the Internet even when Wi-Fi is not available. 

2. Explain any five internet applications with suitable examples. (M-2019)(S-2020)(M-2023) 

1. Job search : 

❖ Nowadays, many people search for their jobs online using naukri.com, monster.com, recuritmentindia.com etc 

as it is quicker. 

2.Online Shopping : 

❖ The internet has also facilitated the introduction of a new market concept consisting of virtual shops.  

❖ For example amazon.com 

3.Stock market updates : 

❖ Selling or buying shares sitting on computer through internet.  

❖ Several websites like ndtvprofit.com, moneypore.com, provide information regarding investment. 

4.Travel : 

❖ One can use internet to gather information about various tourist place. 

❖ It can be used for booking Holiday tours.  

❖ Some of the web sites providing this service are goibibo.com, makemytrip.com, olacabs.com. 

5. Research : 

❖ Research papers are present online which helps in the researcher doing a literature review 

6. Video conferencing : 

❖ It enables direct face-to-face communication across networks via web cameras, microphones, and other 

communication tools.  
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7. E –commerce : 

❖ E–commerce (electronic commerce or EC) is the buying and selling of goods and services, or the transmitting 

of funds or data, Largest e-commerce companies in India are Flip kart, Snap deal, Amazon India, Paytm. 

8. Online payments : 
❖ The rising boom of online payments in India has given way to many new entrants in the industry such as Paytm etc  

9. Social Networking : 
❖ Social networking is the use of internet-based social media programs to make connections with friends, family etc.  

❖ Examples of social networking includes Facebook 

10. e-banking : 

❖ E-banking (Online banking) , also known as internet banking, it is an electronic payment system that enables 

customers of a bank or other financial institution to conduct a range of financial transactions through the 

financial institution's website. 

3. Write a note on any five Internet browsers other than that given in the book. 

1.Google Chrome: 

❖ Google Chrome is a freeware familiar web browser developed by Google Inc.  

❖ It is best for its speed, simplicity, security, privacy and customization features. 

❖ Google Chrome supports on Android 4.0 or higher, iOS 6.0 or higher, Mac OSX 10.6 or higher and Windows 

(XP sp2 or higher) and Linux system. 

2.Mozila Firefox:  
❖ Mozila Firefox is a free and open source web browser developed by Mozilla Foundation and Mozilla Corporation.  

❖ FireFox is default browser in Ubuntu .  

❖ It supports Windows, Mac OS X, Linux and Android system.  

3.Internet Explorer:  

❖ Internet Explorer commonly known as Microsoft Internet Explorer or Windows Internet Explorer is the first or 

default browser for a Windows PC. 

❖ It is developed by Microsoft. 

4.Safari : 

❖ Safari is a web browser developed by Apple Inc. and comes with OS X and iOS.  

❖ Some version of safari browser also supports in Windows Operating System. 

❖ Exclusively used in Apple Mac system. 

5.Opera : 

❖ Opera is smaller and faster than most other browsers, yet it is full- featured. 

❖ Fast, user-friendly, with keyboard interface, multiple windows, zoom functions, and more.  

4. Explain the dos and don’ts of safe surfing on internet. 

1.Don’t give out your personal information : 

❖ Don’t put personal details such as your home address, telephone numbers or parent’s work address online as 

cybercriminals can use this information to create a fake profile with your details 

2.What goes online, stays online :  

❖ Use privacy settings to make sure only your friends and family can see photos you post. 

❖ Avoid posting holiday plans as criminals have been known to track your movements 

3.Check your security and privacy settings  : 

❖ Make sure your social network privacy settings are secured so only your friends can see your personal 

information and use your privacy settings to restrict who can see your posts, videos and photos 

4.Password safety: 

❖ Sharing your password with your parents is a sensible idea, but avoid sharing your password with your friends, 

even if they promise they won’t tell anyone! Also, when setting your password, make sure it isn’t something 

people may guess such as your pet’s name.  

❖ Use a mixture of letters, numbers and upper and lower case characters 

5.Always protect your mobile device: 

❖ Make sure your mobile phone is pin-protected so all your personal information stored on it is safe.  
❖ Download a security app which allows you to remotely wipe any personal data, should your mobile be lost or stolen 

6.Don’t talk to strangers online or offline : 

❖ Don’t meet up with strangers and let your parents know if a stranger has tried to get in contact with you online. 

7.Listen to the adults who know : 

❖ Adults will always be worried about you.  

❖ Help set their mind at rest and avoid chatting online with strangers.  

8.Be wary of unsecured or unknown websites: 

❖ When shopping online, use reputable and known retailers. 

9.Be careful what links you click on : 

❖ Avoid clicking links in an email, Instant Message or on your social network unless you are sure the message is 

from someone you know. 
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1. Explain the different types of interactions in E-governance (J-2019) 

E-governance: 

❖ Electronic governance or e-governance is the application of information and communication technology (ICT) 

for delivering government services.  

Four types: 

Government to citizens(G2C),               Government to Business (G2B),  

Government to Government(G2G) and Government to employees (G2E) 

Benefits of E-governance 

1.Reduced corruption      

2.High transparency   

3.Increased convenience   

4. Reduction in overall cost. 

5. Expanded reach of government. 

2. Explain structure of E-mail (J-2022) 

Structure of email: 

❖ Click the Compose button and then writing an e-mail content requires. 

When sending an e-mail message, several fields are required to be filled: 

❖ The To field is where you type the e-mail address of the person who is the recipient of your message. 

❖ The From field should contain your e-mail address. 

❖ If you are replying to a message, the To and From fields are automatically filled out; if it's a new message, 

you'll need to enter them manually. 

❖ The Subject should consist of a few words describing the e-mail's contents. The Subject lets the recipient see 

what the e-mail is about, without opening and reading the full e-mail. This field is optional. 

❖ The CC (Carbon Copy) field allows you to specify recipients who are not direct addressees (listed in the "To" 

field). This field is optional. 

❖ The BCC (Blind Carbon Copy) field is similar to CC, except the recipients are secret. Each BCC recipient 

will receive the e-mail, but will not see who else received a copy. The addressees (anyone listed in the "To" 

field) remain visible to all recipients. This field is optional. 

❖ Finally, the Message Body is the location you type your main message. It often contains your signature at 

the bottom; similar to a hand-written letter. 

 CHAPTER- 10 HTML - Structural Tags 
1. Write a HTML program to display your school name and address using various getting level tags.                                                                       

<html> 

<head>  

<title> My school </title> 

</head> 

<body bgcolor = yellow> 

       <h1> DSMHSS Hr.Sec.School,</h1> 

        <h2> Singarathoppu </h2> 

         <h3>Otta palam</h3> 

         <h4> Tamil Nadu </h4> 

         <h5> Pin code - 6200000 </h5> 

         <h6> DSMHSS@gmail.com</h6> 

</body> 

</html> 

2. Write the basic structure of a HTML program. 

Sample  program: 

<html> 

<head>  

<title> My First Web Page </title> 

</head> 

<body>  

This is my First Web Page 

</body> 

</html> 

❖ HTML tags generally have an opening and closing tag.  

❖ Opening tag turn-on a feature such as heading, bold, center etc., and closing tag turn-off its features.  

❖ Opening and closing tags have the same name, but the closing tag name is preceded by a slash ( / ).  

❖ For example, <html> is an opening tag, </html> is a closing tab.  

❖ Every web document has two sections viz. Heading Section and Body Section.  

❖ The heading section is used to show the title of a webpage in title bar or tab heading in browser.  

❖ The head section should begin with <head> tag and end with </head> tag.  

❖ The tag <title> is used to specify the title of the webpage.  
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❖ The body section is used to display the main content on the browser window.  

❖ The body section should be with defined within <body> and </body> tags.  

❖ Whatever the text you specify between these tags will be displayed on the browser window. 

Opening 

Tag 

Closing 

Tag 

Description 

<html> </html> ❖ The <html> tag identified the document as an HTML document.  

❖ All HTML documents should begins with <html> and end with </html>. 

<head> </head> ❖ The <head> tag contains information about the document, including its title, scripts 

used, style definition and document descriptions. 

<title> </title> ❖ The <title> tag contains the title of the document.  

❖ <title> tag should be placed within <head> tag. 

<body> </body> ❖ The <body> tag encloses all the tags, attributes and information to be displayed in the web 

page.  

❖ <body> tag should be entered below the </head> tag.  
 

1. Explain various heading level tags in HTML? (S-2021)(M-2022) 

❖ Headings are used to include titles to sections of a web page.  

❖ HTML has six levels of headings viz. <h1> to <h6>.  

❖ The number with h indicates the level of heading. Header tags display the body text as bolder and larger in size 

according to its level.  

The syntax of heading tags:   <h…> Heading text </h…> 

Example : 

<html>  

<head>  

<title> Heading </title> 

</head> 

<body>  

<h1> Welcome to Computer Application</h1>  

<h2> Welcome to Computer Application</h2>  

<h3> Welcome to Computer Application</h3>  

<h4> Welcome to Computer Application</h4>  

<h5> Welcome to Computer Application</h5>  

<h6> Welcome to Computer Application</h6> 

</body> 

</html> 

 CHAPTER- 11 HTML - Formatting text, Creating Tables, List and Links 
1. Write an HTML code the show the following text                                

                           MODERN ATOMIC THEORY 

The findings of modern atomic theory are given as follows: 

• An atom is the smallest particle which takes part in chemical reaction. 

• An atom is considered to be a divisible particle. 

• The atoms of the same element may not be similar in all respects.  

              eg: Isotopes (17Cl35, 17Cl37) 

❖ The atoms of different elements may be similar in some respects.  

             eg. Isobars (18Ar40, 20Ca40) 

Answer: 

<html>  

<head>  

<title> MODERN ATOMIC THEORY</title>  

</head>  

<body>  

<center>MODERN ATOMIC THEORY</center>  

<b>The findings of modern atomic theory are given as follows:</b>  

<ul>  

<li>An atom is the smallest particle which takes part in chemical reaction.  

<li>An atom is considered to be a divisible particle.  

<li>The atoms of the same element may not be similar in all respects.  

eg: Isotopes (<sub>17</sub>Cl<sup>35</sup>, <sub>17</sub>Cl<sup>37</sup>) 

<li>The atoms of different elements may be similar in some respects.  

eg. Isobars (<sub>18</sub>Ar<sup>40</sup>, <sub>20</sub>Ca<sup>40</sup>)  

</ul>  

</body>  

</html> 
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2. Explain the attributes used with <table> tag in HTML.  (M-2019)(S-2022) (J-2024) 

❖ The <table> is a container tag.  

❖ There are several attributes to improve the layout of the table.  

❖ They are listed below: 

Cell spacing:  

❖ It is used to set the space between cells in a table. The value should be in pixels  

Cell padding:  

❖ It is used to set the space between the contents of a cell and its border.  

❖ The value should be in pixels. 

Border:  

❖ Border attribute with <table> tag is used to specify the thickness of the border lines around the table.  

❖ The value of the border attribute should be a non zero value in pixels.  

❖ If its value is zero, HTML displays the table without border.  

❖ The default value is Zero in most the browsers.  

Border color:  

❖ It is used to apply the colour to the border lines. 

Align:  

❖ It is used to set the position of the table within the browser window.  

❖ Left is the default position.  

❖ Right or center may be the value of align attribute. 

BG color : 

❖ It is used to apply background colour to the table.  

Height and Width:  

❖ These two attributes are used to specify the height and width of a table in terms of pixels or percentage. 

Example:  

<table Cellspacing = 3 cellpadding = 10 border = 1 bordercolor=green align=center bgcolour = pink width = 70%> 

3. Explain the types of list with suitable HTML code.   (M-2019) (S-2021)(M-2022)(M-2023) 

1.Numbered List / Ordered List : 

❖ Numbered list is created within the tag pair <OL> ….. </OL> tag.  

❖ The tag <LI> is used to present the list item in the list. Ordered list displays items in a numerical or 

alphabetical order.  

❖ Both <OL> and <LI> tags are container tags.  

❖ But the usual the practice, closing tag </LI> never be used. 

Attributes of Ordered List: 

(1) Type - changing numbering style     (2) Start - changing numbering order 

2.Un-numbered List / Unordered List:  

❖ Unordered lists are often referred as bulleted lists.  

❖ Instead of numbers, each element in the list has prefixed with a special bullet symbol.  

❖ Unordered list is surrounded within <UL> ……… </UL> tags.  

❖ As discussed above, each list element is defined by <LI> tag. 

3.Definition List : 

❖ Definition list is different from other two types of list. No bullet or number is provided for the list items.  

❖ In this list type, the list element has two parts.  

❖ (1) A definition term       (2) The definition description 

❖ Definition list is surrounded within <DL> ……. </DL> tags.  

❖ Definition term is presented in between <DT> ….. </DT> tag and  

❖ Definition description should be surrounded within <DD> ………… </DD>  tag. 

4.Nested Lists:  

❖ A list block can be defined inside another list is called as nested list. 

4. What is Link and explain the types of links. (J-2019)(M-2024) 

Links:  

❖ Link is an important feature of HTML to connect web resources. 

❖ Link in HTML is used to create hyperlinks to web content. 

❖ Make connection with a part of content of same document or an external document. 

There are two important things needs to create a link in HTML,  

         (1) The name of the file or URL to which you want to link  

         (2) The text that will serve as the clickable link.  

❖ The anchor tag <A> is used to create links along with HREF attribute.  

❖ HREF is abbreviated as “Hypertext Reference”.  

Structure of an anchor tag with href: 

<A href = “ Web content path / URL “> Text – Clickable link </A> 

1.Internal Links: 

❖ Creating a link to a particular section of the same document is known as Internal Link.  
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❖ To create an internal like, the attribute Name is used along with <A> tag.  

❖ The Name attribute of <A> tag establish the link to the content within the document. 

2.External Link:  

❖ Establish link with an external web page in known as external linking.  
❖ It is made possible by providing the URL of the external file in the HREF attribute of <A> tag of the current page. 

5. Write HTML code to create the following table:  

A B 

C D E G 

F  

HTML Code:  

<html>  

<head>  

<title>Table</title>  

</head>  

<body>  

<table CELLSPACING = 5 border = 1 width = 50%>  

<tr>  

<td rowspan = 3 align = center> A </td>  

<td colspan = 4 align = center> B </td>  

</tr> 

<tr>  

<td> C </td>  

<td> D </td>  

<td> E </td>  

<td ROWSPAN = 2 align = center> G </td>  

</tr>  

<tr>  

<td colspan = 3 align = center> F </td>  

</tr>  

</table>  

</body>  

</html> 

1. Write an HTML code  to  create the following table (M-2019)(M-2020) 

Class Boys Girls 

XI 75 80 

XII 65 70 

<html> 

<head> 

<title> Table </title> 

</head> 

<body> 

<table border = 11> 

<TR>  

<TH> Class </TH>  

<TH> Boys </TH>  

<TH> Girls </TH> 

</TR> 

<TR>  

<TH> XI </TH>  

<TH> 75 </TH>  

<TH> 80 </TH> 

</TR> 

<TR>  

<TH> XII </TH>  

<TH> 65 </TH>  

<TH> 70 </TH> 

</TR> 

</table></body></html> 
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2. Write an HTML code  to  create the following table (S-2020) 

Reg:No Total % 

1531 360 60% 

1532 420 70% 

<html> 

<head> 

<title> Table </title> 

</head> 

<body bgcolor =”paleGoldenRod”> 

<Table border = 1> 

<caption> Marks and percentage </caption> 

<TR> 

<TH> Registration No </TH> 

<TH> Total </TH> 

<TH> Percentage </TH> 

</TR> 

<TR>  

<TD> 1531 </TD>  

<TD> 360 </TD>  

<TD> 60% </TD> 

</TR> 

<TR>  

<TD> 1532 </TD>  

<TD> 420 </TD>  

<TD> 70% </TD> 

</TR> 

</table> 

</body> 

</html> 

3. Write the output of the following html code (J-2019) 

<html>                                                                  OUTPUT 

<head>                                                              INPUT DEVICES 

<title> Nested List </title>                                  Keyboard 

</head>                                                                Mouse 

<body>                                                                 Light pen 

<OL>  

<LI> INPUT DEVICES                                    OUTPUT DEVICES 

<UL type=Disc>                                                    Monitor 

<LI> Keyboard                                                       Printer 

<LI> Mouse                                                            Speaker 

<LI> Light pen  

</UL>  

<LI> OUTPUT DEVICES 

<UL type=Disc>  

<LI> Monitor 

<LI> Printer 

<LI> Speaker 

</UL>  

</OL> 

</body> 

</html> 

4. Write short note on  1) <strong> 2.<em> 3. <mark> 4. <hr> 5. <sub>  (M-2022) 

a) <strong> Important text : 

1. The <strong> tag is a phrase tag. 2. It is used to define important text by displaying text as bold. 

b) <em> - Emphasized text: 

1. The <em> tag is used to emphasize the text.  2. That means, when you use this tag, the text will be in italics. 

c) <mark> Tag: 

❖ The <mark> tag is used to highlight the text in HTML.  

❖ This is also a container tag.  

❖ Whatever the text given between <mark> and </mark> will be displayed as highlighting with default color 

(mostly yellow). 
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d) <hr> tag: 

The <hr> tag having four attributes viz. size, width, no shade and color. 

1. Size:          Thickness of the horizontal line can be changed with size attribute.  

                         The size is given in terms of pixels.  

2. Width:       The width attribute specifies the horizontal width of the rule line. 

3. Noshade:   The default view of a horizontal rule line is 3D.  

4. Color: The horizontal line is displayed in gray color by default.  

Syntax:         <hr size=valuewidth=valuenoshade, color=color_name/code> 

e) <sub> tag: 

❖ In HTML, the <sub> and <sup> tags are used to create subscript and superscripts respectively.  

❖ As like as other formatting tags, this is also a container tag. 

 CHAPTER- 12 HTML - Adding multimedia elements and Forms 
1. Explain the <form>tag with its attributes (M-2019)                                  

1.Method: 
❖ The method attribute of the form tag is used to identify how the form element names and values will be sent to the server. 

❖ The get method will append the names of the form elements and their values to the URL. 

2.Action: 

❖ The action attribute identifies the server side program or script that will process the form.  

❖ The action will be the name of a Common Gateway Interface (CGI) program written in programming 

languages like Perl, JavaScript, PHP or Active Server Pages (ASP). 

General Format of <form> tag: 

<Form method=get/post action= “back_end_server_script”> Form elements 

</Form> 

2. Explain Input tag with attributes (J-2019) (J-2024) 

<Input> Tag  

❖ Most of the form controls are created by using <input> tag.  
❖ The <input> is an empty tag used to create different form elements or controls such as text box, radio buttons so on.  

Attributes of <input> tag: 

1.Type:This attribute is used define the type of control to be created by <input> tag. 

2.Name: This attribute of <input> tag is used to assign a name to the input controls.  

3.Value: This attribute is used to define default value to some controls. 

4.Size: This is used to set the width of the input text in terms of characters.  

             It is applicable only for textbox and password boxes. 

5.Maxlength: This attribute of <input> tag is used to set the length of the input character (number of 

                       characters to be input) to the textbox and password boxes. 

3. How will you insert images with HTML document? (S-2022) 

Inserting Images with HTML document: 

❖ The <IMG> tag along with the attribute src (Source) is used to add images in HTML document.  

General format: 

<img src = image_name_with_extension>  (OR)  <img src = URL> 

Example: <img src = image1.gif>  

❖ Src attribute is the main attribute used to specify the file name of the image to be inserted.  

❖ If the image is not in the current working folder, the image file name should clearly specify with the path of the 

file or URL, where the file is available. 

Example: <img src = “D:\images\animals\cat.jpeg”> 

An HTML code to insert an inline image 
<html> 

<head> 

<title> Inserting Images </title> 

</head> 

<body>  

<h1 align = center> Bharathiyar </h1>  

<img src = bharathiyar.gif> 

</body> 

</html> 

 CHAPTER- 13 CSS - Cascading Style Sheets 
1. Write an HTML document to display the following paragraph as per the given description Using CSS                                                                       

         • Font Name : Cooper Black  

         • Style : Bold Italics  

         • Color : Blue  

“The State Institute of Education (SIE) was established in 1965 to provide for systematic study of       problems relating 

to School Education under the administration of Directorate of School Education.” 
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Answer: 

Mystyle.css:  

P  

{  

font-family : " Cooper Black ";  

Font-weight : Bold;  

Font-style : Italic;  

Color : blue;  

}  

Test.html:  

<html>  

<head>  

<title> SIE </title>  

<link rel="stylesheet" type="text/css" href="mystyle.css">  

</head> 

<body>  

<H1> State Institute of Education </H1>  

<P>  

The State Institute of Education (SIE) was established in 1965 to provide for systematic study of problems relating 

to School Education under the administration of Directorate of School Education.  

<P>  

</body>  

</html> 

2. List and explain the Font and text element properties and values used CSS. (M-2020)(J-2022) 

Formatting Properties Values Example 

 

 

 

1.Text Colour 

 

 

 

Color 

 

 

 

Predefined_Color_Name 

P 

{ 

color:pink; 

} H1 

{ 

color : MediumSeaGreen; 

} 

 

2.Text Alignment 

 

Text-align 

 

Center / Left / Right / Justify 

P 

{ 

Text-align : center; 

} 

 

3.Font type 

 

Font-family 

 

Font_name 

P 

{ 

Font-family : “Times New Roman”; 

} 

 

 

4.Font Style 

 

 

Font-style 

 

 

Normal / Italic 

P 

{ 

Font-family : “Times New Roman”; Font-style : 

Italic; 

} 

 

 

5.Font Style 

(Bold) 

 

 

Font-weight 

 

 

Normal / Bold 

P 

{ 

Font-family : “Times New Roman”; Font-style : 

Italic; 

Font-weight : bold; 

} 

   

 

6.Font size 

 

 

Font-size 

 

 

Size in pixels 

P 

{ 

Font-family : “Times New Roman”; Font-style : 

Italic; 

Font-size : 14px; 

} 
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7.Backgroud 

Colour 

 

Background 

Colour 

 

Predefined_Color_Name 

Body 

{ 

background-color : violet; 

} 

 

8.Border Colour 

 

Border 

Border thickness 

<space> border style 

<space>Predefined_border    

Color_Name 

 

H2 { border : 2px solid red; } 

 CHAPTER- 14 Introduction to Java script 
1. Explain about the popup dialog boxes in JavaScript   (S-2021) (J-2023)(M-2024)                 

❖ JavaScript supports three important types of dialog boxes.  

❖ Dialog boxes are also called as Popup Boxes.  

❖ These dialog boxes can be used to raise an alert, or to get confirmation on any input or to have a kind of input 

from the users.  

❖ JavaScript supports three kind of popup boxes: Alert box, Confirm box, and Prompt box. 

1.Alert Dialog Box:  

❖ An alert dialog box is mostly used to give a warning message to the users.  

❖ For example, if one input field requires to enter some text but the user does not provide any input, then as a 

part of validation, you can use an alert box to give a warning message.  

❖ Alert box gives only one button "OK" to select and proceed.  

The syntax of alert box is  

                  Alert(“Message”);   (or)   Window.alert(“Message”);  

Example:  

                  alert(“Name is compulsory entry”);   (or)  window.alert(“Name is compulsory entry”); 

2.Confirm Dialog Box:  

❖ A confirmation dialog box is mostly used to take user's consent on any option. 

❖ It displays a dialog box with two buttons: OK and Cancel. 

❖ If the user clicks on the OK button, the confirm() will return true.  

❖ If the user clicks on the Cancel button, then confirm() returns false. 

The syntax of confirm dialog box is  

                  confirm(“message”);  (or)   window.confirm(“message”); 

Example:  

                    confirm(“Hai Do you want to continue:”);  

3.Prompt Dialog Box:  

❖ The prompt dialog box is very useful when the user want to pop-up a text box to get user input.  

❖ Thus, it enables you to interact with the user.  

❖ The user needs to fill in the text box field and then click OK.  

❖ The prompt dialog box is displayed using a method called prompt() which takes two parameters: 

❖ a label which you want to display in the text box   

❖ a default string to display in the text box. 

The Syntax of prompt dialog box is,  

                           Prompt(“Message”,”defaultValue”);  

Example:  

                        prompt(“Enter Your Name:”,”Name”);  

2. Explain about the Arithmetic operator with suitable example.  (M-2020)(M-2022) (J-2024) 

Arithmetic Operators : 

❖ JavaScript supports all the basic arithmetic operators like addition (+), subtraction (–), multiplication (*), 

division (/), and modulus (%, also known as the remainder operator). 

Arithmetic Meaning Example Result 

+ Addition var sum = 20 + 120 Variable sum = 140 

- Subtraction var diff = 20 – 120 Variable diff = 100 

* Multiplication var prod = 10 * 100 Variable prod = 1000 

/ Division var res = 100/522 Variable res = 5.22 

% Modulus operator var rem = 100 % 522 Variable rem = 22 (remainder) 

Example Coding: 

<Html> 

<Head>  

<Title>Demo Program – To test Arithmetic Operators in JavaScript </Title> 

</Head> 

<Body>  

<script language="javascript" type="text/javascript"> 

var value1 = 522, value2=10;  
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document.write("<br>Data1 : "+value1);  

document.write("<br>Data2 : "+value2);  

var sum = value1+value2;  

var diff = value1-value2;  

var prod = value1*value2;  

var res = value1/value2;  

var rem = value1%value2;  

document.write("<br><br>The Sum of Data1 and Data2 : "+sum);  

document.write("<br>The Difference of Data1 and Data2 : "+diff);  

document.write("<br>The Product of Data1 and Data2 : "+prod);  

document.write("<br>The Result after Division of Data1 and Data2 : "+res);  

document.write("<br>The Remainder after Division of Data1 and Data2 : "+rem); 

</script> 

</Body> 

</Html> 

1. Explain relational operator suitable example. (M-2023) 

❖ Relational operators are also called as Comparison operators, they compares two values and the result is true or false. 

Relational (Comparison) 
Operator 

Meaning Example Result 

Assume x=10 and y=20 

== Equality x==y False 

!= In-equality x!=y True 

< Less-than x<y True 

> Greater-than x>y False 

<= Less-than or equal to x<=y True 

>= Greater-than or equal to x>=y False  
 

2. Write a rules of naming variables in Java script program (J-2019) (J-2023) 

1. The first character must be a letter or an underscore (_).  

Number cannot be as the first character.  

2. The rest of the variable name can include any letter, any number, or the underscore.  

You can't use any other characters, including spaces, symbols, and punctuation marks. 

3. JavaScript variable names are case sensitive.  
That is, a variable named Register Number is treated as an entirely different variable than one named register number. 

4. There is no limit to the length of the variable name. 

5. JavaScript's reserved words cannot be used as a variable name.  

All programming languages have a supply of words that are used internally by the language and that cannot be 

used for variable names.  

3. Explain Logical operator with suitable example  (S-2022) 

Logical operator: 

❖ Logical operators perform logical (boolean) operations. Logical operators combine or invert Boolean values.  

❖ Once comparisons are made, the logical operators && (AND), || (OR) and ! (NOT) can be used to create more 

complex conditions. 

Logical Operator Example  Meaning Result 

&& ((4>5(&& )10<5)) 

((expr1) && (expr2)) 

(Logical AND) Returns true if expr1 and expr2 

both true.  

True 

|| ((4>5(|| )10<5)) 

((expr1) || (expr2)) 

(Logical OR) Returns true if either expr1 or 

expr2 is true, or both are true. 

True 

! !(10<5) 

!(expr1) 

(Logical NOT) Returns true if expr1 is false; 

otherwise, returns false. 

False  

Usage :  
❖ For && (AND) the result is false if the first operand is false; otherwise, the result is the Boolean value of the second operand. 

❖ For || (OR) the result is true if the first operand is true; otherwise, the result is the Boolean value of the second operand. 

❖ For ! (NOT) the result is true if the operand is false; otherwise, the result is true. 

 CHAPTER- 15 Control Structure in Java script 
1. Explain for loop with example    (J-2019)(M-2023)                                                           

❖ The for loop is a very rigid structure that loops for a pre-set number of times.  

❖ In JavaScript for structure is very flexible, which makes this type is very useful.  

The syntax of the for loop : 

      for(initialization; condition; increment/decrement)  

      {  

         Body of the loop;  
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       }  

❖ The for structure within parenthesis there are three parts each separated by semicolon.  

❖ They are, 

❖ The first part of the loop initialize a variable which is also called as control variable.  

❖ In most case the control variable is declared as well as initialized. 

❖ The second part is the conditional statement that determines how many times the loop will be iterated. 

❖ The third and final part determines how the value of control variable is changed (Incremented/Decremented)  

Example:                                                                                    Output 

<html>                                                                                        Please enter Table You want :3                                                                     

<head>                                                                                        3x3=0 

<Title> Program - To test for statement in JavaScript </Title>  3x1=3 

</head>                                                                                       3x2=6 

<body>                                                                                        3x3=9 

<script language="javascript" type="text/javascript">               4x3=12 

var no1 = prompt("Please enter Table You want :", "0");           5x3=15 

document.write("<h2> Multiplication for your need </h2>");  

for( var m=0;m<=10;m++) 

{  

document.write(no1+" x "+m+" = "+n*m+"<br>"); 

} 

</script> 

</body>  

</html> 

2. Explain switch case statement with example (M-2019)(S-2021)(S-2022) (J-2024) 

❖ Java Scripts offers the switch statement as an alternate to using if...else structure.  

❖ The switch statement is especially useful when testing all the possible results of an expression.  

The syntax of a switch structure: 

switch(expression) 

{ 

case label 1:  

       statements1;  

       break;  

case label 2:  

       statements2;  

       break;  

 case label n;  

      statements - N;  

      break;  

default:  

      statements; 

} 
❖ The switch statement begins by evaluating an expression placed between parenthesis, much like the if statement.  

❖ The result compared to labels associated with case structure that follow the switch statement.  

❖ If the result is equal to a label, the statements in the corresponding case structure are executed.  

❖ The default structure is can be at the end of a switch structure if the result of the expression that do not match 

any of the case labels. 

Example : 

switch(grade)  

{  

case 1:  

     document.write("Your Grade is Outstanding..");  

     break;  

case 2:  

     document.write("Your Grade is Excellent..");  

     break;  

case 3:  

     document.write("Your Grade is Good..");  

     break;  

case 4:  

      document.write("Your Grade is Satisfectory..");  

      break;  

default:  

        document.write("Your Grade Poor and have to re-appear Exam.."); }  
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3. Write the output for the following program       Output: 

<Html>                                                            Please enter table you want : 5 

<Head>                                                            Multiplication for your need 

<Title> for statement</title>                           5x1=5   5x2=10   5x3=15  5x4=20 

<Head>                                                            5x5=25 

<Body>  

<script language= "java Script" type = "text / javaScript")  

    var no1= prompt ("please enter table you want:", "0" );  

    document write ("<h2> multiplication for your need </h2>")  

for (Var no2= 0; no2<=10; no2++)  

{  

document write (no1+ "x" + no2+ "=" + no1+no2+ "<br>);  

}  

</script> 

</body>  

</Html> 

4. Write a Java Script program using while statement to display 10 numbers. (S-2020) 

<Html>  

<Head>  

<Title> Displaying Numbers</title>  

<Head>  

<Body>  

<script language= "java Script" type = "text/ javaScript">  

var start = prompt ("Enter the start value:", "0" );  

var end = prompt ("Enter the end value:", "10" );  

var inc = prompt ("Enter the increment value:", "1" );  

document.write ("<h2> The numbers are</h2>")  

while (start <= end)  

{  

document.write (start + "<br>”);  

start = start + inc;  

}  

</script>  

</body>  

</Html> 

1. Explain while loop and example. (J-2020) 

While loop : 

❖ In JavaScript while loop is another most basic loop.  
❖ The purpose of a while loop is to execute a statement /block of statement repeatedly as long as an expression is true.  

❖ The while statement creates a loop that executes a specified statement as long as the test condition evaluates to true.  

❖ The condition is evaluated before executing the statement. 

The syntax is:  

while (condition)  

{  

body of the loop  

} 

Example: 

while(no2<=5) 

{  

document.write(no2+" ");  

no2=no2+1; } 

❖ To execute a while statement, the interpreter first evaluates expression.  

❖ If the value of the expression is true the interpreter executes the statement and repeats, jumping back to the top 

of the loop and evaluating expression again 

 CHAPTER- 16 JavaScript Functions 
1. Explain  isNAN function                                                                        

❖ The isNaN() function is used to check whether the given value or variable is valid number.  

❖ This function returns true if the given value is not a number.  

❖ For example isNaN(“12”), isNaN(“A”). 

Another Example: 

if(isNaN(n)==true)  

{  

document.form1.text2.value="Not a Number : "+n;  
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}  

else  

{  

document.form1.text2.value="It is Number : "+n;   }  

2. Describe any five pre-defined functions in JavaScript with examples (M-2019) 

Function Description Example Result 

toUpperCase() Used to convert given string into uppercase  x=”java” 

x.toUpperCase(); 

JAVA 

toLowerCase() Used to convert given string into lowercase x=”JAVA” 

x.toLowerCase(); 

java 

length Used to find length of the given string x=”JAVA” 

x.length(); 

4 

parseInt() Used to convert the given float value into an integer parseInt(34.234); 34 

parseFloat() Used to convert the given string into a integer parseInt(“34.23”); 34.23 
 

 CHAPTER – 17 Computer Ethics and Cyber Security 

1. What are the various crimes happening using computer?  (M-2022) (J-2024)           

1. Cyber Terrorism:  

❖ Hacking, threats, and blackmailing towards a business or a person.  

2. Cyber stalking:  

❖ Harassing through online.  

3. Malware:  

❖ Malicious programs that can perform a variety of functions including stealing, encrypting or deleting sensitive 

data, altering or hijacking core computing functions and monitoring user’s computer activity without their 

permission.  

4. Denial of service attack:  

❖ Overloading a system with fake requests so that it cannot serve normal legitimate requests.  

5. Fraud:  

❖ Manipulating data, for example changing the banking records to transfer money to an unauthorized account.  

6. Harvesting:  

❖ A person or program collects login and password information from a legitimate user to illegally gain access to 

others’ account(s).  

7. Identity theft:  

❖ It is a crime where the criminals impersonate individuals, usually for financial gain.  

8. Intellectual property theft:  

❖ Stealing practical or conceptual information developed by another person or company.  

9. Salami slicing:  

❖ Stealing tiny amounts of money from each transaction.  

10. Scam:  

❖ Tricking people into believing something that is not true.  

11. Spam:  

❖ Distribute unwanted e-mail to a large number of internet users.  

12. Spoofing:  

❖ It is a malicious practice in which communication is send from unknown source disguised as a source known 

to the receiver.  

2. What is piracy? Mention the types of piracy? How can it be prevented?  

❖ Software Piracy is “unauthorized copying of software”. 

❖ It includes stealing of codes / programs and other information illegally and creating duplicate copies by 

unauthorized means and utilizing this data either for one’s own benefit or for commercial profit.  

 
1. Most of the commercial software is licensed for use at a single computer site or for use by only one user at any time. 

2. When a user buys any software, he becomes a licensed user for that software. 

3. He is allowed to make copies of the program for backup purposes, but it is against the law to distribute 

duplicate copies to others.  

4. Such illegal copying and distribution of commercial software should not be practiced. 
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Approach to prevent software piracy: 

1. An entirely different approach to software piracy is called shareware, acknowledges the futility of trying to 

stop people from copying software and instead relies on people’s honesty.  

2. Shareware publishers encourage users to give copies of programs to friends and colleagues but ask everyone 

who uses that program regularly to pay a registration fee to the program’s author directly. 

3. Commercial programs that are made available to the public illegally are often called warez. 

Prevention:  

❖ To pretended being your friend and talk to you on Internet Relay Chart (IRC) or by instant messenger, e-mail 

can also be a source for them. 

❖ They may send official e-mail requesting some sensitive information. 

3. Write the different types of cyber-attacks. (J-2019)(M-2023) (J-2023) 

Cyber Attack                            Function 

Virus ❖ A virus is a small piece of computer code that can repeat itself and spreads from one 

computer to another by attaching itself to another computer file.  

❖ One of the most common virus is Trojan.  

❖ A Trojan virus is a program that appears to perform one function but actually performs 

malicious activity when executed. 

Malware ❖ Malware is a type of software designed through which the criminals gain illegal access to 

software and cause damage.  

Worms ❖ Worms are self- repeating and do not require a computer program to attach themselves.  

❖ Worms continually look for vulnerabilities and report back to the author of the worm when 

weaknesses are discovered. 

Spyware ❖ Spyware can be installed on the computer automatically when the attachments are open, by 

clicking on links or by downloading infected software. 

Ransom 

ware 

❖ Ransom ware is a type of malicious program that demands payment after launching a cyber-

attack on a computer system.  

❖ This type of malware has become increasingly popular among criminals and costs the 

organizations millions each year.  

Pharming ❖ Pharming is a scamming practice in which malicious code is installed on a personal computer 

or server, misdirecting users to fraudulent web sites without their knowledge or permission. 

Phishing ❖ Phishing is a type of computer crime used to attack, steal user data, including login name, 

password and credit card numbers. 
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        CHAPTER 1 TO 18 [2, 3& 5] MARK BOOK INSIDE QUESTION WITH ANSWERS 
 CHAPTER – 1 Introduction to Computers 
1.  Examples of first generation computers: 

▪ First Generation Computers - ENIAC , EDVAC , UNIVAC 1 

2.  Examples of second generation computers: 

▪ Second Generation Computers IBM 1401, IBM 1620, UNIVAC 1108  

3.  Examples of third generation computers: 

▪ Third Generation Computers IBM 360 series, Honeywell 6000 series 

4.  Mention the fifth generation computer software: 

▪ Artificial Intelligence and Expert Systems. 

5.  Fourth generation computer types: 

▪ Micro computer, Portable computer 

6.  Define IPO Cycle. 

▪ The functional components of a computer programs.  

▪ Every task given to a computer follows an Input- Process- Output Cycle (IPO cycle).  

▪ It needs certain input, processes that input and produces the desired output. 

7.  What is NLP? 

▪ Natural Language Processing (NLP) is a component of Artificial Intelligence (AI).  

▪ It provides the ability to develop the computer program to understand human language. 

8.  What is use of VGA? 

▪ The monitor works with the VGA (Video Graphics Array) card.  

▪ The video graphics card helps the keyboard to communicate with the screen.  

▪ It acts as an interface between the computer and display monitor.  

▪ Usually the recent motherboards incorporate built-in video card. 

9.  What is BOOTING? 

▪ When a computer is switched on, there is no information in its RAM. 

▪ At the same time, in ROM, the pre-written program called POST (Power on Self Test) will be executed first.  

▪ This program checks if the devices like RAM, keyboard, etc., are connected properly and ready to operate.  
▪ If these devices are ready, then the BIOS (Basic Input Output System) gets executed. This process is called Booting. 

10.  What is pixels? 

▪ Pictures on a monitor are formed with picture elements called PIXELS. 

11.  Define Cold Booting: 

▪ When the system starts from initial state i.e. it is switched on, we call it cold booting or Hard Booting.  

▪ When the user presses the Power button, the instructions are read from the ROM to initiate the booting process. 

12.  Define Warm Booting: 

▪ When the system restarts or when Reset button is pressed, we call it Warm Booting or Soft Booting.  

▪ The system does not start from initial state and so all diagnostic tests need not be carried out in this case 

13.  Explain any five input devices. 

1.Keyboard:  

▪ Keyboard (wired / wireless, virtual) is the most common input device used today. 

▪  The individual keys for letters, numbers and special characters are collectively known as character keys.  

▪ This keyboard layout is derived from the keyboard of original typewriter.  

▪ The data and instructions are given as input to the computer by typing on the keyboard.  

▪ Apart from alphabet and numeric keys, it also has Function keys for performing different functions.  

▪ There are different set of keys available in the keyboard such as character keys, modifier keys, system and GUI 

keys, enter and editing keys, function keys, navigation keys, numeric keypad and lock keys. 

2.Mouse:  

▪ Mouse (wired/wireless) is a pointing device used to control the movement of the cursor on the display screen. 

▪ It can be used to select icons, menus, command buttons or activate something on a computer.  

▪ Some mouse actions are move, click, double click, right click, drag and drop. 

3.Scanner:  

▪ Scanners are used to enter the information directly into the computer’s memory.  

▪ This device works like a Xerox machine.  

▪ The scanner converts any type of printed or written information including photographs into a digital format, 

which can be manipulated by the computer. 

4.Fingerprint Scanner:  

▪ Finger print Scanner is a fingerprint recognition device used for computer security, equipped with the 

fingerprint recognition feature that uses biometric technology. 

▪ Fingerprint Reader / Scanner is a very safe and convenient device for security instead of using passwords, 

which is vulnerable to fraud and is hard to remember. 

5.Track Ball:  

▪ Track ball is similar to the upside- down design of the mouse.  
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▪ The user moves the ball directly, while the device itself remains stationary.  

6.Retinal Scanner:  
▪ This performs a retinal scan which is a biometric technique that uses unique patterns on a person's retinal blood vessels. 

7.Light Pen:  

▪ A light pen is a pointing device shaped like a pen and is connected to a monitor.  

▪ The tip of the light pen contains a light-sensitive element which detects the light from the screen enabling the 

computer to identify the location of the pen on the screen.  
▪ Light pens have the advantage of ‘drawing’ directly onto the screen, but this becomes hard to use, and is also not accurate.  

8.Optical Character Reader:  
▪ It is a device which detects characters printed or written on a paper with OCR, a user can scan a page from a book.  

▪ The Computer will recognise the characters in the page as letters and punctuation marks and stores.  

▪ The Scanned document can be edited using a word processor. 

9.Bar Code / QR Code Reader:  

▪ A Bar code is a pattern printed in lines of different thickness.  

▪ The Bar code reader scans the information on the bar codes transmits to the Computer for further processing. 

▪ The system gives fast and error free entry of information into the computer.  

QR (Quick response) Code:  
▪ The QR code is the two dimension bar code which can be read by a camera and processed to interpret the image. 

10.Voice Input Systems:  

▪ Microphone serves as a voice Input device.  

▪ It captures the voice data and send it to the Computer.  

▪ Using the microphone along with speech recognition software can offer a completely system new approach to 

input information into the Computer.  

11.Digital Camera:  

▪ It captures images / videos directly in the digital form. It uses a CCD (Charge Coupled Device) electronic chip. 

▪ When light falls on the chip through the lens, it converts light rays into digital format. 

12.Touch Screen:  

▪ A touch screen is a display device that allows the user to interact with a computer by using the finger.  

▪ It can be quite useful as an alternative to a mouse or keyboard for navigating a Graphical User Interface (GUI). 

▪ Touch screens are used on a wide variety of devices such as computers, laptops, monitors, smart phones, 

tablets, cash registers and information kiosks.  
▪ Some touch screens use a grid of infrared beams to sense the presence of a finger instead of utilizing touch-sensitive input. 

13.Keyer:  

▪ A keyer is a device for signalling by hand, by way of pressing one or more switches.  

▪ Modern keyers have a large number of switches but not as many as a full size keyboard.  

▪ Typically, this number is between 4 and 50.  

▪ A keyer differs from a keyboard, which has "no board", but the keys are arranged in a cluster. 

14.  Explain Output devices. 

1.Monitor:  

▪ Monitor is the most commonly used output device to display the information.  

▪ It looks like a TV. Pictures on a monitor are formed with picture elements called PIXELS.  

▪ Monitors may either be Monochrome which display text or images in Black and White or can be color, which 

display results in multiple colors.  

▪ There are many types of monitors available such as CRT (Cathode Ray Tube), LCD (Liquid Crystal Display) 

and LED (Light Emitting Diodes).  

▪ The monitor works with the VGA (Video Graphics Array) card.  

▪ The video graphics card helps the keyboard to communicate with the screen.  

▪ It acts as an interface between the computer and display monitor.  

▪ Usually the recent motherboards incorporate built-in video card. 
▪ The first computer monitor was part of the Xerox Alto computer system, which was released on March 1, 1973. 

2.Plotter:  

▪ Plotter is an output device that is used to produce graphical output on papers.  

▪ It uses single color or multi color pens to draw pictures. 

3.Printers:  

▪ Printers are used to print the information on papers. Printers are divided into two main categories:  

       • Impact Printers    • Non-Impact printers 

Impact Printers:  

▪ These printers print with striking of hammers or pins on ribbon.  

▪ These printers can print on multi-part (using carbon papers) by using mechanical pressure.  

▪ For example, Dot Matrix printers and Line matrix printers are impact printers. 

Non-Impact Printers: 

▪ These printers do not use striking mechanism for printing.  

▪ They use electrostatic or laser technology.  
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▪ Quality and speed of these printers are better than Impact printers.  

▪ For example, Laser printers and Inkjet printers are non-impact printers. 

4.Speakers:  

▪ Speakers produce voice output (audio) .Using speaker along with speech synthesise software, the computer can 

provide voice output.  

▪ This has become very common in places like airlines, schools, banks, railway stations, etc. 

5.Multimedia Projectors:  

▪ Multimedia projectors are used to produce computer output on a big screen.  

▪ These are used to display presentations in meeting halls or in classrooms. 

15.  Types of impact printers. 

1.Dot matric printer: 

▪ A Dot matrix printer that prints using a fixed number of pins or wires.  

▪ Each dot is produced by a tiny metal rod, also called a “wire” or “pin”, which works by the power of a tiny 

electromagnet or solenoid, either directly or through a set of small levers.  

▪ It generally prints one line of text at a time.  

▪ The printing speed of these printers varies from 30 to 1550 CPS (Character Per Second).  

2.Line matrix printer: 

▪ Line matrix printers use a fixed print head for printing. Basically, it prints a page-wide line of dots.  

▪ But it builds up a line of text by printing lines of dots.  
▪ Line printers are capable of printing much more than 1000 Lines Per Minute, resulting in thousands of pages per hour.  

▪ These printers also uses mechanical pressure to print on multi-part (using carbon papers). 

16.  Types non-impact printers. 

1.Laser Printers: 

▪ Laser printers mostly work with similar technology used by photocopiers.  

▪ It makes a laser beam scan back and forth across a drum inside the printer, building up a pattern.  

▪ It can produce very good quality of graphic images.  

▪ One of the chief characteristics of laser printer is their resolution – how many Dots per inch (DPI).  

▪ The available resolution range around 1200 dpi.  

▪ Approximately it can print 100 pages per minute(PPM). 

2.Inkjet Printers:  

▪ Inkjet Printers use colour cartridges which combined Magenta, Yellow and Cyan inks to create color tones.  

▪ A black cartridge is also used for monochrome output.  

▪ Inkjet printers work by spraying ionised ink at a sheet of paper.  

▪ The speed of Inkjet printers generally range from 1-20 PPM (Page Per Minute). 

▪ They use the technology of firing ink by heating it so that it explodes towards the paper in bubbles or by using 

piezoelectricity in which tiny electric currents controlled by electronic circuits are used inside the printer to 

spread ink in jet speed.  

▪ An Inkjet printer can spread millions of dots of ink at the paper every single second. 

 CHAPTER – 2 Number Systems 
1.  What is bit? 

▪ A bit is the short form of Binary digit which can be ‘0’ or ‘1’. It is the basic unit of data in computers. 

2.  What is nibble and Byte? 

▪ A nibble is a collection of 4 bits (Binary digits).  
▪ A collection of 8 bits is called Byte. A byte is considered as the basic unit of measuring the memory size in the computer. 

3.  Define – Word Length: 

▪ Word length refers to the number of bits processed by a Computer’s CPU.  
▪ For example, a word length can have 8 bits, 16 bits, 32 bits and 64 bits (Present day Computers use 32 bits or 64 bits) 

4.  What is computer memory?  

▪ Computer memory is normally represented in terms of Kilo Byte (KB) or Mega Byte (MB).  
▪ In decimal system, 1 Kilo represents 1000, that is , 103. In binary system, 1 KiloByte represents 1024 bytes that is 210. 

5.  Explain computer memory sizes? 

Name Abbr. Size 

Kilo K 2^10 = 1,024 

Mega M 2^20 = 1,048,576 

Giga G 2^30 = 1,073,741,824 

Tera T 2^40 = 1,099,511,627,776 

Peta P 2^50 = 1,125,899,906,842,624 

Exa E 2^60 = 1,152,921,504,606,846,976 

Zetta Z 2^70 = 1,180,591,620,717,411,303,424 

Yotta Y 2^80 = 1,208,925,819,614,629,174,706,173  
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6.  What are the different types of coding schemes? 

▪ Bytes are used to represent characters in a text.  

▪ Different types of coding schemes are used to represent the character set and numbers.  

▪ The most commonly used coding scheme is the American Standard Code for Information Interchange (ASCII). 

▪ Each binary value between 0 and 127 is used to represent a specific character.  

▪ The ASCII value for (blank space) is 32 and the ASCII value of numeric 0 is 48.  

▪ The range of ASCII values for lower case alphabets is from 97 to 122 and the range of ASCII values for the 

upper case alphabets is 65 to 90. 

7.  How the data classified based of their size? 

▪ Bites, Nibble, Bytes and Word. 

8.  Decimal Number System: 

▪ It consists of 0,1,2,3,4,5,6,7,8,9(10 digits).  

▪ It is the oldest and most popular number system used in our day to day life.  

▪ In the positional number system, each decimal digit is weighed relative to its position in the number.  
▪ This means that each digit in the number is multiplied by 10 raised to a power corresponding to that digit’s position. 

9.  Binary Number System:  

▪ There are only two digits in the Binary system, namely, 0 and 1.  
▪ The numbers in the binary system are represented to the base 2 and the positional multipliers are the powers of 2.  

▪ The left most bit in the binary number is called as the Most Significant Bit (MSB) and it has the largest 

positional weight.  

▪ The right most bit is the Least Significant Bit (LSB) and has the smallest positional weight. 

10.  Octal Number System: 

▪ Octal number system uses digits 0,1,2,3,4,5,6 and 7 (8 digits).  

▪ Each octal digit has its own positional value or weight as a power of 8. 

11.  Hexadecimal Number System:  

▪ A hexadecimal number is represented using base 16.  

▪ Hexadecimal or Hex numbers are used as a shorthand form of binary sequence.  

▪ This system is used to represent data in a more compact manner.  

▪ Since 16 symbols are used, 0 to F, the notation is called hexadecimal.  
▪ The first 10 symbols are the same as in the decimal system, 0 to 9 and the remaining 6 symbols are taken from the first 6 

letters of the alphabet sequence, A to F, where A represents 10, B is 11, C is 12, D is 13, E is 14 and F is 15. 

12.  Signed Magnitude: 

▪ Computers can handle both positive (unsigned) and negative (signed) numbers.  

▪ The simplest method to represent negative binary numbers is called Signed Magnitude. 

13.  Sign bit or parity bit: 

▪ In signed magnitude method, the left most bit is Most Significant Bit (MSB), is called sign bit or parity bit. 

14.  Signed Magnitude representation: 

▪ The value of the whole numbers can be determined by the sign used before it.  

▪ If the number has ‘+’ sign or no sign it will be considered as positive.  

▪ If the number has ‘–’ sign it will be considered as negative. 

Example:   + 43 or 43 is a positive number       – 43 is a negative number 

15.  Binary Coded Decimal (BCD)  

▪ This encoding system is not in the practice right now.  

▪ This is 26 bit encoding system. This can handle 26 = 64 characters only. 

16.  ASCII:  

▪ American Standard Code for Information Interchange (ASCII)  

▪ This is the most popular encoding system recognized by United States.  

▪ Most of the computers use this system. Remember this encoding system can handle English characters only. 

▪ This can handle 27 bit which means 128 characters.  

▪ In this system, each character has individual number.  
▪ The new edition (version) ASCII -8, has 28 bits and can handle 256 characters are represented from 0 to 255 unique numbers.  

▪ The ASCII code equivalent to the uppercase letter ‘A’ is 65.  

▪ The binary representation of ASCII (7 bit) value is 1000001. Also 01000001 in ASCII-8 bit. 

17.  EBCDIC: 

▪ Extended Binary Coded Decimal Interchange Code (EBCDIC)  

▪ This is similar to ASCII Code with 8 bit representation.  

▪ This coding system is formulated by International Business Machine(IBM).  

▪ The coding system can handle 256 characters.  

▪ The input code in ASCII can be converted to EBCDIC system and vice – versa 

18.  Unicode: 

▪ This coding system is used in most of the modern computers.  

▪ The popular coding scheme after ASCII is Unicode. ASCII can represent only 256 characters.  

▪ Therefore English and European Languages alone can be handled by ASCII. Particularly there was a situation, 
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when the languages like Tamil, Malayalam, Kannada and Telugu could not be represented by ASCII.  

▪ Hence, the Unicode was generated to handle all the coding system of Universal languages.  

▪ This is 16 bit code and can handle 65536 characters.  

19.  Define MSB & LSB 
▪ The left most bit in the binary number is called as the Most Significant Bit (MSB) and it has the largest positional weight.  

▪ The right most bit is the Least Significant Bit (LSB) and has the smallest positional weight. 

 CHAPTER – 3 Computer Organization 
1.  Microprocessor units: 

▪ The microprocessor is made up of 3 main units.  

1. Arithmetic and Logic unit (ALU): To perform arithmetic and logical instructions based on computer instructions. 

2. Control unit: To control the overall operations of the computer through signals.  

3. Registers (Internal Memory): They are used to hold the instruction and data for the execution of the processor. 

2.  Instruction Set: 
▪ Basic set of machine level instructions that a microprocessor is designed to execute is called as an instruction set. 

3.  What is Bus? 

▪ A bus is a collection of wires used for communication between the internal components of a computer. 

4.  Examples of RISC processors:  

▪ Pentium IV, Intel P6, AMD K6 and K7. 

5.  Examples of CISC processors: 

▪ Intel 386 & 486, Pentium, Pentium II and III, and Motorola 68000. 

6.  Compare bit &  byte: 

▪ The smallest unit of information that can be stored in the memory is called as a bit.  

▪ The memory can be accessed by a collection of 8 bits which is called as a byte. 

7.  What is the use of ports? 

▪ The Motherboard of a computer has many I/O sockets that are connected to the ports 

8.  Define silicon chip. 
▪ Silicon chip is an integrated, set of electronic circuits on one small flat piece of semiconductor material, silicon. 

9.  Define – Hertz. 

▪ Hertz – abbreviated as Hz is the standard unit of measurement used for measuring frequency.  

▪ Since frequency is measured in cycles per second, one hertz equals one cycle per second.  

▪ Hertz is commonly used to measure wave frequencies, such as sound waves, light waves, and radio waves. 

10.  What is USB 3.0? 
▪ USB 3.0 is the third major version of the Universal Serial Bus (USB) standard to connect computers with other electronic gadgets. 

▪ USB 3.0 can transfer data up to 5 Giga byte/second.USB3.1 and USB 3.2 are also released. 

11.  Random-Access Memory (RAM)  

▪ The main memory is otherwise called as Random Access Memory.  

▪ This is available in computers in the form of Integrated Circuits (ICs).  

▪ It is the place in a computer where the Operating System, Application Programs and the data in current use are 

kept temporarily so that they can be accessed by the computer’s processor. 

▪ RAM is a volatile memory, which means that the information stored in it is not permanent.  

▪ As soon as the power is turned off, whatever data that resides in RAM is lost.  

▪ It allows both read and write operations. 

12.  Read Only Memory (ROM)  

▪ Read Only Memory refers to special memory in a computer with pre-recorded data at manufacturing time 

which cannot be modified.  

▪ The stored programs that start the computer and perform diagnostics are available in ROMs.  

▪ ROM stores critical programs such as the program that boots the computer.  

▪ Once the data has been written onto a ROM chip, it cannot be modified or removed and can only be read. 

▪ ROM retains its contents even when the computer is turned off.  

▪ So, ROM is called as a non-volatile memory. 

13.  Programmable Read Only Memory (PROM)  

▪ Programmable read only memory is also a non-volatile memory on which data can be written only once.  

▪ Once a program has been written onto a PROM, it remains there forever.  

▪ Unlike the main memory, PROMs retain their contents even when the computer is turned off.  

▪ The PROM differs from ROM.  
▪ PROM is manufactured as a blank memory, whereas a ROM is programmed during the manufacturing process itself.  

▪ PROM programmer or a PROM burner is used to write data to a PROM chip.  

▪ The process of programming a PROM is called burning the PROM. 

14.  Erasable Programmable Read Only Memory (EPROM)  

▪ Erasable Programmable Read Only Memory is a special type of memory which serves as a PROM, but the 

content can be erased using ultraviolet rays.  

▪ EPROM retains its contents until it is exposed to ultraviolet light.  

▪ The ultraviolet light clears its contents, making it possible to reprogram the memory.  
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▪ An EPROM differs from a PROM, PROM can be written only once and cannot be erased.  

▪ EPROMs are used widely in personal computers because they enable the manufacturer to change the contents 

of the PROM to replace with updated versions or erase the contents before the computer is delivered. 

15.  Electrically Erasable Programmable Read Only Memory (EEPROM)  

▪ Electrically Erasable Programmable Read Only Memory is a special type of PROM that can be erased by 

exposing it to an electrical charge.  

▪ Like other types of PROM, EEPROM retains its contents even when the power is turned off.  

▪ Comparing with all other types of ROM, EEPROM is slower in performance. 

16.  Cache Memory: 
▪ The cache memory is a very high speed and expensive memory, which is used to speed up the memory retrieval process.  

▪ Due to its higher cost, the CPU comes with a smaller size of cache memory compared with the size of the main memory.  

▪ Without cache memory, every time the CPU requests the data, it has to be fetched from the main memory 

which will consume more time.  

▪ The idea of introducing a cache is that, this extremely fast memory would store data that is frequently accessed 

and if possible, the data that is closer to it.  

▪ This helps to achieve the fast response time, where response Time, (Access Time) refers to how quickly the 

memory can respond to a read / write request.  

17.  Explain secondary storage devices: 

1.Hard Disks:  

▪ Hard disk is a magnetic disk on which you can store data.  

▪ The hard disk has the stacked arrangement of disks accessed by a pair of heads for each of the disks.  

▪ The hard disks come with a single or double sided disk. 

2.Compact Disc (CD)  

▪ A CD or CD-ROM is made from 1.2 millimetres thick, polycarbonate plastic material.  

▪ A thin layer of aluminium or gold is applied to the surface.  

▪ CD data is represented as tiny indentations known as "pits", encoded in a spiral track moulded into the top of 

the polycarbonate layer.  

▪ The areas between pits are known as "lands".  

▪ A motor within the CD player rotates the disk. The capacity of an ordinary CD-ROM is 700MB. 

3.Digital Versatile Disc (DVD)  

▪ A DVD (Digital Versatile Disc or Digital Video Disc) is an optical disc capable of storing up to 4.7 GB of 

data, more than six times what a CD can hold.  

▪ DVDs are often used to store movies at a better quality.  

▪ Like CDs, DVDs are read with a laser.  

▪ The disc can have one or two sides, and one or two layers of data per side; the number of sides and layers 

determines how much it can hold.  
▪ Double-layered sides are usually gold-coloured, while single-layered sides are usually silver-coloured, like a CD. 

4.Flash Memory Devices  

▪ Flash memory is an electronic (solid-state) non-volatile computer storage medium that can be electrically 

erased and reprogrammed.  

▪ They are either EEPROM or EPROM. Examples for Flash memories are pen drives, memory cards etc.  

▪ Flash memories can be used in personal computers, Personal Digital Assistants (PDA), digital audio players, 

digital cameras and mobile phones.  

▪ Flash memory offers fast access times.  

▪ The time taken to read or write a character in memory is called access time.  

▪ The capacity of the flash memories vary from 1 Gigabytes (GB) to 2 Terabytes (TB). 

5.Blu-Ray Disc: 

▪ Blu-Ray Disc is a high-density optical disc similar to DVD.  

▪ Blu-ray is the type of disc used for PlayStation games and for playing High-Definition (HD) movies.  

▪ A double-layer Blu-Ray disc can store up to 50GB (gigabytes) of data.  

▪ DVD uses a red laser to read and write data.  

▪ But, Blu-ray uses a blue-violet laser to write.  

 CHAPTER – 4 Theoretical Concepts of Operating System 
1.  Explain software with types. 

▪ A software is set of instructions that perform specific task.  

▪ It interacts basically with the hardware to generate the desired output.  

Types of Software 

▪ Software is classified into two types:  1) Application Software  2) System Software  

1.Application Software:  

▪ Application software is a set of programs to perform specific task.  

▪ For example MS-word is an application software to create text document and VLC player is familiar 

application software to play audio, video files and many more.  
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2.System Software:  

▪ System software is a type of computer program that is designed to run the computer’s hardware and 

application programs. Example Operating System and compiler. 

2.  Single User Operating Systems: 

▪ An operating system allows only a single user to perform a task at a time.  

▪ It is called as a Single user and single Task operating system. 

▪ MS-DOS is an example for a single user and single task Operating System. 

3.  What is process: 

▪ A system task, such as sending output to a printer or screen, can also be called as a Process. 

4.  Process management categories: 

▪ Operating System processes which is executed by system code 

▪ User Processes which is execute by user code 

5.  Fault Tolerance:  

▪ The Operating Systems should be robust.  

▪ When there is a fault, the Operating System should not crash, instead the Operating System have fault 

tolerance capabilities and retain the existing state of system. 

6.  Functions of OS: 

▪ The functions of an Operating System include file management, memory management, process management 

and device management and many more. 

7.  List out OS:  
▪ Some of the popular Operating Systems used in personal computers and laptops are Windows, UNIX and Linux.  

▪ The mobile devices mostly use Android and ioS as mobile OS. 

8.  File Management: 

▪ File management is an important function of OS which handles the data storage techniques.  

▪ The operating System manages the files, folders and directory systems on a computer. 

▪ The FAT (File Allocation Table) stores general information about files like filename, type (text or binary), 

size, starting address and access mode. 

▪ The file manager of the operating system helps to create, edit, copy, allocate memory to the files and also 

updates the FAT.  

▪ There are few other file management techniques available like Next Generation File System (NTFS) and 

ext2(Linux). 

 CHAPTER – 5 Working with Windows Operating System 
1.  Windows uses: 

▪ Windows Operating System uses both Keyboard and mouse as input devices.  

▪ Mouse is used to interact with Windows by clicking its icons.  

▪ Keyboard is used to enter alphabets, numerals and special characters. 

2.  Some of the functions of Windows Operating System are: 

▪ Access applications (programs) on the computer (word processing, games, spread sheets, calculators and so on). 

▪ Load any new program on the computer. 

▪ Manage hardware such as printers, scanners, mouse, digital cameras etc., 

▪ File management activities (For example creating, modifying, saving, deleting files and folders). 

▪ Change computer settings such as colour scheme, screen savers of your monitor, etc. 

3.  Windows Desktop:  

▪ The opening screen of Windows is called “Desktop”. 

4.  The Icons:  

▪ Icon is a graphic symbol representing the window elements like files, folders, shortcuts etc., Icons play a vital 

role in GUI based applications. 

5.  Standard Icons:  

▪ The icons which are available on desktop by default while installing Windows OS are called standard icons. 

▪ The standard icons available in all Windows OS are My Computer, Documents and Recycle Bin. 

6.  Shortcut Icons:  

▪ Shortcut icons can be created for any application or file or folder.  

▪ By double clicking the icon, the related application or file or folder will open. 

7.  Disk drive icons:  

▪ The disk drive icons graphically represent five disk drive options.  

▪ (i) Hard disk (ii) CD-ROM/DVD Drive (iii) Pen drive (iv) Other removable storage such as mobile, smart 

phone, tablet etc., (v) Network drives if your system is connected with other system.  

8.  Application Window:  

▪ It is an area on a computer screen with defined boundaries, and within which information is displayed.  

▪ Such windows can be resized, maximised, minimised, placed side by side, overlap, and so on. 

9.  Document Window:  

▪ A document window is a section of the screen used to display the contents of a document. 
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10.  Start Menu:  

▪ In the lower left-hand corner of the windows screen is the Start button.  

▪ When you click on the button, the Start menu will appear.  

▪ Using the start menu, you can start any application. 

11.  Taskbar: At the bottom of the screen is a horizontal bar called the taskbar 

12.  Computer Icon: 

▪ By clicking this icon, the user can see the disk drivers mounted in the system.  

▪ In windows XP, Vista, this icon is called "My computer" in Windows 8 and 10, it is called "This PC". 

13.  Elements of a window: 

1.Title Bar: 

▪ The title bar will display the name of the application and the name of the document opened.  

▪ It will also contain minimize, maximize and close button. 

2.Menu Bar: 

▪ The menu bar is seen under the title bar.  
▪ Menus in the menu bar can be accessed by pressing Alt key and the letter that appears underlined in the menu title. 
▪ Additionally, pressing Alt or F10 brings the focus on the first menu of the menu bar. 

3.The Workspace: 

▪ The workspace is the area in the document window to enter or type the text of your document.  

4.Scroll bars:  

▪ The scroll bars are used to scroll the workspace horizontally or vertically.  

5.Corners and borders: 

▪ The corners and borders of the window helps to drag and resize the windows.  

▪ The mouse pointer changes to a double headed arrow when positioned over a border or a corner. 

14.  Starting and Closing Applications: 

1. Click the Start button and then point to All Programs. The Program menu appears. 

2. Point to the group that contains the application you want to start, and then click the application name. 

3. You can also open an application by clicking Run on the Start menu, and the name of the application. 

4. To quit an application, click the Close button in the upper right corner of the application window. 

5. You can also quit an application by clicking on File → Exit and File → Close option in Windows 7. 

15.  Creating Folders: 

▪ There are two ways in which you can create a new folder: 

Method I:  

Step 1: Open Computer Icon. 

Step 2: Open any drive where you want to create a new folder.  

Step 3: Click on File → New → Folder. 

Step 4: A new folder is created with the default name “New folder”. 

Step 5: Type in the folder name and press Enter key.  

Method II:  

Step 1: In the Desktop, right click → New → Folder.  

Step 2: A Folder appears with the default name “New folder”. 

Step 3: Type the name you want and press Enter Key. 

Step 4: The name of the folder will change. 

16.  Creating Files (Word pad): 

1. Click Start → All Programs → Accessories → Word pad or Run → type Word pad, click OK. 

2. Type the contents in the workspace and save the file using File → Save or Ctrl + S. 

3. Save As dialog box will be opened.  

4. In the dialog box, select the location where you want to save the file by using look in drop down list box. 

5. Type the name of the file in the file name text box. 

6. Click save button. 

17.  Finding Files and Folders: 

To find a file or folder: 

1. Click the Start button, the search box appears at the bottom of the start menu.  

2. Type the name of the file or the folder you want to search.  
    Even if you give the part of the file or folder name, it will display the list of files or folders starting with the specified name.  

3. The files or the folders with the specified names will appear, if you  

4. There is another option called “See more results” which appears above the search box.  

5. If you click it, it will lead you to a Search Results dialog box where you can click and open that file or the folder. 

Searching Files or folders using Computer icon: 

1. Click Computer Icon from desktop or from Start menu.  

2. The Computer disk drive screen will appear and at the top right corner of that screen, there is a search box option.  

3. Type the name of the file or the folder you want to search.  

    Even if you give the part of the file or folder name, it will display the list of files or folders starting with the  

    specified name. 
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4. Just click and open that file or the folder. 

18.  Renaming Files or Folders 

▪ There are number of ways to rename files menu, left mouse button or right mouse button. 

Method 1 Using the FILE Menu 

1. Select the File or Folder you wish to Rename. 

2. Click File→ Rename. 

3. Type in the new name.  

4. To finalise the renaming operation, press Enter. 

Method 2  Using the Right Mouse Button 

1. Select the file or folder you wish to rename. 

2. Click the right mouse button over the file or folder.  

3. Select Rename from the pop-up menu. 

4. Type in the new name.  

5. To finalise the renaming operation, press Enter. 

Method 3  Using the Left Mouse Button 

1. Select the file or folder you wish to rename. 

2. Press F2 or click over the file or folder. A surrounding rectangle will appear around the name. 

3. Type in the new name. 

4. To finalise the renaming operation, press Enter. 

19.  Moving Files and Folders 

Method I-CUT and PASTE:  

▪ Click on the Edit → Cut or Ctrl + X Or right click → cut from the pop-up menu.  

▪ To move the file(s) or folder(s) in the new location, navigate to the new location and paste it using Click Edit 

→ Paste from edit menu or Ctrl + V using keyboard.  

▪ Or Right click → Paste from the pop-up menu. The file will be pasted in the new location.  

Method II – Drag and Drop  

▪ In the disk drive window, we have two panes called left and right panes.  

▪ In the left pane, the files or folders are displayed like a tree structure.  

▪ In the right pane, the files inside the specific folders in the left pane are displayed with various options. 

▪ In the right pane of the Disk drive window, select the file or folder you want to move. 

▪ Click and drag the selected file or folder from the right pane, to the folder list on the left pane.  

▪ Release the mouse button when the target folder is highlighted (active). 

▪ Your file or folder will now appear in the new area. 

20.  Copying Files and Folders: 

Method I - COPY and PASTE:  

▪ Click Edit → Copy or Ctrl + C or right click→ Copy from the pop-up menu. 

To paste the file(s) or folder(s) in the new location, navigate to the target location then do one of the following: 

▪ Click Edit → Paste or Ctrl + V. 

▪ Or Right click → Paste from the pop-up menu.  

Method II – Drag and Drop: 

▪ In the right pane, select the file or folder you want to copy.  

▪ Click and drag the selected file and/or folder to the folder list on the left, and drop it where you want to copy 

the file and/or folder.  

▪ Your file(s) and folder(s) will now appear in the new area 

21.  Copying Files and Folders to removable disk:  

▪ There are several methods of transferring files to or from a removable disk. • Copy and Paste  • Send To 

METHOD I - Copy and Paste: 

▪ Plug the USB flash drive directly into an available USB port. 

If the USB flash drive or external drive folder does not open automatically, follow these steps: 

▪ Click Start→Computer. 

▪ Double-click on the Removable Disk associated with the USB flash drive. 

▪ Navigate to the folders in your computer containing files you want to transfer 

▪ Right-click on the file you want to copy, then select Copy. 

▪ Return to the Removable Disk window, right-click within the window, then select Paste. 

METHOD II - Send To  

▪ Plug the USB flash drive directly into an available USB port. 

▪ Navigate to the folders in your computer containing files you want to transfer. 

▪ Right-click on the file you want to transfer to your removable disk. 

▪ Click Send To and select the Removable Disk associated with the USB flash drive. 

22.  Deleting Files and Folders:  

▪ When you delete a file or folder, it will move into the Recycle Bin. 

To delete a file or folder: 

▪ Select the file or folder you wish to delete. 
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1. Right- click the file or folder, select Delete option from the po-pup menu  

2. or Click File → Delete or press Delete key from the keyboard. 

3. The file will be deleted and moved to the Recycle bin. 

23.  Creating Shortcuts on the Desktop:  
▪ Shortcuts to your most often used folders and files may be created and placed on the Desktop to help automate your work.  

▪ Select the file or folder that you wish to have as a shortcut on the Desktop. 

▪ Right click on the file or folder. 

▪ Select Send to from the shortcut menu, then select Desktop (create shortcut) from the sub-menu. 

▪ A shortcut for the file or folder will now appear on your desktop and you can open it from the desktop in the 

same way as any other icon. 

24.  Shutting down or Logging off a Computer: 

▪ Once you have closed all open applications, you can either log off your computer or shut down the computer. 

▪ Click start → log off (click the arrow next to Shut down) or Start → Shutdown. 

▪ If you have any open programs, then you will be asked to close them or windows will Force shut down, you 

will lose any un-saved information if you do this.  
• Switch User: Switch to another user account on the computer without closing your open programs and Windows processes. 

• Log Off: Switch to another user account on the computer after closing all your open programs and Windows processes. 

• Lock: Lock the computer while you're away from it. 

• Restart: Reboot the computer. (This option is often required as part of installing new software or Windows update.) 

• Sleep: Puts the computer into a low-power mode that retains all running programs and open Windows in computer memory 

for a super-quick restart. 

• Hibernate (found only on laptop computers): Puts the computer into a low-power mode after saving all running programs 

and open Windows on the machine's hard drive for a quick restart 

 CHAPTER – 6  
1.  Word wrap: 

• When the text reaches the end of the line, the word is automatically wrapped to the next line.  

• This feature in any word processor is known as “Word Wrap”. 

2.  Download and Install open office:  
• Download and Install the latest version of Open Office suite from http://www.openoffice.org/download at free of cost. 

3.  Open office: 

• Open Office is the leading open-source office software suite for word processing, spreadsheets, presentations, 

graphics, databases and much more.  

• It is available in many languages and works on all computers.  

• It stores all data in an International open standard format and can also read and write files from common office 

software packages.  

• Open Office is easy to learn. 

4.  Word processing: 

• Word processor is a computer software to create, edit, manipulate, transmit, store and retrieve a text document. 

• The above said activities are called as “Word Processing”. 

5.  Tamil Word Processors:  

• Tamil openoffice writer, Tamil LibreOffice Writer, Kamban 3.0, Mentamizh2017 – These are familiar word 

processors exclusively for Tamil Language.  

• Microsoft also provides full Tamil interface for all office suits. 

6.  Insertion pointer: 

• The work space is the blank area which is used to type the content of the file. 

• A flashing vertical bar that appears at the beginning of the screen which is called as “Insertion pointer”. 

7.  Tamil Typing Interface: 

• Using Tamil Font   • Using Tamil Interface. 

8.  Tamil interface advantages: 

• It follows Unicode techniqueHence knowledge of Tamil typing is not necessary. 

• It is easy to type documents in Tamil in any word processor. 

• Some of the Unicode fonts like “Arial Unicode” supports all Indian languages including Tamil and English 

using respective language interface. 

9.  Download and Install Tamil Typing Interface: 

• Many Tamil Typing Interfaces are available as open source such as “Murasu”(it is exclusively for Tamil), 

“NHM Writer”(It is universal to all Indian languages) etc. 

To download and install: 

1.“Murasu” use the link : http://anjal.net/download  2.“NHM writer” use the link : http://software.nhm.in 

10.  Deleting rows and columns: 

1. Place the insertion pointer in the row or column to be deleted and right-click. 

2. Choose Row → Delete to delete a row or Column → Delete to delete a column.  

3. The selected row / column is deleted. 
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11.  Preview the document to be printed: 

1. Click File → Page Preview, or click the Page Preview icon. The Writer displays the Page Preview toolbar  

2. In the page preview tool bar click Multiple Pages icon to display multiple pages. 

3. To close the preview click the Close Preview button. 

12.  Setting the Printer and Printing: 

1. Click File → Print or Ctrl + P or Print File Icon which opens the Print dialog box. 

2. Click General Tab. 

3. Select the required printer from the list of printers. 

4. Under Range and copies section: select All Pages option to print all pages, select Pages option to specify the particular page or page range. 

5. Specify Number of Copies using spin arrows. 

6. Click Print button. 

13.  Line Spacing:  

• Line spacing determines the amount of vertical space between lines of text in a paragraph.  

• By default, the lines are single-spaced, that is the spacing accommodates the largest font in that line, plus a 

small amount of extra space.  

• In Open Office, setting line spacing is quite easy through the context menu, select the line or word or phrase, 

right-click → line spacing, select the type single, 1.5 or double.  

• There are seven different types of line spacing as shown in the dialog box  

• Select the entire document by Edit → Select All  

                                   Format → paragraph 

• The paragraph dialog box appears, click Indents & Spacing tab 

• In the line spacing option, select the type and click OK button. 

14.  Tamil font some drawbacks: 

• The user must be aware of Tamil typing. 

• The particular font must be available in the system. 

• It does not support other languages including English. 

• The computer accepts characters as symbols not as language. 

• It is not portable, i.e. if the document is sent to another computer, if the same font is not available, it is 

recognized as symbols not as original characters. 

15.  Open office important features: 

• Templates and styles. 

• Page layout methods, including frames, columns, and tables. 

• Embedding or linking of graphics, spreadsheets, and other objects. 

• Built-in drawing tools. 

• Master documents-to group a collection of documents into a single document. 

• Change tracking during revisions. 

• Database integration, including a bibliography database. 

• Export to PDF. 

16.  Changing or setting page margins in Open Office Writer can be done in two ways:  

1. Using the Rulers - quick and easy, but does not have precise values.  

2. Using the Page Style dialog box - can specify precise values for the margins.  

1. Changing page margins - using Ruler 

1. The shaded sections of the rulers are the margins.  

2. Hold the mouse pointer over the line between the gray and white sections. 

3. The mouse pointer turns into a double-headed arrow. 

4. Hold down the left mouse button and drag the mouse to move the margin and release it at the required point. 

5. The new margin is set.  

2. Using the Page Style dialog box  

• To change margins using the Page Style dialog box 

17.  There are two methods to create a table : 

Method 1. Table Icon  

• To insert a table quickly from the standard tool bar: 

1. Place the insertion pointer where you want the table to appear. 

2. Click the down arrow to the right side of the Table icon . 

3. In the drop down grid, select the number of rows and columns for the table. 

4. The table will appear at the location of the insertion pointer. 

Method 2. Insert table dialog box  

• To insert a table with more control over the settings and properties, use the Insert Table dialog box.  

• To open the dialog box: Select Table → Insert →Table or Ctrl +F12 or left-click the Table icon.  

• From this dialog box, you can: 

• Select the number of rows and columns of the table 
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• Give a Name to the table in the Name Text box 

• Select the Heading check box to define the first row in the table as the heading 

• Select the Repeat heading check box to repeat the heading row if the table spans more than one page 

• Select the Don't split table check box to prevent the table from spanning more than one page 

• Select the Border check box to display table with grid. 

• Click ok 

 CHAPTER – 7  
1.  Features of Open Office Calc:  

1. Connecting with Excel: 

• Ability to open, edit, and save Microsoft Excel spreadsheets  

2. AutoSum: 

• Helps you to add the contents of a cluster of adjacent cells.  

3. List AutoFill: 

• Automatically extends cell formatting when a new item is added to the end of a list.  

4. AutoFill : 

• Allows you to quickly fill cells with repetitive or sequential data such as chronological dates or numbers, and 

repeated text.  

• AutoFill can also be used to copy functions. You can also alter text and numbers with this feature.  

5.Charts: 

• Helps you in presenting a graphical representation of your data in the form of Pie, Bar, Line charts and more. 

2.  How to create a work sheet? 

• A new spreadsheet can also be created by selecting File → New → Spreadsheet 

3.  Cell pointer and Active cell: 

• Cell pointer is a rectangle box which can be moved around the worksheet.  

• The cell in which the cell pointer is currently located is known as “Active cell”. 

4.  Home cell: 

• When you open a new spreadsheet, the cell pointer is located in cell A1.  

• So, the Cell A1 is known as “Home Cell”. 

5.  Auto Fill: 

• The process of Copy and paste can be replaced by a click and drag and it is called as “Auto Fill”.  

• This is an alternate way to copy and paste. 

6.  Auto fill features: 

• Auto Fill feature fills the contents from one cell to all the dragged cells.  

• The content may be a data or formula.  

• If you fill a relative formula, all the addresses of filled formulae will be changed. 

7.  What are the use of Tab , Shift , Enter key: 

• Tab key” is used to move the cell pointer towards the right side or forward direction.  

• “Shift+Tab” is used to move backward i.e. from right to left in a row.  

• “Enter” key is also used to move the cell pointer. 

8.  Range: 

• Reference operators are used to refer cell ranges. A continuous group of cells is called as “Range”. 

9.  Spreadsheet: 

• A spreadsheet is a “Flat file database”.  

• Thus, database operations such as sorting, filtering can be done on spreadsheet 

10.  Database: 

• A database is a repository of collections of related data or facts.  

• It arranges them in a specific structure. 

11.  Sorting:  

• Sorting is the process of arranging data in ascending or descending order.  

• There are three types of sorting in OpenOffice Calc.  

• They are, (1) Simple Sorting, (2) Multi Sorting, (3) Sort by selection 

12.  Filtering: 

• Filter is a way of limiting the information that appears on screen.  

• Filters are a feature for displaying and browsing a selected list or subset of data from a worksheet.  

• The visible records satisfy the condition that the user sets.  

• Those that do not satisfy the condition are hidden, but not removed. 

13.  Reference concatenation operator:  

• Concatenation means joining together.  

• Tilde (~) symbol is used as a concatenation operator in calc.  

Syntax:    reference left ~ reference right Ex:  =SUM(A1:A6 ~ C3:F3) 
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14.  Text Concatenation: 

• In Calc, “&” is a text operator which is used to combine two or more text.  

• Joining two different texts is also known as “Text Concatenation” 

15.  Text Formatting:  
• Making the cell contents as bold, italics, underlined, changing font style, size, colour etc., comes under text formatting.  

• All text formatting options are available as icons in Formatting toolbar learnt in Open Office Writer 

16.  File Extension:  

• A file extension or file name extension helps to identify the type of file. 

17.  Auto Save:  

• The Open Office saves a file at regular intervals.  

• This is called as “Auto Save” feature.  

• The default time interval is 15 minutes.  

• It can be reduced even to one minute.  

• If any unexpected shutdown occurs, this feature will recover your file. 

18.  Function Wizard: 

• A function can be inserted using Function Wizard in Calc.  

• Function Wizard is a dialog box which provides step-by-step procedure to insert a function.  

• Function wizard can be invoked by clicking the Function Wizard icon on the Formula bar (or) Insert → 

Function (or) Ctrl + F2. 

19.  Chart Wizard: 

• Chart wizard is used to insert charts in Calc.  
• Chart wizard can be invoked by clicking “chart” icon from standard toolbar or choosing Insert → Chart command. 

• Chart wizard dialog box has 4 steps viz. (1) Chart type (2) Data Range (3) Data Series and (4) Chart Elements 

20.  Editing Chart elements:  

• After inserting a chart any element of the chart can be modified.  

To modify the element:   

(i) Double click on the element  (ii) Right click on the selected element  (iii) Select Format from the popup menu. 

21.  Work area or work sheet: 

• The outline of the window is very similar to other application windows of Open Office.  

• The main area of the Calc window is called as “Work area” or “Worksheet”.  

• A worksheet is a grid of cells with a programmable calculator attached to each cell. 

22.  Saving Worksheet:  

Step 1: File → Save (or) Ctrl + S (or) Click “Save” icon on the standard tool bar. 

Step 2: If the spreadsheet has not been saved previously, the Save As dialog box will appear. 

Step 3: Type the name in “File Name” list box. OpenOffice Calc Spreadsheets are stored with extension .ods by default. 

Step 4: Click “Save” button. 

23.  Deleting columns and rows: 

Delete single column or row  

A single column or row can be deleted by using the mouse: 

• Select the column or row to be deleted. 

• Choose Edit →Delete Cells from the menu bar.  (Or) 

• Right-click on the column or row header. 

• Choose Delete Columns or Delete Rows from the pop-up menu. 

Delete multiple columns or rows  

Multiple columns or rows can be deleted at a time  

• Select the required columns or rows for deletion. 

• Right-click on the selected columns or row. 

• Choose Delete Columns or Delete Rows from the pop-up menu or Edit → Delete Cells. 

24.  POWER ( ) function:  

• POWER ( ) is a function which is used to calculate power of an exponent value of a number.  

• This function is categorized as a Mathematical function.  

• There are two inputs needed to find the power value of a number.  

• They are, Base value and exponent value.  

• For example, to find the value of 25 to the power of 2 (25
2

) where 25 is the base value, 2 is the exponent value. 

Syntax:     = POWER (Base ; Exponent)  

• Both Base and Exponent are arguments. In Calc, arguments are separated by a semicolon.  

Inserting POWER( ) in a worksheet: 

Step 1: In cell A2 type the base value 25 

Step 2: In cell B2 type the exponent value 2 

Step 3: Move the cell pointer to C2; in which you want display result. 
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Step 4: Click fx icon from Formula bar (or) choose Insert → Functions  (or) Press Ctrl + F2. 

Step 5: Pull down category list box, Choose “Mathematical”  

             All function under Mathematical category is displayed in the “Functions” list box  

Step 6: Scroll the “Functions” list box and select “POWER( )”.  

Step 7: Click “Next” command button. Now, Function wizard appears 

Step 8: Click on the cell which is contains the base value (A2). 

             Now, the minimized wizard shows the cell address you have selected (A2). 

 CHAPTER – 8  PRESENTATION BASICS 
1.  Presentation Software: 

▪ A presentation software is a computer software package used to show information, in the form of a slide show. 

2.  Presentation Software three major functions: 

▪ an editor that allows the text to be inserted and formatted, a method for inserting and manipulating graphic 

images and a slide-show system to display the content.  

▪ Presentation software is used to create presentations, quizzes, e-learning packages and multimedia products. 

▪  Most presentation software packages will create your multimedia product using a series of slides.  

▪ Text, images, video, animations, links and sound can be combined on each slide to create a final product. 

3.  Presentation programs: 

▪ The most commonly known presentation programs are Open Office. Org Impress, Microsoft PowerPoint and 

Apple’s Keynote. 

4.  Impress: 

▪ Impress is Open Office org’s presentations (slide show) module.  

▪ You can create slides using Impress. It contains different elements like text, bulleted and numbered lists, 

tables, charts, clip art and a range of graphic objects.  

▪ Impress has access to the spelling checker and thesaurus.  

▪ Also, it comes with pre-packaged text styles, background styles with online help. 

5.  Opening a new presentation: 

▪ In order to open Impress using Start button,  

▪ Click Start button and select All Programs → Open Office → Open Office Impress. 

▪ If it is already pinned in the Start menu, just click and open it. 

6.  Creating a new presentation: 
1. By selecting an Empty presentation 2. By selecting From template 3. By selecting from Open existing presentation 

7.  Using Template: 

▪ If you choose the option From template, it uses a template design already created as the basis for a new 

presentation.  

▪ The wizard changes to show a list of available templates. 

▪ Choose the template that you want.  

▪ Introducing a New Product and Recommendation of a Strategy are pre-packaged presentation templates. 

8.  Various ways of Starting Impress:  

▪ You can start Impress in various ways.  

▪ 1. You can select the presentation from the system menu or the Open Office. org Quick starter.  

▪ 2. Or you can click the triangle to the right of the New icon on the main toolbar and select Presentation from 

the drop-down menu. 

▪ 3. Or else, choose File → New → Presentation. 

9.  Parts of the main Impress window: 

▪ The main Impress window has three parts: the Slides pane, the Workspace and the Task pane.  

▪ Additionally, several toolbars can be displayed or hidden during the creation of a presentation. 

1.Slides pane:  
▪ The Slides pane contains thumbnail pictures of the slides in your presentation, in the order of our insertion of slides.  

▪ Clicking a slide in this pane selects it and places it in the Workspace.  

▪ While it is there, you can apply any changes that are desired to that particular slide. 

Several additional operations can be performed on one or more slides in the Slides pane:  

▪ Add new slides at any place within the presentation after the first slide.  

▪ Mark a slide as hidden so that it will not be shown as part of the slide show.  

▪ Delete a slide from the presentation if it is no longer needed. 

▪ Rename a slide.  

▪ Copy or move the contents of one slide to another (copy and paste, or cut and paste, respectively).  

It is also possible to perform the following operations, other than using the Slides pane.  

▪ Change the slide transition following the selected slide or after each slide in a group of slides. • 

▪ Change the sequence of slides in the presentation. • 

▪ Change the slide design. (A window opens allowing you to load your own design.) • 

▪ Change slide layout for a group of slides simultaneously.  

2.Tasks pane: 

▪ The Tasks pane has five sections:  

www.Padasalai.Net                                                                     www.Trb Tnpsc.Com

Kindly Send Me Your Key Answer to Our email id - Padasalai.net@gmail.com

www.P
ad

as
al

ai
.N

et

www.P
ad

as
al

ai
.N

et

https://www.padasalai.net/
https://www.padasalai.net/


 

127 
                              PREPARED BY…,   B.MOHAMED YOUSUF M.C.A., B.Ed., (PG ASST IN COMPUTER SCIENCE) 

                              [yousufaslan5855@gmail.com] 

1. Master Pages: 

▪ You define the page style for your presentation using Master Pages.  

▪ Impress contains pre-packaged Master Pages (slide masters).  

▪ One of them by default is blank, and the rest have a specific background. 

2. Layout: 

▪ Pre-packaged layouts are shown.  

▪ You can choose the one that you want, use it as it is or modify it to suit your own requirements.  

▪ At present, it is not possible to create custom layouts. 

3.Table Design: 

▪ Standard table styles are provided in this pane.  

▪ You can further modify the appearance of a table with the selections to show or hide specific rows and 

columns, or to apply a banded appearance to the rows and columns.  

4. Custom Animation: 

▪ A variety of animations for selected elements of a slide are listed here.  

▪ Animation can be added to selected elements of a slide and it can also be changed or removed later.  

5. Slide Transition: 

▪ Transitions are available, including No Transition.  

▪ You can select the transition speed (slow, medium, fast).  

▪ You can also choose between an automatic or manual transition, and how long you want the selected slide to 

be shown (automatic transition only). 

10.  Window elements of Impress: 

▪ The window elements of Impress include Title Bar, Menu Bar, Tool Bar, Ruler Bar and the Scroll Bar which 

are similar to the elements in Open Office writer 

1.View Buttons:  

▪ The Workspace has five tabs:  

▪ Normal, Outline, Notes, Hand-out, and Slide Sorter, These five tabs are called View Buttons.  

2. Status Bar:  
▪ Status Bar is present at the bottom of your window, which gives you some statistics about the file that you are viewing.  

▪ It is a good practice to check the information shown there. In case you do not need the information in the 

Status Bar, you can hide it by selecting View → Status Bar from the main menu.  

3. Navigator: 

▪ The Navigator displays all objects contained in a document.  

▪ It provides another convenient way to move around a document and find items in it.  

▪ The Navigator button is located on the Standard toolbar.  

▪ You can also display the Navigator by choosing Edit → Navigator on the menu bar or pressing Ctrl+Shift+F5 

11.  Normal view: 

▪ There are two ways to place a slide in the Slide Design area of the Normal view:  

▪ Clicking the slide thumbnail in the Slides pane or using the Navigator.  
▪ To open the Navigator, click the Navigator button in the Standard Toolbar or press Ctrl+Shift+F5 and select a slide 

12.  Outline view:  

▪ Outline view contains all the slides of the presentation in their numbered sequence.  

▪ Only the text in each slide is shown. Slide names are not included. 

13.  Outline view serves for two purposes: 

1. Making changes in the text of a slide: 

▪ Add or delete text in a slide just as in the Normal view. 

▪ Move the paragraphs of text in the selected slide up or down by using the up and down arrow buttons (Move 

Up or Move Down) on the Text Formatting toolbar.  

▪ Change the outline level for any of the paragraphs in a slide using the left and right arrow buttons. 

▪ Both move a paragraph and change its outline level using a combination of these four arrow buttons.  

2. Comparing the slides with your outline (if you have prepared one in advance).  
3. If you notice from your outline that another slide is needed, you can create it directly in the Outline view or you can return 

to the Normal view to create it, then return to review all the slides against your outline in the Outline view. 

14.  Notes view: 

Use the Notes view to add notes to a slide: 

1) Click the Notes tab in the Workspace 

2) Select the slide to which you will add notes. 

▪ Double-click the slide in the Slide pane, or 

▪ Double-click the slide’s name in the Navigator. 

3) In the text box below the slide, click on the words Click to add notes and begin typing. 
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15.  Slide Sorter view:  

▪ The Slide Sorter view contains all of the slide thumbnails. 

▪ Use this view to work with a group of slides or with only one slide. 

Change the number of slides per row, if desired: 

1) Check View → Toolbars → Slide View to show the Slide view toolbar. 

2) Adjust the number of slides (up to a maximum of 15). 

3) After you have adjusted the number of slides per row, View → Toolbars → Slide View will remove this toolbar from view. 

16.  To select a group of slides, use one of these methods: 

▪ Use the Control (Ctrl) key: Click on the first slide and, while pressing Control, select the other desired slides. 

▪ Use the Shift key: Click on the first slide, and while pressing the Shift key, select the final slide in the group. 

▪ This selects all of the other slides in between the first and the last. 

▪ Use the cursor: Click on the first slide to be selected. Hold down the left mouse button. 

▪ Drag the cursor to the last slide thumbnail. 

17.  To move a group of slides: 

1) Select the group of slides. 

2) Drag and drop the group to their new location.  

▪ The same vertical black line appears to show you where the group of slides will go.  

▪ You can work with slides in the Slide Sorter view as in the Slide pane. 

18.  Hand-out view:  

▪ Hand-out view is for setting up the layout of your slides for a printed hand-out.  

▪ Click the Hand-out tab in the workspace, then choose Layout in the tasks pane  

▪ You can then choose to print one, two, three, four, or six slides per page. 

19.  To print a hand-out: 

1) Select the slides using the Slide Sorter. (Use the steps listed in selecting a group of slides.) 

2) Select File Print or press Ctrl+P to open the Print dialog box. 

3) Select Options in the bottom left corner of the Print dialog box. 

4) Check Handouts in the Contents section, and then click OK. 

5) Click OK to close the Print dialog box. 

20.  Inserting, deleting and rearranging slides: 

▪ You might also want to activate the Auto Recovery function (Tools → Options → Load/Save → General). 
▪ Make sure that Save Auto Recovery information is selected and that you have entered a suitable recovery frequency. 

21.  Inserting additional slides: 

Step 1: Insert a new slide.  

▪ This can be done in a variety of ways.  

▪ Insert → Slide. • Right-click on the present slide, and select Slide → New Slide from the pop-up menu.  

▪ Click the empty space after the last slide also to create a new slide by right clicking New Slide.  • Click the 

▪ Slide icon in the Presentation toolbar.  

Step 2: Select the layout slide that best fits your needs.  

Step 3: Modify the elements of the slide like removing unneeded elements, adding needed elements and inserting text. 

22.  Deleting a Slide: 

▪ You can delete a slide at any time using the following procedure.  

▪ Select the slide you want to delete. 

▪ Click Edit Æ Delete slide. 

▪ Or else, right click the slide and choose Delete slide from the pop-up menu. 

23.  Rearranging slides: 

▪ Select the slide that you want to rearrange. 

▪ Drag that slide to the desired position by holding the mouse using left click.  

▪ Release the mouse once you drag the slide to the desired place. 

24.  Running the slide show: 

▪ Click Slide Show → Slide Show on the main menu bar. 

▪ Click the Slide Show button on the Presentation toolbar or the Slide Sorter toolbar. 

▪ Press F5 or F9. 

▪ If the slide transition is automatically after x seconds, let the slide show run by itself. 

▪ If the slide transition is on mouse click, do one of the following to move from one slide to the next. • 

▪ Use the arrow keys on the keyboard to go to the next slide or to go back to the previous one. • 

▪ Click the mouse button to advance to the next slide.  

▪ Press the Spacebar on the keyboard to advance to the next slide. 

▪ When you advance past the last slide, the message “Click to exit presentation...” appears.  

▪ Click the mouse or press any key to exit the presentation.  

▪ To exit the slide show at any time, including at the end, press the Esc key. 

25.  Saving a Presentation: 

▪ In order to save a presentation Click File → Save 

▪ After giving save option, Impress will open a dialog box asking the name in which this file should be saved 
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▪ Type the name of the file you want to give in the text box space after File Name in the dialog box.  

▪ You can save the presentation as a PPT presentation also. 

▪ You can also export the presentation directly as pdf. 

 CHAPTER – 9 Introduction to Internet and Email 
1.  Internet: 

▪ The Internet works by using a protocol called TCP/IP.  

▪ TCP/IP allows one computer to talk to another computer via the Internet through compiling packets of data and 

sending them to right location. 

2.  Intranet: 
▪ An Intranet is a website used by organizations to provide a place where employees can access company information  

▪ (eg policies, procedures, staff, directory, and department info), tools (quick links to common apps, forms etc.) 

3.  Extranet: 
▪ An extranet is a private network that uses Internet technology and the public telecommunication system to securely share 

part of a business's information or operations with suppliers, vendors, partners, customers, or other businesses. 

4.  Internet applications: 

• Email • Web-enabled audio/video conferencing services • Online movies and gaming  

• Data transfer/file-sharing, often through File Transfer Protocol (FTP) • Instant messaging • Internet forums  

• Social networking • Online shopping • Financial services 

5.  Domain Name: 

▪ It is a name or an identity which become an online identity and can be accessed by the web browser when 

connected to internet 

6.  What is URL?  

▪ A URL is an address that shows where a particular page can be found on the World Wide Web.  

▪ URL is an abbreviation for 'Uniform Resource Locator (URL) 

▪ Every server on the internet has an IP number, a unique number consisting of four parts separated by dots.  

▪ The IP number is the server’s address 165.113.245.2 128.143.22.55  
▪ At times the number keeps changing hence it is harder for people to remember number than to remember word combinations.  

▪ So, addresses are given “word-based” addresses called URL. The URL and the IP number are one and the same. 

7.  Who Governs the Internet? 

▪ The internet as a whole does not have a single controller.  

▪ But the internet society, which is a voluntary membership organization, takes the responsibility to promote 

global information exchange through the internet technology.  

▪ Internet Corporation for Assigned Names and Numbers ( ICANN) administers the domain name registration.  

▪ It helps to avoid a name which is already registered 

8.  What is W3C?  

▪ W3C stands for "World Wide Web Consortium."  
▪ The W3C is an international community that includes a full-time staff, industry experts, and several member organizations.  

▪ These groups work together to develop standards for the World Wide Web.  

▪ The World Wide Web Consortium (W3C) is an international organization committed to improving the web. 

▪  It is made up of several hundred member organizations from a variety of related IT industries.  

▪ W3C sets standards for the World Wide Web (WWW) to facilitate better communication ability and 

cooperation among all web stakeholders.  

▪ It was established in 1994 by the creator of the WWW, Tim Berners-Lee 

9.  Benefits of E-governance  
• Reduced corruption • High transparency • Increased convenience • Reduction in overall cost. • Expanded reach of government 

10.  Email: 

▪ Electronic mail or email is information stored on a computer that is exchanged between two users over 

telecommunications.  

▪ Email is a message that may contain text, files, images or any other attachments sent through a network to a 

specified individual or group of individuals 

11.  What is sent in an email? 

▪ In addition to text messages being sent over e-mail, it is also possible to attach a file or other data in an e-mail. 
▪ For example, an attachment could be a picture, PDF, word processor document,, or any file stored on the computer 

12.  Botnet (or)  Zombie:  

▪ A botnet is a group of computers connected to the Internet that have been compromised by a hacker using a 

computer virus or Trojan horse.  An individual computer in the group is known as a “zombie“ computer. 

13.  Computer virus:  

▪ A computer virus is a small piece of software that can spread from one infected computer to another.  

▪ The virus could corrupt, steal, or delete data on your computer 

14.  Malware:  

▪ Malware is short form for “malicious software.”  

▪ Malware is used to mean a “variety of forms of hostile, intrusive, or annoying software or program code.” 

▪ Malware could be computer viruses, worms, Trojan horses, dishonest spyware, and malicious rootkits. 
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15.  Spam:  

▪ Spam in the security context is primarily used to describe email spam.  

▪ Unwanted messages in your email inbox. Spam, or electronic junk mail, is a nuisance as it can clutter your 

mailbox as well as potentially take up space on your mail server. 

16.  Phishing:  

▪ Phishing scams are fraudulent attempts by cybercriminals to obtain private information.  

▪ Phishing scams often appear in the guise of email messages designed to appear as though they are from 

legitimate sources.  

▪ For example, the message would try to lure you into giving your personal information by pretending that your 

bank or email service provider is updating its website and that you must click on the link in the email to verify 

your account information and password details 

17.  Rootkit:  

▪ A rootkit is a collection of tools that are used to obtain administrator-level access to a computer or a network of 

computers.  

▪ A rootkit could be installed on your computer by a cybercriminal exploiting a vulnerability or security hole in a 

legitimate application on your PC and may contain spyware that monitors and records keystrokes 

18.  Trojan horse:  

▪ Users can infect their computers with Trojan horse software simply by downloading an application they 

thought was legitimate but was in fact malicious.  

19.  Malicious spyware:  
▪ Malicious spyware is used to describe the Trojan application that was created by cybercriminals to spy on their victims.  

20.  Computer worm:  
▪ A computer worm is a software program that can copy itself from one computer to another, without human interaction. 

21.  Familiar Internet Browser: 

Google Chrome: 

▪ Google Chrome is a freeware familiar web browser developed by Google Inc.  

▪ It is best for its speed, simplicity, security, privacy and customization features.  

▪ Google Chrome supports on Android 4.0 or higher, iOS 6.0 or higher, Mac OSX 10.6 or higher and Windows 

(XP sp2 or higher) and Linux system.  

Mozilla Firefox: 

▪ Mozilla Firefox is a free and open source web browser developed by Mozilla Foundation and Mozilla 

Corporation.  

▪ Fire Fox is default browser in Ubuntu.  

▪ It supports Windows, Mac OS X, Linux and Android system.  

Internet Explorer: 

▪ Internet Explorer commonly known as Microsoft Internet Explorer or Windows Internet Explorer is the first or 

default browser for a Windows PC.  

▪ It was developed by Microsoft.  

Safari: 

▪ Safari is a web browser developed by Apple Inc. and comes with OS X and iOS.  
▪ Some version of safari browser also supports Windows Operating System. exclusively used in Apple Mac system. 

22.  Websites: 

▪ A website is a collection of webpages.  

▪ For example if there is a company that owns sricompany.com then this website will have several Webpages 

like Home, About Us, Contact Us, Testimonials, Products, Services, FAQ’s, and others.  

▪ The first page of the website is called a Home Page.  

▪ All of these pages together make up a Website. 

23.  Web Pages: 

▪ A webpage is a page of a Website.  
▪ A web page can be accessed by a URL in a browser and that page can be copied and or send to a friend for review whereas websites are 

collections of multiple page that must be navigated to view other content A webpage is a page of a Website.  

▪ Every page has a unique address called the Uniform Resource Locator (URL).  

▪ The URL locates the pages on the internet. 

24.  SAFER INTERNET DAY: 

▪ Safer Internet Day (SID) 2018 is celebrated around the world in February of every year with a theme of 

"Create, connect and share respect” 

▪ A better internet starts with you". 

 CHAPTER – 10  HTML – Structural Tags 
1.  HTML: 

▪ HTML is a special mark-up language used to create web pages.  

▪ This language tells the browsers, how to display the text, images, animations and other contents of a hypertext 

document on the screen.  

▪ The language also tells how to make a document interactive through special hyperlinks. 
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▪ HTML is not a word processing tool or a programming language.  

▪ It is only a markup or page layout and hyperlink specification language.  

▪ It describes the structure of a document. 

2.  Writing HTML document: 

▪ HTML is made up of tags and its attributes.  

▪ Tags are known as elements of HTML.  
▪ Additional information such as color, alignment etc., can be included with an HTML tag also known as attribute.  

▪ Attributes are used to improve the appearance of an HTML document.  

▪ You cannot create your own tags to create a new style or feature. 

3.  HTML Document Structure:  

▪ An HTML document contains the text of the page itself and HTML tags, which define the structure and 

appearance of the document.  
▪ It also contains hyperlinks to other pages or to include multimedia elements such as audio, video, animations etc.  

▪ The Entire HTML document is bounded within a pair of <html> and </html> tags. 

4.  Structural Tags of HTML:  

▪ <html>, <head>, <title> and <body> these four tags are known as structural tags.  

▪ These tags are basic essential elements to construct a web page. 

5.  HTML Writing Tools: 

▪ To get started with HTML, there is no need of web server, web hosting or even internet connection.  

▪ You can write, test and link web pages without a network.  

▪ To create and test a HTML document i.e. web page needs an application (text editor) to write HTML code and 

a browser to view it.  

▪ Using a simple text editor (Notepad for Windows or get it for Linux) is a good way to learn HTML coding. 

6.  Creating a Webpage: 

Step 1: Open a text editor  

▪ Windows7 : Start → All Programs →Accessories → Notepad 

Step 2: In the appearing Note pad / Text Editor, type the HTML document.  

Step 3: Save the file as HTML 

▪ Click File → Save (or) Press Ctrl + S 

▪ Save as dialog box appears. 

▪ In “File Name” text box, type a file name with .htm or .html extension. 

▪ Select “All Files” from “Save as type” list box. 

▪ Click “Save” button. 

7.  Viewing Webpage in a Browser: 

Step 1: Open a Browser (Internet Explorer / Mozilla Firefox or any) 

Step 2: Click File → Open File (or) Press Ctrl + O 

Step 3: From the “Open” dialog box, browse the folder in which the HTML document is saved.  

             Choose the File name and click “Open” button.  

             Now, your web page is displayed in the browser. 

8.  Viewing Source file: 

▪ Source file is an HTML document, what you actually type in text editor (Notepad or get it).  

▪ You can view your original source file in the browser.  

The following steps are to be followed to view a source file. 

▪ Double click on the browser 
▪ Select View → Page Source (Firefox and Chrome) / View Source (Internet Explorer) or Press Ctrl + U (all browser) 

▪ Source file will be displayed. 

▪ In Internet Explorer, View → Source is also used to open source file. 

9.  Edit and Reload the source file:  

▪ Source file can be edited only through the text editor.  

▪ So, to edit the source file, open the source file with a text editor.  

▪ When you edit a source file, no need to close browser in which displaying the HTML document.  

The following steps are to be followed to open a source file: 

▪ Go to the folder in which your source files are located. 

▪ According to you default browser, your source file icon is displayed.  

▪ Right click on the source file that you want to edit 

▪ From the pop-up menu, select Open With → Notepad 

▪ Source file will be opened in text editor 

▪ Make the changes and save the file using File → Save or Ctrl + S.  

10.  Reload / Refresh the changes: 

▪ After modify and save the source file, minimize your source file. 

▪ Go to the browser. 
▪ Click Refresh (Internet Explorer) / Reload Current Page (Firefox) / Reload this page (Chrome) icons on the address bar. 

▪ Press Ctrl + R or F5 will be used to refresh / reload the modifications.  
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11.  Attributes of <html> tag:  

▪ The <html> tag is used to specify the beginning and closing of an HTML document.  

▪ This tag does not have any effect on the appearance of a document.  

▪ This is only used to make browsers and other programs, know that this is an HTML document.  

▪ <html> tag has two attributes viz.  

▪ dir and lang to specify the text direction and language setting respectively. 

12.  Attributes of <body> tag:  

▪ The <body> tag defines the document’s body.  

▪ The contents of an HTML page reside within the <body> tag. <body> tag contains several attributes.  

(i) Background Colour: bgcolor = color 

▪ By default all the browsers display the text on white background.  

▪ However, the background color of the browser can be changed by using bgcolor tag.  

The tag to change background colour:   <body bgcolor = color_name/color_code> 

(ii) Body text Colour: text = color: 

▪ The default text colour of body section is “black”, it is often called as automatic color.  

▪ Text attribute within body tag is used to change the text colour.  

The tag to change body text colour:  <body text = color_name/color_code> 

(iii) Background image: background=image  

▪ An image or picture can be applied as background to a webpage.  

▪ When you insert an image as background, the text will be displayed on top of the image.  

▪ Background images can be a texture or bitmap or even a photo.  
▪ When you insert a small image, the browser takes the image and repeats it across and down to fill browser window.  

▪ Inserting animated images (GIF images) creates more interesting.  

The tag to apply an image as background:  <body background = “image_name_with_extenstion”> 

(iv) Setting Margins: margin = value:  

▪ The margin refers the blank area from left or top edge of the browser window.  

▪ Generally there is no default margin setting in any browser.  
▪ If you want to leave some space as margin to left or top; leftmargin or topmargin attributes will be used respectively.  

The tag to specify the left and top margin:  <body leftmargin = value topmargin = value>  

13.  Headings:  

▪ Headings are used to include titles to sections of a web page.  

▪ HTML has six levels of headings viz. <h1> to <h6>.  

▪ The number with h indicates the level of heading.  

▪ Header tags display the body text as bolder and larger in size according to its level.  

The syntax of heading tags:   <h…> Heading text </h…> 

14.  Attribute of Headings tag: 

▪ Align is an attribute to set right, center and justify alignment to headings.  

▪ Left is the default alignment, which is not supported in latest version of HTML.  

▪ Justify alignment is not supported by older browsers. 

The tag is to specify the alignment to headings:  <h# align = value>  

▪ Where # is the level number, value may be Right, Center or Justify.  

▪ Justify alignment is only used for paragraphs.  

▪ The meaning of alignment is similar to what you learnt from Word processor. 

15.  Changing Paragraph alignment:  

▪ You there already know the different types of paragraph alignments in Word processor.  

▪ In HTML documents there are four paragraph alignments viz.  

▪ Left, Right, Center and Justify.  

▪ The text that you type between <p> and </p> is by default aligned to the left.  

▪ To change the alignment of a paragraph align attribute can be used with <p> tag. 

The tag to specify the alignment to paragraph:  <p align = alignment>  

16.  Comments:  

▪ Comments are used to describe the page or provide some kind of indication of the status of the page.  

▪ The tag <!> is used to create comments.  

▪ In HTML, the text what you type within this tag is considered as comments and it is ignored by the browser. 

▪ Comments never show up onscreen.  

▪ Comments can be placed anywhere in HTML document. 

The general form of comments:  <! comments > 

17.  Container and Empty Elements:  

▪ The HTML elements (Tags) can be classified as two types – (1) Container elements (2) Empty elements. 

1.Container Elements:  

▪ The tags which require opening and closing is known as container elements or tags.  

▪ For example: <html>, <body>, <title>, <p> etc., 
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2.Empty Elements: 

▪ The tags which require only opening tag is known as empty elements or tags.  

▪ For example: <br> 

 CHAPTER – 11 HTML - Formatting text, Creating Tables, List and Links 
1.  Physical Style tags: 

▪ <b>, <i>, <u> are the tags to make the text as bold, italic and underline.  

▪ These are all container tags. You know well about container tags.  

▪ All container tags require a closing tag. These tags are otherwise known as “Physical Style” tags. 

2.  <strong> and <em> tags: 
▪ In addition to bold and italic tags i.e. <b> and <i>, HTML provides <strong>, <em> tags to make the text as bold and italics.  

▪ These tags are container tags. 

<strong> Important text 

▪ The <strong> tag is a phrase tag. It is used to define important text.  

▪ This tag displays the text as bold.  

<em> - Emphasized text  

▪ The <em> tag is used to emphasize the text.  

▪ That means, when you use this tag, the text will be in italics. 

3.  <big> and <small> tags:  

<big> tags:  

▪ The <big> tag is used to define the text bigger in size than the normal size.  

▪ It is often used to call attention to a text.  

<small> tags:  

▪ The <small> tag is used to define the text smaller than the current size.  

▪ These two tags are container tags. 

4.  Highlighting text: 

▪ Highlighting is an important formatting feature used to call attention to the reader.  

▪ The <mark> tag is used to highlight the text in HTML.  

▪ This is also a container tag. Whatever the text given between <mark> and </mark> will be displayed as 

highlighting with default color (mostly yellow). 

5.  Subscript: 

▪ A Subscript is a way to display a character or a number below the normal line of type.  
▪ For example: The scientific notation for water is H2O. It should be written as H2O. Here, 2 is appearing below the normal line.  

▪ This is called subscript.  

Superscript: 

▪ A Superscript is also a way to show a character or a number above the normal line of type.  

▪ For example: The familiar algebra equation “a plus b the whole square” should be written as (a+b)2. Here, the 

square value 2 is appearing above the normal line.  

▪ This is called superscript. 

6.  Inserting and Deleting:  

▪ The text what you see on browser cannot be deleted or inserted.  

▪ But you can show a text as deleted or inserted. <del> and <ins> tags are used to markup a segment of text as 

deleted or inserted respectively.  

▪ These two tags are container tags.  

▪ The text what you specify between <del> and </del> will be displayed as strike through.  

▪ The text you specify between <ins> and </ins> will be shown as underlined. 

7.  Strike through:  

▪ To display a text as wrong text, the <s> tag can be used to show the text as strike through style.  

▪ The <s> and <del> tags display the text in similar way.  

▪ This is also a container tag.  

▪ The text you specify between <s> and </s> will be displayed in strike through style. 

8.  Comparison of tags:  

▪ A few tags do the same things you have learned so far.  

▪ For example, <b> and <strong>, <i> and <em>, <u> and <ins> and so on.  

▪ These tags may show the same output, but the usage of tags vary. 

9.  The Center Tag:  

▪ Paragraphs can be centered with Align attribute with <p> tag.  

▪ But for non-paragraph text contents can be centered with <center> tag.  

▪ The <center> tag is used to centralize a segment of text. It is a container tag.  

▪ That means, what you type between <center> and </center> will be displayed in the center of the browser. 

10.  Selection break or Thematic break: 
▪ The <hr> (Horizontal Rules) tag, which is known as “Thematic Breaks” separate sections of an HTML document visually.  

▪ It produces a horizontal line spread across the width of the browser.  

▪ This is an empty tag, which means the tag has no closing tag. 
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11.  Attributes of <TD>, <TH> and <TR> tags: 

1. Align:  

▪ Used to specify the horizontal alignment of content within a cell.  

▪ Left is the default alignment. Possible values are Right and Center. 

2. VAlign:  

▪ Used to specify the vertical alignment of the contents within a cell.  

▪ Bottom is the default alignment. Possible values are Top and Middle 

3. Width:  

▪ Used to specify the width of a cell in terms of pixels or percentage. 

4. BGcolor and Background:  

▪ Bgcolor attribute is used to apply a particular colour to the background of a cell.  

▪ Background attribute is used to apply an image or picture as background of a cell. 

5. Rowspan and Colspan  

▪ Rowspan attribute is used to merge two or more cells in a row as a single cell.  

▪ Colspan attribute is used to merge two or more cells in a column as a single cell. 

12.  Lists in HTML:  

▪ HTML supports three types of lists viz. numbered, unnumbered and definition.  

▪ These lists are called as Ordered List, Unordered List and Definition List respectively.  

1. Numbered List / Ordered List:  

▪ Numbered list is created within the tag pair <OL> ….. </OL> tag.  

▪ The tag <LI> is used to present the list item in the list.  

▪ Ordered list displays items in a numerical or alphabetical order.  

▪ Both <OL> and <LI> tags are container tags. But the usual practice, closing tag </LI> is normally not used. 

2. Un-numbered List / Unordered List:  

▪ Unordered lists are often referred as bulleted lists.  

▪ Instead of numbers, each element in the list is prefixed with a special bullet symbol.  

▪ Unordered list is surrounded within <UL> ……… </UL> tags.  

▪ As discussed above, each list element is defined by <LI> tag. 

3. Definition List: 

▪ Definition list is different from other two types of list.  

▪ No bullet or number is provided for the list items. In this list type, the list element has two parts.  

       (1) A definition term   (2) The definition description 

▪ Definition list is surrounded within <DL> ……. </DL> tags.  

▪ Definition term is presented in between <DT> ….. </DT> tag and  

▪ Definition description should be surrounded within <DD> ………… </DD> tag. 

4.Nested Lists:  

▪ A list block can be defined inside another list is called as nested list. 

13.  Links:  

▪ Link is an important feature of HTML to connect web resources.  

▪ Link in HTML is used to create hyperlinks to web content.  

▪ Web content may be an HTML document or an external webpage or any multimedia content such as an image, 

video, audio, animation etc., or even a part of the current document. 

1.Internal Links: 

▪ Creating a link to a particular section of the same document is known as Internal Link.  

▪ To create an internal link, the attribute Name is used along with <A> tag.  

▪ The Name attribute of <A> tag establish the link to the content within the document. 

2.External Link:  

▪ To Establish link with an external web page in known as external link.  

▪ It is created by providing the URL of the external file in the HREF attribute of <A> tag of the current page. 

14.  <font> tag: 

▪ The <font> tag is used to change the style, size and color of text. 

▪ A font is a named set of certain style of character or numbers 

 CHAPTER – 12 HTML - Adding multimedia elements and Forms 
1.  Image editing applications: 

▪ Image editing applications such as Photoshop, Picasa, GIMP etc., 

2.  Inserting Images with HTML document: 

▪ The <IMG> tag along with the attribute src (Source) is used to add images in HTML document.  

General format: 

<img src = image_name_with_extension> (OR) <img src = URL> 

Example:  <img src = image1.gif> 

3.  Other Attributes of <img> tag:  
▪ Other than src, the <img> tag has many attributes that enable to control how the image is presented on the page.  
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1.Alt (Alternative Text): 

▪ The alt attribute within <img> tag is used to give description of the image, so that some text is conveyed even 

when the image cannot be displayed.  

Example:  <img src = bharathiyar.gif alt = “National Poet of India”> 

2.Width and Height:  

▪ Width and Height attributes are used to set the width and height of the image.  

▪ The values of these attributes should be either pixels or percentage of its actual size.  

▪ If these attributes are not specified, the browser displays the image in its original size. 

3.Vspace (Vertical Space) and Hspace (Horizontal Space): 

▪ Vspace and Hspace attributes are used to set Vertical and Horizontal space between the images. 

4.  Scrolling text using <Marquee>: 

▪ In HTML, a piece of text or image can be moved horizontally or vertically by using <marquee> tag.  

▪ This feature makes a web page as more attractive.  

General format:  <marquee> Text or image to be scroll </marquee> 

Attributes of <marquee> 

1.Height and Width  

▪ These attributes are used to set height and width of the marquee.  

▪ The values should be either in pixels or in percentage the browser window. 

2.Direction:  

▪ This is used to specify the direction of the movement of text or image.  

▪ The text or image will move towards right to left by default.  

▪ So, the default direction is left.  

▪ The Possible values are ‘up’, ‘down’, ‘left’ or ‘right’. 

3.Behaviour:  

▪ This attribute is used to specify the type of scrolling.  

▪ The values are ‘scroll’, ‘slide’ and ‘alternate’. 

4.Scrolldelay:  

▪ This attribute is used to define the time delay between each jump. The time unit should be in seconds. 

5.Scrollamount:  

▪ This is used to define the speed of the scroll. 

6.Loop:  

▪ This is used for defining how many times the marquee element should repeat on the screen.  

▪ The default value is ‘infinite’, which means the marquee element scrolls endlessly. 

7.Bgcolor:  

▪ This is used to specify the background color to the marquee elements. 

8.Hspace and Vspace:   

▪ This is for defining the horizontal and vertical space around the marquee.  

▪ The value can be in pixels or percentage. 

5.  Adding Video and Sound: 

▪ The <embed> tag is used to attach an audio or video file easily within webpage.  

▪ This tag includes the control of the multimedia automatically in the browser.  
▪ The <noembed> tag may be used as an alternate to display some other media file, in case the browser does not support <embed> tag.  

▪ Src is the primary attribute used with <embed> tag.  

▪ The src attribute is used to specify the name of the media file with its source location.  

▪ Other attributes such as alt, is height, width and align are used as it is used with <img>. 

General Format:  <embed src = audio / video file name with location> </embed> 

6.  Background music:  

▪ Music can be played in the background to a webpage, while the page is viewed.  

▪ This is known as ‘inline’ sound or movie.  

▪ The <bgsound> tag is used to attach an inline sound file in HTML.  

▪ The src attribute is used to define the location of the media file.  

▪ Volume attribute is used to adjust volume control.  

▪ The loop attribute defines the duration of play.  

▪ The ‘infinite’ value causes the audio play as long as the page is in view. 

General Format: <bgsound src=music file name with location> 

7.  <form> tag: 

▪ The <form> tag is used to create a form.  

▪ An HTML form starts with <form> and ends with </form> tag.  
▪ Forms contain many types of form elements, such as text boxes, radio buttons, check boxes, buttons and drop-down lists.  

▪ The form has a special element, known as submit button, which will submit the entries of a form to a server 

application to process the entries. Each element in the form is assigned a name using the name attribute.  
▪ Users enter values into the text boxes, or make selections from the radio buttons, check boxes, and drop down lists.  

▪ The values they enter or select are passed with the name of the corresponding form element to the Web server. 
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8.  Attributes frequently used with <form> tag:  

▪ The important attributes used with the <form> tag are method and action attributes. 

1.Method: 
▪ The method attribute of the form tag is used to identify how the form element names and values will be sent to the server.  

▪ The get method will append the names of the form elements and their values to the URL.  

▪ The post method will send the names and values of the form elements as packets. 

2.Action:  

▪ The action attribute identifies the server side program or script that will process the form.  

▪ The action will be the name of a Common Gateway Interface (CGI) program written in programming 

languages like Perl, JavaScript, PHP or Active Server Pages (ASP). 

General Format of <form> tag:  

<Form method=get/post action= “back_end_server_script”> 

      Form elements  

</Form> 

9.  Form Controls:  

▪ In HTML, there are different types of form controls used to collect data.  

▪ They are Text box, Password, Checkbox, Radio buttons, Text area, Select box, Submit and Reset Button. 

10.  <Input> Tag:  

▪ Most of the form controls are created by using <input> tag.  
▪ The <input> is an empty tag used to create different form elements or controls such as text box, radio buttons so on. 

11.  Attributes of <input> tag: 

1.Type:  

▪ This attribute is used define the type of control to be created by <input> tag 

2.Name:  

▪ This attribute of <input> tag is used to assign a name to the input controls.  

▪ When the form is submitted, the data values are passed to the server along with the names of the controls. 

3.Value:  

▪ This attribute is used to define default value to some controls. 

4.Size:  

▪ This is used to set the width of the input text in terms of characters.  

▪ It is applicable only for textbox and password boxes. 

5.Max length:  

▪ This attribute of <input> tag is used to set the length of the input character (number of characters to be input) 

to the textbox and password boxes. 

12.  <Select> Tag:  

▪ The <select> tag is used to create dropdown list box in HTML.  

▪ It provides a list of various options as a dropdown list.  

▪ This element is more helpful when a number of options are to be displayed in a limited space.  

▪ The <option> tag is used to specify list items.  

13.  Attributes of <Select> tag: 

Name – Provide the name to the control, which is sent to the server. 

Size – Determine the style of dropdown list box.  

Size = 1 dropdown list box  

Size = 2 List box 

Multiple – Allows user to select multiple values. 

14.  Attributes of <Option> tag: 

1.Selected – Indicate default selection  2.Value – Value to be submitted to server 

15.  <Textarea> tag:  

▪ The <Textarea> tag is used to receive multi line text data as input. It is a container tag.  

The main attributes of <Textarea>: 

1.Name – Used to define a name to the control 

2.Rows – Specifies the number of rows in the text area control 

3.Cols – Specifies the number of columns in the text area. (number of characters in a line) 

 CHAPTER – 13 CSS - Cascading Style Sheets 
1.  Page-Level Styles or Internal Style sheets: 

▪ The <style> tag controls the presentation styles of a particular HTML document. 
▪ If you want to use a particular tag with the same style applied in one HTML document to another is not possible.  

▪ Thus, the <style> tags are called as Page-Level Styles or Internal Style sheets. 

2.  Site wide Style sheets” or “External Style: 

▪ The “Internal Style sheet” is defined and implemented only within an HTML document.  

▪ If you want use the same style to multiple pages, you should define styles as a separate style file.  

▪ These separate style files are known as Site wide Style sheets or External Style Sheets.  

▪ Professional web developers do not use internal styles. 
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3.  Site wide Style Sheets:  

▪ Cascading Style Sheets (CSS) are also called as Site wide Style sheets or external style.  

▪ CSS is a style sheet language used for describing the formatting of a document written in HTML.  

▪ Using CSS, you can control the font colour, font style, spacing between pages, columns size, border colour, 

background image or colour and various other effects in a web page.  
▪ In external styles, you can store all style information in a separate file and include it in your web pages using an HTML tag.  

▪ The separate file should be saved with the extension .css 

4.  Advantages of CSS:  

1.Maintainability: 

▪ CSS are also defined and stored as separate files.  

▪ So, the style and appearance of a web page can be dynamically changed and maintained with less effort.  

2.Reusability:  

▪ The styles defined in CSS can be reused in multiple HTML pages.  

Easy to understand: 

▪ The tags in web pages are well organized with style specifications and therefore it is easy to understand. 
5.  Creating CSS style sheets: 

▪ Open an empty notepad. 

▪ Type the style properties and their values as given in the table given above. 

▪ Save the file with extension .css 
6.  Linking CSS with HTML: 

• The <link> tag is used to add CSS file with HTML in head section.  

• While using <link> tag, the following attributes are also included along with standard values. 

1.rel = “stylesheet”  2.type = “text/css” 

• The href attribute is used to link the .css file. 
General format of <Link> tag:    <Link rel = “stylesheet” type = “text/css” href = CSS_File_Name_with_Extension> 

7.  CSS Comments: 

• Many times, you may need to put additional comments in your style sheet blocks.  

• So, it is very easy to comment any part in style sheet.  

• You can simply put your comments inside /*.....this is a comment in style sheet.....*/. 

 CHAPTER – 14 Introduction to Java script 
1.  JavaScript:  

• On December 4, 1995, Netscape and Sun Inc. jointly introduced JavaScript 1.0.  

• JavaScript had truly bridged the gap between the simple world of HTML and the more complex Common 

Gateway Interface (CGI) programs on the Server.  

• It provides a common scripting language for Web developers to design, test and deploy Internet Applications.  

• The JavaScript client-side technology provides many advantages over traditional CGI Server-side scripts.  
• For example, JavaScript code can be used to check if the user has entered a valid e-mail address in a form field. 

• The JavaScript code is executed when the user click Submit button in the form, and only if all the entries are 

valid, they would be submitted to the Web Server. 

2.  Advantages of JavaScript Programming Language: 

• In HTML chapter we have learnt how to develop static web pages.  

• But in real, life web pages must be interactive.  

• So to develop such interactive pages (Dynamic Web page ) JavaScript programming language is used. 

• User entered data in the Dynamic Web page can be validated before sending it to the server.  

• This saves server traffic, which means less load on your server. 

• JavaScript includes such items as Textboxes, Buttons, drag-and-drop components and sliders to give a Rich 

Interface to site visitors.  

• For example Creating a New email account in any service provider. 

3.  Using JavaScript in HTML page with <script> tag :  

• JavaScript can be implemented using <script>... </script> tags.  

• The <script> tag containing JavaScript can be placed anywhere within in the web page, but it is normally 

recommended to be kept within the <head> tags.  
• The <script> tag alerts the browser program  to start interpreting all the text between these tags as a script command.  

• The syntax of JavaScript segment in Hyper Text Markup Language (HTML) or Dynamic Hyper Text Markup Language 

(DHTML) is as follows:  
         <script language="javascript" type="text/javascript">  

            JavaScript code  
         </script> 

4.  The <SCRIPT> tag takes two important attributes: 

1.Language: 

• This attribute specifies the scripting language.  

• Typically, its value will be java script.  
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• Although recent versions of HTML (EXtensible HyperText Markup Language - XHTML, its successor) has 

phased out the use of this attribute is optional.  

2.Type: 

• This attribute is used to indicate the scripting language and its value should be set to "text/javascript". 

5.  Steps to follow to code JavaScript Language: 

• Enter HTML and JavaScript code using any text editor. 

• Save the latest version of this code. 

• Use any browser to see the result.  

• For example : Internet Explorer, Google Crome, etc., 

• If this is a new document, open the file via browser's Open Menu.  
• If the document is already loaded in the Memory, to reload the file into the browser use "Refresh" or press F5 button. 

6.  Lexical Structure of a JavaScript Program: 

• The lexical structure of a programming language is the set of elementary rules that specifies how to write 

programs in that language.  

• It is the lowest-level syntax of a language.  

• The Lexical structure specifies variable names, the delimiter characters for comments, and how one program 

statement is separated from the next.  

• Though JavaScript is a case-sensitive language.  

• It is a good programming practice to type the commands in lowercase. 

• JavaScript ignores spaces that appear between tokens (identifiers, operators, punctuator, constants and 

keywords) in programs. 

• JavaScript supports two styles of comments.  
• Any text following a “//” till the end of that line is treated as a single line comment and is ignored by JavaScript.  

• Any text between the characters “ /* */” is also treated as a multiline comment. 

• JavaScript uses the semicolon (;) to separate statements. Many JavaScript programmers use semicolons to 

explicitly mark the end of statements.  

• A literal is a data value for variable that appears directly in a program. 

• An identifier is simply a name.  
• In JavaScript, identifiers are used to name variables, functions and to provide labels for certain loops in JavaScript code. 

• In JavaScript certain keywords are used as reserved words. 

• These words cannot be used as identifiers in the programs 

7.  JavaScript Variables:  

• Variable is a memory location where a value can be stored.  

• Variable is a symbolic name for a value.  

• Variables are declared with the var keyword in JavaScript.  

• Every variable has a name, called identifier 

8.  Basic Data types and Declaring variables:  

• Every variable has a data type that indicates what kind of data the variable holds.  

• The basic data types in JavaScript are Strings, Numbers, and Booleans.  
• A string is a list of characters, and a string literal is indicated by enclosing the characters in single or double quotes.  

• Strings may contain a single character or multiple characters, including whitespace and special characters such 

as \n (the newline).  

• Numbers can be integer or floating-point numerical value and numeric literals are specified in the natural way.  

• Boolean can be any one of two values: true or false.  

• Boolean literals are indicated by using true or false directly in the source code.  

9.  Rules for naming variable: 

• The first character must be a letter or an underscore (_). Number cannot be as the first character.  

• The rest of the variable name can include any letter, any number, or the underscore.  

• You can't use any other characters, including spaces, symbols, and punctuation marks. 

• JavaScript variable names are case sensitive.  
• That is, a variable named Register Number is treated as an entirely different variable than one named register number. 

• There is no limit to the length of the variable name. 

• JavaScript's reserved words cannot be used as a variable name. All programming languages have a supply of 

words that are used internally by the language and that cannot be used for variable names.  

10.  Scope of variables:  

• The scope of a variable is the life time of a variable of source code in which it is defined. 

• A global variable has global scope; it can be defined everywhere in the JavaScript code. 

• Variables declared within a function are defined only within the body of the function.  

• They are local variables and have local scope. 
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11. \ Assigning values to variables: 

• var numericData1 = 522;  

• var stringData = "JavaScript has strings\n It sure does";  

• var numericData = 3.14;  

• var booleanData = true; 

12.  JavaScript Literals:  

• A literal is a fixed value given to a variable in source code.  

• Literals are often used to initialize variables.  

• Values may be Integer, Floating point, Character, String and Boolean.  

For Example:  

• var int_const=250; //Integer constant//  

• var float_const=250.85; //Floating point constant//  

• var char_const=’A’; //Character constant//  

• var string_const=”Raman”; //String constant//  

• var boolean_const=true; //Boolean constant// 

General Syntax:  document.write ("string " + var); 

13.  Type casting in JavaScript: 

• Type conversion is the act of converting one data type into a different data type which is also called as casting. 

• In JavaScript there are two type of casting, 1.Implicit casting, 2.Explicit casting  

14.  Implicit casting: 

• Implicit casting occurs automatically in JavaScript when you change the data stored in a variable: 

15.  Operator / Operators: 

• An operator combines the values of its operands in some way and evaluates to a new value.  

• Operators are used for JavaScript’s arithmetic expressions, comparison expressions, logical expressions, 

assignment expressions.  

16.  Expression: 

• An expression is a phrase of JavaScript that a JavaScript interpreter can evaluate to produce a value.  

• The data types are used directly as literals or within variables in combination with simple operators, such as 

addition, subtraction, and so on, to create an expression 

17.  Arithmetic Operators: 

• JavaScript supports all the basic arithmetic operators like addition (+), subtraction (–), multiplication (*), 

division (/), and modulus (%, also known as the remainder operator). 

18.  Assignment Operator:  

• An assignment operator is the operator used to assign a new value to a variable.  

• Assignment operator can also be used for logical operations such as bitwise logical operations or operations on 

integral operands and Boolean operands.  

• In JavaScript = is an assignment operator, which is used to assign a value to a variable.  

• Often this operator is used to set a variable to a literal value,  

For example: 

• var number1=10;  

• var number2=number1;  

• var name=”Computer Science”;  

• var booleanvar=true;  

• The assignment operator is used to assign a value to a single variable, but it is possible to perform multiple 

assignments at once by stringing them together with the = operator 

19.  Relational or Comparison Operators:  
• Relational operators are also called as Comparison operators, they compare two values and the result is true or false.  

• JavaScript provides a rich set of relational operators including == (equal to), != (not equal to), < (less than), > 

(greater than), <= (less than or equal to), and >= (greater than or equal to).  
• Using a relational operator in an expression causes the expression to evaluate as true if the condition holds or false if otherwise. 

20.  Logical Operators:  

• Logical operators perform logical (boolean) operations.  

• Logical operators combine or invert boolean values.  

• Once comparisons are made, the logical operators && (AND), || (OR) and ! (NOT) can be used to create more 

complex conditions. 

21.  String Operators:  

• One of the built-in features of JavaScript is the ability to concatenate strings.  

• The + operator performs addition on numbers but also serves as the concatenation operator for strings.  

• Because string concatenation has precedence over numeric addition, + will be interpreted as string 

concatenation if any of the operands are strings.  
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• + operator which is also called as the string concatenation operator. 

22.  Increment Operators:  

• The ++ operator increments its single operand.  
• The operator converts its operand to a number, adds 1 to that number, and assigns the incremented value back into the variable.  

• The return value of the ++ operator depends on its position relative to the operand.  

• When ++ is used before the operand, where it is known as the pre-increment operator. 

23.  Decrement Operators:  

• The -- operator decrements its single operand.  
• It converts the value of the operand to a number, subtracts 1, and assigns the decremented value back to the operand.  

• Like the ++ operator, the return value of -- depends on its position relative to the operand 

24.  Unary + and - Operator:  

▪ + has no effect on numbers  

▪ – Negation (changes the sign of the number or converts the expression to a number and then changes its sign) 

25.  Typeof Operator:  

▪ The typeof operator is used to get the data type (returns a string) of its operand.  

▪ The operand can be either a literal or a data structure such as a variable, a function, or an object.  

▪ The operator returns the data type. 

Syntax: 

typeof operand  

or  

typeof(operand)  

▪ typeof returns: boolean, function, number, string, and undefined.  

▪ The following table summarizes possible values returned by the typeof operator. 

26.  Conditional Operator (?:)  
▪ The ?: is the conditional operator in JavaScript, which requires three operands, hence it is called the ternary operator.  

Syntax:  var variablename=(condition) ? value1 : value2; 

27.  Comments in JavaScript: 

▪ A very important aspect of good programming style is to insert remarks and commentary directly in source 

code, making it more readable to yourself as well as to others.  

▪ Any comments you include will be ignored by the JavaScript interpreter.  

▪ There are two types of comments, Single line and Multiple line comments.  

▪ Single-line comments begin with a double slash (//), causing the interpreter to ignore everything from that 

point to the end of the line.  

▪ Multiple line comments begins with /* and ends with */. 

For example:  

▪ // JavaScript single line comment// 

▪ Multiple line comments begins with /* and ends with */ 

 CHAPTER – 15 Control Structures in Java Script 

1.  Conditional statements: 

▪ Conditional statements execute or skip one or set of statements depending on the value of a specified 

conditional expression.  

▪ There are two types of controls,  1.Branching / Selection 2.Looping / repetitive 

2.  Branching Statements:  
▪ JavaScript supports branching statements which are used to perform different actions based on different conditions.  

▪ Branching is a transfer of control from the current statement to another statement or construct in the program unit.  

▪ A branch alters the execution sequence. 

▪ There are different branching statements.  

▪ They are,   • if statement  • if … else statement  • else if statement  • switch statement 

3.  if Statement:  

▪ The if statement is the fundamental control statement that allows JavaScript to make decisions to execute 

statements conditionally.  

▪ This statement has two forms. The form is for only true condition. 

4.  If..else statement: 

▪ if..else contorl structure in either of the two branches depending on the condition is executed.  

▪ In the simple if construction, no special processing is performed when the condition evaluates to false.  

▪ But if processing must follow one of two paths, hence need to use if...else format 

5.  else if Statement:  
▪ The if ... else statement evaluates an expression and executes one of two pieces of code, depending on the outcome.  

▪ The else if statement is used to specify a new condition if the first condition is false. 

6.  Switch case Statement:  

▪ JavaScript offers the switch statement as an alternate to using if...else structure.  

▪ The switch statement is especially useful when testing all the possible results of an expression. 
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7.  Break and Default Statement:  
▪ The switch statement begins by evaluating an expression placed between parenthesis, much like the if statement.  

▪ The result is compared to labels associated with case structure that follow the switch statement.  

▪ If the result is equal to a label, the statements in the corresponding case structure are executed.  

▪ The default structure is given at the end of a switch structure if the result of the expression that does not match 

any of the case labels.  
▪ The break statement is also used commonly within switch to exit the statement once the appropriate choice is found. 

8. L Loops: 

▪ In JavaScript there are times when the same portion of code needs to be executed many times with slightly 

different values called as Loops 

9.  Looping statements types:  • for loop  • while loop  • do..while loop 

10.  For loop:  

▪ The for loop is a very rigid structure that loops for a pre-set number of times.  

▪ In JavaScript for structure is very flexible, and is very commonly used 

11.  Break and continue statement:  

▪ JavaScript also supports statements used to modify flow control, specifically break and continue.  

▪ The break statement will terminate the loop early. 

12.  Continue statement: 

▪ The continue statement will skip back to the loop condition check.  
▪ When the continue statement is executed, the current iteration of the enclosing loop is terminated, and the next iteration begins 

13.  While loop:  

▪ In JavaScript while loop is another most basic loop.  
▪ The purpose of a while loop is to execute a statement /block of statement repeatedly as long as an expression is true.  

▪ The while statement creates a loop that executes a specified statement as long as the test condition evaluates to true.  

▪ The condition is evaluated before executing the statement 

14.  Do .. while loop:  
▪ The do..while loop is like a while loop, except that the loop expression is tested at the end of the loop rather than at the beginning.  

▪ This means that the body of the loop is always executed at least once 

 CHAPTER – 16  JAVA SCRIPT 
1.  Function: 

▪ A function is a block of JavaScript code that is defined once but may be executed or invoked any number of times.  

▪ Functions are used to encapsulate code that performs a specific task. Sometimes functions are defined for 

commonly required tasks to avoid the repetition entailed in typing the same statements over and over 

2.  Function types: 

▪ JavaScript supports two types functions.  

▪ They are 1.Pre-defined or Library Functions 2.User-defined Functions 

3.  Some common pre-defined functions.  

▪ Pre-defined functions are already defined in the JavaScript library which are also called Library functions.  

▪ For example isNaN(), toUpperCase(), toLowerCase(), length(), alert(), prompt(),write() etc., are pre-defined  

4.  User defined functions:  
▪ User-defined functions allow the programmer to modularize a program. Most computer programs that solve real-world 

problems are much large, occupy more space in the computer memory and takes more time to execute.  

▪ Hence such large programs are divided into small programs called modules. 

 CHAPTER – 17 Computer Ethics and Cyber Security 
1.  What is CYBER CRIME?  

▪ Cybercrime is an intellectual, white-collar crime.  

▪ Those who commit such crimes generally manipulate the computer system in an intelligent manner.  

▪ For example – Illegal money transfer via internet. 

2.  Define Cyber-crime: 

▪ A cyber-crime is a crime which involves computer and network. 

▪ This is becoming a growing threat to society and is caused by criminals or irresponsible action of individuals 

who are exploiting the widespread use of Internet. 

3.  What is ethics? 

▪ Ethics is a set of moral principles that govern the behaviour of an individual in a society, and Computer ethics 

is set of moral principles that regulate the use of computers by users. 

4.  Define Ethics: 

▪ Ethics means “What is wrong and What is Right”.  

▪ It is a set of moral principles that rule the behaviour of individuals who use computers.  

▪ An individual gains knowledge to follow the right behaviour, using morals that are also known as ethics. 

5.  COMPUTER ETHICS: 
▪ Computer ethics deals with the procedures, values and practices that govern the process of consuming computer technology 

and its related disciplines without damaging or violating the moral values and beliefs of any individual, organization or 

entity. 
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6.  SOFTWARE PIRACY:  
▪ Software Piracy is about the copyright violation of software created originally by an individual or an institution.  

▪ It includes stealing of codes / programs and other information illegally and creating duplicate copies by 

unauthorized means and utilizing this data either for one’s own benefit or for commercial profit. 

▪ In simple words, Software Piracy is “unauthorized copying of software”. 

7.  What is Shareware? 

▪ An entirely different approach to software piracy is called Shareware, 

8.  UNAUTHORIZED ACCESS: 

▪ Unauthorized access is when someone gains access to a website, program, server, service, or other system by 

breaking into a legitimate user account. 

▪ To prevent unauthorized access, Firewalls, Intrusion Detection Systems (IDS), Virus and Content Scanners, 

Patches and Hot fixes are used. 

9.  HACKING:  

▪ Hacking is intruding into a computer system to steal personal data without the owner’s permission or 

knowledge (like to steal a password).  

▪ It is also gaining unauthorized access to a computer system, and altering its contents.  

▪ It may be done in pursuit of a criminal activity or it may be a hobby 

10.  CRACKING:  

▪ Cracking is where someone edits a program source so that the code can be exploited or modified.  

▪ A cracker (also called a black hat or dark side hacker) is a malicious or criminal hacker.  

▪ “Cracking” means trying to get into computer systems in order to steal, corrupt, or illegitimately view data. 

11.  Cracker: 

▪ A cracker is someone who breaks into someone else's computer system, often on a network, bypassing 

passwords or licenses in computer programs. 

12.  Phishing: 
▪ Phishing is a type of computer crime used to attack, steal user data, including login name, password and credit card numbers.  

▪ It occurs when an attacker targets a victim into opening an e-mail or an instant text message 

13.  Pharming: 

▪ Pharming is a scamming practice in which malicious code is installed on a personal computer or server, 

misdirecting users to fraudulent web sites without their knowledge or permission.  

▪ Pharming has been called "phishing without a trap” 

14.  Man In The Middle (MITM)  
▪ Man-in-the-middle attack (MITM; also Janus attack) is an attack where the attacker secretly relays and possibly alters the 

communication between two parties who believe they are directly communicating with each other.  

▪ Example: Suppose Alice wishes to communicate with Bob. Meanwhile, Mallory wishes to intercept the 

conversation to overhear and optionally to deliver a false message to Bob. 

15.  Web sites typically use cookies: 

▪ To collect demographic information about who has visited the Web site. 
▪ Sites often use this information to track how often visitors come to the site and how long they remain on the site.  

▪ It helps to personalize the user's experience on the Web site.  

▪ Cookies can help store personal information about users so that when a user sub sequent returns to the site, a 

more personalized experience is provided.  

16.  Encryption and Decryption:  
▪ Encryption and decryption are processes that ensure confidentiality that only authorized persons can access the information. 

▪ Encryption is the process of translating the plain text data (plaintext) into random and mangled data (called cipher-text).  

▪ Decryption is the reverse process of converting the cipher-text back to plaintext. 

▪ Encryption and decryption are done by cryptography.  

▪ In cryptography a key is a piece of information (parameter) that determines the functional output of a 

cryptographic algorithm. 

17.  E-commerce: 

▪ E-Commerce is electronic data exchange or electronic filing of information. 

18.  How to protect the information? 

▪ Complex password setting can make your surfing secured.  

▪ When the internet is not in use, disconnect it. 

▪ Do NOT open spam mail or emails that have an unfamiliar sender.  

▪ When using anti-virus software, keep it up-to-date. 

 CHAPTER – 18 Tamil Computing 
1.  Search Engines in Tamil: 

▪ The “Search Engines” are used to search any information from the cyber space.  

▪ Although there are many search engines, but only a few of them are frequently in use.  

▪ In the top ten search engines, Google, Bing and Yahoo take first three places respectively.  

▪ Google and Bing provide searching facilities in Tamil, which means you can search everything through Tamil. 

▪ The Google search engine gives you an inbuilt Tamil virtual keyboard. 
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2.  E – Governance: 

▪ Getting Government services through internet is known as e-Governance.  

▪ Govt. of Tamilnadu has been giving its services through Internet.  

▪ One can communicate with Govt. of Tamilnadu from any corner of the World.  

▪ One can get important announcements, government orders, and government welfare schemes from the web 

portal of Govt. of. Tamilnadu. 

3.  E-Library: 

▪ E-Libraries are portal or website of collection of e-books.  

▪ Tamil e-Library services provide thousands of Tamil Books as e-books mostly at free of cost.  

▪ It is the most useful service to Tamil people who live far away from their home land. 

4.  Familiar Tamil Keyboard Interface: 

▪ NHM Writer, E-Kalappai and Lippikar – are familiar Tamil keyboard interfaces software that is used for Tamil 

typing which works on Tamil Unicode, using phonetics.  

▪ Sellinam and Ponmadal – are familiar Tamil keyboard layouts that works on Android operating system in 

Smart phone using phonetics.  

5.  Famous Office automation software: 

▪ Microsoft Office, Open Office etc 

6.  Tamil Translation Applications: 

▪ Thamizpori (தமிழ்ப ொறி) is a Tamil tranlation application having more than 30000 Tamil words equalent 

to English words.  

▪ Using this application, we can translate small english sentences into Tamil.  

▪ Google also gives an online translation facility, using this online facility we can translate from Tamil to any 

other language and vice versa. 

7.  Tamil Programming Language: 

▪ Programming languages to develop software in computers and smart phones are available only in English. 

▪ Now, efforts are taken to develop programming languages in Tamil.  

▪ Based on Python programming language, the first Tamil programming language “Ezhil” (எழில்) is designed. 

With the help of this programming language, you can write simple programs in Tamil. 

8.  ISCII (Indian Script Code for Information Interchange)  

▪ This is one of the encoding schemes specially designed for Indian languages including Tamil.  

▪ It was unified with Unicode. 

9.  Unicode:  

▪ Unicode is an encoding system, designed to handle various world languages, including Tamil.  

▪ Its first version 1.0.0 was introduced in October 1991.  

▪ When Unicode was introduced it could handle nearly 23 languages including Tamil.  

▪ Among the various encoding scheme, Unicode is the best suitable to handle Tamil. 

10.  Tamil Operating System:  

▪ An operating system is needed to access electronic systems such as computer and smart phone.  

▪ Microsoft Windows is very popular operating system for personal computers.  

▪ Linux is another popular open source operating system. Operating systems are used to access a computer 

easily.  

▪ An operating system should be easy to work and its environment should be in an understandable form.  

▪ Thus, all operating systems used in computers and smart phones are offered in Tamil environment.  

▪ Windows Tamil Environment interface should be downloaded and installed from the internet.  

▪ It displays all window elements such as Taskbar, desktop elements, names of icons, commands in Tamil. 

11.  Tamil Wikipedia:  

▪ Wikipedia is a open source encyclopaedia where any person can write an article about any subject.  

▪ There are more than one lakh articles in Tamil Wikipedia.  

▪ Web Site: https://ta.wikipedia.org/  

▪ In order to make Tamil as a living language, it is the duty of every Tamilian to actively use Tamil in the 

development of technology. 
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                 IMPORTANT TOPICS (NUMBER SYSTEMS,  METHODS SYNTAX WITH EXAMPLE    
                                      DECIMAL TO BINARY ,OCTAL , HEXA DECIMAL 
1.  Decimal to Binary 

Conversion 

Convert  (65)10  into equivalent binary number 

2  65 

2  32-1 

2  16-0                 (65)10  = (1000001)2 

2  8-0 

2  4-0 

2  2-0 

    1-0 

2. 2

. 

Decimal to Octal Conversion Convert  (65)10  into its  equivalent  octal  number 

8  65 

8  8-1             (65)10 =  (101)8 

    1-0 

3. 3

. 

Decimal to Hexadecimal 

Conversion 

 

Convert  (31)10  into equivalent hexadecimal number 

16   31 

16   1-15                      (31)10 = (1F)16 

4. . Fractional decimal to binary Convert  (98.46)10  to binary: 

I.   Integer Part:    II. Fractional Part:      

2  98                                 0.46x2= 0.92 = 0            98 = (1100010)2 

2  49-0                    0.92x2= 1.84  = 1           (46)10 = (.0110010)2 

2  24-1                    0.84x2= 1.68 = 1 

2  12-0                    0.68x2= 1.36  = 1           (98.46)10 = (1100010.0111010….)2 

2  6-0                      0.36x2 = 0.72 = 0 

2  3-0                      0.72x2= 1.44  = 1 

    1-1                      0.44x2= 0.88  = 0 

Convert the following Decimal numbers to its equivalent Binary, Octal, Hexadecimal. 1) 1920     2) 255     3)126 

1) 1920 

Decimal to binary                              Decimal to octal                              Decimal to hexa decimal 

2 1920                                                  8 1920                                              16 1920         

2 960-0   192010 = 11100000002               8 240-0    192010 = 36008                         16 120-0      192010 = 78016 

2 480-0                                                 8 30-0                                                     7-8 

2 240-0                                                     3-6 

2 120-0 

2 60-0 

2 30-0 

2 15-0 

2 7-1 

2 3-1 

   1-1 

2) 255 

Decimal to binary                              Decimal to octal                              Decimal to hexa decimal 

2 255                                                    8 255                                                16 255  

2 127-1    25510 = 111111112              8 31-7   25510 = 3778                                                15-15   25510 = FF16 

2 63-1                                                      3-7           

2 31-1               

2 15-1                   

2 7-1 

2 3-1            

   1-1                  

3) 126 

Decimal to binary                              Decimal to octal                              Decimal to hexa decimal 

2 126                                                    8 126                                                16 126 

2 63-0  12610  = 11111102                               8 15-6  12610  = 1768                             7-14      12610 = 7E16 

2 31-1                                                       1-7 

2 15-1 

2 7-1 

2 3-1 

   1-1 
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                                BINARY TO DECIMAL, OCTAL,HEXA DECIMAL 
1.  Binary to Decimal 

Conversion 

Positional 

Notation 

Weight 

20 1 

21 2 

22 4 

23 8 

24 16 

25 32 

26 64 

27 128 
 

Convert (111011)2 into its equivalent decimal number. 

Weight 32 16 8 4 2 1 

Positional 

Notation 

25 24 23 22 21 20 

Given  

number 

1 1 1 0 1 1 

                                                                    

= 32+16+8+0+2+1                                                             

= (111011)2  = (59)10 

2.  Binary to Octal Conversion 
Octal Binary equivalent 

0 000 

1 001 

2 010 

3 011 

4 100 

5 101 
 

(11010110)2 

11010110 ( ? )8 

011    010   110 

 3        2        6 

(11010110)2  =  (326)8 

3.  Binary to Hexadecimal 

Conversion 

(1111010110)2  into Hexadecimal Number. 

1111010110 ( ? )16 

0011    1101   0110 

 3            D        6 

(1111010110)2  =  (3D6)16 

4.  Fractional binary to decimal 

Positional  

Notation 

Weight 

2-1 (1/2) 0.5 

2-2 (1/4) 0.25 

2-3 (1/8) 0.125 

2-4 (1/16) 0.0625 

2-5 (1/32) 0.03125 

2-6 (1/64) 0.015625 

2-7 (1/128) 0.0078125 
 

11.0112 Binary to decimal equivalent                                                

(11)2 = 3 

21  20    . 2-1    2-2   2-3 

 

1    1     .  0     1     1 

                                      =3+ . ( 0x0.5+1x0.25+1x0.125 ) 

                                      = 3.375 

                      (11.011)2 = (3.375)10 

Convert the given Binary number into its equivalent Decimal, Octal and Hexadecimal number. 

1) 101110101            2) 1011010           3) 101011111 

1) 101110101 

Decimal                                                                                             Octal                    Hexadecimal 

 = 1x28+0x27+1x26+1x25+1x24+0x23+1x22+0x21+1x20                      101 110 101              0001  0111  0101 

 = 256+64+32+16+4+1                                                                  5     6     5                   1        7        5 

 1011101012 = 37310                                                                        1011101012 = 5658                            1011101012 = 17516                  

2) 1011010 

Decimal                                                                                            Octal                         Hexadecimal 

 = 1x26+0x25+1x24+1x23+0x22+1x21+0x20                                                        001 011 010                      0101  1010      

 = 64+16+8+2                                                                                    1     3     2                    5        A(10) 

 10110102 = 9010                                                                                      10110102 = 1328                                            10110102 = 5A16       

3) 101011111 

Decimal                                                                                            Octal                         Hexadecimal 

 = 1x28+0x27+1x26+0x25+1x24+1x23+1x22+1x21+1x20                   101  011  111            0001  0101  1111 

 = 256+64+16+8+4+2+1                                                                     5     3      7                 1        5       F(15) 

 1010111112 = 35110                                                                       1010111112 = 5378                                                1010111112 = 15F16 

                                    OCTAL TO DECIMAL, BINARY 
1.  Octal to decimal conversions 

Positional 

Notation 

Weight 

80 1 

81 8 

82 64 

83 512 

Convert (1265)8 into its equivalent decimal number. 

Weight 512 64 8 1 

Positional 

Notation 

83 82 81 80 

Given  

number 
1 2 6 5 
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84 4096 

85 32768 
 

(1265)8 = 512x1+64x2+8x6+1x5 

             = 512+128+48+5 

(1265)8 = (693)10 

2. 2

. 

Octal  to binary conversion 

 

(6213)8  to equivalent binary number 

6           2         1          3 

 

110       010      001     011 

(6213)8 = (110010001011)2 

Convert the following Octal numbers into Binary numbers. (A) 472 (B) 145 (C) 347 (D) 6247 (E) 645 

Octal to binary: 

(A) 472                     (B) 145                     (C) 347                     (D) 6247                          (E) 645 

4       7      2                1      4      5               3     4      7                6      2      4      7                6     4      5 

100   111  010            001  100 101            011 100  111            110  010  100   111           110 100  101 

4728 = 1001110102      1458=0011001012      3478=0111001112     62478=1100101001112     6458= 1101001012  

                                       HEXADECIMAL TO DECIMAL, BINARY 
1. . Hexadecimal  to Decimal 

Conversions 
Positional 

Notation 

Weight 

160 1 

161 16 

162 256 

163 4096 

164 65536 

165 1048576 
 

(25F)16  into its equivalent  Decimal  number 

Weight 256 16 1 

Positional 

Notation 

162 161 160 

Given  

number 

2 5 F(15) 

 (25F)16  =2x256+5x16+15x1 

                =512+80+15 

(25F)16  = (607)10 

2. . Hexadecimal  to Binary 

Conversions 

(8BC) into equivalent Binary numbers 

8            B           C 

 

1000      1011     1100 

(8BC)16  =  (100010111100) 

Convert the following Hexadecimal numbers to Binary numbers (A) A6 (B) BE (C) 9BC8 (D) BC9 

Hexadecimal numbers to Binary numbers: 

(A) A6                      (B) BE                      (C) 9BC8                                       (D) BC9 

A       6                      B         E                     9      B         C        8                      B       C       9 

 

10      6                     11        14                    9       11        12      8                     11       12      9 

1010   0110              1011    1110                1001 1011    1100  1000               1011   1100  1001 

A616 = 101001102    BE16= 101111102            9BC816=10011011110010002           BC916= 1011110010012 

                                       Binary Representation for signed numbers 
1’s Compliment Representation 

(-24) 

2  24        24     = 11000 

2  12-0     8 bit  = 00011000 

2  6-0       1s      = 11100111 

2  3-0 

    1-1 
2’s Compliment Representation                                            

(-24) 

2  24        24     = 11000 

2  12-0     8 bit  = 00011000 

2  6-0       1s      = 11100111 

2  3-0                                  1 

    1-1       2s      = 11101000 

Write the 1’s complement number and 2’s complement number for the following decimal numbers: 

(A) 22 (B) -13 (C) -65 (D) -46 

(A) 22                                          (B) -13 

2 22       22 = 10110                     2 13                -13 = 1101 

2 11-0    8bit = 00010110            2 6-1               8bit = 00001101 

2 5-1                                            2 3-0                1s   = 11110010 

2 2-1                                               1-1                                        1 

   1-0                                                                     2’s    11110011 
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(C) -65                                          (D) -46 

2 65                                                2 46 

2 32-1         - 65 = 1011111           2 23-0            - 46 = 101110 

2 16-1         8bit = 01011111         2 11-1            8bit = 00101110 

2 8-1            1s  = 10100000          2 5-1              1s   = 11010001 

2 4-1                                   1          2 2-1                                      1 

2 2-1            2s =  10100001             1-0               2s  = 11010010 

   1-0 

                                          BINARY ARITHMETIC (Addition &Subtraction) 
1. Binary  Addition 

Rules 

A B Sum 

(A+B) 

Carry 

0 0 0 - 

0 1 1 - 

1 0 1 - 

1 1 0 1 
 

11010102+1011012                                                           

 1 1  1     

  1 1 0 1 0 1 0 

   1 0 1 1 0 1 

+ 1 0 0 1 0 1 1 1 

11010102+1011012  = 100101112 

 10112+10012 

1  1 1  

 1 0 0 1 

 1 0 1 1 

1 0 1 0 0 

10112+10012 = 101002 

2310 + 1210   

Step:1                                          Step:2                                           Step:3 

2 23       23   = 10111                  2 12       12    = 1100                      23  = 00010111 

2 11-1   8bit = 00010111            2 6-0      8bit  = 00001100              12  = 00001100 

2 5-1                                           2 3-0 

2 2-1                                              1-1                                                 35 = 00100011 [2310 + 1210 = 3510=001000112 ] 

   1-0 

1. Binary Subtraction 

Rules 

A B Difference Borrow 

0 0 0 - 

0 1 1 1 

1 0 1 - 

1 1 0 - 

Extra : 1 0 (one zero) – 1 = 1 

11010112 - 1110102                                                             

  0 10 10     

  1 1 0 1 0 1 1 

   1 1 1 0 1 0 

-  0 1 1 0 0 0 1 

11010112  - 1112 =  1100012 

 10010102-101002 

0 1 10 0 10   

1 0 0 1 0 1 0 

  1 0 1 0 0 

 1 1 0 1 1 0 

10010102-101002 = 1101102 

(-21)10 + (5)10   

Step:1                                          Step:2                                           Step:3 

2  21       - 21 = 10101                 2  5        5     = 101                        - 21 = 11101011 

2  10-1    8bit = 00010101           2  2-1    8bit =  00000101               5    = 00000101 

2  5-0      1s   = 11101010                1-0 

2  2-1                                                                                           -16 = 11110000  [ (-21)10 + (-16)10 = 111100002 ]   

    1-0      2s   = 11101011 

Perform the following binary computations: (A) 1010 + 1510   (B) –1210 + 510     (C) 1410 – 1210     (D) (–210) – (–610) 

(A) 1010 + 1510 

Step:1                                          Step:2                                           Step:3 

2 10       10  = 1010                     2 15         15      = 1111                  10 = 00001010 

2 5-0     8bit = 00001010            2 7-1         8bit   = 00001111          15 = 00001111 

2 2-1                                           2  3-1                      

   1-0                                               1-1                                                25 = 00011001       [1010 + 1510 = 2510=000110012 ] 
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(B) –1210 + 510   

Step:1                                          Step:2                                           Step:3 

2 12      12   = 1100                     2 5           5     = 101                      - 12 = 11110100 

2 6-0     8bit = 00001100            2 2-1        8bit = 00000101              5   = 00000101 

2 3-1     1s   = 11110011                1-0                                                

                                      1                                                                   -7   = 11111001     [-1210 + 510 = -710=111110012 ] 

              2s  =  11110100 

(C) 1410 – 1210 

Step:1                                          Step:2                                           Step:3 

2 14     14    = 1110                     2 12         - 12 = 1100                     14 = 00001110 

2 7-0    8bit =  00001110            2 6-0        8bit = 00001100           - 12 = 11110100 

2 3-1                                            2 3-0        1s   = 11110011 

   1-1                                                1-1                               1             2 = 100000010     [1410-1210 = 210=1000000102 ] 

                                                                     2s   = 11110100 

(D) (–210) – (–610) 

Step:1                                          Step:2                                           Step:3 

2 2      -2    = 10                            2 6         6     = 110                       - 2 = 11111110 

   1-0  8bit =  00000010                2 3-0     8bit =  00000110             6   = 00000110 

           1s   =  11111101                   1-1 

                                    1                                                                     4  = 100000100   [ (-2)10 - (-6)10 = 410= 1000001002 ] 

          2s   =   11111110 

                                CHAPTER – 6 TO 16 
1. 2

. 

Merge cells 1. Select the cells to merge. 

2. Right click and choose Cell → Merge or choose Table → Merge Cells from the menu bar. 

2.  Insert rows and columns Choose Row → Insert – to insert a row or Column →  Insert – to insert a column. 

3. . Save document ❖ You can save by clicking File→ Save on top left corner and then click 

❖ File→ Save As or Ctrl +Shift +S 

4. . Change the line spacing of 

text 
1Right click→ line spacing, select the type single, 1.5 or double.  

2.Select the entire document by Edit → Select All Format →  paragraph 

5.  Short cut keys for 

LEFT,RIGHT,CENTER 

AND JUSTIFIED 

alignments 

1.LEFT       -  Ctrl +L      2.RIGHT  –   Ctrl +R  

3.CENTER -   Ctrl +E     4.JUSTIFIED -    Ctrl +J 

6.  EXTRA IMPORTANT  

TOIPICS 

1. Saving the Document : Click File → Save → (or) File → Save As (or) Ctrl + S 

2. Closing a Document: File → Close (or) Press Ctrl + W. 

3. Opening an existing document Click File → Open or Ctrl + O,  

4. Help System in writer- Tools→Option→Open office. 

5. Styles of bullets and numbering: Format → Bullets and Numbering. 

6. Inserting Header and Footer: Insert → Header → Default. 

7. Inserting and Formatting page numbers: Insert → Fields → Page Number 

8. Find & Replace: Edit → Find & Replace (or) Ctrl + F. 

9. Automatic correction: Tools → AutoCorrect 

10. Insert table dialog box:Table → Insert →Table or Ctrl +F12 or left-click. 

11. Inserting rows and columns: Right-click. Choose Row →Insert – to insert a 

new row or Column → Insert. 

12. Deleting rows and columns: Right-click. Choose Row → Delete to delete a 

row or Column → Delete to delete a column. 

13. Inserting pictures: Insert → Picture → From file.  

14. Inserting AutoText: Edit → AutoText (or press Ctrl+F3). 

15. Page Preview: File → Page Preview, or click the Page Preview icon 

16. Setting the Printer and Printing: File → Print or Ctrl + P or Print File Icon 

7.  Download and Install 

Tamil Typing Interface 

❖ “Murasu” use the link : http://anjal.net/download 

❖ “NHM writer” use the link : http://software.nhm.in 

8.  Shortcut keys ❖ Refer  book page no :98 

9. . Text operator syntax ❖ text reference1 & text reference2             Example:       =A1 &B1 

10.  Constructing a formula ❖ Formula:     = cell reference1 <operator> cell reference2 <operator>  

❖ Example:      =A1+B1*5   

11.  Short cut key cut, copy, paste ❖ 1.Ctrl+x – Cut the cell; 2.Ctrl+C- Copy the cell ; 3.Ctrl+V  - Paste the cell 

12. 7

. 

Creating a new worksheet  ❖ Start → All Programs → Open Office → Open Office Calc (or)  

❖ From Star centre (Welcome Screen):  Double-click on “Open Office” icon the desktop 

13.  Reference concatenation operator ❖ Tilde (~) symbol is used as a concatenation operator in calc.  

www.Padasalai.Net                                                                     www.Trb Tnpsc.Com

Kindly Send Me Your Key Answer to Our email id - Padasalai.net@gmail.com

www.P
ad

as
al

ai
.N

et

www.P
ad

as
al

ai
.N

et

http://anjal.net/download
https://www.padasalai.net/
https://www.padasalai.net/


  

149 

                       PREPARED BY…,   B.MOHAMED YOUSUF M.C.A., B.Ed., (PG ASST IN COMPUTER SCIENCE) 

                       [yousufaslan5855@gmail.com] 

 

❖ Syntax:  reference left ~ reference right  Example:   =SUM(A1:A6 ~ C3:F3) 

14.  New spreadsheet ❖ File → New → Spreadsheet 

15.  Intersection Operator ❖ Reference left ! reference right  Example: (A2:D3 ! B2:E4) 

16.  POWER () function syntax ❖ = POWER (Base ; Exponent) 

17.  Chart Wizard ❖ Insert → Chart command. A "Chart wizard" appear 

18.  Opening a new presentation  ❖ Click Start button and select All Programs → Open Office → Open Office Impress. 

19.  Remove slide pane or task pane ❖ View – click- Close (X) 

20.  Show or hide slide pane or task  ❖ View → Slide Pane or View → Task Pane/Side bar. 

21.  Navigator ❖ Edit → Navigator on the menu bar or pressing Ctrl+Shift+F5. 

22.  Status bar (hide) ❖ View → Status Bar from the main menu. 

23.  Workspace ❖ View → Toolbars. 

24.  Hand out view ❖ Tasks pane → Layouts 

25.  Normal view ❖ Standard Toolbar or press Ctrl+Shift+F5 

26.  Changes the text style ❖ Press the F11 key to open the Styles and Formatting window. 

27.  Changethe number slides per row ❖ Check View → Toolbars → Slide View to show the Slide view toolbar 

28.  To select a group of slides ❖ Control (Ctrl) key, Shift key,  cursor 

29.  To print a hand out ❖ Select File print or press Ctrl+P 

30.  Components of URL ❖ URL:Uniform Resource Locator 

❖ Ex: http://www.google.com 

❖ 1.Protocol: http://  2.Subdomain: www 

❖ Domain: google    4. Top level domain: Com 

31.  Examples of IP number ❖ 165.113.245.2                   128.143.22.55 

32. . Creating a Webpage  

 

❖ Step 1: Open a text editor   :   

Windows7 : Start → All Programs →Accessories → Notepad 

❖ Step 2: In the appearing Note pad / Text Editor, type the HTML document.  

❖ Step 3: Save the file as HTML     Click File → Save (or) Press Ctrl + S 

33.  Heading ❖ HTML has six levels of headings viz. <h1> to <h6>. 

34. . Structural tags ❖ <html>, <head>, <title> and <body> 

35.  Headings syntax ❖ The syntax of heading tags:      <h…> Heading text </h…> 

❖ Attribute of Headings tag:        <h# align = value> 

36.  Comments 

 

❖ The tag <!> is used to create comments 

❖ The general form of comments:  <! comments > 

37.  Examples of container & 

Empty elements 

❖ Container Elements:  For example: <html>, <body>, <title>, <p> etc., 

❖ Empty Elements:  For example: <br> 

38.  How do you include an image as 

your web page background? 
❖ The tag to apply an image as background:  

❖ <body background = “image_name_with_extenstion”> 

39.  How do you save a file as 

HTML file?  

 

❖ Start→ All programs→ Notepad→ Accessories  (Windows 7) 

❖ Click File → Save (or) Press Ctrl + S 

❖ Save as dialog box appears 

40.  <font> tag with attributes  

 

<font face= “font_name” size=value color=color_name / color_code>  

Text to be displayed  

</font> 

41.  Attributes of <hr> tag syntax ❖ <hr size=valuewidth=valuenoshade,color=color_name/code> 

42.  Examples of Comparison of tags ❖ <b> and <strong>, <i> and <em>, <u> and <ins> and so on 

43.  Use of <mark> tag ❖ The <mark> tag is used to highlight the text in HTML. 

Ex: A computer is an <mark> electronic</mark> devices. 

44.  Structure of an anchor tag with 

href 
❖ <A href=”Web content path/URL”>Text-Clickable ink </A> 

45.  Internal Links Example 

 
❖ <A href = #AP> Andhra Pradesh, </A> 

❖ <A Name = AP><B> Andhra Pradesh </B> </A> 

46.  External Link Example 

 
<A href = “http://www.tnscert.org”>  

         State Council of Educational Research and Training, Tamilnadu </A> 

47.  Highlighting text ❖ The <mark> tag is used to highlight the text in HTML 

48.  Strike through ❖ The <s> and <del> tags are display the text in similar way 

49.  Comparison of tags Tag Usage Tag Usage Final Output 

<b> To show the text in bold <strong> To show important text Bold 

<i> To show the text as italics <em> To Call attention  Italics 

<u> To show the text as underlined <ins> To insert a text Underline 

<s> To show the wrong text <del> To replaced or deleted text Strike through  
 

50.  General format of marquee 

 
<marquee> Text or image to be scroll </marquee> 
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Example:  

❖ <marquee> <b> The Government of Tamilnadu </b>, Directorate of 

School Education </marquee> 

51.  General Format of <form> 

tag 

 

<Form method=get/post action= “back_end_server_script”> 

 Form elements 

</Form> 

52.  Inserting Images with 

HTML document 

<img src = image_name_with_extension>  (OR)   <img src = URL> 

Example:   <img src = image1.gif> 

53.  Adding Video and Sound 

General Format  

❖ <embed src = audio / video file name with location> </embed> 

54.  Background music  

General Format 

❖ <bgsound src=music file name with location> 

 

55.  Other Attributes of <img> 

tag 

❖ Alt (Alternative Text): 

❖ Example:   <img src = bharathiyar.gif alt = “National Poet of India”> 

56.  Which tag is used to 

specify the list of items in 

dropdown list box?  

❖ The <select> tag is used to create dropdown list box in HTML.  

❖ The <option> tag is used to specify list items. 

57.  Use of <form> tag 

 

❖ The <form> tag is used to create a form.  

❖ An HTML from starts with <form> and ends with </form> tag. 

58.  <Select> Tag ❖ The <select> tag is used to create dropdown list box in HTML.  

59. . General format of linking 

CSS with HTML. 

❖ <Link rel = “style sheet” type = “text/css” href = 

CSS_File_Name_with_Extension> 

60.  General format of CSS 

declaration. (CSS Rules) 

Selector          Declaration     

HTML Tag    { Properties : Values; }  
61.  Example of <style> tag?                                                               

 

<style>  

 h3  

 { color:blue;  font-family: “Copper plate Gothic Bold”;  

font-size:14pt; }  

</style> 

62.  CSS file to define text color 

and alignment to <p> tag. 

 

P  

{  

color:pink;  

} 

Text-align:center  }  The above code can be saved para.css  

63.  CSS file to define font type, 

style and size to <h1> tag 

 

h1  

Font-family : “Times New Roman”;  

{  

Font-style : Bold;  

Font-size : 10px; 

} 

The above code can be saved  as heading1.css 

64.  Creating CSS style sheets 

 

❖ Open an empty notepad. 

❖ Type the style properties and their values as given in the table given above. 

❖ Save the file with extension .css 

P  

{ 

font-style : Italic; 

color :MediumSeaGreen; 

} 

H1 

{ 

border:2px solid red; 

} 

The above code should be saved with extension .css 

65.  Syntax of <script> tag 

 

<script language="javascript" type="text/javascript 

  JavaScript code 

</script> 

66. 2

. 

Conditional operator give 

suitable example 

 

The ?: is the conditional operator  

Syntax:  var variablename=(condition) ? value1 : value2; 

Example: var result=(10>15) ?100 :150 
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67. 3

. 

Alert Dialog Box syntax 

with examples 

 

❖ The syntax of alert box is  

                  Alert(“Message”);   (or)   Window.alert(“Message”);  

❖ Example:  

                  alert(“Name is compulsory entry”);   (or)  

                  window.alert(“Name is compulsory entry”); 

68. 4

. 

Confirm Dialog Box syntax 

with examples 

 

 

❖ The syntax of confirm dialog box is  

                  confirm(“message”);  (or)   window.confirm(“message”); 

❖ Example:  

                    confirm(“Hai Do you want to continue:”);  

69. 5

. 

Prompt Dialog Box syntax 

with examples 

 

❖ The Syntax of prompt dialog box is,  

                           Prompt(“Message”,”defaultValue”);  

❖ Example:    prompt(“Enter Your Name:”,”Name”); 

70. 6

. 

Comments in JavaScript 

 

❖ Comments. Single-line comments begin with a double slash (//), 

❖ For example: // JavaScript single line comment//  

                             Multiple line comments begins with /* and ends with */ 

71. 7

. 

Unary + and - Operator  

 

❖ + has no effect on numbers but causes non-numbers to be converted into numbers  

❖ -  Negation (changes the sign of the number or converts the expression to a 

number and then changes its sign) 

72. 9

. 

First JavaScript Program 

 

<Html>  

<Head>  

<Title>My First JavaScript Program</Title>  

<script language="javascript" type="text/javascript">  

document.write("Hello World!") 

</script> 

</Head> 

<Body> 

</Body> 

</Html> 

73.  JavaScript Literals  For 

Example  

 

var int_const=250; //Integer constant//  

var float_const=250.85; //Floating point constant//  

var char_const=’A’; //Character constant//  

var string_const=”Raman”; //String constant//  

var boolean_const=true; //Boolean constant// 

❖ General Syntax:    document write ("string " + var); 

74. 1

. 

If statement syntax 

 

if (condition)                      

{                                          

True block;                      

} 

75. 2

. 

If.. else statement syntax 

 

if (expression)  

{  

statements if true  

}  

else  

{  

statements if false  

} 

76. 3

. 

Syntax for else-if 

statement. 

 

if (n == 10)  

{                            // Execute code block #1 }  

else if (n == 20)  

{                           // Execute code block #2 }  

else if (n == 30)  

{                          // Execute code block #3 }  

else  

{                          // If all else fails, execute block #4 

77. 4

. 

Write the general syntax 

for switch statement. 

 

Switch (expression) { 
 

case label1: statements1; break; 

case label 2: statements2; break; 

case label n; statements – N; break; default: (optional) 

statements;   

}   
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78. 5

. 

The syntax of the for loop                              

 

for(initialization; condition; increment/decrement)         

{                                                                                          

 Body of the loop;                                                           

}                                                                                          

79. 6

. 

While loop syntax  while (condition)  

{  

body of the loop  

} 

80. 7

. 

Do  while loop Syntax 

 

do  

{  

body of the loop  

} while (expression); 

81. 1

. 

Write the syntax of 

functions.  

 

Function function-name(parameters list) 

{ 

Function Body ; 

} 

82. 2

. 

User defined functions 

Example: 

 

function sum(x,y)  

{  

var m=x+y;  

return m;  

} 

83. 3

. 

The format of function  

Definition (User defined 

function) 

Function Definition  

The format of a function definition is  

 

Function function-name(parameters list)  

{ 

 Declarations of variable executable statements; 

Function body 

} 
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           PUBLIC EXAMINATIONS COMPULSORY QUESTIONS WITH answers 
 TWO MARKS: (Q.NO 24) 

1.  Write the output of the following HTML code.  (J-2024) 

<html>                                                                                    OUTPUT 

<head>                                                                                    Tamil 

<title> Number List </title>                                                   Telugu 

</head>                                                                                   English 

<body>                                                                                    Computer Applications                           

<OL>                                                                                       Commerce                     

   <LI> Tamil                                                                           Accountancy                                                

   <LI> Telugu                                                                          Economics 

   <LI> English                                                                          

   <LI> Computer Applications 

   <LI> Commerce 

   <LI> Accountancy 

   <LI> Economics 

</OL> 

</body> 

</html> 

2.  What is cyber-crime? (M-2024) 

❖ A cyber-crime is a crime which involves computer and network. 

❖ Cyber-crime is an intellectual, white-collar crime. 

❖ Those who commit such crimes generally manipulate the computer system in an intelligent manner. 

3.  Convert  (1560)8  into equivalent Decimal number  (J-2023) 

Weight 512 64 8 1 

Positional 

Notation 

83 82 81 80 

Given  

number 

1 5 6 0 

                                                                       

(1560)8 = 512x1+64x5+8x6+1x5 

             = 512+320+48+0 

(1560)8 = (880)10 

4.  What is meant by signed magnitude? (M-2023) 

❖ The simplest method to represent negative binary numbers is called Signed Magnitude. 

5.  What are the guidelines to be followed by any computer user? (S-2022) 

1.Honesty :  

❖ Users should be truthful while using the internet. 

2.Confidentiality:  

❖ Users should not share any important information with unauthorized people. 

3.Respect :  

❖ Each user should respect the privacy of other users.  

4.Professionalism:  

❖ Each user should maintain professional conduct. 

5.Obey The Law:  

❖ Users should strictly obey the cyber law in computer usage. 

6.Responsibility: 

❖ Each user should take ownership and responsibility for their actions. 

6.  Convert (65)10 into Binary number  (S-2021)(M-2022) 

2  65      LSB 

2  32-1           (46)10  = (1000001)2 

2  16-0 

2  8-0 

2  4-0 

    2-0     

    1-0     MSB 

7.  What are the two types of encryption? (S-2020) 

❖ Encryption is the process of translating the plain text data (plaintext) into random and mangled data (called cipher-text). 
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❖ For example data being transferred via networks (e.g. the Internet, ecommerce), mobile telephones, wireless 

microphones, wireless intercom systems, Bluetooth devices and bank automatic teller machines.. 

8.  Write any four common library functions (M-2020) 

1.isNaN( ), 2.toUpperCase( ), 3.toLowerCase( ), 4.length( ), 5.alert( ), 6.prompt( ),    7.write( ) 

9.  Write the formula to find the sum of the contents of the cells A1,A2 and A3 in a worksheet (J-2019) 

 =A1+A2+A3 (Add the values in cells A1,A2 and A3) 

10.  Write about short cut keys for LEFT,RIGHT, CENTER AND JUSTIFIED alignments.  (M-2019) 

1.LEFT       -  Ctrl +L    2.RIGHT        –   Ctrl +R  3.CENTER -   Ctrl +E   4.JUSTIFIED -    Ctrl +J 

 THREE MARKS: (Q.NO. 33) 

1.  A) Add : 10112+10012   B) Subtract : 10010102-101002      (J-2024) 

A) Add : 10112+10012    

1 1 1  

     1 0 1 1 

     1 0 0 1 

 1  0 1 0 0 

  

10112+10012  = 101002 

 

 

B) Subtract : 10010102-101002       

  1 10  10   

 10 0 0 1  0 0 1 0 

   1 0 1 0 0 

  1 1 0 1 1 0 

10010102-101002     = 1101102 

2.  Add: (A)  -2010 + 2510  (M-2024) 

Step:1                                          Step:2                                           Step:3 

2 20       -20   = 10100                  2 25       25    = 11001                     -20  = 11101100 

2 10-0   8bit = 00010100            2 12-1      8bit  = 00011001               25 = 00011001 

2 5-0     1s = 11101011               2 6-0 

2 2-1                           1                2 3-0                                                  -5 =1000001012   

   1-0      2s= 11101100                    1-1                                                       [-2010 + 2510 = -510=1000001012 ] 

(B) 2210 + 1510        

Step:1                                          Step:2                                           Step:3 

2 22       22  = 10110                     2 15         15      = 1111                  22 = 00010110 

2 11-0    8bit = 00010110             2 7-1         8bit   = 00001111          15 = 00001111 

2 5-1                                              2  3-1                      

   2-1                                              1-1                                                   37 = 001001012        

   1-0                                                                                                      [2210 + 1510 = 3710=001001012 ] 

3.  What is indenting text in writer? Write its types (J-2023) 

Indenting text: 

❖ Indent is the distance from the left and right margin of a paragraph.  
❖ It is used to improve the efficiency and readability of the paragraph and makes the paragraph look more attractive. 

There are four types of indentations:  

• Left Indent   • Right Indent   • First Line Indent  • Hanging Indent. 
4.  Compare CUT-PASTE and COPY- PASTE (M-2023) 

CUT and PASTE: 

 To move a file or folder, first select the file or folder and then choose one of the following: 

❖ Click on the Edit → Cut or Ctrl + X or right click → Cut from the pop-up menu. 

❖ To move the file(s) or folder(s) in the new location, navigate to the new location and paste it using Click Edit 

→ Paste or Ctrl + V or Right click → Paste from the popup menu.  

❖ The file will be pasted in the new location. 

COPY and PASTE:  

To copy a file or folder, first select the file or folder and then choose one of the following: 

❖ Click Edit → Copy or Ctrl + C or right click→ Copy from the pop-up menu. 

❖ To paste the file(s) or folder(s) in the new location, navigate to the target location and paste it using Click Edit 

→ Paste or Ctrl + V or Right click → Paste from the popup menu.  

❖ The file will be pasted in the new location 
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5.  What are the uses of <strong> and <em> tag? (S-2022) 

1.<strong> Important text: 

The <strong> tag is a phrase tag. It is used to define important text. This tag displays the text as bold.  

2.<em> - Emphasized text:  

The <em> tag is used to emphasize the text. That means, when you use this tag, the text will be in italics. 

6.  Describe any three pre-defined functions in JavaScript with examples (M-2022) 

Function Description Example Result 

toUpperCase() Used to convert given string into uppercase  x=”java” 

x.toUpperCase(); 

JAVA 

toLowerCase() Used to convert given string into lowercase x=”JAVA” 

x.toLowerCase(); 

java 

length Used to find length of the given string x=”JAVA” x.length(); 4 

parseInt() Used to convert the given float value into an integer parseInt(34.234); 34 

parseFloat() Used to convert the given string into a integer parseInt(“34.23”); 34.23 
 

7.  Write the syntax for  else-if statement. (S-2021) 

If (condition 1)  

{  block 1; }  

else if (condition 2)  

{  block 2; }  

else if (condition 3)  

{ block 3; }  

else  

{ block 4;} 

8.  Define – Unicode (S-2020) 

❖ Unicode is an encoding system, designed to handle various world languages, including Tamil.  

❖ Its first version 1.0.0 was introduced in October 1991. 

❖ Unicode is the best suitable to handle Tamil. 

9.  What is the decimal equivalent sequence for (547)8 octal sequence? (M-2020) 

(547)8  = 5x82+4x81+7x80 

             =5x64+4x8+7x1 

             =320+32+7 

             =(359)10 

 

10.  What message will be displayed, if the input marks is given as 60, for the following snippet.(J-2019)   
if (marks> = 40 )                                                    Message will be display like, 

{                                                                                    you have passed  

alert (“you have passed”}         

}                                                                           

else                                                            

alert (“you have failed”);  

 } 

11.  Write an HTML code to scroll the following message in a web page. (M-2019) 

“Welcome to HTML” 

<html> 

<head> 

<title> Marguee </title> 

</head> 

<body> 

<marguee > Welcome to HTML </marquee> 

</body> 

</html> 
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