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COMPUTER APPLICATIONS
1. INTRODUCTION TO COMPUTERS
SECTION-A

Choose the correct answer:

1. First generation computers used
(a)Vacuum tubes (b) Transistors

2. Name the volatile memory

(c) Integrated circuits (d) Microprocessors

(a) ROM (b) PROM (c) RAM (d) EPROM
3. Identify the output device

(a) Keyboard (b) Memory (c) Monitor (d) Mouse
4. ldentify the input device

(@) Printer (b) Mouse (c) Plotter (d) Projector
S Output device is used for printing building plan, flex board, etc.

(@) Thermal printer (b) Plotter

(c) Dot matrix (d) inkjet printer

6. In ATM machines, which one of the following is used to

(@) Touch Screen (b) speaker
7. When a system restarts

(a) Warm booting (b) Cold booting
8. Expand POST

(a) Post on self Test

c) Power on Self Test

(c) Monitor (d) Printer

which type of booting is used.

(c) Touch boot (d) Real boot.

(b) Power on Software Test
(d) Power on Self Text

9. Which one of the following is the main memory?

(a) ROM (b) RAM (c) Flash drive (d) Hard disk
10. Which generation of computer used IC’s?
(@) First (b) Second (c) Third (d) Fourth
SECTION-B
Short Answers

1.What is a computer?

A computer is an electronic device that processes the input according to the set of instructions

provided to it and gives the desired output at a very fast rate.

2.Distinguish between data and information.

Data

Information

Data is defined as an unprocessedcollection of
raw facts, suitable for communication,

Interpretation or processing.

Information is a collection of facts from which

conclusions may be drawn.

Example: 134, 16 ‘Kavitha’, ‘C’are data.

Example: Kavitha is 16 years old.

http://www trbtnpsc.com/2018/06/latest-plus-one-1ith-study-materials-tamil-medium-english-medium-new-syllabus-based html


mailto:jbaskaran89@gmail.com
mailto:jilakkia@gmail.com

www.Padasalai Net www. TrbTnpscom

3. What are the components of a CPU?

The CPU has three components which are Control unit, Arithmetic and logic unit (ALU) and
Memory unit.

4. What is the function of an ALU?

The ALU is a part of the CPU where various computing functions are performed on data. The ALU
performs arithmetic operations such as addition, subtraction, multiplication, division and logical
operations.

5. Write the functions of control unit.

The control unit controls the flow of data between the CPU, memory and 1/0O devices. It also
controls the entire operation of a computer.

6. What is the function of memory?

* The Memory Unit is of two types which are primary memory and secondary memory.

* The primary memory is used to temporarily store the programs and data

* The secondary memory is used to store the data permanently.

7. Differentiate Input and output unit.

Input Unit Output Unit
An Input unit is used to feed any form of data to | An Output Unit is any hardware component that
the computer, which can be stored in the conveys information to users in an
memory unit for further processing. understandable form
Example: Keyboard, mouse Example:Monitor, Printer

8. Distinguish Primary and Secondary memory.

Primary Memory Secondary memory
The Primary Memory is volatile, that is, the The Secondary memory is non-volatile, that is,
content is lost when the power supply is the content is available even after the power
switched off. supply is switched off.
The primary memory is used to temporarily The secondary memory is used to store the data
store the programs and data permanently
Example: Random Access Memory (RAM). Example: Hard disk, DVD ROM.
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SECTION-C
Explain in Brief
1. What are the characteristics of a computer?
Computers have revolutionized our lives with their speed, accuracy, storage, reliability, versatility
and diligence performing a job, it is truly remarkable.
2. Write the applications of computer.
Computers are seen everywhere around us, in all spheres of life, in the field of education, research,
travel and tourism, weather forecasting, social networking, e-commerce, Robotics
Nanotechnology, Bioengineeringetc.
3. What is an input device? Give two examples.
An input device is a hardware or peripheral device used to send data to a computer. An input device
allows users to communicate and feed instructions and data to computers for processing, display,
storage and/or transmission.
Example: Keyboard, mouse, Scanner, Track Ball, Light Pen.
4. Name any three output devices.
An output device is any peripheral that receives data from a computer
Monitor:Monitor is the most commonly used output device to display the information. It looks like
aTV.
Plotter:Plotter is an output device that is used to produce graphical output on papers.
Printers:Printers are used to print the information on papers.
Speakers: Using speaker along with speech synthesize software, the computer can provide voice
output.
Multimedia Projectors: Multimedia projectors are used to produce computer output on a big
screen

5. Differentiate optical and Laser mouse

Optical mouse Laser mouse

Measures the motion and acceleration of Measures the motion and acceleration of

pointer. pointer.

It uses light source instead of ball to judge the Laser Mouse uses Laser Light

motion of the pointer.

Optical mouse is less sensitive towards surface. | Laser Mouse is highly sensitive and able to

work on any hard surface
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6. Write shortnote on impact printer

*An impact printer is a type of printer that works by direct contact of hammers or pins on ribbon.
*These printers can print on multi-part (using carbon papers) by using mechanical pressure.For
example, Dot Matrix printers and Line matrix printers are impact printers.
Dot Matrix printer :A Dot matrix printer that prints using a fixed number of pins or wires. Each
dot is produced by a tiny metal rod, also called a “wire” or “pin”.
Line matrix printers :Line matrix printers use a fixed print head for printing. Basically, it prints a
page-wide line of dots. But it builds up a line of text by printing lines of dots.
7. Write the characteristics of sixth generation.
*Sixth Generation, computers could be defined as the era of intelligent computers, based on
Artificial Neural Networks.
*The most dramatic changes in the sixth generation will be the explosive growth of Wide Area
Networking.
*Natural Language Processing (NLP) is a component of Artificial Intelligence (Al).
*1t provides the ability to develop the computer program to understand human language.
8. Write the significant features of monitor.
*Monitor is the most commonly used output device to display the information. It looks like a
TV.Pictures on a monitor are formed with picture elements called PIXELS.
*There are many types of monitors available such as CRT (Cathode Ray Tube), LCD (Liquid
Crystal Display) and LED (Light Emitting Diodes).
*Monochrome which display text or images in Black and White or can be color, which display
results in multiple colors.
*The monitor works with the VGA (Video Graphics Array) card. The video graphics card helps the
keyboard to communicate with the screen.

SECTION -D
Explain in detalil
1. Explain the basic components of a computer with a neat diagram.
* The computer is the combination of hardware and software. Hardware is the physical component
of a computer like motherboard, memory devices, monitor, keyboard etc.
* Software is the set of programs or instructions. Both hardware and software together make the
computer system to function.Every task given to a computer follows an Input- Process- Output
Cycle (IPO cycle). It needs certain input, processes that input and produces the desired output.

Components of a computer
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Figure 1.3 components of a computer

Input Unit

Input unit is used to feed any form of data to the computer, which can be stored in the memory unit
for further processing. Example: Keyboard, mouse, etc.

Central Processing Unit

CPU is the major component which interprets and executes software instructions. It also control the
operation of all other components such as memory, input and output units. The CPU has three
components which are Control unit, Arithmetic and logic unit (ALU) and Memory unit.

Arithmetic and Logic Unit

The various computing functions are performed on data. The ALU performs arithmetic operations
such as addition, subtraction, multiplication, division and logical operations.The logical operations
of ALU promote the decision-making ability of a computer.

Control Unit

The control unit controls the flow of data between the CPU, memory and I/O devices. It also
controls the entire operation of a computer.

Output Unit

An Output Unit is any hardware component that conveys information to users in an understandable
form. Example: Monitor, Printer etc.

Memory Unit

* The Memory Unit is of two types which are primary memory and secondary memory. The
primary memory is used to temporarily store the programs and data. The Primary Memory is
volatile, that is, the content is lost when the powersupply is switched off. The Random Access

Memory (RAM) is an example ofa main memory.
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* The secondary memory is used to store the data permanently. The Secondary memory is non-
volatile, that is, the content is available even after the power supply is switched off. Hard disk, CD-

ROM and DVD ROM are examples of secondary memory.

2. Explain the following

a. Inkjet Printer

* Inkjet Printers use colour cartridges which combined Magenta, Yellow and Cyan inks to create
color tones.

* A black cartridge is also used for monochrome output. Inkjet printers work by spraying ionised
ink at a sheet of paper.

* The speed of Inkjet printers generally range from 1-20 PPM (Page Per Minute).

* An Inkjet printer can spread millions of dots of ink at the paper every single second.

* A tiny electric currents controlled by electronic circuits are used inside the printer to spread ink in
jet speed.

b. Multimedia projector

* Multimedia projectors are used to produce computer output on a big screen. These are used to
display presentations in meeting halls or in classrooms.

c. Bar code

* A Bar code is a pattern printed in lines of different thickness. The Bar code readerscans the
information on the bar codes transmits to the Computer for further processing.

* The system gives fast and error free entry of information into the computer.

d. QR code Reader

The QR code is the two dimension bar code which can be read by a camera and processed to

interpret the image.
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S Generation

Period

Main Component
s ed

Merits/Demerits

First
Generation

1942-
1955

Vacuum tubes

LI

Big in size

Consumed more power
MMaltfunction due to overheat
Machine Language was used

First Generation Computers - ERNLAC |,
ENIAC weighed about 27 tons,

size B feet = 100 feet
watts of power

EDWAC, UNIVAC 1

= 3 feet and consumed around 150

Second
Generation

1955-
1964

>

Transistors

Smaller compared to First
Creneration

Crenerated Less Heat
Consumed less power
compared to first generation
Punched cards were used
First operating system was
developed - Batch Processing
and Multiprogramming
Orperating Systen

Machine language as well as
Assembly language was used.

Second Generation Computers IBM 1401, TBM 1620, UNIVAC 1108

Thicrd
Generation

1964
1975

Integrated
Circuwits (IC)

Computers were smaller,
faster and more reliable
Consumed less power
High Lewvel Languages were
nsed

Third Generation Computers

IBM 360 series,

Honeywell 6000 series

Fourth
Generation

197 5- 1980

Microprocessor
Wery Large Scale
Integrated Circuits

(W ILSID)

Smaller and Faster
Microcomputer series such
as IBM and APPLE were
developed

Portable Computers were
introduced.

Fifth
Generation

1980 - till
date

Ultra Large
Scale Integration
(ULSI)

Parallel Processing

Super conductors

Computers size was drastically
reduced.

Can recognize Images and
Graphics

Introduction of Artificial
Intelligence and Expert
Systems

Able to solve high complex
problems including decision
making and logical reasoning

Sixth
Generation

In future

Parallel and Distributed
computing

Computers have become
smarter, faster and smaller
Development of robotics
Natural Language Processing
Development of Voice
Recognition Software
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COMPUTER APPLICATIONS
2. NUMBER SYSTEMS
SECTION-A

Choose the correct answer:

1. Which refers to the number of bits processed by a computer’s CPU?

A) Byte B) Nibble C) Word length D) Bit
2. How many bytes does 1 Kilobyte contain?
A) 1000 B) 8 C) 4 D) 1024

3. Expansion for ASCII
A) American School Code for Information Interchange
B) American Standard Code for Information Interchange
C) All Standard Code for Information Interchange
D) American Society Code for Information Interchange

4. 2”50 is referred as

A) Kilo B) Tera C) Peta D) Zetta
5. How many characters can be handled in Binary Coded Decimal System?

A) 64 B) 255 C) 256 D) 128
6. For 11012 what is the Hexadecimal equivalent?

A) F B) E C)D D)B
7. What is the 1°s complement of 001001107

A) 00100110 B) 11011001 C) 11010001 D) 00101001
8. Which amongst this is not an Octal number?

A) 645 B) 234 C) 876 D) 123

SECTION-B

Short Answers

1. What is data?
The term data comes from the word datum, which means a raw fact. The data is a fact about
people, places or some objects.

2. Write the 1’s complement procedure.

Step 1: Convert given Decimal number into Binary

Step 2: Check if the binary number contains 8 bits , if less add 0 at the left most bit, to make it as 8
bits.

Step 3: Invert all bits (i.e. Change 1asOand O as 1)
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3. Convert (46),o into Binary number

2 46

2 2—3 - 0 Lse}
2 11 -1

2 |5 -1

2 |2 1
mMsB 1 -0

(46)1 = (101110),
4. We cannot find 1’s complement for (28),,. State reason.
Reason :We cannot find 1’s complement for (28);0, Because it is a positive number.
complement apply only with negative number.
5. List the encoding systems for characters in memory.
There are several encoding systems used for computer.

BCD — Binary Coded Decimal

EBCDIC - Extended Binary Coded Decimal Interchange Code

ASCII — American Standard Code for Information InterchangeUnicode

ISCII - Indian Standard Code for Information Interchange
SECTION-C

Explain in Brief

1. What is radix of a number system? Give example

* Each number system is uniquely identified by its base value or radix.

* Radix or base is the count of number of digits in each number system.
* Radix or base is the general idea behind positional numbering system.

* Radix or base is the general idea behind positional numbering system.

Example:

Binary Number System - Radix 2 (1010),
Octal Number System - Radix 8 (457)g
Decimal Number System - Radix 10 (312)49

Hexadecimal Number System

Radix 16 (25F)16
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2. Write note on binary number system.

* There are only two digits in the Binary system, namely, 0 and 1.

* The numbers in the binary system are represented to the base 2 and the positional multipliers are
the powers of 2.

* The left most bit in the binary number is called as the Most Significant Bit (MSB)and it has the
largest positional weight.

* The right most bit is the Least Significant Bit (LSB) and has the smallest positional weight.

3. Convert (150),0 into Binary, then convert that Binary number to Octal

2 | 150  Binary Number
2 75 -0LsB4
2 37 -1
2 18 -1
2 9 -0
2 4 -1
2 2 -0
MsB 1 -0

(150);0 = (10010110),

Binary Number to Octal

10010110 =7
010 010 110
2 2 6

(10010110),= (226)s

4. Write short note on ISCI|I

* |ISCII means Indian Standard Code for Information Interchange. Itis the system of handling the
character of Indian local languages.

* This as a 8-bit coding system. Therefore it can handle 256 (2°) characters.

* The department of Electronics in India in the year 1986- 88 and recognized by Bureau of Indian
Standards (BIS).
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5. Add a) -22;0+154

2 22

2 11 -0 LSBA

2 5 -1

2 2 -1

MSB 1 -0 The Binary equivalent of 22,9 =(10110),

Binary equivalent of +22 = 10110
8 bit format = 00010110
1’s complement = 11101001
Add 1 bit = +1
2’s complement —22 = 11101010

2 15

2 7 - 1Ls

2 | 3 -1

MsB1l -1 The Binary equivalent of 15, = (111),

The binary addition of =22 and 15

22y = 11101010
+155p = 00001111
T = 11111001

—710=(11111001),
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b) 2010+254¢

2 20

2 10 -0LsB

2 5 -0

2 2 -1
MSB 1 -0 The Binary equivalent of 20,9 = (10100),

2 25

2 12 - 1LsBt

2 6 -0

2 3 -0
MSB 1 -1

The Binary equivalent of 25, = (11001),

8 bit format of 204, = 00010100
8 bit format of 254, = 00011001
45, = 00101101

45, = (00101101),

SECTION - D
Explain in detalil
1. a) Write the procedure to convert fractional Decimal to Binary
The method of repeated multiplication by 2 has to be used to convert such kind of decimal
fractions. The steps involved in the method of repeated multiplication by 2:
Step 1: Multiply the decimal fraction by 2 and note the integer part. The integer part is either 0 or 1.
Step 2: Discard the integer part of the previous product. Multiply the fractional part of the previous
product by 2. Repeat Step 1 until the same fraction repeats or terminates (0).
Step 3: The resulting integer part forms a sequence of Os and 1s that become the binary equivalent
of decimal fraction.
Step 4: The final answer is to be written from first integer part obtained till the last integer part

obtained.
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b) Convert (98.46),, to Binary

1) Integer Part

2 98 4

2 49 -0 LsSE

2 24 -1

2 12 -0

2 6 -0

2 3 -0
MSB 1 -1

9810 = (1100010),

i) Fraction Part
0.46x2 =0.92 =0
092x2 =184 =1
0.84x2 =168 =1
068x2 =136 =1
0.36x2 =072 =0
072x2 =144 =1
044x2 =088 =0 v
46,0 = (0111010),

(98.46)0 = (1100010. 0111010....),
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2. Find 1’s Complement and 2’s Complement for the following Decimal number

a) -98

2 98

2 49 —oLse |

2 24 -1

2 12 -0

2 6 -0

2 3 -0

MsB 1 -1 The Binary equivalent of 98, = (1100010),

Binary equivalent of +98 = 1100010
8 bit format = 01100010
1’s complement = 10011101
Add 1 bit = +1
2’s complement —98 = 10011110

~98 = (10011110),

b) -135

2 135

2 67 - 1LSBp

2 33 -1

2 16 -1

2 8 -0

2 4 -0

2 2 -0

MSB 1 -0
The Binary equivalent of 135, = (1000111),

Binary equivalent of +135 = 10000111
8 bit format = 10000111
1’s complement = 01111000
Add 1 bit = +1
2’s complement —135 = 01111001

~135 = (01111001),
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3. a) Add 1101010,+101101,

0+1=1
1101010, + 101101, = 10010111, 1+0=1
1+1=10
1+1+1=11
b) Subtract 1101011, — 111010,
1 1 0 1 0 1 1
— 1 1 1 0 1 0
0 1 1 0 0 0 1
1-0=1
1-1=0
10-1=1
1101011, — 111010, = 0110001,
J. BASKARAN M.Sc., B.Ed. (C.S) J. ILAKKIA M.Sc., M.Phil., B.Ed. (C.S)
jbaskaran89@gmail.com jilakkia@gmail.com

http://www trbtnpsc.com/2018/06/latest-plus-one-1ith-study-materials-tamil-medium-english-medium-new-syllabus-based html


mailto:jbaskaran89@gmail.com
mailto:jilakkia@gmail.com

www.Padasalai Net www. TrbTnpscom
J. BASKARAN M.Sc., B.Ed. (C.S) J. ILAKKIA M.Sc., M.Phil., B.Ed. (C.S)
jbaskaran89@gmail.com jilakkia@gmail.com

COMPUTER APPLICATIONS
3. COMPUTER ORGANIZATION
SECTION-A

Choose the correct answer:
1. Which of the following is said to be the brain of a computer?
(a) Input devices  (b) Output devices (c) Memory device (d) Microprocessor

2. Which of the following is not the part of a microprocessor unit?

(@ ALU (b) Control unit (c) Cache memory (d) register
3. How many bits constitute a word?
@8 (b) 16 (c) 32 (d) Determined by the processor used.
4. Which of the following device identifies the location when address is placed in thememory address
register?
(a) Locator (b) Encoder (c) Decoder (d) Multiplexer
5. Which of the following is a CISC processor?
(@) Intel P6 (b) AMD K6 (c) Pentium 111 (d) Pentium 1V
6. Which is the fastest memory?
(a) Hard disk (b) Main memory (c) Cache memory (d) Blue-Ray dist
7. How many memory locations are identified by a processor with 8 bits address busat a time?
(@) 28 (b) 1024 (c) 256 (d) 8000
8. What is the capacity of 12cm diameter DVD with single sided and single layer?
(@) 4.7 GB (b) 5.5 GB (c) 7.8GB (d)2.2GB
9. What is the smallest size of data represented in a CD?
(a) Blocks (b) Sectors (c) Pits (d) Tracks
10. Display devices are connected to the computer through.
(a) USB port (b) Ps/2 port (c) SCSI port (d) VGA connector
SECTION-B
Short Answers

1. What are the parameters which influence the characteristics of a microprocessor?

A Microprocessor’s performance depends on the following characteristics:

* Clock speed * Instruction set * Word size

2. What is an instruction?

A command which is given to a computer to perform an operation on data is called an instruction.
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3. What is a program counter?

The Program Counter (PC) is a special register in the CPU which always keeps the address of the
next instruction to be executed.
4. What is HDMI?
High-Definition Multimedialnterface is an audio/video interfacewhich transfers the uncompressed
videoand audio data from a video controller,to a compatible computer monitor, LCDprojector, digital
television etc.
5. Which source is used to erase the content of a EPROM?
Ultraviolet rays is used to erase the content of a EPROM.

SECTION-C
Explain in Brief

1. Differentiate Computer Organization from Computer Architecture.

Computer organization Computer Architecture

Computer organization deals with the hardware | Computer Architecture also deals with how
components of a computer system. It includes | they are interconnected to implement an
Input / Output devices, the Central Processing | architectural specification.

Unit, storage devices and primary memory.

Computer Organization deals with the | Computer architecture deals with the

hardware components that are transparentto the | engineering considerations involved in

programmer. designing a computer.

2. Classify the microprocessor based on the size of the data.

Depending on the data width, microprocessors can process instructions. The microprocessors can be
classified as follows:

* 8-bit microprocessor

*16-bit microprocessor

* 32-bit microprocessor

* 64-bit microprocessor

3. Write down the classifications of microprocessors based on the instruction set.

RISC stands for Reduced Instruction Set Computers. They have asmall set of highly optimized
instructions.Complex instructions are alsoimplemented using simple instructions,thus reducing the
size of the instruction set.

Example: RISC processors are Pentium 1V, Intel P6, AMD K6 and K7.
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CISC stands for Complex Instruction Set Computers. They supporthundreds of instructions.

Computerssupporting CISC can accomplish a widevariety of tasks, making them ideal forpersonal
computers.
Example: CISC processors are Intel 386& 486, Pentium, Pentium Il and 111, and Motorola 68000.

4. Differentiate PROM and EPROM.

PROM

EPROM

Programmable read only memory is also a non-

volatile memory

Erasable Programmable Read Only Memory is

a special type of memory

PROMs retain their contents even when the

computer is turned off.

EPROM retains its contents until it is exposed

to ultraviolet light.

PROM can be written only once and

cannot be erased.

Ultraviolet rays is used to erase the content of a
EPROM

5. Write down the interfaces and ports available in a computer.

Serial Port:To connect the external devices, found in old computers.

Parallel Port:To connect the printers, found in old computers.

USB Ports:To connect external devices like cameras, scanners, mobile phones, external hard disks

and printers to the computer.

VGA Connector:To connect a monitor or any display device like LCD projector.

Audio Plugs: To connect sound speakers,microphone and headphones.

PS/2 Port:To connect mouse and keyboard to PC.

SCSI Port: To connect the hard disk drives and network connectors.

6. Differentiate CD and DVD

CD

DVD

CD stands for Compact Disk

DVD stands for Digital Versatile Disc

CD data is represented as tiny indentations

known as "pits"

DVD-ROM can be visually determined by

noting the number of data sides of the disc

The capacity of an ordinary CD-ROM is
700MB.

The capacity of DVD is 4.7 GB

A CD is made from 1.2 millimeters thick,

polycarbonate plastic material.

A DVD is made from 12 cm diameter disc with

single sided,single layer has 4.7 GB capacity
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7. How will you differentiate a flash memory and an EEPROM?

Flash Memory EEPROM
Flash memory is an electronic (solid-state) non- | Electrically Erasable Programmable Read Only
volatile computer storage Memory is a special type of PROM
Flash memory offers fast access times. EEPROM is slower in performance.

It can be erased by exposing it to an electrical | It can be electrically erased and reprogrammed.

charge.

SECTION -D
Explain in detail
1. Explain the characteristics of a microprocessor.
A Microprocessor’s performance depends on the following characteristics:
* Clock speed * Instruction set * Word size
Clock speed
Every microprocessor has an internal clock that regulates the speed at which it executes instructions.
The speed at which the microprocessor executes instructions is called the clock speed. Clock speed is
measured in MHz (Mega Hertz) or in GHz (Giga Hertz).
Instruction Set
A command which is given to a computer to perform an operation on data is called an instruction.
Basic set of machine level instructions that a microprocessor is designed to execute is called as an
Instruction set. This instruction set carries out the following types of operations:
* Data transfer
* Arithmetic operations
* Logical operations
* Control flow
* Input/output
Word Size
» The number of bits that can be processed by a processor in a single instruction is called its word
size. Word sizedetermines the amount of RAM that canbe accessed by a microprocessor at one
time and the total number of pins on the microprocessor. Total number of input and output pins in

turn determines the architecture of the microprocessor.
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2. How the read and write operations are performed by a processor? Explain.
The read operation fetches data from memory and transfers to MDR. A single control line performs
two operations like Read/Write using 1or 0. Also, the write operation transfers data from the MDR to

memory.
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Figure 3.3 Bus connectivity between CPLU
ard Adermory

The word in the RAM has the same size (no. of bits) as the Memory DataRegister (MDR). If the
processor is an 8-bit processor like Intel 8085, its MDR and the word in the RAM both have 8 bits. If
the size of the MDR is eight bits, which can be connected with a word in the memory which is also
eight bits size.The data bus has eight parallel wires to transfer data either from MDR to word or word
to MDR based on the control(Read or write). This control line is labeled as R/W , which becomes 1

means READ operation and 0 means WRITE operation.
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Figure 3. 4 Before the read operation
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Figrre .5 After the read operation

The content of MDR and the word before the READ operation.Also, the content of MDR and the
word after the READ operation.The read operation transfers the data(bits) from word to memory data

register. The write operation transfers the data(bits) from memory data register to word.
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3. Arrange the memory devices in ascending order based on the access time.
Blu-Ray Disc

Blu-Ray Disc is a high-density optical disc similar to DVD. Blu-ray is the type of disc used for
PlayStation games and for playing High-Definition (HD) movies. A double-layer Blu-Ray disc can
store up to 50GB (gigabytes) of data.

This is more than 5 times the capacity of a DVD, and above 70 times of a CD. The format was
developed to enable recording, rewriting and playback of high-definition video, as well as storing
large amount of data.

Hard Disks

Hard disk is a magnetic disk on which you can store data. The hard disk has the stacked
arrangement of disks accessed by a pair of heads for each of the disks. The hard disks come with a
single or double sided disk.Hence, it is called as Blu-Ray.

Random-Access Memory (RAM)

The main memory is otherwise called as Random Access Memory. This is available in
computers in the form of Integrated Circuits (I1Cs). It is the place in a computer where the Operating
System,

Application Programs and the data in current use are kept temporarily so that they can be accessed by
the computer’s processor. The smallest unit of information that can be stored in the memory is called
as a bit. The memory can be accessed by a collection of 8 bits which is called as a byte.

Cache Memory

The cache memory is a very high speed and expensive memory, which is used to speed up the
memory retrieval process. Due to its higher cost, the CPU comes with a smaller size of cache
memory compared with the size of the main memory. Without cache memory, every time the CPU
requests the data, it has to be fetched from the main memory which will consume more time.

The idea of introducing a cache is that, this extremely fast memory would store data that is
frequently accessed and if possible, the data that is closer to it. This helps to achieve the fast response
time, Whereresponse Time, (Access Time) refers to how quickly the memory can respond to a read /

write request. The arrangement of cache memory between the CPU and the main memory.
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4. Explain the types of ROM.
Read Only Memory (ROM)

Read only memory refers to special memory in a computer with pre-recorded data at
manufacturing time which cannot be modified. The stored programs that start the computer and

perform diagnostics are available in ROMs.

Programmable Read Only Memory (PROM)

Programmable read only memory is also a non-volatile memory on which data can be written
only once. Once aprogram has been written onto a PROM, it remains there forever. Unlike the main
memory, PROM S retain their contents even when the computer is turned off.

The PROM differs from ROM. PROM is manufactured as a blank memory, whereas a ROM
is programmed during the manufacturing process itself. PROM programmer or a PROM burner is
used to write data to a PROM chip. The process of programming a PROM is called burning the
PROM.

Erasable Programmable ReadOnly Memory (EPROM)

Erasable Programmable Read Only Memory is a special type of memory which serves as a
PROM, but the content can be erased using ultraviolet rays. EPROM retains its contents until it is
exposed to ultraviolet light. The ultraviolet light clears its contents, making it possible to reprogram
the memory.

An EPROM differs from a PROM,PROM can be written only once and cannot be erased.
EPROMs are used widely in personal computers because they enable the manufacturer to change
the contents of the PROM to replace with updated versions or erase the contents before the computer
Is delivered.

Electrically Erasable Programmable Read Only Memory (EEPROM)

Electrically Erasable Programmable Read Only Memory is a special type of PROM that can be
erased by exposing it to an electrical charge. Like other types of PROM, EEPROM retains its
contents even when the power is turned off. Comparing with all other types of ROM, EEPROM is

slower in performance.
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COMPUTER APPLICATIONS
4. THEORETICAL CONCEPTS OF OPERATING SYSTEM

SECTION - A
Choose the correct answer:
1. Operating system is a
a) Application Software  b) Hardware c) System Software d) Component
2. ldentify the usage of Operating Systems
a) Easy interaction between the human and computer b) Controlling input & output Devices
¢) Managing use of main memory d) All the above
3. Which of the following is not a function of an Operating System?
a) Process Management b) Memory Management
c) Security management d) Complier Environment
4. Which of the following OS is a commercially licensed Operating system?
a) Windows b) UBUNTU c) FEDORA d) REDHAT
5. Which of the following Operating systems support Mobile Devices?
a)Windows 7 b)Linux c) BOSS d) iI0S
6. File Management manages
a) Files b) Folders c) Directory systems d) All the Above
7. Interactive Operating System provides
a) Graphics User Interface (GUI) b) Data Distribution
¢) Security Management d) Real Time Processing
8. Android is a
a) Mobile Operating system b) Open Source
c) Developed by Google d) All the above
9. Which of the following refers to Android operating system’s version?
a) JELLY BEAN b) UBUNTU c) 0S/2 d) MITTIKA
SECTION-B
Short Answers

1. What are the advantages of memory management in Operating System?
* Keeping track of which portion of memory are currently being used and who is using them.

* Determining which processes (or parts of processes) and data to move in and out of memory.
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* Allocation and de-allocation of memory blocks as needed by the program in main memory.

(Garbage Collection)

2. What is the multi-user Operating system?

Multi-user Operating system is used in computers and laptops that allow same data and applications
to be accessed by multiple users at the same time. The users can also communicate with each other.
Example: Windows, Linux and UNIX

3. What is a GUI?

The GUI is a window based system with a pointing device to direct 1/0, choose from menus, make
selections and a keyboard to enter text. Its vibrant colours attract the user very easily.

4. List out different distributions of Linux operating system.

There are a few different distributions of Linux, like Ubuntu, Mint, Fedora, RedHat, Debian, Google's
Android, Chrome OS, and Chromium OS which are popular among users.

5. What are the security management features available in Operating System ?

The Operating System provides three levels of securities to the user end. They are File access level,
System level, Network level

6. What is multi-processing?

Multi-processing is a one of the features of Operating System. It has two or more processors for a
single running process (job). Processing takes place in parallel is known as parallel processing. Each
processor works on different parts of the same task

7. What are the different Operating Systems used in computer?

Some of the popular Operating Systems used in personal computers and laptops are Windows, UNIX
and Linux.

The different Operating Systems used in computer are:

* Single User Operating Systems* Multi-user Operating Systems* Distributed Operating Systems
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SECTION-C

Explain in Brief

1. What are the advantages and disadvantages of Time-sharing features?

Advantages

Disadvantages

In time sharing systems all the tasks are given
specific time and task switching time is very

less so applications don’t get interrupted by it.

The big disadvantages of time sharing systems
is that it consumes much resources so it need

special operating systems.

Many applications can run at the same time.
You can also use time sharing in batch systems

if appropriate which increases performance.

Switching between tasks becomes sometimes
sophisticated as there are lot of users and
applications running which may hang up the

system

Provides the advantage of quick response,
Avoids duplication of software, Reduces CPU

idle time.

Problem of reliability, Question of security and
integrity of user programs and data, Problem of

data communication

2. Explain and List out examples of mobile operating system.

* A mobile operating system controls a mobile device and its design supports wireless and

communication and different types of mobile applications.

* It operates such as phones, tablets and MP3 players are different from desktop and laptop

computers and hence they need special Operating Systems

Android : Android is a mobile operating system developed by Google, based on Linux and designed

primarily for touch screen mobile devices such as smart phones and tablets.

10S - iPhone OS : It is the Operating System that presently powers many of the company's mobile

devices, including the iPhone, iPad and iPod Touch.
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3. What are the differences between Windows and Linux Operating system?

Windows Linux

Windows is a licensed operating system in | Linux is a free and open source operating

which source code is inaccessible. system based on Unix standards.
Windows Series - for desktop and laptop Linux - Open source Operating System for
computers. desktop and server.

Microsoft Windows is one of the most popular | Linux is one of the popular Open
Graphical User Interface (GUI). Source versions of the UNIX Operating
System.

Windows must boot from the primary partition. | Linux it can be booted from either primary or

logical partition.

4. Explain the process management algorithms in Operating System.

* Process management is function that includes creating and deleting processes and providing
mechanisms for processes to communicate and synchronize with each other.

* The following algorithms are mainly used to allocate the job (process) to the processor, SJF, Round
Robin, Based on Priority

FIFO (First In First Out) : This algorithm is based on queuing technique.

SJF (Shortest Job First) : This algorithm works based on the size of the job being executed by the
CPU.

Round Robin : The Round Robin (RR) scheduling algorithm is designed especially for time sharing
systems.

Based On Priority: The given job (process) is assigned based on a Priority.
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SECTION-D
Explain in detail
1. Explain the concept of a Distributed Operating System.
* This feature takes care of the data and application that are stored and processed on multiple physical
locations across the world over the digital network (internet/intranet).
* The Distributed Operating System is used to access shared data and files that reside in any machine
around the world. The user can handle the data from different locations. The users can access as if it

is available on their own computer.

=8
T
5

Figure: 4.4 Distributed Operating Systems

The advantages of distributed Operating System are as follows:

* A user at one location can make use of all the resources available at another location over the
network.

* Many computer resources can be added easily in the network

* Improves the interaction with the customers and clients.

* Reduces the load on the host computer.

2. Explain the main purpose of an operating system.

* Operating System has become essential to enable the users to design applications without the
knowledge of the computer’s internal structure of hardware. Operating System manages all the

Software and Hardware. Operating System manages all the Software and Hardware.

Application

Software

Operating
“

Figure: 4.2 Interaction of Operating system
ard user
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* Most of the time there are many different computer programmes running at the same time, they all
need to access the Computers, CPU, Memory and Storage.
* The need of Operating System is basically - it is the interface between the user and hardware.
Operating System converts processed information into user readable form

*To ensure that a computer can be used do to exact if what the user wants it do.

* Easy interaction between the users and computers.

* Starting computer operation automatically when power is turned on (Booting).

* Controlling Input and Output Devices

* Manage the utilization of main memory.

* Providing security to user programs.

3. Explain advantages and disadvantages of open source operating systems.
Advantages:
* Open-source software is free to use, distribute, and modify. It has lower costs, and in most cases
this is only a fraction of the cost of their proprietary counterparts.
* Open-source software is more secured as the code is accessible to everyone. Anyone can fix bugs as
they are found, and users do not have to wait for the next release.

* Lower costs?

* No vendor lock-in

* Increased potential of adaptation and innovation

« Highly interactive if you wish to network with greater community

* Reduction in time and effort if you just want to be a consumer

* Quality of software

« Security

» Easier to locate and fix “bugs”

» Creativity
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Disadvantages
* The main disadvantage of open-source software is not being straightforward to use. Open-source
operating systems like Linux cannot be learned in a day.
* There is a shortage of applications that run both on open source and proprietary software; therefore,
switching to an open-source platform involves a compatibility analysis of all the other software used
that run on proprietary platforms.

* Not as user friendly as commercial software

» Adequate support from IT department?

» 0SS is a work-in-progress

» Lack of technical ability

» Fear of the unknown

+ Institutional and organizational procurement process affecting the decision making process

J. BASKARAN M.Sc., B.Ed. (C.S) J. ILAKKIA M.Sc., M.Phil., B.Ed. (C.S)
jbaskaran89@gmail.com jilakkia@gmail.com

http://www trbtnpsc.com/2018/06/latest-plus-one-1ith-study-materials-tamil-medium-english-medium-new-syllabus-based html


mailto:jbaskaran89@gmail.com
mailto:jilakkia@gmail.com

www.Padasalai Net www. TrbTnpscom
J. BASKARAN M.Sc., B.Ed. (C.S) J. ILAKKIA M.Sc., M.Phil., B.Ed. (C.S)
jbaskaran89@gmail.com jilakkia@gmail.com

COMPUTER APPLICATIONS

5. WORKING WITH TYPICAL OPERATING SYSTEM
PART - | WORKING WITH WINDOWS
PART - 1l WORKING WITH LINUX
SECTION - A
Choose the correct answer:

1. From the options given below, choose the operations managed by the operating system.

a. Memory b. Processes c. Disks and 1/0 devices d. All of the above
2. Which is the default folder for many Windows Applications to save your file?

a. My Document  b. My Pictures c. Documents and Settings d. My Computer
3. Under which of the following OS, the option Shift + Delete — permanently deletes a file or
folder?

a. Windows 7 b. Windows 8 c.Windows10 d. All of the OS
4. What is the meaning of "Hibernate" in Windows XP/Windows 7?

a. Restart the Computer in safe mode

b. Restart the Computer in hibernate mode

¢. Shutdown the Computer terminating all the running applications

d. Shutdown the Computer without closing the running applications
5. Which of the following OS is not based on Linux?

a. Ubuntu b. Redhat c. CentOS d. BSD
6. Which of the following in Ubuntu OS is used to view the options for the devices installed?
a. Settings b. Files c. Dash d. VBox_GAs 5.2.2

7. Identify the default email client in Ubuntu.
a. Thunderbird b. Firefox c. Internet Explorer d. Chrome

8. Which is the default application for spreadsheets in Ubuntu? This is available in the software

launcher.
a. LibreOffice Writer b. LibreOffice Calc
c. LibreOffice Impress d. LibreOffice Spreadsheet

9. Which is the default browser for Ubuntu?

a. Firefox b. Internet Explorer c. Chrome d. Thunderbird
10. Where will you select the option to log out, suspend, restart, or shut down from the desktop of
Ubuntu OS?

a. Session Indicator b. Launcher c. Files d. Search
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SECTION-B
Short Answers
1. Differentiate cut and copy options.
Cut Copy

An option that allows the user to move the

content from one document to another.

An option that allows the user to make a

duplicate of the original content.

The shortcut keys used for moving a text is
Ctrl + X

The shortcut keys used for copying a text is
Ctrl +C

2. What is the use of a file extension?

A file extension or file name extension helps to identify the type of file. The extension indicates a

characteristic of the file contents or its intended use.

Examples: .txt, .doc / .docx, .odt, .ods, .odp

3. Differentiate Files and Folders.

Files

Folders

A file consists of a collection of data.

A folder stores files and folders. It is also called

a directory.

Each file has its own extension.

A folder does not have any extension

Folder and sub folder cannot be created in a file

Folder and sub folder can be created in a folder

4. Differentiate Save and Save As option.

Save

Save As

Save” command is use to save a document by

only one name

“Save As” command we can save a file by two

or more than two names.

The shortcut keys used for save a text is
Ctrl + S

The shortcut key used for Save As in MS-Word
is F12

The shortcut keys used for Save As in Open
Office is Ctrl+Shift+S

5. What is Open Source?

Open Source refers to a program or software in which the source code is available in the web to the

general public free of cost.
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6. What are the advantages of open source?

* Open source is available in the web to the general public free of cost.

* Open-source software is more secured as the code is accessible to everyone.

* Open source code can continuously improve by the programmers in the web.

7. Mention the different server distributions in Linux OS.

The most popular Linux server distributors are:

* Ubuntu Linux

* Linux Mint

* Arch Linux

* Deepin

* Fedora

* Debian

* CentOS

8. How will you log off from Ubuntu OS?

After finishing your work, you can choose Log Out, Suspend or Shut down through the Session

Indicator on the far right side of the top panel to log off your computer.
SECTION-C

Explain in Brief

1. Analyze: Why the drives are segregated?

* Drives are segregated to organize the space on a hard drive.

* It is also used to isolate the operating system or programs from other user.

*You Can Use Multiple Operating Systems On The Same PC in different drives.

* Hard disk drives usually work better on smaller chunks of data rather than one big partition.

2. If you are working on multiple files at a time, sometimes the system may hang. What is the
reason behind it. How can you reduce it?

*Each application open on the system takes some internal and hardware resources to keep it
running.

*If you are running multiple programs at one time then, much more storage will be in use to run
them properly.

* So your PC may run low or hang.

*To avoid this, it is advisable to run one program at a time or upgrade your Pc’s Configuration to

run multiple applications at the same time.
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3. Are drives such as hard drive and floppy drives represented with drive letters? If so why, if
not why?
*Yes hard drives and floppy drives can be identified by drive letters such as "C:", "D:", "E:" etc.
*A drive letter is a single alphabetic character A through Z that has been assigned to a physical
computer drive.
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*In the above example,

Drive A: is the floppy drive,

C: is the primary hard drive,

D: and E: are partitions of the hard drive, and

Typically, the CD-ROM drive is the last drive letter, so in most situations the hard drive is the
C: drive..

4. Write the specific use of Cortana.

* Cortana is a voice-controlled virtual assistant for Microsoft Windows.

* Cortana is used to get weather forecasts, set reminders, Entertainment, send email,
Maps/Navigation, Random tips and tricks, find files, search the Internet and so on.

5. List out the major differences between Windows and Ubuntu OS.

Windows Ubuntu

Windows is a closed-source operating system Ubuntu is an open-source Linux-based

operating system

Majority of Windows OS is developed by | Ubuntu is developed by Canonical Limited.

Microsoft

Windows supports the office suite called MS | Ubuntu supports the office suite called
Office. LibreOffice.

Default web browser for Windows OS is | Default web browser for Ubuntu OS is Firefox.

Internet Explorer.
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6. Are there any difficulties you face while using Ubuntu? If so, mention it with reasons.

Yes, many difficulties are these while using Ubuntu operating system

* It becomes difficult to configure modem to start work on internet.

* 1t is not possible to play the modern games in Ubuntu OS. It shows the poor graphics quality

* Though Linux (Ubuntu) has number of free applications and software available on net, but most

of the applications are not found for Linux use.

* Ubuntu is not capable of playing MP3 files by default.

* The drivers support is also absent in most of the cases as compared other operating system.

* Different desktop managers lead to a fragmented experience.

7. Differentiate Thunderbird and Firefox in Ubuntu OS.

Thunderbird

Firefox

Ubuntu has in-built email software

called Thunderbird

Firefox is a Web Browser, you can directly

browse the internet

It gives the user access to email such as

Exchange, Gmail, Hotmail, etc.

Firefox is great for new users to the Web as

well as long time Web surfers.

8. Differentiate Save, Save As and Save a Copy in Ubuntu OS.

Save

Save As

Save a Copy

In Ubuntu, the “Save” option

will save the document

without requesting for a new

location or name.

In Ubuntu, the “Save ASs”
option, it will prompt the task
of saving with the help of a

dialog box.

In Ubuntu, the “Save A Copy”
you will be prompted to save a
copy using the same dialog

box as “Save As”.

It will definitely over-write the

original one.

You can easily change the
name of file as well as

location.

You may change the file name

as well as location.
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SECTION-D

1. Explain the versions of Windows Operating System.
Versions Year Specific fealures
Windows « Introduction of GULin 16 - bit. processor
L
| x 1985 |« Mouse was introduced as an input
' device.
« Supports to minimize or maximize
windows.
Windows
X 1987 |« Control panel feature was introduced
X
with various system settings and
customising  options.
« Introduced the concept of multitasking.
Windows 1993 | supported 256 colours which brought
3x M a more modern, colourful look to the
HCROSOF L . e
VINDOWS interface.
= Introduced 5Start button, the taskbar,
Windows 1065 Windows Explorer and Start menu.
95 « Introduced 32 - bit processor and
WIN < focused more on  multitasking.
« Integration of the Web browser (Internet
Wind Explorer) with the Operating System.
indows
o8 1998 |« DOS gaming began to disappear as
Windows based games improved.
WINDOWS « Plug and play feature was introduced.
Windows _ _
NT « Designed to act as servers in network.

WINDOWS
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Windows
Me

M

..
towe

2000

automated
recovery

« It introduced
diagnostics  and

system
tools.

Windows
2000

2000

« Served as an Operating System for
business desktop and laptop systems.
« Four versions of Windows 2000 were
released: Professional (for business
desktop and laptop systems), Server
(both a Web server and an office server),
Advanced Server (for line-of-business
applications) and Data Centre Server
(for high-trafic computer networks).

Windows
XP

2001

« Introduced 64-bit Processor.
« Improved Windows appearance with
themes and offered a stable version.

Windows
Vista

2006

« Updated the look and feel of Windows.

Windows 7

2009

« Booting time was improved, introduced
new user interfaces like Aero Peek,
pinning programs to taskbar,
handwriting recognition and
Internet Explorer 8.

etc.

Windows 8

2012

« Windows 8 was faster than previous
versions of Windows.

« Start button was removed.

« Windows 8 takes better advantage of
multi-core processing, solid state drives
(SSD), touch screens and other alternate
input methods.

« Served as common platform for mobile
and computer.

Windows
10

2015

« Start Button was added again.

« Multiple desktop.

« Central Notification Center for App
notification and quick actions.

« Cortana voice activated personal assistant.
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2. Draw and compare the icon equivalence in Windows and Ubuntu.

Icon Windows Icon Ubuntu

m/ My Computer Files

{}. Recycle Bin Trash

S

/‘Q Internet Explorer Fire Fox
o= . : :
'_”_’_-3 MS-Word LibreOffice Writer
L *

Xﬂl MS-Excel LibreOffice Calc

MS-PowerPoint LibreOffice Impress

Search Programs and Files Search your computer

“ofF

Windows

s Windows

Ubuntu

>
=
-
==
ra
a
o
=
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3. Complete the following matrix

Navigational Me Located on Ideally suited for

The Start menu can be used
to quickly start the installed
programs as well as other
Windows features

Start button Task bar

Exploring your disk drives and
My Computer Desktop usiflg sysgt’e)r/n tools

_ Seeing  hierarchy of all

resources in one window.

Enables a user the ability to
Quick Launch Task Bar launch  their  programs
quickly

4. Observe the figure and mark all the window elements. Identify the version of the Windows
OS.

The version of OS is Windows 7
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Title Bar
Corners Borders Corners
-~ — .
T - g - - T
T Menu bar N T

O I S T )
B-B-ve  LOCPE - B G B e
195.'.." D!----.'—- :]u E}Itu.ln-gtt:

N e ) 'f ‘3 ’ w-nw.p -4 -

5
L -z
R Scroll Bar 5
n Workspace : '
- g !

l fu - & S —— N l
gty G - e 11
) .

Corners Borders Corners

Figure 5.10 The elements of a window.

Title Bar - The title bar will display the name of the application and the name of the document
opened.

Menu Bar -The menu bar is seen under the title bar.

The Workspace -The workspace is the area in the document window to enter or type the text of
your document.

Scroll bars - The scroll bars are used to scroll the workspace horizontally or vertically.

Corners and borders -The corners and borders of the window helps to drag and resize the

windows.
J. BASKARAN M.Sc., B.Ed. (C.S) J. ILAKKIA M.Sc., M.Phil., B.Ed. (C.S)
jbaskaran89@gmail.com jilakkia@gmail.com
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5. Write the procedure to create, rename, delete and save a file in Ubuntu OS. Compare it
with Windows OS.

Procedure in Ubuntu OS

Create a file -A new File or new Folder can be created by using File—>New menu or right click the
mouse button and then select the type of file to create.

Rename a file - Select the file or folder to be renamed, right-click, and select Rename from the
context menu. Type the new name for the file / folder, and press Enter. The file or directory is
renamed. Or rename with the “mv command”

Delete a file - A file / folder created by you can be moved to trash by using right click or by using
menu. Or use rmdir. Example: rmdir('myfiles’)

Save a file - To save the file and exit at the same time, you can use the ESC and :X key and hit

[Enter]. Optionally, press [Esc] and type Shift + Z to save and exit the file.

Procedure in Windows OS

Create a file — To create a text file on a computer you need a text editor such as wordpad. Choose
File->New or Ctrl+N.

Rename a file — Select the file/ folder need to renamed and do any one of the following,

* Click File->Rename menu, or

* Right click the file or folder and choose rename option, or

* Press F2 then Type the new name and press enter.

Delete a file - Click File=>Delete or press Delete key then the deleted file or folder will move into
the Recycle Bin

Save a file - Save the content of the file using File ->Save or Ctrl + S.

J. BASKARAN M.Sc., B.Ed. (C.S) J. ILAKKIA M.Sc., M.Phil., B.Ed. (C.S)
jbaskaran89@gmail.com jilakkia@gmail.com
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COMPUTER APPLICATIONS
6. INTRODUCTION TO WORD PROCESSOR
SECTION-A

Choose the correct answer
1. Which is the opening screen of OpenOffice?
a. Star desktop b. Star center c. Star screen d. Star window

2. Which option allows you to assign text, tables, graphics and other items to a key or key

combination

a. Auto format b. Automatic c. Auto text d. Auto graphics
3. Which menu contains the Numbering option.

a. File b. Edit c. Tools d. Format
4. Which is displayed at the top most part of the window?

a. Menu bar b. Tool bar c. Title bar d. Format bar
5. Which is changing the default appearance of the text called?

a. Text formatting b. Page formatting

c. Special formatting d. Paragraph formatting
6. The Find & Replace option is available in which menu?

a. File b. Edit c. Format d. Tools
7. Which button selects all instances of the search text in the document?

a. Find b. Find All c. Replace d. Replace All
8. What is the shortcut key to go to the start of the document?

a. Ctrl + Home b. Ctrl + End c. Home d. End
9. What is the shortcut key for finding and replacing text in a document?

a. Ctrl + F1 b. Ctrl + F c. Ctrl + F5 d. Ctrl +F7
10. What is the short cut key for Undo?

a. Ctrl +E b. Ctrl + U c.Ctrl+Z d. Ctrl +n

SECTION-B

Short Answers

1. How do you insert pictures in to your document?

Open office Writer has the ability to insert and edit images in a more simple way.
Place the insertion pointer where you want the image to appear

* Select Insert - Picture = From file
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*The insert picture dialog box appears where the picture gallery opens from which the desired

picture can be selected.

* If the picture is not in the gallery, then browse the pictures from the folder, choose the desired one
and Click on the Open button

* The selected picture is inserted into the document

2. What are the different packages in OpenOffice?

OpenOffice is a productive office suite with a collection of different software packages such as

OpenOffice Writer - Word Processor to create text documents
OpenOffice Calc - Spreadsheet to createworksheets
OpenOffice Base - Database

OpenOffice Impress - Presentation software

OpenOffice Draw - Drawing Software

OpenOffice Formula - Create formula and equations

3. What is auto text in writer?

AutoText allows you to assign text, tables, graphics and other items to a key or key combination.
For example, rather than typing "TamilNadu™ every time you use that phrase, you might just type
"tn" and press F3.

4. How do you merge cells in a table?

To merge a group of cells:

* Select the cells to merge.

* Right click and choose Cell > Merge or

*Choose Table ->Merge Cells from the menu bar.

5. State the difference between proprietary software and open source software?

Proprietary software Open source software
Package Developer Package Developer
Microsoft Word Microsoft Corporation | OpenOffice Writer Apache
) ) ) ) The document
WPS Word Kingsoft LibreOffice Writer )
foundation
WordPro Lotus Corporation Abiword Abisource
J. BASKARAN M.Sc., B.Ed. (C.S) J. ILAKKIA M.Sc., M.Phil., B.Ed. (C.S)
jbaskaran89@gmail.com jilakkia@gmail.com
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SECTION-C
Explain in Brief

1. What is the difference between moving and copying text?

Moving text Copying text
To move a text from one location to another To copy a text from one location to another
Select the text to be moved select the text to be copied
Click Ctrl + X or Cut Icon X or Edit >Cut Click Ctrl + C or Copy Icon or Edit >Copy

The text is removed from the source location and | A duplicate copy of the text is made and

placed in the clipboard send to the clipboard

Take the insertion pointer to the new location to | Take the insertion pointer to the new

be moved location to be copied

2. What are the different types of orientation?

There are two different orientations:

Landscape — The width of the document is more than the height. This is best suited for displaying
professional photos, invitations, albums, tables etc.

Portrait — This is the most common and default orientation . Here, the height of the document is
more than the width. Normally books, newspapers will be displayed in this format.

3. How do you insert rows and columns?

* Place the insertion pointer in the row or in the column where you would like to add new rows or
columns and rightclick.

* Choose Row —>Insert — to insert a row or Column = Insert — to insert a column.

A dialog box will appear, from which you can select the number of rows or columns to insert. You
can also set the position of the new rows or columns to Before or After

4. What are the different ways to save a document?

* You can save by clicking File> Save on top left corner and then click File>Save As or

Ctrl+Shift+S . After that browse the location where exactly you want to save in your computer.
* You can also save by just pressing Ctrl + S and then browse the location where you want to save.

* All documents in OpenOffice writer will be stored with .odt extension. You can store your

OpenOffice document as Microsoft Word document or pdf.

http://www trbtnpsc.com/2018/06/latest-plus-one-1ith-study-materials-tamil-medium-english-medium-new-syllabus-based html




www Padasalai.Net www. TrbTnpscom
5. Write the steps to change the line spacing of text.

Rightclick—> line spacing, select the type single, 1.5 or double.
Select the entire document by Edit - Select All
* Format - paragraph
* The paragraph dialog box appears, click Indents & Spacing tab
* In the line spacing option, select the type and click OK button.
SECTION-D
Explain in detail
1. What are the different methods to change margin in writer?
Page margins are the white space around the top, bottom, left, and right of your document.
Changing or setting page margins in Openoffice writer can be done in two ways:
* Using the Rulers - quick and easy, but does not have precise values.
* Using the Page Style dialog box — can specify precise values for the margins.
Changing page margins - using Ruler
* The shaded sections of the rulers are the margins.
* Hold the mouse pointer over the line between the gray and white sections.
* The mouse pointer turns into a double headed arrow.
* Hold down the left mouse button and drag the mouse to move the margin and release it at the
required point.
* The new margin is set.
Using the Page Style dialog box
To change margins using the Page Style dialog box
* Right-click anywhere on the page and select Page from the popup menu and select page tab of
page style dialog box.
* In the Margins boxes, specify the values for left , right , top and bottom margins.
* Click on ok button.
2. What are Header and Footer? How do you insert page numbers?
The header is a section of the document that appears in the top margin, which displays the title or
chapter name , author name of a document.
* Select from the main menu Insert - Header - Default
* The header text area is separated from the normal text area.
* In the header area, Enter the text that is to be repeated in all pages or Select Insert >
Fields > Title.
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The footer is a section of the document that appears in the bottom margin of the page which
displays the page number, date, time etc. which gets displayed on all the pages automatically.

* Select from the main menu Insert - Footer - Default

* Place the insertion pointer in the footer part of the page.

* Select Insert > Fields—>Date to insert date in all the pages.

Inserting and Formatting page numbers

The page numbers can be inserted by performing the following steps:

* Position the insertion pointer where you want to insert the page number

*choose Insert > Fields > Page Number

* The page number appears with a gray background

Normally, the page numbers appear as 1,2,3....., To change the numbering style, the

following sequence of steps can be performed:

* Position the cursor where the page number has to appear

* Select Format - page, which will bring the page style dialog box as on Figure 6.29.

* Select page Tab

* In the Layout settings, select the format drop down combo box

* Select the desired style and click OK button.

3. Write the steps to Find and Replace a word with another word in OpenOffice writer?
OpenOffice Writer has a Find and Replace feature that helps to locate for a text inside a document
and replace it with another word.

* Click Edit = Find & Replace (or) Ctrl + F

Steps to find & replace a text

* Type the text you want to find in the Search for box

For Example : To search a word "Bombay" in a document and replace with "Mumbai", enter the
word "Bombay" in the Search for box.

* To replace the text with different text, type the new text in the Replace with box

Enter the word " Mumbai" in the Replace with box and Click Find button , to start the search , the
found word is highlighted and the first occurrence of "Bombay" is highlighted.

* To replace text, click Replace button.

The highlighted word is replaced with the word given in the Replace with box.

* Click Find All, Writer selects all instances of the search text in the document .

http://www trbtnpsc.com/2018/06/latest-plus-one-1ith-study-materials-tamil-medium-english-medium-new-syllabus-based html



www.Padasalai Net www. TrbTnpscom

All occurrences of Bombay are highlighted.

* Click Replace All button, Writer replaces all matches.

This will replace all occurrences of

"Bombay" with "Mumbai".

* Enable Match case to perform the search case sensitively so that uppercase and lower cases are
distinguished separately.

* Enable Whole Words only to make the search more specific to words used separately alone.

rl-_lm:l & Replace w
Search for | — |
Bombay El -
| Fined 4l |

Feplace with |

| hMumbai |E|

Reglace |

| Replace All |

[T Match case
Whole words only

rrar—— | Help | | ke |

Figure 6.30 Find 8t Replace dialog box
4. Explain Page formatting in writer.
Page formatting
The most important thing in a word processor is how to format the page with elements such as
margins, numbering, page layout, headers and footers. Formatting your pages makes them look
more attractive and makes them easier to read.
Changing page size
The default page size in writer is 8.5 x 117, the same as that of a standard A4 printing paper.
However, for different types of documents, you may need to change the page size. To change the
paper size:
* Select the page whose page size is to be changed
* Select Format - Page, the page style dialog box
* Select Page Tab
* In the paper format group, select the format like A4, legal ....

* Or the width and height option can be used to set the page size.
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Page Style: Default w
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Figure 6.26 Page style dialog box

Changing Page margins

*Page margins are the white space around the top, bottom, left, and right of your document.
*Margins let Writer know where to start placing the text at the top of a document, when to move on
to the next page at the bottom, where to start typing text on the left side, and where to stop and
move to the next line on the right.

Changing or setting page margins in Openoffice writer can be done in two ways:

* Using the Rulers - quick and easy, but does not have precise values.

* Using the Page Style dialog box — can specify precise values for the margins.

Orientation

Page orientation refers to how the document will be displayed on screen and printed. There are two
different orientations:

Landscape - The width of the document is more than the height. This is best suited for displaying
professional photos, invitations, albums, tables etc.

Portrait — This is the most common and default orientation. Here, the height of the document is

more than the width. Normally books, newspapers will be displayed in this format.
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Page colour

Changing the page color is not quite common. To do so, in the Page style dialog box, select
Background tab, In As option click on color and select the “color” from the color palette or select
“graphic” to apply an image as a page background.

[ Page Styte: Detault [—>)

Background |Header | Footer | Borders |Columns |Foctnote

A =]

Background color

{

Mo Fill

0
0
O
g
]

|y

mim(n] | [ [ [ s
UOENNRRERCOE
ECCNNENERECE
B ENRRREEECE
s BOENNRNNEREEN
" BONNNENEEEEDN
BOOENRREECOON
ROCERRREECCEN
BOCENRREECCEN
OUCENREECCCCm

4

2
)
-

OK ][ Cancel ][ Help ][ Reset ]

—_—

Pigure 6.27 Background color
Borders

Borders can be applied to an entire document, an entire page, paragraph, or just to certain sections
of the document. From the page style dialog box, select the Border tab, the user defined area helps

to define the area of borders, the line style of borders, color of borders can be selected.

" Page Seyte: Defoutt
[Organizer [Page [Backsround [Hesder [Footer |Borders Columns [Feotnote |
Line Qe 3 Line Spacing to contents
S ERERY. S Left (000 om 53
15851 [ e ] [ 5] Righs 000 em I3
Uses-defived e e
Iop (G0 o (S
Bottom (000 em iz
{¥] Synchronige
Shadow style
Postion Dastange Color
@gt@l@!igl IO.;S cm = [- Gray & ~1
[ ox ][ cances ][ stetp ][ Beser |
Figure 6.28 Page style dialog box - Borders
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COMPUTER APPLICATIONS
7. WORKING WITH OPEN OFFICE CALC
SECTION-A

Choose the correct answer
1. Which is the first electronic spreadsheet?

(A)Excel (B) Lotus 1-2-3 (C) Visicalc (D) OpenOffice Calc
2. Which of the following applications was the parent to OpenOffice Calc?
(A)Visicalc (B) LibreCalc (C) Lotus 123 (D) StarOffice Calc
3. Grid of cells with a programmable calculator:
(A)Spreadsheet  (B) Database (C) Word processor (D) Linux
4. A column heading in Calc is represented using
(A)Number (B) Symbol (C) Date (D) Alphabet
5. Which key is used to move the cell pointer in the forward direction within the worksheet?
(A)Enter (B) Tab (C) Shift + Tab (D) Delete
6. A formula in calc may begin with
(A) = (B) + (C) - (D) All the above
7. What will be the result from the following formula (Assume Al=5, B2=2)? + A1"B2
(A) 7 (B) 25 (C) 10 (D) 52

8. What will be the result from the following expression (Assume H1=12, H2=12)? =
H1<>H2

(A) True (B) False (C) 24 (D) 1212
9. Which of the following symbol is used to make a cell address as an absolute reference?
(A) + (B) % ©C) & (D) $
10. Which of the following key combinations is used to increase the width of the current column?
(A)Alt + Right arrow (B) Ctrl + Right arrow
(C)AIt + Left arrow (D) Ctrl + Left arrow
SECTION-B
Short Answers

1. What are the types of toolbars available in OpenOffice calc?
There are three toolbars available by default. They are:

* Standard Toolbar * Formatting Toolbar * Formula bar
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2. What is a Cell pointer?

Cell pointer is a rectangle box which can be moved around the worksheet. The cell in which the cell
pointer is currently located is known as “Active cell”. When you type any content, it will appear in
the active cell.

3. Write about the text operator in OpenOffice Calc.

In Calc, “&” is a text operator which is used to combine two or more text. Joining two different
texts is also known as “Text Concatenation” An expression using the text operator has the following
syntax: text referencel & text reference2

4. Write the general syntax of constructing a formula in Calc.

General Syntax of constructing a formula is:

= cell referencel <operator> cell reference2 <operator> ...................

5. What are the keyboard shortcuts to cut, copy and paste?

Ctrl + X is used to cut the cell

Ctrl + C is used to copy the cell

Ctrl + V is used to paste the cell

6. Can you edit the contents of a cell? If yes, explain any one of the method of editing the cell
content.

Yes, we can edit the contents of a cell.

* Using keyboard, after selecting the cell, Press the F2 key and the cursor is placed at the end of the
cell. The use the keyboard arrow keys to move the cursor through the text in the cell.

7. What are the options available in “Insert Cells” dialog box?

There are four options available in Insert cells

* Shift cells down

* Shift cells right

* Entire row

* Entire Column

8. Match the following

SI.No A B
1 Cut, Copy, Paste Standard Toolbar
2 Cell Pointer Active Cell
3 Selection Mode Status Bar
4 $A3$5 Absolute Cell
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9. Define the following (i) Text Operator (ii) Rows and Columns of spreadsheet

Text Operator

In Calc, “&” 1s a text operator which is used to combine two or more text. Joining two different
texts is also known as “Text Concatenation” An expression using the text operator has the following
syntax: text referencel & text reference2

Rows and Columns of spreadsheet

*A row is a horizontal group of values within a table. It contains values for multiple fields, which
are defined by columns. The rows are numbered from 1, 2, 3.... OpenOffice Calc version 4.1.5
contains 10,48,576 rows.

*A column is a vertical group of values within a table. It contains values from a single field in
multiple rows. Each column is labelled as A, B, C, D ..... AA, AB, AC ....It contains 1024
columns.

10. Differentiate between Copy -Paste and Cut-Paste
Copy -Paste Cut-Paste

Select the cell or group of cells you want to copy, | Select the cell or group of cells you want to
then using Select Edit-> Copy or Click “Copy” cut, then using Edit - Cut or Click “Cut” icon

icon from the standard toolbar or Press Ctrl + C from the standard toolbar or Press Ctrl + X

Copy leaves the cell information in its original ) o ) )
) _ _ But in Moving it removes the information and
location and makes copy of the cell information . _
) pastes it in another location
when pasted it

Move the cell pointer to the cell in which you Move the cell pointer to the cell in which you
want to paste.Edit > Paste or Click “Paste” icon | want to paste. Edit - Paste or Click “Paste”

or Press Ctrl + V icon or Press Ctrl + VV

SECTION-C
Explain in Brief
1. Write a short note on OpenOffice Calc.
* OpenOffice Calc is a popular open source spreadsheet application maintained by Apache
Foundation.
* StarOffice calc was the parent application of OpenOffice Calc which was developed by a German
Company namely, Star Division in 1985.
* Calc is the spreadsheet component of OpenOffice. You can enter any kind of data in a spreadsheet

and then manipulate this data to produce certain results.
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2. Write about inserting columns and rows in Calc.

Inserting Rows - In Calc, we can insert a new row anywhere in the worksheet.

Step 1: Select the row where a new row to be inserted.

Step 2: Right-click on the row number, a pop-up menu appears

Step 3: click “Insert Rows” option from the menu.

Now, a new row will be inserted to above the current row. Insert >Rows command is used to insert
a new row.

Inserting a Column - In Calc, we can insert a new column anywhere in the worksheet.
Step 1: Select the column where a new column should be inserted.

Step 2: Right-click on the selected column name that you selected. A pop-up menu appears.
Step 3: click the “Insert Columns” option from the menu.

Now, a new column will be inserted to the left of the current column.

A new column can also be inserted using Insert - Columns command.

3. Differentiate Deleting data using Backspace and Delete

Backspace Delete

Backspace key is used to delete the character | Delete key is used to delete the character

left of the insertion pointer of the cell right of the insertion pointer of the cell

4. Write any three formatting options.

Formatting Option Keyboard Shortcut Description
Bold Ctrl + B Used to make the data as
Bold
Italic
Ctrl + | Used to Italicize data
Underline Ctrl + U )
Used to Underline the data

J. BASKARAN M.Sc., B.Ed. (C.S) J. ILAKKIA M.Sc., M.Phil., B.Ed. (C.S)
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5. In cell A1=34 A2=65 A3=89 write the formula to find the average.
To find the average, using anyone of the following way:
i) = AVERAGE (A1:A3) =62.7%

SECTION-D

1. Explain about changing the column width in Calc.
Resize the width of a column using the mouse

Use the right hand border to increase or decrease the width of a column.

« Position the cursor on the right hand border of the column letter box, until you see a double

headed arrow.

« Hold down the left hand mouse button and drag the border to the left or right to make the

column narrower or wider as required.

As you carry out this action, the width of the column displays.

I I
Al wvwidth: 1.16 ™ Jfe

N

Using the mouse to widen a column

Resize one or more columns using Format
* Select the column(s) whose width you wish to change
* Select Format = Column - Width...

* The Column Width dialog displays

Width o.so" =] | OK |
[l Default valus | Cancel |
Ce I Help |
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* Enter a value in the Width window or check the Default value check box to select the default

column width.

* Click OK.

The selected columns display with the new width.

2. Write the steps to generate the following series. 5, 10, 20 ..... 2560

STEPS TO GENERATE THE SERIES 5,10,20,...2560

1. Select the required number of cells to generate the series.

2. Click EDIT-> FILL, the Fill Series dialog box appears as shown below,

Fill Series

Direction Series type Tirme unit
@ Down ) Linear @) Day
Right © Growth: Weekd Cancel
O Up ) Date Month Help

Left ) AuteFill Year
Start value 5
End value 2580
Increment 2

EX3

3. Select the Direction as Down in fill series dialog box.
4. Select the Series type Growth.

5. Initial value of the series 5 should be typed in Start Value box.

6. Maximum value of the series 2560 should be typed in End Value box.

7. The value 2 should be typed in Increment box .

8. Click OK. Now the series is generated as given below,
I B I

10
20
40
80
150
320
540
1280
25650
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3. Read the following table

A B C D E
1 Year Chennai Madurai Tiruchi Coimbatore
2 2012 1500 1250 1000 500
3 2013 1600 | 1000 | 950 - 350
4 2014 1900 | 1320 | 750 300
5 2015 1850 1415 820 200
6 2016 1950 | 1240 | 9210 250

Above table shows the sales figures for “Air Cooler” sold in four major cities of TamilNadu from
the year 2012 to 2016. Based on this data, write the formula to calculate the following.

(1) Total sales in the year 2015.

(2) Total sales in Coimbatore from 2012 to 2016.

(3) Total sales in Madurai and Tiruchi during 2015 and 2016.

(4) Average sales in Chennai from 2012 to 2016

(5) In 2016, how many “Air Coolers” are sold in Chennai compared to Coimbatore?

ANSWER:
SL.NO QUESTION FORMULA ANSWER
1 Total sales in the year 2015. =SUM(B5:E5) 4285
Total sales in Coimbatore from 2012 to
2 =SUM(E2:E6) 1600
2016.
Total sales in Madurai and Tiruchi
3 =SUM(C5:D6) 4395

during 2015 and 2016.

Average sales in Chennai from 2012 to
4 2016 =AVERAGE(B2:B6) 1760

In 2016, how many “Air Coolers” are
5 sold in Chennai compared to =B6-E6 1700

Coimbatore?
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