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CHAPTER – 4 

ALGORITHMIC STRATEGIES 

1. A __________ is a finite set of instructions to accomplish a particular task.  

a) Array   b) Structure   c) Algorithm   d) Program 

2. __________ is a step-by-step procedure for solving a given problem.  

a) Array   b) Structure   c) Algorithm   d) Program 

3. An __________ can be implemented in any suitable programming language. 

a) Array   b) Structure   c) Algorithm   d) Program 

4. __________ can be developed to store, manipulate and retrieve data from such data structures. 

a) Array   b) Structure   c) Algorithm   d) Program 

5. The way of defining an algorithm is called __________  

a) Algorithmic Solution b) Algorithmic Strategy c) Algorithm Analysis  d) All the above 

6. An __________ that yields expected output for a valid input is called an algorithmic solution 

a) Algorithmic Solution b) Algorithmic Strategy c) Algorithm Analysis  d) All the above 

7. __________ helps to solve a given problem logically  

a) Array   b) Structure   c) Algorithm   d) Program 

8. __________ is an expression of algorithm in a programming language  

a) Array   b) Structure   c) Algorithm   d) Program 

9. __________ resembles a pseudo code which can be implemented in any language  

a) Array   b) Structure   c) Algorithm   d) Program 

10. __________ is more specific to a programming language  

a) Array   b) Structure   c) Algorithm   d) Program 

11. Analysis of algorithms and performance evaluation can be divided into __________ different phases 

a) 3   b) 2    c) 5    d) 4 

12. This is a theoretical performance analysis of an algorithm.  

a) Posteriori Testing b) Priori Estimates  c) Time Complexity         d) Space Complexity 

13. Efficiency of an algorithm is measured by assuming the __________ factors.  

a) Posteriori Testing b) Priori Estimates  c) Internal          d) External 

14. __________ is called performance measurement.  

a) Posteriori Testing b) Priori Estimates  c) Time Complexity         d) Space Complexity 

15. In this analysis, actual statistics like running time and required for the algorithm executions are collected.  

a) Time   b) Space   c) Algorithm   d) Array 

16. An estimation of the time and space complexities of an algorithm for varying input sizes is called 

__________. 

a) Algorithmic Solution b) Algorithmic Strategy c) Algorithm Analysis  d) All the above 

17. __________ is measured by counting the number of key operations like comparisons in the sorting 

algorithm. 

a) Time   b) Space   c) Algorithm   d) Array 

18. __________ is measured by the maximum memory space required by the algorithm. 

a) Time   b) Space   c) Algorithm   d) Array 
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19. __________  of an algorithm is the amount of memory required to run to its completion. 

a) Space Complexity b) Time Complexity  c) Algorithm Strategy  d) Algorithm 

20. A __________ is defined as the total space required for storing certain data and variables for an algorithm. 

a) Fixed Part  b) Variable Part  c) Algorithm   d) Array 

21. A __________ is defined as the total space required by variables, which sizes depends on the problem and 

its iteration. 

a) Fixed Part  b) Variable Part  c) Algorithm   d) Array 

22. The __________ can be measured based on the usage of different resources. 

a) Algorithmic Solution b) Efficiency of Algorithm c) Time Complexity  d) Space 

23. A way of designing algorithm is called __________ 

a) Algorithmic Solution b) Algorithmic Strategy c) Algorithm Analysis  d) All the above 

24. __________ is often used to describe the worst-case of an algorithm. 

a) Big O   b) Big Omega   c) Big P   d) Big Theta 

25. __________ is the reverse Big O 

a) Big O   b) Big Omega   c) Big P   d) Big Theta 

26. If __________ is used to describe the upper bound (worst - case) of an asymptotic function. 

a) Big O   b) Big Omega   c) Big P   d) Big Theta 

27. __________ is used to describe the lower bound (best-case). 

a) Big O   b) Big Omega   c) Big P   d) Big Theta 

28. __________ also called sequential search 

a) Linear Search  b) Binary Search  c) Bubble Sort   d) Insertion Sort 

29. __________ is a sequential method for finding a particular value in a list. 

a) Linear Search  b) Binary Search  c) Bubble Sort   d) Insertion Sort 

30. __________ Method checks the search element with each element in sequence until the desired element is 

found or the list is exhausted. 

a) Linear Search  b) Binary Search  c) Bubble Sort   d) Insertion Sort 

31. __________ also called half-interval search algorithm. 

a) Linear Search  b) Binary Search  c) Bubble Sort   d) Insertion Sort 

32. __________ finds the position of a search element within a sorted array. 

a) Linear Search  b) Binary Search  c) Bubble Sort   d) Insertion Sort 

33. __________ is a simple sorting algorithm.  

a) Linear Search  b) Binary Search  c) Bubble Sort   d) Insertion Sort 

34. __________ Algorithm starts at the beginning of the list of values stored in an array. 

a) Linear Search  b) Binary Search  c) Bubble Sort   d) Insertion Sort 

35. __________ compares each pair of adjacent elements and swaps them if they are in the unsorted order. 

a) Linear Search  b) Binary Search  c) Bubble Sort   d) Insertion Sort 

36. __________ algorithm is also called as a comparison sort 

a) Linear Search  b) Binary Search  c) Bubble Sort   d) Insertion Sort 
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37. __________ Algorithm is simple and it is too slow and less efficient when compared to insertion sort and 

other sorting methods. 

a) Linear Search  b) Binary Search  c) Bubble Sort   d) Insertion Sort 

38. The __________ is a simple sorting algorithm that improves on the performance of bubble sort 

a) Linear Search  b) Binary Search  c) Insertion Sort  d) Selection Sort 

39. __________ Algorithm will first find the smallest elements in array and swap it with the element in the 

first position of an array. 

a) Linear Search  b) Binary Search  c) Insertion Sort  d) Selection Sort 

40. __________ Algorithm repeatedly selects the next-smallest element and swaps in into the right place for 

every pass. 

a) Linear Search  b) Binary Search  c) Insertion Sort  d) Selection Sort 

41. __________ is a simple sorting algorithm.  

a) Linear Search  b) Binary Search  c) Insertion Sort  d) Selection Sort 

42. __________ works by taking elements from the list one by one and inserting then in their correct position 

in to a new sorted list. 

a) Linear Search  b) Binary Search  c) Insertion Sort  d) Selection Sort 

43. __________ algorithm uses n-1 number of passes to get the final sorted list 

a) Linear Search  b) Binary Search  c) Insertion Sort  d) Selection Sort 

44. __________ is an algorithmic design method that can be used when the solution to a problem can be 

viewed as the result of a sequence of decisions.  

a) Dynamic Programming b) Memoization  c) Algorithmic Strategy d) Binary Search 

45. __________ Approach is similar to divide and conquer. 

a) Dynamic Programming b) Memoization  c) Algorithmic Strategy d) Binary Search 

46. __________ is used whenever problems can be divided into similar sub-problems. 

a) Dynamic Programming b) Memoization  c) Algorithmic Strategy d) Binary Search 

47. __________ Approaches are used to find the solution in optimized way. 

a) Dynamic Programming b) Memoization  c) Algorithmic Strategy d) Binary Search 

48. __________ is an optimization technique used primarily to speed up computer programs 

a) Dynamic Programming b) Memoization  c) Algorithmic Strategy d) Binary Search 
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CHAPTER – 5 

PYTHON VARIABLES AND OPERATORS 

1. The language was released in __________. 

a) 1981   b) 1990   c) 1980   d) 1991 

2. __________ is a platform independent programming language. 

a) C++   b) Java    c) Python   d) C 

3. __________ is a general purpose programming language which can be used for both scientific and non-

scientific programming. 

a) C++   b) Java    c) Python   d) C 

4. The programs written in __________ are easily readable and understandable. 

a) C++   b) Java    c) Python   d) C 

5. In __________, programs can be written in two ways 

a) C++   b) Java    c) Python   d) C 

6. The __________ allows us to write codes in Python command prompt 

a) Interactive Mode b) Script Mode  c) Python   d) Command 

7. __________ programs can be written and stored as separate file 

a) Interactive Mode b) Script Mode  c) Python   d) Command 

8. __________ is used to create and edit python source file. 

a) Interactive Mode b) Script Mode  c) Python   d) Command 

9. In __________ Python code can be directly typed and the interpreter displays the result(s) immediately. 

a) Interactive Mode b) Script Mode  c) Python   d) Command 

10. The __________ indicates that Interpreter is ready to accept instructions. 

a) <<   b) >>    c) <<<    d) >>> 

11. A __________ is a text file containing the Python statements.  

a) Word   b) Notepad   c) Script             d) Interactive mode 

12. __________ Scripts are reusable code. 

a) C++   b) Java    c) Python   d) C 

13. The Command used to create script in Python 

a) File→New   b) File→New File  c) File→Open   d) Edit→New File 

14. The Keyboard Shortcut used to create script in Python 

a) Ctrl+M   b) Ctrl+N   c) Ctrl+O   d) Ctrl+P 

15. The Command used to save the script in Python is __________ 

a) Edit→Save  b) File→Save   c) File→Saveas  d) View→Save 

16. The Extension of Python is __________ 

a) .pu   b) .pt    c) .py    d) .ph 

17. The Command used to execute in Python Script is __________ 

a) Run→Run  b) Run→Run Module  c) Run→Execute  d) Execute→File 

18. The Keyboard Shortcut used to execute in Python Script is __________ 

a) F4   b) F5    c) F3    d) F2 

19. The __________ function helps to enter data at run time by the user  

a) print( )   b) input( )   c) print    d) input 
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20. __________ is used to display the result of the program on the screen after execution. 

a) print( )   b) input( )   c) print    d) input 

21. The __________ function is used to display result on the screen 

a) print( )   b) input( )   c) print    d) input 

22. The __________ evaluates the expression before printing it on the monitor. 

a) print( )   b) input( )   c) print    d) input 

23. __________ is used as a separator in print ( ) to print more than one item. 

a) . (dot)   b) , (comma)   c) : (colon)   d) semicolon(;)  

24. __________ Function is used to accept data as input at run time. 

a) print( )   b) input( )   c) print    d) input 

25. __________ string in the syntax is a statement or message to the user, to know what input can be given. 

a) Key   b) Prompt   c) Point   d) Set of 

26. The __________ accepts all data as string or characters but not as numbers. 

a) print( )   b) input( )   c) print    d) input 

27. The __________ function is used to convert string data as integer data explicitly. 

a) print( )   b) input( )   c) print    d) int( ) 

28. In Python, comments begin with hash symbol __________. 

a) @   b) $    c) #    d) & 

29. Python breaks each logical line into a sequence of elementary lexical components known as __________. 

a) Tokens   b) Identifiers   c) Keywords   d) Delimiters 

30. Tokens are classified into __________ categories 

a) 3   b) 4    c) 5    d) 6 

31. A __________ is a name used to identify a variable, function, class, module or object. 

a) Tokens   b) Identifiers   c) Keywords   d) Delimiters 

32. __________ are special words used by Python interpreter to recognize the structure of program. 

a) Tokens   b) Identifiers   c) Keywords   d) Delimiters 

33. __________ are special symbols which represent computations, conditional matching etc.  

a) Operators  b) Operands   c) Association   d) Literal 

34. The value of an operator used is called __________. 

a) Operators  b) Operands   c) Association   d) Literal 

35. A __________ operator is also called as Comparative operator  

a) Arithmetic  b) Relational   c) Logical   d) Conditional 

36. A __________ operator checks the relationship between two operands. 

a) Arithmetic  b) Relational   c) Logical   d) Conditional 

37. In python, __________ operators are used to perform logical operations on the given relational expressions. 

a) Arithmetic  b) Relational   c) Logical   d) Conditional 

38. There are __________ logical operators 

a) 3   b) 4    c) 5    d) 6 

39. In Python, __________ is a simple assignment operator to assign values to variable. 

a) &   b) *    c) =    d) % 

40. Ternary operator is also known as __________ operator 

a) Arithmetic  b) Relational   c) Logical   d) Conditional 
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41. __________ operator that evaluates something based on a condition being true or false. 

a) Arithmetic  b) Relational   c) Logical   d) Conditional 

42. Python uses the symbols and symbol combinations as __________ 

a) Tokens   b) Identifiers   c) Keywords   d) Delimiters 

43. __________ is a raw data given in a variable or constant. 

a) Operators  b) Operands   c) Association   d) Literal 

44. __________ consists of digits and are immutable (unchangeable).  

a) Character Literal b) String Literal  c) Boolean Literal           d) Numeric Literals 

45. Numeric literals can belong to __________ different numerical types 

a) 3   b) 4    c) 5    d) 6 

46. In Python a __________ is a sequence of characters surrounded by quotes. 

a) Character Literal b) String Literal  c) Boolean Literal           d) Numeric Literals 

47. A __________ is a single character surrounded by single or double quotes.  

a) Character Literal b) String Literal  c) Boolean Literal           d) Numeric Literals 

48. The value with __________ is used to give multi-line string literal. 

a) Single Quotes  b) Double Quotes  c) Triple Quotes  d) None of these 

49. A __________ can have any of the two values 

a) Character Literal b) String Literal  c) Boolean Literal           d) Escape Sequence 

50. In Python strings, the backslash "\" is a special character, also called the __________. 

a) Character Literal b) String Literal  c) Boolean Literal           d) Escape Sequence 

51. _________ Escape Sequence is used to create a new line 

a) \n   b) \r    c) \t    d) \v 

52. _________ Escape Sequence is used to create a tab 

a) \n   b) \r    c) \t    d) \v 

53. _________ Escape Sequence is used to create a carriage return 

a) \n   b) \r    c) \t    d) \v 

54. A __________ data is represented by a sequence of decimal digits that includes a decimal point. 

a) Floating Point  b) Decimal   c) Complex Number  d) Numeric 

55. __________ is made up of two floating point values 

a) Floating Point  b) Decimal   c) Complex Number  d) Numeric 
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